LINUX.ORG.RU
ФорумAdmin

Запрет запуска php скриптов с определенной директории (apache)

 ,


0

1

Добрый день! Php5.5, Apache/2.2.22 Цель: запретить запускать php скрипты с определённого каталога.

Пишу в файл настройки виртуального хоста:

<Directory "/var/www/games/www/upload">
        php_flag engine off
        AddType "text/html" .php .cgi .pl .fcgi .fpl .phtml .shtml .php2 .php3 .php4 .php5 .asp .jsp
        AllowOverride None
</Directory>

Создаю в каталоге /var/www/games/www/upload/test.php с содержимым:

<html>
 <head>
  <title>Тестируем PHP</title>
 </head>
 <body>
 <?php echo '<p>Привет, мир!</p>'; ?>
 </body>
</html>

Вбиваю в браузере http://<имя сайта>/upload/test.php и мне говорят «Привет, мир». А не должно. Что я делаю не так? Заранее спасибо

Попробуй добавить

RemoveType .php .cgi .pl .fcgi .fpl .phtml .shtml .php2 .php3 .php4 .php5 .asp .jsp
RemoveHandler .php .cgi .pl .fcgi .fpl .phtml .shtml .php2 .php3 .php4 .php5 .asp .jsp
SetHandler default-handler
Options -ExecCGI

no-such-file ★★★★★
()
Ответ на: комментарий от hudsucker

Нет, ты просто тонких намёков на толстые обстоятельста не замечаешь — тебе бекдор зааплоадить два пальца об асфальт.

deep-purple ★★★★★
()
Ответ на: комментарий от deep-purple

Так я над этим и работаю) Но, как видишь, ничего не получается

hudsucker
()
Ответ на: комментарий от hudsucker

я о другом. Покажи мне не то что у тебя на сервере, а то, что возвращается браузеру. В Google Chrome ты можешь это сделать правой кнопкой по странице > Просмотр кода страницы

либо сочетанием Ctrl+U

r0ck3r ★★★★★
()
Ответ на: комментарий от r0ck3r
<html>
 <head>
  <title>Тестируем PHP</title>
 </head>
 <body>
 <?php echo '<p>Привет, мир!</p>'; ?>
 </body>
</html>

Привет, РјРёСЂ! - это есть «Привет, мир!» =)

hudsucker
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.