LINUX.ORG.RU
ФорумAdmin

Доступ к монитору через RDP

 


0

1

Raspberry Pi с Raspbian с lxde. Подключен монитор. При запуске на нем появляется окно авторизации. В тоже время я удаленно подключаюсь по RDP. В системе присутствует только виртуальный монитор с удаленным рабочем столом. Как получить доступ с этого удаленного рабочего стола к монитору на малинке? Спасибо!


Ты хочешь чтобы локальный монитор показывал то, что ты сейчас делаешь в системе? Но зачем? Это не есть задача rdp.

morse ★★★★★ ()
Ответ на: комментарий от morse

Нет, туда прога должна данные выводить. А вот запускать её и настраивать надо удаленно.

VladM ()

Из наиболее доступных средств тебе нужен x11vnc, запущенный на X11 дисплее с физическим монитором. Подключатся к нему с виртуального дисплея или сразу с удалённого места любым VNC клиентом. Могут быть и другие варианты, но этот вероятно потребует минимум манипуляций.

Elyas ★★★★★ ()
Ответ на: комментарий от Elyas

Спасибо, попробовал. Получилось полное дублирование. Железный полностью повторяет виртуальный и в системе только он один. Как можно сделать два независимых экрана?

VladM ()

В общем пока добился следующего: с real vnc в системе только виртуальный монитор. При этом на железном мониторе висит совершенно независимый рабочий стол, с которым удаленно ничего не сделать. С x11vnc в системе железный монитор, при этом он полностью дублирует виртуальный. Как получить в системе два монитора?

VladM ()

x2go. хошешь - подключайся к существующей иксовой сессии, хочешь - создавай новую сессию. это единственное нормальное решение в иксах.

vvviperrr ★★★★★ ()

На debian с помощью xorgxrdp из репов ваша задача решается. Вот вам примерный мануал:

apt install -y xrdp xorgxrdp
dpkg-reconfigure xserver-xorg-legacy # Разрешить всем

mcedit /etc/xrdp/xrdp.ini # После Session types оставить только настройки xorg
; Session types

[Xorg]
name=Xorg
lib=libxup.so
username=ask
password=ask
ip=127.0.0.1
port=-1
code=20

# Для корректной работы переключения раскладки правим /etc/xrdp/xrdp_keyboard.ini
# проверить их наличие
[default_rdp_layouts]
rdp_layout_us=0x00000409
rdp_layout_ru=0x00000419

# Всё что ниже добавляем в конце не забывая что переключение происходит сочетанием  клавиш alt+shift
[layouts_map_ru]
rdp_layout_us=ru,us
rdp_layout_ru=ru,us

[rdp_keyboard_ru]
keyboard_type=4
keyboard_type=7
keyboard_subtype=1
; model=pc105 при необходимости
options=grp:alt_shift_toggle
rdp_layouts=default_rdp_layouts
layouts_map=layouts_map_ru
Потом ещё /etc/xrdp/xrdp.ini покурите, а то блоха может не потянуть всю красоту и что-то там с курсором отключить надо, чтоб квадратом не был.

Dimarius ()
Ответ на: комментарий от morse

rdp это все лишь протокол. А ТС только rdp клиента может запустить.

Dimarius ()

Если ты для доступа по RDP используешь пакет «xrdp», то у него в настройках вроде можно задать DISPLAY.

По умолчанию, DISPLAY<>0 (равен 1), а тебе надо сделать его в 0. Сам я так не делал, но может у тебя получится.

Novator ★★★★★ ()
Ответ на: комментарий от VladM

Xrdp использует vncserver, возможно, в нём уже задается DISPLAY. Я точно не знаю, просто направление мысли.

Ты можешь подключиться по RDP и из под root посмотреть командами:

ps -few | grep rdp
ps -few | grep vnc

Какой дисплей используется.
Потом по /etc поиском поищи «DISPLAY» или как там.

P.S. В консоли в рут переключаться командой:

su

Но перед этим нужно рута включить - задать ему пароль:

sudo passwd
из-под обычного пользователя.

Novator ★★★★★ ()
Последнее исправление: Novator (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.