LINUX.ORG.RU
решено ФорумAdmin

ssh разрешает подключение только root'у

 


0

1

имеется сервер с Debian 6, на нем установил ssh. Минимальная настройка: PermitRootLogin no. Кроме root'а на сервере только 1 пользователь superroot. Пробую войти на самом сервере, пишет
Permission denied, please try again.

Если открыть доступ root'у, то ssh root@localhost или с другого компьютера в сети ssh -l root <server_IP> прекрасно срабатывает Что нужно сделать, чтобы не использовать root'а, а входить superroot'ом? Вот это вывод ssh

superroot@server:~$ ssh superroot@localhost
superroot@localhost's password:
Permission denied, please try again.
superroot@localhost's password:
Permission denied, please try again.
superroot@localhost's password:
Permission denied (publickey,password).

А это log

May 12 14:28:52 linuxserver sshd[22580]: Failed password for superroot from 127.0.0.1 port 50303 ssh2
May 12 14:28:57 linuxserver sshd[22580]: Failed password for superroot from 127.0.0.1 port 50303 ssh2
May 12 14:29:01 linuxserver sshd[22580]: Failed password for superroot from 127.0.0.1 port 50303 ssh2
May 12 14:29:01 linuxserver sshd[22580]: PAM 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=localhost user=superroot

Полностью конфиг sshd покажи. Только на этот раз сразу используя lorcode, а то без форматирования читать никто не будет.

shell-script ★★★★★ ()
Ответ на: комментарий от anc

Если открыть доступ root'у, то ssh root@localhost или с другого компьютера в сети ssh -l root <server_IP> прекрасно срабатывает

mokynis ()
Ответ на: комментарий от shell-script

Port 22
Protocol 2

HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
#PermitRootLogin yes
PermitRootLogin no
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

AllowUsers superroot

mokynis ()
Ответ на: комментарий от anc

немного не то ответил. Хотел вот это

Кроме root'а на сервере только 1 пользователь superroot. Пробую войти на самом сервере, пишет Permission denied, please try again.

mokynis ()
Ответ на: комментарий от mokynis

вот я балбес. Подсказывали же! У меня на двух копмах одинаковые юзеры с разными паролями, так я упорно вбивал не тот пароль

mokynis ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.