LINUX.ORG.RU
ФорумAdmin

Ошибка при обновлении

 


0

1

Добрый день!

При попытке обновления yum update получил ошибку:

file /usr/lib64/libhashkit.so.2.0.0 from install of libmemcached-last-libs-1.0.18-6.el6.remi.x86_64 conflicts with file from package libmemcached10-1.0.16-1.ius.el6.x86_64
file /usr/lib64/libmemcached.so.11.0.0 from install of libmemcached-last-libs-1.0.18-6.el6.remi.x86_64 conflicts with file from package libmemcached10-1.0.16-1.ius.el6.x86_64
file /usr/lib64/libmemcachedutil.so.2.0.0 from install of libmemcached-last-libs-1.0.18-6.el6.remi.x86_64 conflicts with file from package libmemcached10-1.0.16-1.ius.el6.x86_64

yum list installed libmemcached*

Installed Packages
libmemcached10.x86_64 1.0.16-1.ius.el6 @webtatic

Надо удалить libmemcached10.x86_64 и установить libmemcached-last-libs, далее yum update, т.е. yum remove libmemcached10.x86_64 yum install libmemcached-last-libs yum update ?


Возможно будет достаточно yum upgrade.

Elyas ★★★★★ ()
Ответ на: комментарий от mrxk

Надо удалить libmemcached10.x86_64 и установить libmemcached-last-libs, далее yum update, т.е. yum remove libmemcached10.x86_64 yum install libmemcached-last-libs yum update ?

Да, только еще и либо отключить remi, либо понизить ему приоритет (см. yum-plugin-priorities).

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

отключить remi

вроде как конфликт с ius, наверное отключить репозитарии webtatic и ius?

mrxk ()
Ответ на: комментарий от mrxk

yum repolist

base       CentOS-6 - Base
epel       Extra Packages for Enterprise Linux 6 - x86_64
extras     CentOS-6 - Extras   
ius        IUS Community Packages for Enterprise Linux 6 - x86_64   
mariadb    MariaDB   
nginx      nginx repo                           
remi-php70 Remi's PHP 7.0 RPM repository for Enterprise Linux 6 - x86_64   
remi-php71 Remi's PHP 7.1 RPM repository for Enterprise Linux 6 - x86_64 
remi-safe  Safe Remi's RPM repository for Enterprise Linux 6 - x86_64   
updates    CentOS-6 - Updates                            
webtatic   Webtatic Repository EL6 - x86_64 

mrxk ()
Ответ на: комментарий от mrxk

У тебя еще и webtatic, и до сих пор ничего не конфликтовало? Везунчик 8-0

Сколь я помню, http://wiki.centos.org уже достаточно давно рекомендует ius и не рекомендует ни remi, ни webtatic. Соответственно, я бы отключил (или хотя бы понизил приоритет) именно их при условии отсутствия необходимости использовать какие-либо пакеты, которых больше нет нигде. Если такая необходимость есть, то оставил бы соответствующий репозиторий, а другие два отключил бы (или понизил приоритет). В любом случае, конфликтующие пакеты имеет смысл устанавливать из какого-то одного репозитория.

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

отключил remi-php70 remi-php71 и webtatic - нечего обновлять))) при включенном remi-php71 есть обновление php с 7.1.1 до 7.1.2 Как правильно поступить?

mrxk ()
Ответ на: комментарий от mrxk

Я бы попробовал перейти на IUS полностью (см. https://ius.io/SafeRepo/, кстати), но не зная ничего о том, что у тебя за сервер(ы) и сайты, не рискну давать категоричных советов (вдруг ты под моим чутким руководством угробишь какой-нибудь серьезный production? :)

dexpl ★★★★★ ()
Последнее исправление: dexpl (всего исправлений: 1)
Ответ на: комментарий от dexpl

Предлагаешь подождать пару недель пока там не появится php 7.1.2(сейчас в этом репозитарии php 7.1.1) ?

mrxk ()
Ответ на: комментарий от mrxk

Видимо, я как-то неудачно формулирую свою основную мысль: предлагаю оставить что-нибудь одно — или ius, или remi, или на худой конец webtatic, и обновляться по мере поступления пакетов в соотв. репу. Что именно оставлять — сам выбирай, но, повторюсь, пока что-то одно не оставишь, тут и там будут конфликты.

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Спасибо за совет. А не будет конфликта при обновлении пакетов из другого репозитария. Например, сейчас у меня php стоит из webtatic,а репозитарий ius, или он его не будет обновлять?

mrxk ()
Ответ на: комментарий от mrxk

А не будет конфликта при обновлении пакетов из другого репозитария.

Будет. Точнее, уже есть — твой нынешний вопрос как раз и вызван таким конфликтом.

dexpl ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.