LINUX.ORG.RU
ФорумAdmin

Старая версия Arch

 , , , ,


0

1

Я установил Arch Linux 2008 в QEMU (без KVM). Проблема в том, что pacman не может прочитать загружаемые через него пакеты (*.pkg.tar.xz), пишет Unrecognized archive format: Invalid or incomplete multibyte or wide character. Обновлять систему не хочется, так как ядра 3.x и 4.x в эмуляторах работают крайне медленно. Как быть?

Обновлять систему не хочется, так как ядра 3.x и 4.x в эмуляторах работают крайне медленно.

С трудом верится, что ядро 2008-го года принципиально быстрее.

QEMU (без KVM)

Тоже довольно странная ситуация. У тебя на хосте не x86? Или рач под ARM?

anonymous ()
Ответ на: комментарий от greenman

Обновил libarchive и докачал xz-utils вручную. Теперь пакеты (*.pkg.tar.xz) устанавливаются, но выдаются ошибки вроде «error: could not open file: /var/lib/pacman/sync ... packagename/depends: No such file or directory». Как следствие, некоторые программы после установки просто не запускаются из-за неудолетворенных зависимостей. Команду pacman -S --refresh выполнял.

MVoloshin ()
Ответ на: комментарий от MVoloshin

Частичные обновления не поддерживаются.

Имхо, без шансов. Тот же софт из АУР каждый раз нужно пересобирать при смене версии boost.

Тебе нужно поставить несколько приложений, не обновляя систему? Возьми PKGBUILD-ы и попробуй пересобери.

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 3)
Ответ на: комментарий от MVoloshin

QEMU для Windows

Нахрена, особенно если ты недоволен производительностью?

anonymous ()
Ответ на: комментарий от MVoloshin

А использовать более пригодный эмулятор на оффтопике не позволяет религия? Даже виртуалбокс будет и то получше этого.

Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.