LINUX.ORG.RU
решено ФорумAdmin

«aptitude upgrade» погрязла в конфликтах.

 , , ,


0

1

Aptitude тужиться и выдает примерно такую строчку которая бесконечно меняется:

open: 37067; closed: 68995; defer: 68; conflict: 103

Я хотел бы найти источники конфликтов и разрешить их. Дело в том, что я по незнанию соединил unstable, testing и stable в своем source.list, теперь хочу исправить ситуацию перейдия полностью на testing. Собственно у меня в source.list теперь только testing. Осталось сделать апгрейд, и именно с этим у меня проблема. FAQsFromDebianUsers советует мне использовать apt-show-versions чтобы посмотреть с какой ветки какие программы, но проблема в том, что чтобы его установить synaptic требует удалить кучу другого софта. Например, требуется безвозвратно удалить ни в чем не повинный glogic.

Что мне делать? Переустанавливать с нуля очень не хочу.

Deleted

Дело в том, что я по незнанию соединил unstable, testing и stable в своем source.list,

Да-а-а, намесил.

Я сразу говорю, что созданием подобной помойки и ее разгребанием не занимался. Но направление, куда копать в случае, если такое встречу, предполагаю. Попробуй принудительно через apt pinning повысить приоритет testing. Читать в инете по поиску «apt pinning» и man apt_preferences.

Zubok ★★★★★ ()

Простого решения не существует. Тут только в диалоговом режиме смотреть зависимости и понемногу удалять лишнее

at ★★ ()
Ответ на: комментарий от at

да, если что не так то скидывай сюда, будем разбираться.
у тебя скорее всего конфликт из-за унстэбла, но тут надо с каждым пакетом отдельно разбираться, что не так

outsider ★★ ()
Ответ на: комментарий от outsider

Если в системе были намешаны репы. То apt-get upgrade скорей всего не пройдет. Унстэбл тут не при чем, софт из разных веток требует разные либы

P.S. то есть apt-get upgrade не сможет удалить пакет из сида, т.к. другое репы (из которых ставились пакеты) уже отключены пакет будет считаться поставленным локально, apt просто не сможет разрешить конфликт

at ★★ ()
Последнее исправление: at (всего исправлений: 1)
Ответ на: комментарий от at

ну так я и говорю что с каждым пакетом придется разбираться отдельно,
но для начала хотябы увидеть что там за конфликты, а с унстейблом если есть более новые версии то апт-гет его поставит.

outsider ★★ ()
Ответ на: комментарий от outsider

Не выйдет. Только pinning, так как если у него пакеты из unstable стоят, то надо делать downgrade, а штатно apt этого не будет делать, он только обновляет. Чтобы он делал downgrade, надо настраивать pinning.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
  1. Верни в список репозиториев stable и unstable sudo apt-get update
  2. Скачай apt-untangle, лучше всего склонируй текущую ветку через hg, нумерованный выпуск там вроде бы отстаёт.
  3. С её помощью устрани пакеты из stable и unstable (см. в README как).
  4. Удали stable и unstable из репозиториев
proud_anon ★★★★★ ()
Ответ на: комментарий от outsider

вот именно. Твоё предложение с apt-get upgrade/apt-get dist-upgrade в данном случае просто сломает систему либо ничего не сможет сделать

at ★★ ()
Последнее исправление: at (всего исправлений: 1)
Ответ на: комментарий от outsider

дык одно и тоже, сейчас у ТС стоит в соурс тестинг

но пакеты есть и из других веток

at ★★ ()
Ответ на: комментарий от outsider

так я и предлагаю ТС перейти на сид, чтоб легче было разгребать

А, ну это можно. testing от unstable недалеко стоит. Большого смысла использовать testing не вижу.

P.S. Сам на stable всегда.

Zubok ★★★★★ ()

Я временно добавил назад unstable и stable, и сделал apt-get update. Теперь я могу видеть в Synaptic какие пакеты из какой ветки.

Deleted ()
Ответ на: комментарий от Zubok

Я проверил, у меня действительно некоторые пакеты стоят из unstable. Чтобы не заморачиваться pinning каждого пакета попробую сменить все на unstable.

Deleted ()
Ответ на: комментарий от Deleted

убери все кроме унстэбла и покажи что выдаст апгрейд после апдэйта, только не соглашайся на вопрос продолжения работы.

outsider ★★ ()
Ответ на: комментарий от proud_anon

Или, в качестве альтернативы, просто удали stable и unstable из репозиториев, сделай sudo apt-get update, а потом sudo apt-untangle --untangle-unavailable, если только у тебя нет пакетов, которые ты ставил вообще не из репозиториев.

proud_anon ★★★★★ ()
Ответ на: комментарий от at

апт (аптитуде не помню) всегда спрашивает продолжать или нет, да и дист-апгрейд только в самом конце надо делать, когда апгрейд все установил и нет конфликтов

outsider ★★ ()

1. aptitude есть труп
2. ССЗБ, ибо соединил unstable, testing и stable не разобравшись
3. если хочешь перейти полностью на testing, то учти, там тоже старьё (как впрочем и в unstable в основном)
4. ставь базовую систему с ubuntu-dailybuild mini.iso, там свежее всё (свежее чем в fedora rawhide) и нет никаких проблем, DE/WM поставишь на своё усмотрение

amorpher ★★★★★ ()
Последнее исправление: amorpher (всего исправлений: 1)
Ответ на: комментарий от outsider

да и дист-апгрейд только в самом конце надо делать, когда апгрейд все установил и нет конфликтов

так у ТС конфликты УЖЕ есть!

at ★★ ()
Ответ на: комментарий от outsider

Я так и сделал. Aptitude upgrade по преженому впадает в транс.

Apt-get upgrade выводит следующее: http://freetexthost.com/0ae2iop5lw (ссылку поставил потому, что ЛОР не дает полностью опубликовать сообщение как слишком большое)

Deleted ()
Ответ на: комментарий от at

так мы же пытаемся ему помочь разобрать эти конфликты, а для начала надо выбрать одну ветку, сделать апдейт и посмотреть что выдаст апгрейд (без продолжения работы) и уже смотреть что за конфликты и думать как это исправить

тут немного выше тоже дельно предложили с apt-untangle

outsider ★★ ()
Ответ на: комментарий от outsider

(без продолжения работы)

и ты про это сразу же написал

1. apt-get update (в соурс должен быть только тестинг)

2. apt-get upgrade

3. apt-get dist-upgrade

at ★★ ()
Ответ на: комментарий от Deleted

что-то я криминального не увидел ничего, можно обновлять, удалять он тебе ничего не собирается

outsider ★★ ()
Ответ на: комментарий от outsider

тут немного выше тоже дельно предложили с apt-untangle

вот здесь х.з. сам никогда не работал, поэтому советовать не буду

at ★★ ()
Ответ на: комментарий от at

Постарайся для начала решить мелкие конфликты

Легко сказать.

Во-первых, я никогда еще конфликты вручную не решал, соответсвенно я плохо представляю что мне надо делать.

Во-вторых, я сейчас сижу и искрене не понимаю откуда aptitude вообще берет конфликты когда я переключил все на unstable. Ну в самом деле, что мешает ему просто все тупо обновить?

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от at

Просто интересно. На десктопе или сервере

Э-э-э, дектопе или сервере что?

А, ну это можно. testing от unstable недалеко стоит. Большого смысла использовать testing не вижу.

На десктопе.

P.S. Сам на stable всегда.

На сервере и десктопе.

Zubok ★★★★★ ()
Ответ на: комментарий от Deleted

Во-вторых, я сейчас сижу и искрене не понимаю откуда aptitude вообще берет конфликты когда я переключил все на unstable. Ну в самом деле, что мешает ему просто все тупо обновить?

Хотя если подумать ... Может быть причина в софте который я установил в обход репозитория? Например, если мне не изменяет память, я таким образом установил Google Chrome. Как мне найти все пакеты которые я установил «извне», дабы быть уверенным что я ничего не пропустил?

Deleted ()
Ответ на: комментарий от at

если ТС спрашивает здесь совета, я думаю, что если у него будут доп вопросы, он здесь же и спросит.

на счет аптитуды - это фломастеры, мне с апт-гет удобнее

outsider ★★ ()
Ответ на: комментарий от Zubok

дектопе

я ни не писал, возможно опечатка

Просто поинтересовался где ты используешь стабильную ветку. У меня на сервере, как правило (если нет других ограничений) стабильная деба. На моей машине сид, ну и винда на ноуте

at ★★ ()
Ответ на: комментарий от Deleted

Во-вторых, я сейчас сижу и искрене не понимаю откуда aptitude вообще берет конфликты когда я переключил все на unstable. Ну в самом деле, что мешает ему просто все тупо обновить?

Кажется, я сталкивался с тем, что aptitude иногда не додумывается обновить несколько пакетов, если невозможно обновить каждый из них в отдельности. Попробуй aptitude --full-resolver, может помочь.

proud_anon ★★★★★ ()
Последнее исправление: proud_anon (всего исправлений: 1)
Ответ на: комментарий от Deleted

Может быть причина в софте который я установил в обход репозитория? Например, если мне не изменяет память, я таким образом установил Google Chrome.

Хром вроде при установке добавляет свой репозиторий. И он должен работать и на stable, и на testing, и на unstable. Или нет?

proud_anon ★★★★★ ()
Ответ на: комментарий от outsider

на счет аптитуды - это фломастеры, мне с апт-гет удобнее

не совсем. Если всегда работаешь с одной веткой apt-а достаточно, аптитуд бывает полезен для решения нестандартных ситуаций

at ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.