LINUX.ORG.RU
ФорумAdmin

Debian, php 5.3.3-7+squeeze19, не могу запустить php5-fpm через TCP

 , , ,


1

1

Есть сервачок с Дебианом на борту, воткнул на него nginx, php5, после чего пришлось еще вот этим способом php5-fpm ставить. Все заработало. Тестовая страничка открылась. Все отлично. Но есть один нюанс: для проекта, который требуется запустить на данном сервере нужно чтоб php5-fpm работал не через сокет, а через 127.0.0.1:9000 И вот почему-то сразу после внесения соответствующих изменений в конфиг ногинска:

 
fastcgi_pass   127.0.0.1:9000;
#fastcgi_pass unix:/var/run/php5-fpm.sock;

и в /etc/php-fpm-pool.conf

;listen = /var/run/php5-fpm.sock
listen = 127.0.0.1:9000

... ногинск перезапускается без ошибок, а вот php5-fpm тоже вроде как перезапускается без ошибок, но потом и сайт не грузится (502 ошибка) и на 9000 порту ничего нет, и статус выдает следующее:

# /etc/init.d/php5-fpm status
php5-fpm is not running ... failed!

Подскажите, коли не сложно, куда копать? Что проверять? Спасибо!

Ответ на: комментарий от invokercd

В логах php-fpm к сожалению ничего нет интересного. Там все пучком, когда через сокет работает, а когда меняю на TCP, то в логе просто ничего нового не появляется...

kklkkl ()
Ответ на: комментарий от xorik

Да нет. В этом логе никакой ругани нет. Когда с сокетом, все отлично логируется без ошибок. Когда меняю на tcp - то и в логах ничего нет.

kklkkl ()
Ответ на: комментарий от xorik

Да я же написал, что пусто... ) Не запущен и порт не занят... Не хочет почему-то по TCP пускаться и все тут... (( А на сокете - работает...

kklkkl ()

Вероятно что-то с конфигом не то. Попробуй запустить так и посмотреть, в чём именно проблема:

sudo /usr/sbin/php5-fpm --fpm-config /etc/php5/fpm/php-fpm.conf
Kilte ★★★★★ ()

Выложи конфиг и выхлопы fpm на пейстбин.

invokercd ★★★★ ()
Ответ на: комментарий от Kilte

Вот спасибо тебе огроменное!!! Я до такого что-то и не додумался. Век живи век учись!

В общем, дело было вот в чем:

 [ERROR] [pool www] cannot get uid for user 'nginx '

Пофиксить удалось довольно экстравагантно - подставив в конфиге после user = nginx - точку с запятой... )))

После этого php5-fpm успешно запустился через TCP!

Проект правда че-то все-равно не пошел, но там уже какие-то другие баги... Буду дальше ковырять. ))) Еще раз ОГРОМНОЕ СПАСИБО за помощь! )

kklkkl ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.