LINUX.ORG.RU
решено ФорумAdmin

Нет доступа к серверу, не принимает ни какие пароли


0

3

Доброе...

Поставил CentOS 6.6 x64, дал пароль для root.

Система встает, после установки перегружается, просит ввести логин и пароль.

Ввожу root и к нему пароль, и тишина .. ни ошибки , ничего, просто заново просит логин и пароль.

Делаю сброс пароля. при загрузке жму е, потом выбираю 1 или single. Заменяю passwd ввожу новый пароль и все равно не пускает, создаю другого пользователя и тоже не пускает.

Ставлю систему заново, ввожу пароль 123456, вдруг что с раскладкой и та же история.

Дополню, все крутится на kvm. Весь день сегодня ставил разные системы и все нормально, а тут, что-то не то ...

Что может быть, подскажите пожалуйста.

Какой-нибудь шутник дописал exit в конец .bash_login или другого подобного конфига?

Или, может, шелл для рута выставлен /bin/false?

В общем, если ошибки после логина нет - логин наверняка проходит удачно. Просто шелл завершается по какой-то причине.

si0 ★★★ ()
Ответ на: комментарий от Zubok

Вариант с шутниками откидываю, так как я один клоун с машиной)))

...

Ничего не пишет, точней не пускает ни где и ни как ...

Тут решил по разному создавать виртуалки и эмпирическим путем выявил, что создавая с ключом --extra-args=«vnc sshd=1 sshpw=secret ip=static reboot=b selinux=0» \ как раз получаю такую проблему.

Убрав все это, нормально завелось, а нужные параметры добавил позже.

Но все равно, так и не понял, почему оно так себя ведет...

Всем спасибо, на мысли на будущее наставили)

firefedot ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.