LINUX.ORG.RU
ФорумAdmin

Ошибка при запуске демона оракла.

 ,


0

1

Добрый день.
Установил по гайду(http://avinmathew.com/install-oracle-xe-11g-r2-on-ubuntu-12-04/) оркал, но начались проблемы с запуском демона, выдает ошибку:

Starting Oracle Net Listener.
Starting Oracle Database 11g Express Edition instance.
Failed to start Oracle Net Listener using /u01/app/oracle/product/11.2.0/xe/bin/tnslsnr and Oracle Express Database using /u01/app/oracle/product/11.2.0/xe/bin/sqlplus.
Ставил я его на ubuntu 12.04 server на VPS.
Настройки лисенера:
# listener.ora Network Configuration File:

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = SOFFP)
      (ORACLE_HOME = /u01/app/oracle/product/11.2.0/xe)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE))
      (ADDRESS = (PROTOCOL = TCP)(HOST = Ubuntu-1204-precise-64-minimal)(PORT = 1521))
    )
  )

DEFAULT_SERVICE_LISTENER = (XE)


oracle linux, ubuntu server

Вы бы, для начала, с тегами разобрались. А затем внимательно прочитали статью. «Oracle XE is officially supported on Windows and Red Hat Linux-based systems (the Developer Days VMs are Oracle Linux). Debian Linux-based systems don’t seem to be officially supported» - оттого отвечать на вопрос, смысла не вижу.

robot12 ★★★★★ ()

Повангую, ты забыл прописать переменные окружения или линковок не хватает.

P.S Ubuntu, vps(openvz?)), XE - да ты извращенец.

kukara4 ★★ ()
Последнее исправление: kukara4 (всего исправлений: 3)

И вообще, даже не смешно, ну читайте же вы требования и сертификации, сначала пытаетесь впихнуть невпихуемое, а потом Oracle виноват, у них говно продукты.

kukara4 ★★ ()
Ответ на: комментарий от kukara4

насчет того что у них продукты говно я не чего не говорили и так не считаю, я вообще в первый раз его ставил, до этого мускулом пользовался, но на одном проекте потребовался оракл, вот и пришлось сидеть париться.
еще хотел у тебя спросить насчет впихнуть невпихуемое, я так понимаю он просто у меня на VPS и пойти не может, из за того что уме не хватает мощностей ?

rdbn ()
Ответ на: комментарий от rdbn

впихнуть невпихуемое, я так понимаю он просто у меня на VPS

Изначальная ошибка в том, что ты его начал ставить на убунту. Из всего сертифицированого, Оракл работает на винде, аиксе, соляре и редхате. Все. И то, иногда еще фиг заведешь. А ты на убунту первый раз решил ставить. Для начала попробуй поставить на центось или оракл линукс.

Для запуска на мощности пофиг, если у тебя openvz виртуализация - то это тоже извращение. Бери минимум KVM, XEN в паравирте тоже в топку.

В общем возьми редхат подобный линукс и нормальную виртуалку с аппаратной виртуализацией.

kukara4 ★★ ()

вангую что запускаешь от рута.

dada ★★★★★ ()

Резолвится ли на этой машине имя Ubuntu-1204-precise-64-minimal?

Если нет, смени на что-то более адекватное или добавь в /etc/hosts

anonymous ()
Ответ на: комментарий от kukara4

Не ври, на оракле оракл тоже отлично работает

anonymous ()
Ответ на: комментарий от kukara4

вообщем проблема оказалась проще ему просто не хватает оперы и дело было даже не в этой ошибки. Всем спасибо за ответы.

rdbn ()
Ответ на: комментарий от anonymous

Oracle XE воровать незачем, он и так бесплатный. Большой Оракл ты тоже можешь юзать бесплатно в целях ознакомления или разработки единственного приложения.

alex_the_v ★★★ ()

А почему не PostgreSQL? Или ты адепт Оракла?

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Ты писатель херни. Где было написано исключительно про RHEL?

kukara4 ★★ ()

default_service_listener=xe, а sid_name=SOFFP, не в этом ли дело ?

nt_crasher ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.