LINUX.ORG.RU

Установка Oracle на 11.10


0

1

Никак не выходит, как только делаю sudo /etc/init.d/oracle-xe configure так вылетает

Starting Oracle Net Listener...touch: cannot touch `/var/lock/subsys/listener': No such file or directory Done Configuring database... Database Configuration failed. Look into /u01/app/oracle/product/11.2.0/xe/config/log for details

В логах фигурирует ошибка

ERROR at line 1:
ORA-01034: ORACLE not available
Process ID: 0
Session ID: 0 Serial number: 0


как тут быть?

Перемещено JB из Development


sudo touch /var/lock/subsys/listener не канает?

backbone ★★★★★ ()
Ответ на: комментарий от backbone

mkdir-нул subsys сработало но Database Configuration failed. Look into /u01/app/oracle/product/11.2.0/xe/config/log for details осталось, с той-же ошибкой.

vsrmis ()

> `/var/lock/subsys/listener': No such file or directory

Что не понятно?

mkdir /var/lock/subsys ?

r2d2 ()

Что такое 11.10? Default Linux?

mv ★★★★★ ()

Либо ставь на текущий LTS, либо дождись апреля, когда выйдет следующий LTS. Либо ставь на debian stable.

cab ★★★★ ()
Ответ на: комментарий от cab

Вполне можно и в виртуалку засунуть - запаса мощи для того оракела хватит с головой, большого проседания по перфомансу все равно не будет.

cab ★★★★ ()
Ответ на: комментарий от vsrmis

Совет использовать LTS - только из-за длительной поддержки и более-менее общей вылизанности. Тот оракл ведь зависимости не обновляетю.
Я лично попробовал бы на стабильном дебиане. А оракел ХЕ у меня отлично работал на прежнем LTS.
И еще - я бы не рекомендовал для продакшена этот оракел. Хоть он лицензионно чист и относительно быстрый, но и место там жрется не в свою меру. Тоесть годится для обучения и подсадивания клиента. Если по уму делать советую либо постгресс, либо бесплатный DB2. Практичней по-любому будет. Даже бесплатный MS-совский намного лучше.

cab ★★★★ ()
Ответ на: комментарий от cab

Пока что ставлю для обучения. так что сойдёт. Спасибо. Поставил на Убунту 10.04. Работает.

vsrmis ()
Ответ на: комментарий от vsrmis

Пока что ставлю для обучения

Для обучения можешь нормальный поставить, оракловцы его и так роздают. Он полнофункциональный, его только нельзя в продакшене использовать и обновления недоступны.

cab ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.