LINUX.ORG.RU
ФорумAdmin

сеть на virtualbox

 


0

1

Доброго времени суток! Пытаюсь в целях самообучения настроить сеть в virtualbox-е из 3 виртуалок с debian. Для этого: 1. Создала виртуальную машину на ubuntu 12.04 с Debian (NAT, по умолчанию). 2. Установила необходимые пакеты, такие как: bind9, samba, etс. 3. Настроила /etc/network/interfaces следующим образом:

iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
dns-nameservers 192.168.0.1

(не указывать днс пробовала, результат был тот же) 4. после этого виртуалка была клонирована с изменением mac-адреса, и в настройках сети выставлена «внутренняя сеть». в /etc/network/interfaces на каждой виртуалке прописан свой ip адрес (192.168.0.2 и 192.168.0.3 соответственно).

В результате ifconfig выдает только lo, eth0 не виден. Иногда eth0 бывает виден , но виртуалки не пингуют друг друга. Что я делаю неправильно? Мечтаю о своей сети на виртуалках, pls, help )))

Мечтаю о своей сети на виртуалках

Мне такое в голову еще не приходило... UPD: Я так понимаю, что ты запускаешь несколько виртуалок и всё? Они ничего друг о друге, по идее, не знают.

coderage ()
Последнее исправление: coderage (всего исправлений: 1)
Ответ на: комментарий от coderage

Они находятся в одном диапазоне ip-шников, во «внутренней сети» - поидее должны пинговаться.

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Я такими извращениями никогда не занимался :) Но опять же, предположительно, это то же самое, что поставить рядом несколько компьютеров, задать им всем одну подсеть, не соединять их кабелем, но ждать, что они друг друга увидят.

Подождем лучше комментов от кого-нибудь еще.

coderage ()

помниццо, там надо виртуальный маршрутизатор настраивать, нет? а может это на вмваре было...

foreigner_web ()
Ответ на: комментарий от coderage

Делала точно так с виндой, там был dhcp на ad и клиентская машина тоже получала от нее по dhcp. Там работало без дополнительных настроек, с «внутренней сетью» только. И пинговалось и виделись шары. То есть я к тому, что как вы написали, компы поставлены рядом, и уже соединены кабелями.

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

про «сетевой мост» сказали уже?

anonymous ()

настрой мост и сетевые карты вируалок прикручевай к нему

vxzvxz ★★★ ()

Как настроена адаптеры у виртуалок? По умолчанию виртуалбокс сажает их за НАТ, в этом случае они друг друга видеть и не должны.

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от ya-betmen

По умолчанию был NAT, после установки пакетов у всех виртуалок в параметрах адаптера была выставлена «внутренняя сеть» с одинаковым именем.

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Хм, я конечно не гуру в виртуалбоксе, но я бы просто выставил всем один виртуальный адаптер, виртуалбокс имеет собственный DHCP, поэтому все interfaces можно фтопку (есть только статик ip прописывать, но это зло).

ya-betmen ★★★★★ ()
Ответ на: комментарий от ya-betmen

Как раз Static ip и был прописан (код в первом посте). Собственно, и есть один адаптер.

Technoblondinka ()

В результате ifconfig выдает только lo, eth0 не виден...

сотрите /etc/udev/rules.d/70-persistent-net.rules

mycop ()
Ответ на: комментарий от mycop

в виртуалке этого файла не было, нашелся /etc/udev/rules.d/70-persistent-cd.rules. стерла на всяк. случай - безрезультатно (ifconfig выдает только Lo)

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Ну вы похоже по интерфейсам разминулись, есть предположение что ваш сетевой адаптер это не eth0.

Можно взглянуть на VBoxManage showvminfo <vm name> | grep NIC? (Или даже весть VBoxManage showvminfo <vm name>.)

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от ya-betmen
user@linuxtest02:~$ vboxmanage showvminfo Debian | grep NIC
NIC 1:           MAC: 080027A65D61, Attachment: Internal Network 'intnet', Cable connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Хм, пропустил это сообщение.

Создаёте в виртуалке файл
/etc/udev/rules.d/70-persistent-net.rules

SUBSYSTEM==«net», ACTION==«add», DRIVERS=="?*", ATTR{address}==«<mac address>», ATTR{dev_id}==«0x0», ATTR{type}==«1», KERNEL==«eth*», NAME=«eth0»

В /etc/network/interfaces оставляете только

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.10
netmask 255.255.255.0

После этого перегружаете виртуалку и у вас там должен подняться интерфейс eth0 с адресом 192.168.0.10

ya-betmen ★★★★★ ()

Когда ты сменил тип интерфейса с NAT на intnet, у тебя в гостевой системе сетевуха переехала с eth0 на eth1.

Меняй имя в /etc/network/interfaces.

thesis ★★★★★ ()

1. Респект что женщина.
Так все правильно и описано. nat.
Там еще способы есть.
Попробуй сделать тупо 'сетевой мост'.

Забыл.
в /etc/network/interfaces делать ничего не нужно.

hbars ★★★★★ ()
Последнее исправление: hbars (всего исправлений: 1)
Ответ на: комментарий от Technoblondinka

в виртуалке этого файла не было, нашелся /etc/udev/rules.d/70-persistent-cd.rules.

А какие ещё файлики лежат в /etc/udev/rules.d ?

ya-betmen ★★★★★ ()
Ответ на: комментарий от ya-betmen

В /etc/udev/rules.d после создания файла /etc/udev/rules.d/70-persistent-net.rules - как на скриншоте http://imgur.com/NnLQ4Wb после этих действий ifconfig выводил только Lo. два других предложенных способа (тупо «сетевой мост» и переименовывание eth0 в eth1, испробованные по очереди) - не сработали (ifconfig упрямо выводил только lo). На данный момент, виртуалки удалены и созданы заново, с настройками по умолчанию (nat и тд), при этом у клонированной виртуалки и у установленной повторно одинаковые ip-шники. http://imgur.com/gUONcZZ Есть ли у кого-нибудь еще соображения?

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Всё замечательно, но <mac address> следовало заменить на мак адрес виртуальной сетевухи и всё бы заработало. Погуглите по теме udev rules, всё подробно описано.

НАТ в данном случае не подойдёт.

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от ya-betmen

При клонировании виртуалок была поставлена галочка «сгенерировать новый mac address». насколько я понимаю, в данном случае это условие выполняется же?

Technoblondinka ()
Ответ на: комментарий от coderage

Мне такое в голову еще не приходило...

а некоторым даже виртуальное сетевое оборудование приходило. и даже пришло.

mos ★★☆☆☆ ()
Ответ на: комментарий от Technoblondinka

Не могу ответить на вопрос, т.к. не понял его. Поэтому просто краткий ликбез.

Смотрите, у вашей виртуальной сетевушки есть мак адрес. Этот мак адрес (по идее разный у каждой ВМ) дожен быть прописан в правиле udev (пресловутый /etc/udev/rules.d/70-persistent-net.rules), где к маку прицепится сетевой интерфейс (например eth0). Только после этого записи в /etc/network/interfaces будут иметь смысл, т.к. иначе у вас просто не будет сетевого интерфейса внутри виртуальной ОС.

Т.е. для каждой ВМ создайте /etc/udev/rules.d/70-persistent-net.rules, пропишите в него то, что я написал выше, но при этом замените <mac address> на ваш виртуальный мак.

PS. Не заставляйте меня шутить про вторую часть вашего ника.

ya-betmen ★★★★★ ()
Ответ на: комментарий от ya-betmen

Проблема решилась изменением /etc/network/interfaces как на скриншоте, без создания файла /etc/udev/rules.d/70-persistent-net.rules, все 4 виртуалки друг друга видят. В настройках virtualbox - «внутренняя сеть».

http://imgur.com/Vh1gG67

Technoblondinka ()
Ответ на: комментарий от Technoblondinka

Ну я давал совет учитывая это

/etc/network/interfaces на каждой виртуалке прописан свой ip адрес (192.168.0.2 и 192.168.0.3 соответственно

и это

в виртуалке этого файла [/etc/udev/rules.d/70-persistent-net.rules] не было

Ситуация должна быть абсолютно такой же. Впрочем раз проблема решена то уже неважно.

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от ya-betmen

В итоге, я так поняла, редактирование /etc/network/interfaces по образцу который вы написали и помогло. Спасибо. Далее буду пытаться настраивать dns на этих виртуалках, надеюсь, своими силами получится.

Technoblondinka ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.