LINUX.ORG.RU

2
Всего сообщений: 116

Не работает touchpad после обновления arch

Обновил сегодня arch

# pacman -Syy
# pacman -Su
После чего у меня тачпад перестал работать.

В System Settings написано

No touchpad found

# lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 0bda:5648 Realtek Semiconductor Corp. VGA WebCam
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04ca:3015 Lite-On Technology Corp. 
Bus 001 Device 002: ID 09da:9090 A4Tech Co., Ltd. XL-730K / XL-750BK / XL-755BK Mice
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
$ cat /usr/share/X11/xorg.conf.d/70-synaptics.conf 
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection 

 , , ,

Hi ()

Upgrade без удаления пакетов

Приветствую.

Upgrade без удаления пакетов, такое возможно? Когда обновлялся c 14.04 до 16.04 установщик снес фигову тучу нужных пакетов, которые перестали поддерживаться.

Если пакет был удален из репозитория, как бы считать, что в апрейженной версии этот пакет установлен вручную...

 , ,

Bill_Baklushi ()

Обновление системы. Ошибка. (ещё не созданы или были удалены из Incoming)

apt upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 gnustep-base-runtime : Зависит: gnustep-base-common (= 1.26.0-4) но 1.24.9-3.1 будет установлен
 libgnustep-base1.26 : Зависит: gnustep-base-common (= 1.26.0-4) но 1.24.9-3.1 будет установлен
E: Сломанные пакеты

Как это лечить и что делать, что бы обновить систему?

uname -a

Linux HOME_SERVER 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux

 ,

macik ()

Можно ли ещё досыпать памяти?

Есть довольно убогий ноут, на котором доводится сейчас работать (Asus X555LJ). В нём изначально шло 4Гб рам, что очень мешало, потому что система тупо вешалась периодически и своп не помогал. В спецификации написано, что максимум можно увеличить по 8Гб, но я на свой страх взял плашку на 8 в дополнение к четырём имеющимся, и сейчас суммарные 12 прекрасно работают. И вот вопрос в чём, можно ли ещё увеличить объём? Можно ли как-то это проверить иными способами, кроме метода тыка?

 , , , ,

beaver ()

Lenovo Yoga 710-15IKB - memory upgrade

Задумал память добавить в ноут.

Читаю форум https://forums.lenovo.com/t5/Lenovo-Yoga-Series-Notebooks/Yoga-710-15-quot-RAM-Upgrade/td-p/3370497 - пишут, что несложно добраться. Ок.

Вот сервисная книжка https://download.lenovo.com/consumer/mobiles_pub/yoga_710-14isk_14ikb_15isk_15ikb_hmm_201605.pdf - Ок.

Тут пишут про подходящие комплектующие https://www.crucial.com/ScanListView?modelCatId=1651519&storeId=14152&urlRequestType=Base&modelTypeDisplay=&manuFacturer=Lenovo&msg=compatible-upgrade-for&langId=-20&catalogId=14152 - ок.

На выбор ищу в ДНС:

  1. https://www.dns-shop.ru/product/228337fce6a23330/operativnaa-pamat-sodimm-crucial-ct16g4sfd824a-16-gb/

  2. https://www.dns-shop.ru/product/ba9dcf783eb23330/operativnaa-pamat-sodimm-kingston-valueram-kvr24s17d816-16-gb/

  3. https://www.dns-shop.ru/product/e7c2e07d64d13332/operativnaa-pamat-sodimm-crucial-basics-cb16gs2400-16-gb/

  4. https://www.dns-shop.ru/product/38c4681e33581b80/operativnaa-pamat-sodimm-goodram-gr2666s464l1916g-16-gb/

  5. https://www.dns-shop.ru/product/12bc65a512053330/operativnaa-pamat-sodimm-crucial-ct16g4sfd8266-16-gb/

  6. https://www.dns-shop.ru/product/0fcc30be2dd83332/operativnaa-pamat-sodimm-goodram-iridium-ir-2666s464l1616g-16-gb/

  7. https://www.dns-shop.ru/product/96288447e6441b80/operativnaa-pamat-sodimm-samsung-m471a2k43cb1-ctd-16-gb/

Вопрос: на оф. сайте пишут, что поддерживается до 3200 частота памяти. Но https://realadmin.ru/perefiriya/markirovka-operativnoj-pamyati.html тут указано, что для i7 7го поколения максимум - 2666. Где правда?

И какую фирму выбрать? Сейчас стоит вот что:

> sudo dmidecode --type 17

Handle 0x0025, DMI type 17, 40 bytes
Memory Device
	Array Handle: 0x0024
	Error Information Handle: No Error
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 8192 MB
	Form Factor: SODIMM
	Set: None
	Locator: ChannelA-DIMM0
	Bank Locator: BANK 0
	Type: DDR4
	Type Detail: Synchronous
	Speed: 2133 MT/s
	Manufacturer: Samsung
	Serial Number: 0306A621
	Asset Tag: 9876543210
	Part Number: M471A1K43CB1-CRC    
	Rank: 1
	Configured Memory Speed: 2133 MT/s
	Minimum Voltage: 1.25 V
	Maximum Voltage: 1.5 V
	Configured Voltage: 1.2 V

 , , , ,

bvn13 ()

ASUS-ZenBook-UX303L установка доп. памяти

никто не подмкажет сколько памяти можно доставит 4 или 8.

https://www.asus.com/Laptops/ASUS-ZenBook-UX303LN/specifications/

что-то я торможу...

 , ,

samy_volosaty ()

Как продолжить обновление Ubuntu 14.04 -> 16.04?

Обновил на ноутбуке с Ubuntu 14.04 до 16.04, всё прошло идеально как часики, заработало всё как прежде. Решил что обновление сработает нормально и на основном ПК.

Поставил обновляться, утром вижу что скрипт обновления висит в каком-то месте после какого-то пакета на этапе замены версий пакетов. Сделал софт-ребут - система не грузится.

Возможно ли как-то продолжить обновление? Или как-то его запустить заново и довести до конца? Там 95% примерно пакетов успешно обновилось...

Осложняется тем, что хомяк шифрован. Думаю это не проблема должна быть. На крайняк, есть внешний USB HDD на 1 Тб и я спокойно выцеплю свои полудрагоценные данные и установлю заново (драгоценные фоты хранятся еще на другом отдельном USB HDD), но может есть способ всё же выправить ситуацию?

Я там Xubuntu desktop наворачивал, возможно этот эксперимент подкосил ненадежный скрипт обновления, в котором не додумались сделать пропуск каких-то этапов второстепенной важности типа не базовых пакетов. Еще драйвер nVidia ставил отдельно из run-инсталлятора, а не из реп ввиду новизны карты на тот момент.

Решение найдено, подробности в моем последнем сообщении в теме: Как продолжить обновление Ubuntu 14.04 -> 16.04? (комментарий)

 ,

I-Love-Microsoft ()

Во время обновления с Дебиан 9.9 до 10 стал мигать экран

Недавно установленный Дебиан 9.9 еще чистый абсолютно почти кроме кучи ДЕ которые были установлены с нетинстала.

Апгрейд шел гладко. Этап скачивания закончился и начался этап установки. Я отошел от пк. Вернувшись увидел это. На ctr+F1-F7 никак не реагировал кроме этого. ctr+shift+backspace не помогает.

Xorg, xfce, lightdm

Что можно сделать?

UPD
через минут 15 єкран перестал мигать и появилось приглашение входа lightdm, но при попытку войти получаю это

могу войти в другие консоли

UPD2
Не понял что нажал на клаве но блокировка снялась, установка продолжается...

 ,

deepforest ()

Full desktop upgrade

Всем привет. Пришло время обновить/выкинуть свой старый ПэКа и обзавестись новыми железками. Накидал вот такое. Не могу определиться с RAM'ой :-( По сути мне 8Gb хватит с головой, но можно, конечно и рассмотреть вариант до 16-32. Если будут комментарий по списку, буду рад их прочесть также :)

 , ,

ubik ()

Куда девается свободное место?

Не могу обновиться, система пишет недостаточно соводно места

Подготовка к распаковке …/00-gnome-theme-kali_2019.2.0_all.deb …
Распаковывается gnome-theme-kali (2019.2.0) на замену (2018.3.0) …
dpkg: ошибка при обработке архива /tmp/apt-dpkg-install-OSEbnj/00-gnome-theme-kali_2019.2.0_all.deb (--unpack):
 не удалось создать «/usr/share/icons/Vibrancy-Kali/apps/22/onboard.png.dpkg-new» (при обработке «./usr/share/icons/Vibrancy-Kali/apps/22/onboard.png»): На устройстве не осталось свободного места
dpkg-deb: ошибка: вставка subprocess was killed by signal (Обрыв канала)
gtk-update-icon-cache: Failed to open file /usr/share/icons/Vibrancy-Kali/.icon-theme.cache : На устройстве не осталось свободного места
WARNING: icon cache generation failed for /usr/share/icons/Vibrancy-Kali
gtk-update-icon-cache: Failed to open file /usr/share/icons/Vibrancy-Kali-Dark/.icon-theme.cache : На устройстве не осталось свободного места
WARNING: icon cache generation failed for /usr/share/icons/Vibrancy-Kali-Dark
gtk-update-icon-cache: Failed to open file /usr/share/icons/Vibrancy-Kali-Full-Dark/.icon-theme.cache : На устройстве не осталось свободного места
WARNING: icon cache generation failed for /usr/share/icons/Vibrancy-Kali-Full-Dark
dpkg: unrecoverable fatal error, aborting:
 не удалось создать «/var/lib/dpkg/updates/tmp.i»: На устройстве не осталось свободного места

Хотя

root@kali:~# df -h
Файловая система         Размер Использовано  Дост Использовано% Cмонтировано в
udev                       456M            0  456M            0% /dev
tmpfs                       93M          11M   82M           12% /run
/dev/mapper/crypt_sdcard    29G          15G   13G           53% /
tmpfs                      464M            0  464M            0% /dev/shm
tmpfs                      5,0M            0  5,0M            0% /run/lock
tmpfs                      464M            0  464M            0% /sys/fs/cgroup
/dev/mmcblk0p1              61M          29M   33M           47% /boot
tmpfs                       93M          16K   93M            1% /run/user/0
tmpfs                       93M         4,0K   93M            1% /run/user/109

В чем загвоздка?

 , ,

Kaernk ()

Обновился с testing до sid - обнова была всего 11мб и ядро теперь 4.19, это нормально?

?

 , ,

deepforest ()

Гайд как научить ПК больше ОЗУ чем заложено производителем

https://www.downtowndougbrown.com/2019/04/adventures-of-putting-16-gb-of-ram-...
Суть в правке ACPI таблиц BIOS
Переводить не буду

 , , , ,

bga_ ()

модернизация дисковой системы в ноуте

Есть относительно старый ноут, в котором два физических диска: ssd 256 Gb (/) и hdd ~730 Gb (/home). Оба диска на SATA интерфейсе, других интерфейсов нет по причине возраста ноута.

Вопрос в том, есть ли резон(ы) заменить hdd на ssd 500 Gb. Торренты не качаю, в игрушки не играю. Комп в основном используется для счёта.

 , ,

miron_g ()

apt upgrade не обновляет

# apt update
...
3 packages can be upgraded. Run 'apt list --upgradable' to see them.
# apt list --upgradable
Listing... Done
python3-distutils/bionic,bionic 3.7.3-1ubuntu1~18.04.york1 all [upgradable from: 3.7.1-1~18.04.york0]
python3-gdbm/bionic 3.7.3-1ubuntu1~18.04.york1 amd64 [upgradable from: 3.7.1-1~18.04.york0]
python3-lib2to3/bionic,bionic 3.7.3-1ubuntu1~18.04.york1 all [upgradable from: 3.7.1-1~18.04.york0]
# apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded

Как это понять?

 ,

beaver ()

Обновление Ubuntu 14.04 до 16.04

Всем привет. Есть ноутбук Lenovo Ideapad B50-10 с Ubuntu 14.04.5. Так как срок поддержки у нее истекает в апреле, было решено ее проапгрейдить до следующего LTS. Возможно ли это сделать на «живой» системе? Раньше так делал и получалось. А как теперь, у кого-нибудь есть истории успеха? Поделитесь ими, пожалуйста, желательно в виде рецептов или ссылок на таковые. Всем спасибо.

 , ,

LongLiveUbuntu ()

Suse. Command was killed by signal 11 (Segmentation fault)

Была (а похоже и осталась) версия Suse 42.3 Удрал старые, поставил новые репозитории от leap 15. Удали часть софта. zypper dup повылезало много ошибок типа «Command was killed by signal 11 (Segmentation fault)».

Переход - состоялся. Взял дистрибутив 15, поставил на обновление. Те же ошибки при обновлении. Внешнее, система изменилась. Друге шрифты, xfce новее и т.д. но версию кажет (старую) уже новую.

Много искал в сети информации, но все не то. Заранее спасибо!

 , , ,

stslit ()

Slackware автоматическая сборка нового ядра

Доброго дня, может у кого-нибудь есть уже готовый bash-скрипт для автоматической сборки и обновления ядра linux который можно запихнуть в cron? Т.е при запуске проверяет на kernel.org новую версию, качает исходник, распаковывает, конпеляет, опакечивает всё в txz, устанавливает, обновляет grub.cfg. Знаю, что можно самому написать, но может такой велосипед уже у кого-то есть?

 , ,

sholmes ()

замена процессора в ноутбуке

Задумался о целесообразности замены процессора в ноутбуке. Материнка acer v3-571g, i5 2450m на сокете g2, 35w. Пока вижу два стула варианта:

  • найти на условной барахолке i7, например, исходя из тепловыделения и производительности 3632QM. Сравнение;
  • снять с другого ноутбука i7 2670QM (45w), но будет горячо, а пересобирать придется меньше. Сравнение.

Хочу более лучше компилять, генту там, игры — вот это всё. Стоит ли вообще затевать такой апгрейд?

PS: SSD есть, RAM по максимуму.

 , , ,

parar ()

Обновить nginx c 1.15.3 до 1.15.7 centos 7

Как безопасно всё сделать с сохранением всех настроек .conf ?

P.S.

Если возможно пошагово (мануал в сети ненагуглил :( )

 , ,

suffix ()

Обновить PHP - Смена версии

Добрый день.

Имеется приложение FileRun, позволяющее развернуть файлопомойку с веб-доступом внутри организации. Проблема в том, что она требует для своей работы ioncube и PHP 5.6/7. На сервере установлена PHP 5.5.

После apt-get remove php5 php5-common php5-cli всё удаляется. Затем я качаю и устанавливаю PHP5.6 из исходников и он устанавливается, но система продолжает работать «в режиме PHP 5.5». В чём может быть дело?

Установлена древняя Ubuntu 14.04. Подключить PPA-репозиторий для обновления не представляется возможности в следствии корявости используемого Proxy. Что можно сделать в данной ситуации?

Прямо сейчас я пробую установить последнюю версию CentOS и вкорячить всё туда, включая перенос БД. Но есть проблема. Дело в том, что на том-же сервере находится база ГОСТов в виде веб-интерфейса. И я нигде не могу найти и скачать её дистрибутив со всей документацией. Конечно-же, я могу попробовать перенести старую базу, но она работает полностью на JS и я понятия не имею, как это всё будет работать.

Буду признателен за любую помощь.

UPD. Альтернатива - сделать так, чтобы при вводе внутреннего адреса открывался внешний ресурс, но это было незаметно для стороннего наблюдателя. Это скорее всего решит мою проблему на корню.

 , ,

zerropull ()