LINUX.ORG.RU

19
Всего сообщений: 210

purge xfce4-pulseaudio-plugin не удаляя xfce4

в общем, тут на форуме посоветовали, если уж поставил devuan, то удаляй все поделки поттеринга, пытаюсь удалить pulseaudio, выдает вот такую фигню

The following packages have unmet dependencies:
 xfce4 : Depends: xfce4-pulseaudio-plugin but it is not going to be installed

соответственно предлагает удалить xfce4, как удалить пакет xfce4-pulseaudio-plugin не удаляя xfce4, подумал, переписать зависимости в xfce4 control.tar.xz и создать локальный репозиторий с переписанным пакетом, но придется тогда менять версию xfce4 и переписывать зависимости всех пакетов, которые завязаны на xfce4, это не реально, есть ли простой способ?

 , , ,

IvanR ()

Кто собирал пакеты для Debian? Прошу помощи

Доброго дня, ЛОР!

У кого есть опыт, прошу поделиться: есть ли какая-нибудь деректива в пакете, которая может исполнить bash-сценарий ДО начала установки зависимостей, указанных у этого пакета. Конкретно нужно несколько вызовов debconf-set-selections, чтобы пакеты в зависимостях установились с заранее выбранными ответами без интерактивного окна.

Большое спасибо! Буду очень рад, если такой инструмент имеется :)

 , ,

rmu ()

Debian не видит всей ОЗУ

Приветствую.

В ноуте стоит 2 плашки по 8 ГБ. По характеристикам бука это максимальный объем озу, который он может переварить (объем и частоту проверял на сайте производителя бука и процессора). Смотрю командой dmidecode –type 17, все как надо

https://i.imgur.com/kvLotf3.png

Но если посмотреть через less /proc/meminfo, картина совсем грустная, показывает, что памяти 6,75 ГБ

  • MemTotal: 7076368 kB
  • MemFree: 3226264 kB
  • MemAvailable: 3880964 kB

Как так-то ? Как сказать системе использовать всю возможную память, а не меньший ее кусок ?

Спасибо

 ,

Azel ()

Как обновить libgtk до 3.0-18

У меня дебиан, кажется jessie, в системе и репозитариях похоже стоит 3.0 3.14 ставлю pulse-effects, и он требует >=3.18, как поставить?

 , , ,

libgtk318 ()

форматы пакетов

на мой взгляд, наиболее изящный формат пакетов - это deb. идея запихать метаинформацию и собственно файлы в два разных тарбола и связать их ar-ом - гениальна в своей простоте. никакие rpm и прочие t?z с этим не сравнятся.

 , , ,

ananas ()

Конвертировать deb в appimage

У меня линукс Fedora, разработчик приложения выложил deb пакет. Возможно ли сконвертировать deb пакет в appimage на Fedora? Либо в rpm пакет, но устанавливать rpm пакет не хотелось бы, удобнее запускать через appimage

 ,

dimagra ()

imagepng Не сохраняет изборажение

Код такой (php)

imagepng($pic, "/home/vvediteima/photo.png"); // Сохранение рисунка

$pic - Это изображение, тут ошибок нет, если путь не указывать, то оно выводится в бинарном виде. Но если указать путь, то пишет

PHP Warning:  imagepng(/home/vveditima/photo.png): failed to open stream: No such file or directory in /home/vvediteima/tr.php on line 15

Где ошибка?

 , ,

vvediteima ()

Запустить python через apache2

Как запустить Файл на python3.7 через apache2. Можно прям додробную инструкцию с нуля

 , ,

vvediteima ()

Кросс-сборка DEB-пакета для другой архитектуры

Всем здравствуйте.

Собственно, для начала хочу научиться собирать пакеты для x86 и x32 ABI на amd64-хосте.

Статью CrossCompiling на Debian Wiki видел.

Насколько я понимаю, есть два официально одобренных инструмента – sbuild (восход Солнца вручную) и pbuilder (всё достаточно автоматизировано, но до уровня Docker не дотягивает).

Вопросы:

  • почему (для решения тех же задач) так непопулярен Docker? Смотрю на PackagingWithDocker – и это какой-то позор. Такое ощущение, что на wiki.debian.org пишут исключительно старцы в маразме, государственные чиновники и дети-инвалиды.

    • При этом исправить самому нет никакой возможности: регистрация уже несколько лет, как не работает:

      Account creation failed: Automatic account creation disabled to stop spammers signing up. Please contact wiki@debian.org and describe what you want to do in the wiki. Please contact us in English, otherwise we will have to pass your message to online translation services.

      Ау, вы сеьёзно?! 21-й век на дворе, а вы не можете справиться со спамерами?! Я, чёрт побери, хочу править вашу убогую Wiki, чтобы сделать её чуточку лучше. Какое ещё описание вам нужно?

  • как наладить сборку с помощью CI-сервера (Jenkins/TeamCity/другого)? Я когда-то сам писал статью на эту тему, но мой опыт – это исключительно самодеятельность, и с жизненным циклом дебиановского пакета оно вяжется плохо.

  • как организовать сборку, имея пул не локальных Docker-контейнеров, а доступных по сети физических или виртуальных машин с целевой архитектурой и окружением?

 , , ,

Bass ()

Пересборка DEB-пакета с собственными настройками

Всем здравствуйте.

Хочу пересобрать дебиановский пакет, слегка изменив настройки (либо добавив ключи при вызове configure, либо наложив несколько мелких патчей).

Upstream-версия останется той же.

Бинарная совместимость (пересобираю библиотеку) сохранится.

Хочется (и это логично), чтобы пересобранный пакет был отличим от пакета из репозитория Debian.

Этого можно добиться двумя способами:

  1. Слегка инкрементировав версию (1.2.3-4+deb10u2 -> 1.2.3-4+deb10u2~vasyapupkin). При этом, если параллельно не заморачиваться с apt pinning, после обновления по-прежнему можно затереть «свой» пакет версией из репозитория.

  2. Переименовав пакет (libfoo42 -> libfoo42-vasyapupkin provides libfoo42).

Вопросы:

  1. Какой из вариантов каноничнее?
  2. Как организовать систему веток и git remote’ов, чтобы можно было не только разово собрать, но и периодически делать merge из upstream и из Debian?
  3. Быть может, вопрос не нов, и на эту тему уже что-то написано?

 ,

Bass ()

deb archives

установленные онлайн с фидов deb пакеты хранятся в var/cache/apt/archives , но это почему то не наблюдается у большей части имиджей Dream os ( enigma2 ) Подскажите , где и как найти в системе пакеты устанавливаемые с фида если они отсутствуют по выше указанной директории ?

 

wrath ()

cdesktopenv precompiled для Linux Mint

Хочу поставить CDE, но собирать его очень долго. Есть ли где-то в природе .deb-пакет?

 ,

eugrus ()

Cinelerra deb 10

У меня deb10 amd64, мне нужно установит cinelerra, я пытался установить через apt install, но ничего не получилось, погуглил, нашел просто пакеты, по устанавливал их, ничего не вышло. ПАМАГИТИ

 , , ,

vvediteima ()

Выгибающаяся скорость видео

В видеоредакторе Sony Vegas есть такой эффект, как ВЫГИБАЮЩАЯСЯ СКОРОСТЬ. В каком из видеоредакторов Линукс есть такой эффект?

 , , ,

vvediteima ()

Discord не видит устройства ввода-вывода

У меня Debian GNU/Linux 10 (buster), в какой то момент Discord перестал видеть устройства ввода-вывода. То есть не дает их выбрать (скрин http://3.120.174.176/photo.png). В чем проблема?

 , , ,

vvediteima ()

Нужна помощь в создании пакетов .deb и Appimage для Cine Encoder 2020

Всем привет!

Я застрял я на создании пакетов .deb и Appimage для Cine Encoder. Программа написана на Python3, что-то не понятно даже с чего начать. Кругом какая-то разрозненная информация, не могу в кучу всё собрать, чтоб можно было пошагово это сделать.

 , ,

Oleg1980 ()

Где взять пакет OpenCV 3 для Ubuntu 20.04?

В новой убунте выкинули OpenCV 3. Теперь там четвёртая версия. У меня софт использует третью. В нём много вызовов методов из OpenCV Contrib, которых нет в четвёртой. Софт писал не я, во всяких видеоаналитиках не разбираюсь, поэтому сам портировать не могу.

Мне нужен именно пакет, т.к. я эту свою софтину запакую и буду распространять в deb и хочу по зависимостям связываться с OpenCV 3. Так что вариант со сборкой в /opt не подходит. Поэтому у меня возник извечный русский вопрос: кто виноват и что делать? Вот у себя в арчике я из aur накатил, а убунтуводы в пролёте. Что как бы намекает на ненужность некоторых дистрибутивов.

 , , , ,

ox55ff ()

где взять утилиту ifdtool под убунту?

где взять утилиту ifdtool под убунту?

вроде как она должна быть в https://www.coreboot.org/downloads.html но там в сорсах в tools ее не увидел

 

Regacar ()

Установка пакетов в подмонтированный образ диска

Добрый день! Есть система ubuntu-18.04.1, есть файл, образ диска другой системы, то же ubuntu-18.04.1 и той же архитектуры что и хост. Этот образ успешно монтируется. Как то можно установить пакеты в систему этого подмонтированного образа? Раньше в таком случае тупо загружался с этого образа, сейчас возможности так сделать нет, надо поправить образ удаленно.

 , ,

NVN ()

Прошу подтверждения бага - не работает gdebi на 18.04

Xubuntu 18.04.

При попытке установки пакета через gdebi-gtk он просто закрывается.

Если попробовать то же самое в консольной версии (на которой построен gdebi-gtk), то:

alex@ThinkPad-L560:~/downloads/dists$ sudo gdebi ./zoom_amd64_2.deb 
[sudo] пароль для alex: 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done

Zoom, #1 Video Conferencing and Web Conferencing Service 
 Zoom, the cloud meeting company, unifies cloud video conferencing, simple online meetings, and group messaging into one easy-to-use platform. Our solution offers the best video, audio, and screen-sharing experience across Zoom Rooms, Windows, Mac, Linux, iOS, Android, and H.323/SIP room systems.
Вы хотите установить этот пакет? [д/Н]y

alex@ThinkPad-L560:~/downloads/dists$ echo $?
0

alex@ThinkPad-L560:~/downloads/dists$ sudo gdebi ./zoom_amd64_2.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done

Zoom, #1 Video Conferencing and Web Conferencing Service 
 Zoom, the cloud meeting company, unifies cloud video conferencing, simple online meetings, and group messaging into one easy-to-use platform. Our solution offers the best video, audio, and screen-sharing experience across Zoom Rooms, Windows, Mac, Linux, iOS, Android, and H.323/SIP room systems.
Вы хотите установить этот пакет? [д/Н]д
(Чтение базы данных … на данный момент установлено 277074 файла и каталога.)
Подготовка к распаковке ./zoom_amd64_2.deb …
Распаковывается zoom (5.0.418682.0603) на замену (3.5.361976.0301) …
run post uninstall script, action is upgrade ...
Настраивается пакет zoom (5.0.418682.0603) …
run post install script, action is configure...
Обрабатываются триггеры для gnome-menus (3.13.3-11ubuntu1.1) …
Обрабатываются триггеры для desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
Обрабатываются триггеры для shared-mime-info (1.9-2) …

Предполагаю, что проблема в том, что он перестал реагировать на английские y/N, которые гуй ему и посылает.

 ,

PPP328 ()