LINUX.ORG.RU

Сообщения zero_one_two

 

Не загружается винда в grub2

Всем привет. Стоит opensuse, разбил диск и установил windows 10. Добавил её в grub, а она не запускается. В grub она есть.

вывод fdisk:


/dev/nvme0n1p1      2048   1050623   1048576  512M EFI System
/dev/nvme0n1p2   1050624   1067007     16384    8M BIOS boot
/dev/nvme0n1p3   1067008 164907007 163840000 78.1G Linux filesystem
/dev/nvme0n1p4 164907008 250066943  85159936 40.6G Microsoft basic data

вывод os-prober:

/dev/nvme0n1p4:Windows 10:Windows:chain

вывод grub2-mkconfig -o /boot/grub2/grub.cfg:


Generating grub configuration file ...
Found theme: /boot/grub2/themes/openSUSE/theme.txt
Found linux image: /boot/vmlinuz-5.15.12-1-default
Found initrd image: /boot/initrd-5.15.12-1-default
Found linux image: /boot/vmlinuz-5.15.8-1-default
Found initrd image: /boot/initrd-5.15.8-1-default
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows 10 on /dev/nvme0n1p4
done

вывод из grub.cfg:

248 menuentry 'Windows 10 (on /dev/nvme0n1p4)' --class windows --class os $menuentry_id_option 'osprober-chain-F6DA31B2DA31704B' {
249         insmod part_gpt   
250         insmod ntfs
251         set root='hd0,gpt4'
252         if [ x$feature_platform_search_hint = xy ]; then
253           search --no-floppy --fs-uuid --set=root --hint='hd0,gpt4'  F6DA31B2DA31704B
254         else
255           search --no-floppy --fs-uuid --set=root F6DA31B2DA31704B
256         fi
257         drivemap -s (hd0) ${root}
258         chainloader +1
259 }

 , ,

zero_one_two ()

Всем Привет. Проблема со snap в Opensuse Tumbleweed

Возникла проблема с установкой снапа в opensuse Tumbleweed. При запуске демона выдает ошибку и ссылает на journalctl, я чекнул, но ничего не понимаю. Помогите пожалуйста.

Вот выхлоп:

Jan 12 17:10:54 localhost.localdomain snapd[17790]: cannot run daemon: state startup errors: [cannot obtain snap-seccomp version information: fork/exec /usr/libexec/snapd/snap-seccomp: no such file or directory]
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ An ExecStart= process belonging to unit snapd.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ The unit snapd.service has entered the 'failed' state with result 'exit-code'.
Jan 12 17:10:54 localhost.localdomain systemd[1]: Failed to start Snap Daemon.
░░ Subject: A start job for unit snapd.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit snapd.service has finished with a failure.
░░ 
░░ The job identifier is 6832 and the job result is failed.
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Scheduled restart job, restart counter is at 5.
░░ Subject: Automatic restarting of a unit has been scheduled
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ Automatic restarting of the unit snapd.service has been scheduled, as the result for
░░ the configured Restart= setting for the unit.
Jan 12 17:10:54 localhost.localdomain systemd[1]: Stopped Snap Daemon.
░░ Subject: A stop job for unit snapd.service has finished
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A stop job for unit snapd.service has finished.
░░ 
░░ The job identifier is 6930 and the job result is done.
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Start request repeated too quickly.
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ The unit snapd.service has entered the 'failed' state with result 'exit-code'.
Jan 12 17:10:54 localhost.localdomain systemd[1]: Failed to start Snap Daemon.
░░ Subject: A start job for unit snapd.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ A start job for unit snapd.service has finished with a failure.
░░ 
░░ The job identifier is 6930 and the job result is failed.
Jan 12 17:10:54 localhost.localdomain systemd[1]: snapd.service: Triggering OnFailure= dependencies.

 , , ,

zero_one_two ()

ошибка при конфигурации

Установил pure os и захотел запустить ssh ,а тут нет демона я попытался установить openssh-client openssh-server ,что-то сломалось и теперь вообще не могу установить пакеты . Помогите пожалуйста,спасибо)

You might want to run ‘apt –fix-broken install’ to correct these. The following packages have unmet dependencies: mysql-cluster-community-client : Depends: mysql-cluster-community-client-core (= 8.0.23-1debian10) but it is not going to be installed ssh : Depends: openssh-client (>= 1:7.9p1-10+deb10u2) but it is not going to be installed Depends: openssh-server (>= 1:7.9p1-10+deb10u2) but it is not going to be installed E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).

dpkg: error processing archive /var/cache/apt/archives/mysql-cluster-community-client-plugins_8.0.23-1debian10_amd64.deb (–unpack): trying to overwrite ‘/usr/lib/mysql/plugin/authentication_ldap_sasl_client.so’, which is also in package mysql-community-client-plugins 8.0.23-1debian10 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Preparing to unpack …/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb … Unpacking mysql-cluster-community-client-core (8.0.23-1debian10) … dpkg: error processing archive /var/cache/apt/archives/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb (–unpack): trying to overwrite ‘/usr/bin/mysql’, which is also in package mysql-community-client-core 8.0.23-1debian10 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/mysql-cluster-community-client-plugins_8.0.23-1debian10_amd64.deb /var/cache/apt/archives/mysql-cluster-community-client-core_8.0.23-1debian10_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

 ,

zero_one_two ()

адаптер сетевой карты

Всем привет . Я двигаю за СПО ,сейчас сижу на arch linux ,хочу перейти на полностью свободный дистрибутив присмотрелся к parabola и hyperbola ,но я уже обжигался с trusquel(установил а сети нет "я использую ноутбук lenovo сетевая карта atheros 10). Так вот в чем суйть ,я хочу узнать можно ли поставить свободный драйвер на этот адаптер?

 , , ,

zero_one_two ()

arch linux gnome-terminal

Установил arch,поставил гном, а терминал не работает ,прогуглил всё это дело сгенерировал locale ,а проблема осталась

gnome-terminal

Locale not supported by C library.

Using the fallback ‘C’ locale.

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

locale -a locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_COLLATE to default locale: No such file or directory C POSIX en_US.utf8 ru_RU.utf8

locale-gen Generating locales… en_US.UTF-8… done ru_RU.UTF-8… done en_US.UTF-8… done Generation complete.

locale -a locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_COLLATE to default locale: No such file or directory C POSIX en_US.utf8 ru_RU.utf8

 , ,

zero_one_two ()

Провода в guix

Решил перейти на спо, выбрал дистрибуив(Guix) и сделал back up файлов , но тут проблема при запуске gui установки нет интернет соединения ,и wi-fi не работатет.В случае с wi-fi есть объяснение, в случае с проводами ничего не понятно .При запуске установки есть grub меню мб там можно что-то подкрутить ,чтоб всё заработало? Помогите пожалуйста.

 , ,

zero_one_two ()

Посоветуйте свободный дистибутив ,пожалуйста

Сейчас стоит ubuntu ,но я в шоке от него.Хотел поставить arch ,но были проблемы.Ищу свободный дистрибутив .

 

zero_one_two ()

grub-install /* не устанавливается

Всем привет. Решил я со своего не свободного убунту перескочить на свободный Arch , но я не совсем тупой и понимаю ,что лучше сначала провести пробный забег.Начал установку на машину VMR ,но сдесь сразу несколько проблем — mkinitcpio -p linux не выполняет свои функции (ERROR: Failed to load preset: ‘/etc/mkinitcpio.d/linux.preset’) .Я не знаю связано ли это но grub-install /* выдаёт ошибку EFI (grub-install: errorcannot find EFI directory) .Прошу помощи и литературы для изучения линукса

 , ,

zero_one_two ()

Не могу установить need for speed underground 2

Пробовал установить через crossover толку нет в конце установки вылезает Runtime error.Через PlayOnLinux тоже самое . Прошу помощи !

 ,

zero_one_two ()

RSS подписка на новые темы