LINUX.ORG.RU

Сообщения vikt3r

 

Arch Linux и Bash[РЕШЕНО]

Форум — General

В общем, собрал минимальную систему арч, настроил под себя и все дела, но есть одно «НО» - это то,что в командной строке(основной шелл - Bash) у меня как бы строка неполная(не до конца экрана) и при вводе символов, доходя до границы строки, баш начинает печатать на той же строке только в начале и как бы перепечатывает старые символы на новые. Так только с 1ой и втрой строкой, затем он доезжает до конца экрана и нормально переносит строки

 , , , ,

vikt3r ()

Slackware 13 + USB = Kernel-panic

Форум — Linux-install

Вообщем установил на USB ядро и слаку:

dd if=usbboot.img of=/dev/sda5 bs=512
При загрузке с флешки и вводе команды вроде:
hugeблаблабла.s root=/dev/sdb5 блаблабла
И ожидании пока он прогружает систему мне выдает:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

vikt3r ()

Монтирование флешки - fail.

Форум — Linux-hardware

Ubuntu 10.04 перестала автоматически монтироваться флешка (gnome). Когда монтирую ручками

mount -a /dev/sdb /mnt
Мне пишет - укажите тип ФС. При указании типов (всех)
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       В некоторых случаях полезная информация может быть
       найдена в syslog - попробуйте dmesg | tail или что-то
       в этом роде

Вот dmesg: Pastebin dmesg.log dmesg | tail:

[   63.788975] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[   63.808965]  sdb: unknown partition table
[   63.809954] sd 7:0:0:0: [sdb] No Caching mode page present
[   63.809958] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[   63.809961] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[   94.926935] FAT-fs (sdb): invalid media value (0x06)
[   94.926938] FAT-fs (sdb): Can't find a valid FAT filesystem
[  109.650828] EXT3-fs (sdb): error: can't find ext3 filesystem on dev sdb.
[  501.106681] FAT-fs (sdb): invalid media value (0x06)
[  501.106691] FAT-fs (sdb): Can't find a valid FAT filesystem

Что тут можно сделать?

vikt3r ()

Проблема с libphp5.so - уже другая!

Форум — General

И так все норм скомпилилось, библиотека libphp5.so поместилась в /usr/local/modules, НО при старте апача вот, что выдает:

httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: zend_parse_parameters

Вот как прописан модуль: LoadModule php5_module modules/libphp5.so В httpd.conf

vikt3r ()

Apache2 + PHP5 = ?

Форум — General

Нужна помощь. Собрал апач из сорцов с офф сайта. Апач запустил, попробовал тестовую страницу index.html в броузере зашел на localhost и все на ок заработало, но нужно к апачу еще присоединить PHP. Собираю

./configure --prefix=/usr/local/php5
make
make install
Далее во всех статьях пишут про создние симлинка на ./libs (папка в директории с сорцами, но у меня она почему-то пуста)/libphp5.so в папке apache/modules. Так вот собственно у меня эта папка ./libs пуста... И где искать libphp5.so я не знаю. Пробовал поиск.
updatedb 
locate libphp5.so
Ничего не находит. Что делать ума не приложу.

P.S. Апач в дире /usr/local/apache2

 , ,

vikt3r ()

Преобразование string в const char [C++]

Форум — Development

И так есть код:точнее его кусочек писанный на C++

                cout << "Enter Path of downloaded JRE or JDK: " ;
                string JrePath;
                cin >>JrePath;
                system("update-alternatives --install /usr/bin/java java " << JrePath.c_str() << " 3");
                system("update-alternatives --configure java");
                if (boost::filesystem::exists("/usr/bin/java/bin/java") == 0)
                {
                    cout << "Java hasn't configured! Path /usr/bin/java/bin/java hasn't exists" << endl;
                    cout << "Enter Command: ";
                    cin >> a; 
                }
При компиляции получаю вот что -
main.cpp:36: error: invalid operands of types ‘const char [50]’ and ‘const char*’ to binary ‘operator<<’
main.cpp:49: error: jump to case label
main.cpp:34: error:   crosses initialization of ‘std::string JrePath’
main.cpp:54: error: jump to case label
main.cpp:34: error:   crosses initialization of ‘std::string JrePath’
main.cpp:27: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result
main.cpp:37: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result
main.cpp:55: warning: ignoring return value of ‘int system(const char*)’, declared with attribute warn_unused_result

Много каких решений перепробовал, ничего не помогает. Прошу помощи.

vikt3r ()

Intel + nVidia под управлением bumblebee

Форум — Linux-hardware

Вот у меня вопрос собственно вот в чем.

Запуск с видяхой intel: Приложение идет с такими мини-подвисаниями

root@notebook:~# glxspheres
Polygons in scene: 62464
Visual ID of window: 0x41
Context is Indirect
OpenGL Renderer: Software Rasterizer
9.420489 frames/sec - 6.685081 Mpixels/sec
7.892776 frames/sec - 5.600967 Mpixels/sec
7.758582 frames/sec - 5.505738 Mpixels/sec
7.836121 frames/sec - 5.560762 Mpixels/sec

Запуск того же с видяхой nVidia: Идет гладко как по маслу

root@notebook:~# optirun glxspheres
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 525M/PCIe/SSE2
18.989223 frames/sec - 13.475360 Mpixels/sec
30.044698 frames/sec - 21.320679 Mpixels/sec
29.776484 frames/sec - 21.130346 Mpixels/sec

Далее запускаю шестеренки. Intel - с подвисаниями:

root@notebook:~# glxgears
2984 frames in 5.0 seconds
2920 frames in 5.0 seconds
2932 frames in 5.0 seconds
Один хрен не радует глаз.

То же самое только с nVidia - идет как по маслу;

root@notebook:~# optirun glxgears
474 frames in 5.0 seconds
469 frames in 5.0 seconds
458 frames in 5.0 seconds
ОДНАКО! Показатели на nVidia с шестеренками ниже, будто я запустил все на nVidia 5600 или еще хуже на брате только от AMD. Но с nVidia то идет гладко, а с интелом подвисания. Почему так? А с шариками все ОК.

 , ,

vikt3r ()

Разрешение экрана в ubuntu 10.04 и Debian Squeeze 6.0.4

Форум — General

Здравствуйте. Ох намаялся я уже... И прошу помощи. И так что имеем. Ноут dell n5110 серии r15 , интегрированное видео intel sandy bridge 3000, и дискретное видео nvidia 525m. Ну и ессно 2 системки на харде, а именно ubuntu 10.04 чудом выжившая на 2ом компе (на харде, так то там win7 стоит) и debian squeeze 6.0.4 (давно качал). Ну и вообщем все бы зер гут, да разрешеньице в выше-описанных системах максимум 1024x768, когда у меня экран 1366x768 (и в установленной Win7HBasic) было все ок, Вот думаю я тут дело в драйвере. Вот мой xorg.conf из бубунты (кое как сгенерировал его с помощью nvidia-xconfig)

http://pastebin.com/SnskqVpP

вот. Сдается мне что тут виновен во всем VESA драйвер. Потому как с помощью xrandr я колдовал часа полтора и все безуспешно. Так вот, а если я ставлю тама драйвер intel, то мне при старте иксов выдают: «no screens found! (Fatal server error)». Так то. Так что, УМОЛЯЮ окажите помощь утопающему!!!

 , , ,

vikt3r ()

что за нафиг? debian 6 squeeze

Форум — General

Блин, что за нафиг? Установил Debian 6 Squeeze. До этого работал в Linux Mint 12 , Ubuntu 10.04.

Радостный такой запускаю. И тут... Нету апплета настройки сети. (wifi,lan) Ну это ладно чуть попыхтя узнал что установлен network-manager и ручками настроил конфиг. Все пошло. Но тут браузер Epiphany - неудобный, решил поставить оперу или мозилу. Скачал deb пакет оперы и ? как его установить? Через консоль я ни разу не устанавливал deb. ПКМ по файлу, но там нет никаких менеджеров или что нибудь похожее. Следущее - нету звука как не пыхтел так и не получил звук. Далее почему-то команда apt-get и aptitude --> update просматривает мало репозиториев, а upgrade ничего не обновляет. Пробовал установить aptitude install firefox - он ничего не нашел.

Помогите пожалуйста!Первый день в Debian.

P.S. при открытии архивов выскакивает:

GConf error

GConf error: Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details - 1: Ошибка проверки доступности сервера: IDL:omg.org/CORBA/COMM_FAILURE:1.0) All further errors shown only on terminal

P.S.S. А при открытии регулятора громкости вот что:

Не удается запустить регулятор громкости: Не удалось выполнить процесс-потомок «gnome-volume-control» (Нет такого файла или каталога)

И еще шрифт убийственный. А в меню Система->Параметры нет настройки шрифта

Еще псс. Так кинь тогда ссылку на доки плз. Минта глючная на ноутах с интегрированным видео и дискретным

vikt3r ()

RSS подписка на новые темы