LINUX.ORG.RU

Сообщения mentax

 

Haproxy - возобновление подключений к основной зоне

Форум — Admin

Здравствуйте, Имеется haproxy который перенаправляет трафик на 6 узлов. Узлы находятся в разных датацентрах. При пропадании связи с удаленными датацентрами, ноды помечаются как Down и выводятся из haproxy как не рабочие узлы. Есть ли возможность в haproxy как то указать чтобы узлы автоматически переподключались когда узлы снова становятся доступными? Как я понял, haproxy по умолчанию проверяет доступность узлов 3 раза с интервалом в 1 секунду.

listen CouchDB-Data 0.0.0.0:15984
  balance roundrobin
    server s1z1.123.net 208.XX.XX.97:5984 check
    server s2z1.123.net 208.XX.XX.38:5984 check
    server s3z1.123.net 208.XX.XX.128:5984 check

    server s1z2.123.net 172.XX.XX.7:5984 check backup
    server s2z2.123.net 172.XX.XX.164:5984 check backup
    server s3z2.123.net 172.XX.XX.21:5984 check backup

 

mentax ()

Cisco C2960S режет скорость интернета

Форум — Admin

Доброго Local time.

Есть проблемка, в домашний циско свитч приходит канал в 600Mb, а вот со свича на комп приходит всего 70Mb. Не пойму в чем может быть дело, хитрых правил на циске нет, все в большинстве своем по умолчанию. Пробовал подключаться к разным портам, результат одинаковый. Uplink на 24м порту

C2960S-Home#sh interfaces vlan 1
Vlan1 is up, line protocol is up
  Hardware is EtherSVI, address is f4ea.679e.4540 (bia f4ea.679e.4540)
  Internet address is 192.10.1.254/24
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:02, output 00:01:41, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4525205 packets input, 780305022 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     124535 packets output, 29538225 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
C2960S-Home#sh run
Building configuration...

Current configuration : 6328 bytes
!
! Last configuration change at 19:02:34 EST Sun Jan 1 2006
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname C2960S-Home
!
boot-start-marker
boot-end-marker
!
enable password 7 XXX
!
username admin privilege 15 password 7 XXX
no aaa new-model
clock timezone EST -5 0
clock summer-time EDT recurring
switch 1 provision ws-c2960s-24ps-l
!
!
ip name-server 1.1.1.1
ip name-server 4.2.2.2
!
!
!
!
!
!
mls qos map policed-dscp  0 10 18 24 46 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos
!
crypto pki trustpoint TP-self-signed-1738425600
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1738425600
 revocation-check none
 rsakeypair TP-self-signed-1738425600
!
!
crypto pki certificate chain TP-self-signed-1738425600
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31373338 34323536 3030301E 170D3036 30313032 30303031
  34385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37333834
  32353630 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C0F7 69ED300B E11E010C B3BF5275 D89828B8 C0E2CE91 0627BBDD 288499F4
  70BEE490 7DB0F5CB 99822939 8CF9FFCC 894EF501 9F4986A5 7A4A7665 DBF5B606
  CDE26136 2CFBEDD7 27945ECA BA242BB0 70250674 1AFCC28F 1B8FC5B7 B6901655
  33F11229 9EA9AF79 0E881758 4887C1DA 415309B7 F390BEFE B655C10A AF7ED394
  20530203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 14A88341 78BB649F AB810B23 178E3297 50329C6A 43301D06
  03551D0E 04160414 A8834178 BB649FAB 810B2317 8E329750 329C6A43 300D0609
  2A864886 F70D0101 05050003 8181002C CD0C548A 826C7871 AD1C22DC A632F491
  88FB9D7C 110194B1 6AF72C9F F267E7B0 3502B18F 33368BA2 781D8C32 48E67F8E
  A3CCE3B3 203B8BBE 88A26B45 8EBEC3D1 4391E513 DF2CBC0D 95F21A83 8B0C9710
  38AF3415 EBD2E3EF A53F4230 E633FB4B AD415152 D4F47A03 313F4266 E3EFA85B
  C1714FB2 329B1D65 2E658E7F 28DC11
        quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
lldp run
!
class-map match-all AUTOQOS_VOIP_DATA_CLASS
 match ip dscp ef
class-map match-all AUTOQOS_DEFAULT_CLASS
 match access-group name AUTOQOS-ACL-DEFAULT
class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
 match ip dscp cs3
!
policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
 class AUTOQOS_VOIP_DATA_CLASS
  set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_VOIP_SIGNAL_CLASS
  set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_DEFAULT_CLASS
  set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit
!
!
!
!
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
 switchport mode access
 switchport voice vlan 1
 switchport port-security maximum 2
 switchport port-security violation  restrict
 switchport port-security aging time 2
 switchport port-security aging type inactivity
 switchport port-security
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 macro description cisco-phone
 auto qos voip cisco-phone
 spanning-tree portfast
 spanning-tree bpduguard enable
 service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 description === Uplink to INTERNET ===
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.10.1.254 255.255.255.0
 ip helper-address 192.10.1.1
!
ip default-gateway 192.10.1.1
no ip http server
ip http authentication local
ip http secure-server
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
ip access-list extended AUTOQOS-ACL-DEFAULT
 permit ip any any
!
!
line con 0
line vty 0 4
 login
 transport input telnet ssh
line vty 5 15
 login
!
ntp server time.nist.gov
ntp server pool.ntp.org minpoll 10
end

 

mentax ()

DNS: Ошибка NAPTR записи и пути решения

Форум — Admin

Всем привет. Пытаюсь настроить NAPTR запись на cloudflare. Запись стандартная, но cloudflare выдает ошибку

iMac:~ mentax$ host -t NAPTR sip.domain.net clyde.ns.cloudflare.com
;; Got bad packet: syntax error
199 bytes
3b 17 85 00 00 01 00 03 00 00 00 00 03 73 69 70          ;............sip
06 75 73 76 6f 69 70 03 6e 65 74 00 00 23 00 01          .domain.net..#..
c0 0c 00 23 00 01 00 00 01 2c 00 2b 00 0a 00 64          ...#.....,.+...d
01 53 07 53 49 50 2b 44 32 55 02 22 22 04 5f 73          .S.SIP+D2U.""._s
69 70 04 5f 75 64 70 03 73 69 70 06 75 73 76 6f          ip._udp.sip.doma
69 70 03 6e 65 74 00 c0 0c 00 23 00 01 00 00 01          in.net....#.....
2c 00 2b 00 0a 00 64 01 53 07 53 49 50 2b 44 32          ,.+...d.S.SIP+D2
54 02 22 22 04 5f 73 69 70 04 5f 74 63 70 03 73          T.""._sip._tcp.s
69 70 06 75 73 76 6f 69 70 03 6e 65 74 00 c0 0c          ip.domain.net...
00 23 00 01 00 00 01 2c 00 2d 00 0a 00 64 01 53          .#.....,.-...d.S
08 53 49 50 53 2b 44 32 54 02 22 22 05 5f 73 69          .SIPS+D2T.""._si
70 73 04 5f 74 63 70 03 73 69 70 06 75 73 76 6f          ps._tcp.sip.doma
69 70 03 6e 65 74 00                                     in.net.

Если смотреть на все это дело через сервис https://dnslookup.online/naptr.html все показывается, но на деле NAPTR не работает. Думаю может они некорректные значения выдают? Можно как то проследить в чем может быть затык? Надеюсь в DNS есть какой то запрос чтобы посмотреть что отдает сервер в удобочитаемом варианте? Создал такую же конфигурацию на другом DNS, все работает...

sip.domain.net.	300	IN	NAPTR	10 100 "S" "SIPS+D2T" "" _sips._tcp.sip.domain.net.
sip.domain.net.	300	IN	NAPTR	10 100 "S" "SIP+D2U" "" _sip._udp.sip.domain.net.
sip.domain.net.	300	IN	NAPTR	10 100 "S" "SIP+D2T" "" _sip._tcp.sip.domain.net.

 

mentax ()

Letsencrypt wildcard и кластер серверов

Форум — Admin

Есть кластер машин (~150 серверов) который используется для балансировки и горячего резервирования. Пытаюсь придумать решение как настроить letsencrypt для автоматической синхронизации SSL по всем этим машинам.

Поиски привели меня на проект getssl. Вроде бы то что нужно, но проект заброшен и не поддерживает получение wildcard сертификатов. Может кто то сталкивался с подобным и сможет поделиться или натолкнуть на правильную мысль?

 

mentax ()

Использовать Ansible чтобы изменить опции монтирования

Форум — Admin

Доброго localtime.

Появилась задача изменить опции монтирования для /tmp на всех linux машинах(скажем машин 300). В парке стоит Redhat и Centos 7. Проблема в том что на некоторых машинах точки монтирования различаются Где то стоит /dev/mapper/vg0-tmpvol /dev/mapper/vg0-tmp /dev/mapper/rhel-tmp

Есть ли в ansible возможность изменить только опции, оставляя все остальное? Как пример найти строчку /tmp и применить опцию к этой строке?

/dev/mapper/vg0-tmpvol /tmp ext4 nodev 1 2 чтобы получилось /dev/mapper/vg0-tmpvol /tmp ext4 nodev,nosuid,noexec 1 2

 ,

mentax ()

Мистика с закрытыми портами

Форум — Admin

Добрый день, Столкнулся скрайне странной проблемой, не могу попасть на сервер. Пытаюсь подключится по ssh, не получается, сканирую nmap'ом на наличие портов, говорит что порт закрыт. Локально с машины могу делать ssh на другие сервера. Выключил iptables, перезагрузил машину, все равно не помогает. Firewalld тоже выключен, но что то блокирует порт. ssh localhost с локальной машины проходит. Ума не приложу в чем может быть дело и что может блокировать порты

 ,

mentax ()

CentOS 7 Errata

Форум — Admin

Всем привет! В RedHat Satellite system есть замечательное средство которое показывает сколько и каких пакетов нужно обновить, а так же какие криточеские уязвимости были пофиксены... Можно ли собрать данную инфу без использования Satellite или Spacewalk на centos? У нас в строю до сих пор стоит CentOS 7.2 и никак мне не удается убедить начальство перейти на 7.4 =( Надо как нибудь собрать все бажные репорты - errata (А их я думаю за 2 года накопилось овердохера)

 

mentax ()

Проброс интернета в сеть без интернета

Форум — Admin

Имеется куча серверов в сети без доступа к интернету. Доступ к серверам осуществляется через jump сервер, который в свою очередь тоже не имеет интернета. Нужно каким то образом подключить один сервер к интернету чтобы получить некоторые важные обновления. Сервера не имееют доступа к внутренней сети... В общем весьма не тривиальная задача... Можно как то через SSH пробросить доступ в интернет на машину находящуюся в сети без интернета?

 ,

mentax ()

snmp - Получить количество роутов

Форум — Admin

Здравствуйте коллеги,

На серверах настроен fail2ban отправляющий нежелательные IP в blackhole и соответственно добавляющий роут в таблицу локального роута.

Использую SNMP для сбора статистики с серверов. Есть ли возможность забрать по snmp текущее количество роутов с линукс машины?

Что то вроде: [root@linux]# route -n | wc -l

Хочется наглядно видеть статистику в веб интерфейсе по количеству заблокированных хостов.

 ,

mentax ()

Webserver Failover

Форум — Admin

Всем привет,

Возникла одна задумка/идея сделать failover своих веб серверов. Задача такая: есть 3 идентичных web сервера разбросанных географически. Необходимо чтобы при падении основного сервера траффик перенаправлялся на оставшийся сервер. Подумывал над вариантом добавления 3-х A records в DNS, но получается не то что хотелось, в этой схеме происходит round-robin перенаправление и выбирается произвольный сервер (Что меня в корне не устраивает).

Есть у DNS хорошая штука - SRV запись, и она позволяет делать все необходимое т.е. выставлять приоритеты (правда я очень сильно не уверен что браузеры поддерживают эту штуку) В общем то при использовании SRV записи ты указываешь:

В данном примере показано как это реализовано для SIP:

Hostname	                Type	       Address	        TTL	Priority	
_sip._tcp.sip.example.com	SRV	1 5060 64.12.34.56	300	10
_sip._tcp.sip.example.com	SRV	1 5060 64.12.34.76	300	20
_sip._tcp.sip.example.com	SRV	1 5060 64.12.34.96	300	30

Может как то можно завернуть траффик с помошью SRV записи? В общем буду раз любым соображениям по этому поводу

 , , ,

mentax ()

Touch Screen, Core M и Debian Jessie

Форум — General

Здравствуйте уважаемые форумчане. Есть у меня планшет - Cube i7, валялся давно, все никака руки не доходили. В общем сегодня удалил Win 10 что шел в стандартной поставке и установил Debian 8.5, накатил ядро из бекпортов версии 4.5. Все вроде установилось нормально, после небольших шаманских танцев с бубном удалось завести wifi. Основная проблемма - не определился touch screen. На нажатия не реагирует совсем =( Может есть кто то кто сможет подсказать в какую сторону копать?

root@i7:/home/mentax# lspci 
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
root@i7:/home/mentax# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:5830 Realtek Semiconductor Corp. 
Bus 001 Device 023: ID 0911:2188 Philips Speech Processing 
Bus 001 Device 022: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 004: ID 0bda:b720 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 0bda:5875 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 ,

mentax ()

Мониторинг SNMPd + OpenVZ venet0:0

Форум — Admin

Коллеги здравствуйте!

Есть порядка 10 OpenVZ контейнеров купленных у одного из хостеров разнесенные географически. Пытаюсь снять статистику внешнего интерфейса, но не выходит.

На машине мониторинга пытаюсь посмотреть доступные интерфейсы удаленной машины - host1:

[root@mon ~]# ./check_centreon_snmp_traffic -H 123.12.23.45  --show
Interface 1 :: lo :: up
Interface 2 :: gre0 :: down
Interface 3 :: gretap0 :: down
Interface 4 :: venet0 :: up

Когда пытаюсь получить данные с интерфейса venet0:

[root@mon]# ./check_centreon_snmp_traffic -H 123.12.23.45 -i "venet0" -n
CRITICAL: Interface speed equal 0! Interface must be down.|traffic_in=0B/s traffic_out=0B/s

При попытке получить данные с venet0:0

[root@mon]# ./check_centreon_snmp_traffic -H 123.12.23.45 -i "venet0:0" -n
ERROR: Can't find interface name 'venet0:0' in cache file '/var/lib/centreon/centplugins/traffic_cache_123.12.23.45'. Maybe you need a cache rebuild (Command with option '-a 0').

Интерфейсы на удаленной машине:

[root@host1 ~]# ifconfig -a
gretap0   Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1476  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

gre0      Link encap:UNSPEC  HWaddr 00-00-00-00-FF-FF-80-EB-00-00-00-00-00-00-00-00
          NOARP  MTU:1476  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:27695824 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27695824 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4185127021 (3.8 GiB)  TX bytes:4185127021 (3.8 GiB)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:63183952 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57510647 errors:0 dropped:46 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14652624965 (13.6 GiB)  TX bytes:10235413085 (9.5 GiB)

venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:123.12.23.45  P-t-P:123.12.23.45  Bcast:123.12.23.45  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1

Что я делаю не так? Как снять статистику по интерфейсу в OpenVZ?

 ,

mentax ()

Различия в значениях размера жесткого диска

Форум — Admin

Мучаю систему мониторинга, наткнулся на странность

[root@mon1 centreon-plugins]# ./centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode=storage --hostname=localhost --name --storage='/boot'
OK: Storage '/boot' Total: 476.22 MB Used: 72.09 MB (15.14%) Free: 404.13 MB (84.86%) | 'used'=75591680B;;;0;499355648

[root@mon1 centreon-plugins]# df -h /boot
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1       477M   73M  380M  16% /boot

То есть через snmp показывает что свободного места 404.13 MB, а команда df на тот же диск показывает 380M свободного места...

Кому верить?

 , ,

mentax ()

Статистика загрузки Catalyst 3750

Форум — Admin

Доброго localtime.

Пытаюсь прикрутить к cacti статистику свича. Гугление привело меня к мибу: .1.3.6.1.4.1.9.2.1.58.0

Однако, попытка запросить этот миб с помощью snmpwalk выдает ошибку

snmpwalk -v 3 -a SHA -A super_secret_pass -l authPriv -u admin -x AES -X super_secret 10.71.12.254 .1.3.6.1.4.1.9.2.1.58.0

iso.3.6.1.4.1.9.2.1.58.0 = No more variables left in this MIB View (It is past the end of the MIB tree)

image: c3750-ipservicesk9-mz.150-2.SE7

Как можно запросить загрузку по процессору за 5 минут?

 

mentax ()

Клонирование существующей системы Centos и последующая загрузка ее с LiveCD

Форум — Admin

Доброго localtime Встала одна интересная задача, хочу сравнить производительность существующей/установленной на жестком диске системы и системы которая загружена в RAM. До этого в основном пользовался PXE и создавал образы rootfs.cgz. На данный момент нет подящего железа/времени чтобы поднять это хозяйство =) В общем вопрос: как существующий раздел на сервере(со всеми конфигами и пакетами) записать в ISO и потом с него загрузиться - аналог toram в кноппиксе? Нужно чтобы система целиком и полностью работала из RAM, а загружалась с CDROM.

mentax ()

IPV6 NAT?

Форум — General

На роутер от провайдера приходит dhcp6. Маска /128 что разрешает мне использовать только один IPV6 адрес. Если модем подключен напрямую к компу я могу использовать dual-stack, по dhcp приходит ipv4 а так же ipv6/128. IPV6 и IPV4 работает без проблем. Провайдер клянется что IPV6 для оконечных обонентов не поддерживает (пока) =( В этой ситуации мне думается так - на роутере (SonicWall TZ210) для IPV6 необходимо пробросить нат (так как это делается с IPV4) чтобы можно было общаться с внешними ресурсами по IPV6(провайдер моего колокейшна дал мне подсеть IPV6). Внимание вопрос: есть ли в IPV6 аналог локальных адресов которые можно использовать для LAN подсети? Как правильно сделать чтобы у меня дома были серые IPV6 в LAN? А может существует какой либо другой пример решения данной проблемы? тунели не предлагать.

mentax ()

Cisco BTS 10200

Форум — General

Господа, расскажите что есть Cisco BTS 10200 ? Что это за зверь такой? Как настраиваеться и какие возможности применения существуют? Гугл ничего толкового не выдал =(

mentax ()

Доступ по ключу к localhost

Форум — Admin

Не получаеться законектиться к локалхосту используя ключ. Есть скрипт для cacti которому надо конект делать посредством ключа. Пытаюсь прописать локалхост так же как и удаленные машины:

root@home ~ # su cacti

bash-4.1$ ssh-copy-id cacti@localhost

cacti@localhost's password: *****

Now try logging into the machine, with «ssh 'cacti@localhost'», and check in:

.ssh/authorized_keys

to make sure we haven't added extra keys that you weren't expecting.

bash-4.1$ ssh cacti@localhost

cacti@localhost's password:

К удаленным машинам конектица нормально, а вот к самому себе не хочет. Какие либо идеи?

P.S. маленький дебаг:

OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010

debug1: Reading configuration data /etc/ssh/ssh_config

debug1: Applying options for *

debug1: Connecting to localhost [::1] port 22.

debug1: Connection established.

debug1: identity file /usr/share/cacti/.ssh/identity type -1

debug1: identity file /usr/share/cacti/.ssh/id_rsa type 1

debug1: identity file /usr/share/cacti/.ssh/id_dsa type -1

debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3

debug1: match: OpenSSH_5.3 pat OpenSSH*

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_5.3

debug1: SSH2_MSG_KEXINIT sent

debug1: SSH2_MSG_KEXINIT received

debug1: kex: server->client aes128-ctr hmac-md5 none

debug1: kex: client->server aes128-ctr hmac-md5 none

debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

debug1: SSH2_MSG_KEX_DH_GEX_INIT sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

debug1: Host 'localhost' is known and matches the RSA host key.

debug1: Found key in /usr/share/cacti/.ssh/known_hosts:13

debug1: ssh_rsa_verify: signature correct

debug1: SSH2_MSG_NEWKEYS sent

debug1: expecting SSH2_MSG_NEWKEYS

debug1: SSH2_MSG_NEWKEYS received

debug1: SSH2_MSG_SERVICE_REQUEST sent

debug1: SSH2_MSG_SERVICE_ACCEPT received

debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with- mic,password

debug1: Next authentication method: gssapi-keyex

debug1: No valid Key exchange context

debug1: Next authentication method: gssapi-with-mic

debug1: Unspecified GSS failure. Minor code may provide more information

Credentials cache file '/tmp/krb5cc_493' not found

debug1: Unspecified GSS failure. Minor code may provide more information

Credentials cache file '/tmp/krb5cc_493' not found

debug1: Unspecified GSS failure. Minor code may provide more information

debug1: Unspecified GSS failure. Minor code may provide more information

debug1: Next authentication method: publickey

debug1: Trying private key: /usr/share/cacti/.ssh/identity

debug1: Offering public key: /usr/share/cacti/.ssh/id_rsa

debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with- mic,password

debug1: Trying private key: /usr/share/cacti/.ssh/id_dsa

debug1: Next authentication method: password

cacti@localhost's password:

 , ,

mentax ()

Проброс нескольких портов через ssh тунель

Форум — Admin

Доброго localtime!

Есть у меня сеточка в которой крутятся около десятка supermicro серверов. Всего один внешний ip адрес у этой сети есть (linux машина выступающая в роли nat). На это машину имеется ssh. Пробую заходить туда используя комманду ssh -D 8080 X.X.X.X, потом указываю в браузере использовать порт 8080 как socks. Могу попасть во внутреннюю сеть, попасть на ipmi, про попытке подключиться к виртеальному дисплею выдает ошибку соединения =( Возможно ли как то посредство ssh тунеля пробросить одновременно 4 порта? Нуженые порты как мне кажется:

HTTP: 80 (TCP) HTTPS: 443 (TCP) Remote console: 5900 (TCP) Virtual media: 623 (TCP)

mentax ()

bcm5716 - загрузка по сети

Форум — Linux-hardware

Доброго localtime!

Столкнулся тут с одной проблемкой так сказать курицы и яйца... Настроил netboot через pxe. Старенькие машинки грузяться без проблем, проблема с новыми серверами - стоит сетевая карточка bcm5716. Дистрибутив - Debian squeeze. При попытке загрузки данного девайса через pxe происходит загрузка ядра, затем вываливается в kernel panic когда не находит драйвера сетевой карты... Данные драйвера содержаться в non-free ветке. Загрузка всех машин производиться с одного образа. Внимание вопрос: Как сделать так чтобы машинка смогла загрузиться? Как добавить эти драйвера в этап начальной загрузки?

mentax ()

RSS подписка на новые темы