LINUX.ORG.RU

Python 2.5.6

 ,


0

0

26-го мая вышел корректирующий релиз Python 2.5.6 с исправлениями ошибок, связанных с безопасностью

  • исправлена ошибка, позволяющая провести XSS-атаки в модуле SimpleHTTPServer
  • В urllib и urllib2 добавлено игнорирование перенаправлений, если схема URL отлична от HTTP, HTTPS и FTP
  • Решена проблема с расчётом длины строки в audioop
  • в модуле audioop добавлены дополнительные проверки перенаправлений

>>> Подробности

и кто пользуется этим окаменелым говном мамонта?

AVL2 ★★★★★ ()
Ответ на: комментарий от AVL2

AltLinux, например. А вслед за ним и все наши школы. Nам в p5 до сих пор 2.5.4, а в 5.1, с которого сейчас пишу, 2.5.5 как раз. Видимо, туда портируют и эту окаменелость.

Кстати, кто помнит, какая версия ставится по умолчанию в RHEL 5.X, не 2.5 ли случаем? Или там 2.4?

Vudod ★★★★★ ()

Ненужен, тем более такое решето.

И да, щаз набтгут ПаХаПщики и тред не уместится на одной странице...

win7 ()
Ответ на: комментарий от anonymous

Многие программы тянут второй Питон, тот же Веснот, например; или Блендер. Другое дело, что почти все они давно переключились на использование ветки 2.6, которая даже по стабильности уже не уступает 2.5. А кое-кто уже переориентировался на 2.7.

Vudod ★★★★★ ()

Минорщина. Да ещё и с замороженой ветки

anonymoos ★★★★★ ()

На кой хрен это нужно, если есть Java?

anonymous ()
Ответ на: комментарий от anonymous

двачер-двачерочек, уходи отсюда, ракуй вы другом месте.

nutz ★★ ()

На FreeBSD стандартно Python 2.6.2, хотя можно переключиться на 2.4.5, 2.5.5, 2.6.6, 2.7.1, 3.1.3 или 3.2.0. Вот как!

Кто может сказать, чем отличаются версии, чтобы, например, спланировать переход с одной на другую? Быстродействие/память что ли меняются в рантайме соответствующих версий или это не заметно?

iZEN ★★★★★ ()
Ответ на: комментарий от iZEN

>Кто может сказать, чем отличаются версии, чтобы, например, спланировать переход с одной на другую?

2.4 не умеет ternary expression и with statement. В 2.6 появилась функция print, но старый print statement тоже работает. Вообще, чем больше версия второго питона - тем лучше.

Третий питон сильно отличается.

anonymous ()
Ответ на: комментарий от iZEN

> На FreeBSD стандартно Python 2.6.2, хотя можно переключиться на 2.4.5, 2.5.5, 2.6.6, 2.7.1, 3.1.3 или 3.2.0. Вот как!

Чего ж ты тогда постоянно плачешь, что у тебя Deluge не работает из-за несовместимости пэйтона, если на бзде всё так прекрасно?

anonymous ()
Ответ на: комментарий от Vudod

> Кстати, кто помнит, какая версия ставится по умолчанию в RHEL 5.X, не 2.5 ли случаем? Или там 2.4?

Я не помню, просто сходил посмотрел. Там всё совсем энтерпрайзненько: python-2.4.3-44.el5.

Lumi ★★★★★ ()

А оно ещё шевелится? Вот я который раз задаю себе вопрос... зачем у меня в системе стоит python-2.7 (зависимостями), а недавно и вовсе python-2.6 стоял. когда давно вышли python-3.2/3.1. Почему-то некоторые пакеты упрямо зависят именно от второй ветки питона, а она с третьей не совместима. %)

Пора бы уже тогда переходить что ли на python-3.1

BattleCoder ★★★★★ ()
Ответ на: комментарий от nutz

>Кококококо

ЛОР превратился в курятник. Это печально.

anonymous ()
Ответ на: комментарий от BattleCoder

Глянь выше. 2.4 будет ещё не один год популярна. До 5.8 шапки уж точно наверняка. :D

Lumi ★★★★★ ()
Ответ на: комментарий от BattleCoder

Да она уже и 6.1 есть, только зачем с работающей 5.6 мигрировать, если пятёрка будет ещё несколько лет поддерживаться?

Lumi ★★★★★ ()

Теперь уже не нужно, есть 2.7 и 3.1

ostin ★★★★★ ()
Ответ на: комментарий от anonymous

Показать бы посты твоим друзьям-двачерам, тебя бы быстро зашкварили, задеанонили и отпетушили бы в подъезде =3

nutz ★★ ()

Блин, ну почему нельзя уже перейти на Ruby ^[4^W версию 3.2 ?

babusha ()
Ответ на: комментарий от anonymous

Вторая ветка и 2.5, это разные вещи.

Во второй ветке давно уже есть 2.6 и 2.7, которые практически полностью совестимы с 2.5.

AVL2 ★★★★★ ()
Ответ на: комментарий от BattleCoder

>А оно ещё шевелится? Вот я который раз задаю себе вопрос... зачем у меня в системе стоит python-2.7 (зависимостями), а недавно и вовсе python-2.6 стоял. когда давно вышли python-3.2/3.1.

Вторая и третья ветки, это разные питоны.

Перепиши весь софт на питоне и модули и вуаля, можно выносить.

AVL2 ★★★★★ ()
Ответ на: комментарий от iZEN

2.5 не умеет обрабатывать try...except в стиле Python-3.X (когда ссылка на исключение находится во временной области, а не оласти функции)

2.5 не доконца умеет декораторы

2.5 сраное гавнецо

user_id_68054 ★★★★★ ()
Ответ на: комментарий от iZEN

...а ещё вспомнил — что у python-2.5 — проблемы с IPv6 :-)

неее.., функция getaddrinfo() конешноже работает в python-2.5 , но вот остальные подключаторные-функции так и хотят использовать IPv4-only :-D

user_id_68054 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.