LINUX.ORG.RU

Новая уязвимость в ProFTPD


0

0

Новая уязвимость в ProFTPD. Можно удаленно выполнить код с привилегиями рута.

Impact: Execution of arbitrary code via network, Root access via network Fix Available: Yes Vendor Confirmed: Yes

Version(s): prior to 1.2.9rc3

Description: Two vulnerabilities were reported in ProFTPD. A remote user with write privileges can execute arbitrary code with root privileges on the target system.

>>> Подробности

anonymous

Проверено: maxcom

Re: Новая уязвимость в ProFTPD

мдааа
у меня уже хз сколько стоит релиз proftpd 1.2.9
так что скорее всего это старые дыры, давно залатанные :/

Rost ★★★★ ()

Re: Новая уязвимость в ProFTPD

Народ, вы че?
1.2.9 уже хз когда вышел.

Этой баге в обед 100 лет будет.

MakcuM ()

Re: Новая уязвимость в ProFTPD

Ну есть же vsftpd, нафиг ProFTPD то юзать?

McMCC ★★★ ()
Ответ на: Re: Новая уязвимость в ProFTPD от McMCC

Re: Re: Новая уязвимость в ProFTPD

vsftpd не такой фичастый как proftpd.
а насчет дырки - нублин, rel вышел уже хрен знает когда. нашли, что постить в новости. :/

thresh ★★★ ()
Ответ на: Re: Re: Новая уязвимость в ProFTPD от thresh

Re: Re: Re: Новая уязвимость в ProFTPD

Да это запостили здесь еще вчера http://www.securitylab.ru/25175.html
ну и уж чтоб не было разнотолков обратите внимание на то, что там говорится о "rc" - если кто не знает это devel весии, да и пофикшено это было еще в rc3 :-)

Зачем пользоваться, если есть "vs...", а кто мне запрещает - что хочу то и пользую :-)

yumi ★★ ()
Ответ на: Re: Новая уязвимость в ProFTPD от Sun-ch

Re: Re: Новая уязвимость в ProFTPD

>А вы проверьте :)

$ ./proft_put_down -t localhost -l 127.0.0.1 -u rost -p XXXXX -U /home/rost
proftpd 1.2.7 - 1.2.9rc2 remote r00t exploit
by Haggis (haggis@haggis.kicks-ass.net)
[ Connecting ]-[ Stack: 0xbffff4ec ]-[ RET: 0xbffff5b4 ]

No r00t for you today I'm afraid.
$ proftpd -v
- ProFTPD Version 1.2.9


НЕ работает :P

Rost ★★★★ ()
Ответ на: Re: Re: Re: Новая уязвимость в ProFTPD от Reset

Re: Re: Re: Re: Новая уязвимость в ProFTPD

>а ты часто пользуешься этими фичами?

я пользуюсь ;)
модулем шифрования tls

и еще, proftpd самый гибкий в настройке ftp daemon! apache-like configuration syntax вам ни о чем не говорит? ;0
мое мнение

Rost ★★★★ ()
Ответ на: Re: Re: Re: Новая уязвимость в ProFTPD от yumi

Re: Re: Re: Re: Новая уязвимость в ProFTPD

мля, дырка-то новая, но в старых версиях...

я вот использовал 1.2.8, потому что в 1.2.9 не работают ни class-ы ни network acl-и, пришлось перебиратся на последний квс снапшот...

anonymous ()

Re: Новая уязвимость в ProFTPD

СУКА ЕБАНАЯ это анонимоус, дыры уже почти пол года нет!!!!!!!!!!!!
Нахуй такие новости пропускать??????????????????

anonymous ()
Ответ на: Re: Новая уязвимость в ProFTPD от Sun-ch

Re: Re: Новая уязвимость в ProFTPD

Саныч - че-то у тебя все эксплойты нерабочие.
То с паролями в MySQL, то теперь вот с proftp -
$./proftp -t localhost -l eth0
proftpd 1.2.7 - 1.2.9rc2 remote r00t exploit
by Haggis (haggis@haggis.kicks-ass.net)
[ Connecting ]-[ Stack: 0xbffff4ec ]-[ RET: 0xbffff5b4 ]

No r00t for you today I'm afraid.
$proftpd -v
- ProFTPD Version 1.2.8

geekkoo ()
Ответ на: Re: Re: Новая уязвимость в ProFTPD от geekkoo

Re: Re: Re: Новая уязвимость в ProFTPD

Есть, правда, одно подозрение - потому что система - Slackware.
Поэтому если видите сообщение об эксплойте, первый вопрос должен быть (стандартно)
А НА СЛАКЕ ЭТО БУДЕТ РАБОТАТЬ?

geekkoo ()
Ответ на: Re: Re: Re: Новая уязвимость в ProFTPD от geekkoo

Re: Re: Re: Re: Новая уязвимость в ProFTPD

Cистема - Slackware версия Proftpd - 1.2.8 данный эксплойт не работает :) может из-за включения через inetd и tcp wrapper?

anonymous ()
Ответ на: Re: Re: Re: Re: Новая уязвимость в ProFTPD от Rost

Re: Re: Re: Re: Re: Новая уязвимость в ProFTPD

Я сам юзаю:

1) vsftpd - for anonymous ftp server

2) pure-ftpd - for hosting services

Если нужны фичи: how about pure-ftpd? ;)

o Security first.

Unlike other popular FTP servers, the number of root exploits found since the very first released version is zero.

o Pure-FTPd works on your server.

The same source code compiles and runs on Linux, OpenBSD, NetBSD, FreeBSD, Solaris, Tru64, Darwin, Irix and HPUX.

o Pure-FTPd speaks your language.

All server messages are translated in .., Russian, ...

Ну и так далее: полная версия фич: http://www.pureftpd.org/index.shtml

dotcoder ★★★★★ ()

Re: Новая уязвимость в ProFTPD

В каком фтп сервере можно настроить перекодировку названий файлов. ну или какой другой способ кто знает. чтоб koi8r<->cp1251

есть конечно вариант написать через lufs перекодировщик, примаунтить и его расшаривать, но это изврат :)

blind ()
Ответ на: Re: Новая уязвимость в ProFTPD от blind

Re: Re: Новая уязвимость в ProFTPD

> В каком фтп сервере можно настроить перекодировку
> названий файлов. ну или какой другой способ кто знает.
> чтоб koi8r<->cp1251
А что - в proftpd разве возможно ?
пример конфига - в студию !

anonymous ()
Ответ на: Re: Re: Re: Re: Re: Новая уязвимость в ProFTPD от dotcoder

Re: Re: Re: Re: Re: Re: Новая уязвимость в ProFTPD

зачем менять шило на мыло?
у меня proftpd работает без проблем годами ;)
проблемы с безопасностью решаются грамотной настройкой acl'ов в grsecurity ;)

Rost ★★★★ ()
Ответ на: Re: Новая уязвимость в ProFTPD от blind

Re: Re: Новая уязвимость в ProFTPD

>В каком фтп сервере можно настроить перекодировку названий файлов. ну или какой другой способ кто знает. чтоб koi8r<->cp1251

согласно rfc, это не возможно сделать на стороне сервера
только на стороне клиента
far например, точно умеет koi8=>win1251

подробнее => http://www.opennet.ru/openforum/vsluhforumID1/35674.html
поиск рулит ;)

Rost ★★★★ ()
Ответ на: Re: Новая уязвимость в ProFTPD от blind

Re: Re: Новая уязвимость в ProFTPD

под лялих\уних есть замечательная кривая программка gFTP ;)
она умеет перекодировку.
правда, глючит не по детски. :)

thresh ★★★ ()

Re: Новая уязвимость в ProFTPD

А интересно, glftpd кто-нибудь здесь юзает? Или он слишком сложен для простого легального ftp?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.