LINUX.ORG.RU

Webasyst — PHP-фреймворк (платформа) для разработки веб-приложений

 ,


0

0

Webasyst представляет собой инструмент для авторизации пользователей, регулирования прав доступа, маршрутизации, создания сайтов, CSS-инструментарий для создания веб-интерфейсов.

  • Много приложений, единый вход — единый многопользовательский бекенд с набором установленных в него приложений
  • Создание сайтов, мультисайтов
  • Фреймворк разработан в соответствии с принципом проектирования MVC
  • Установка практически на любой хостинг
  • Установка новых приложений в один клик — системное приложение «Инсталлер» позволяет устанавливать в уже работающий Webasyst новые приложения из репозитория фреймворка одним щелчком по кнопке «Установить»
  • Smarty, jQuery, jQuery UI и jQuery Mobile входят в базовый состав фреймворка и готовы к использованию
  • Гибкие инструменты для настройки прав доступа к приложениям и их данным для пользователей и групп пользователей
  • Скоро будет реализована единая точка входа для запросов к API, которые будут маршрутизироваться на нужное приложение. Будет предложен единый рекомендуемый формат упаковки данных в API-запросы.

>>> Подробности

★★★★★

Проверено: mono ()

Zend, Symfony и другие популярные PHP-фреймворки ориентированы на решение абстрактных задач, а Вебасист спроектирован для решения более узкой задачи — задачи создания веб-приложений с бекендом.

О, да, это прорыв!

baverman ★★★ ()

Чем оно отличается от других фреймворков?

jessey ()
Ответ на: комментарий от gray

Про специализацию Вэ-басиста, собственно, ни слова

Binary ★★★★★ ()
Ответ на: комментарий от Binary

Про специализацию Вэ-басиста, собственно, ни слова

очевидно же! -

создание веб-приложений с бекендом

)

kelyar ★★★★★ ()

Код особо не смотрел, но сайт и документация понравились. Молодцы.

kelyar ★★★★★ ()

Укажи (узнай) лицензию.

И пни разработчиков, а то так не годится:
1 - В коде указано, что LGPL, но не указана версия лицензии.
2 - В архиве нет текста лицензии. Он вроде для LGPL тоже должен поставляться с кодом.

winddos ★★★ ()

Оно к MySQL, что-ли, гвоздями прибито? Почему, как python или ruby, так всегда пожалуйста sqlite3, а как PHP, так mysql.

deb ()
Ответ на: комментарий от r2d2

Ну это же фреймворк, а не готовый веб сервис.
Т.е подразумевается, что на нем могут и вполне закрытую вещь делать.

Ну а вообще номер версии так или иначе надо в коде указывать, и на сайте, и текст приложить.
Иначе не ясно совершенно.

winddos ★★★ ()
Ответ на: комментарий от winddos

Ну а вообще я не понимаю как именно на скрипты перекладываются пункты лицензии, с линковкой все проще.

winddos ★★★ ()

Есть ли тесты производительности типа как по ссылке?

http://www.yiiframework.com/performance/

Ссылку привел специально, ИМХО, пока что Yii рулит и педалит. И как ведет себя фреймворк для высоконагруженных сайтов - крайне важный параметр.

northerner ★★★ ()

не совсем понял целевую аудиторию данного «фреймворка»

если делаешь «для людей» то почему не цмс? где все в три клика ставят, а потом получают баттхерт, когда нужно что то нестандартное?

если делаешь новый фреймворк для «разработчиков» то надо делать минимальную версию 5.3 сейчас, тут даже неймспейсы не используются, что печально, в релизе уже 5.4.. а мы строим фреймворк на устаревших технологиях

MySQL это плохо, любой нормальный современный фреймворк должен поддерживать PDO или иметь адекватную ORM. Тут какие то зачатки AR, но это примитив. Если не умеете делать свое, берите чужое -> Doctrine2, Propel уже все сделали за вас

хотя покопавшись подольше в документациях создалось впечатление «национального фреймворка для визиток»

вердикт: пациент скорее мертв чем жив, устарев уже при первом релизе настолько насколько это возможно

umren ★★★★★ ()

Посмотрел сайт и документацию - неплохо.

exst ★★★ ()
Ответ на: комментарий от umren

то надо делать минимальную версию 5.3 сейчас

Полно хостингов с 5.2 ещё.

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

Пока разработчики будут идти на поводу у хостеров, развитие будет топтаться на месте.

Sky4eg ()
Ответ на: комментарий от northerner

И как ведет себя фреймворк для высоконагруженных сайтов - крайне важный параметр.

Тест Apache bench'ем пустого проекта, безусловно, в этом смысле весьма показателен.

sjinks ★★★ ()
Ответ на: комментарий от Sky4eg

Пока разработчики будут идти на поводу у хостеров, развитие будет топтаться на месте.

А смысл? :) Неймспейсы в PHP пока не слишком хороши. Синтаксис — вообще тошнотворен. Вот что реально полезно из PHP 5.3 — это всякие get_called_class(). Но пока приходится держаться за совместимость с legacy :)

KRoN73 ★★★★★ ()
Ответ на: комментарий от northerner

Есть ли тесты производительности типа как по ссылке?

Ну а ты думаешь, зачем новость на лоре запостили? Чтобы под нагрузкой посмотреть, как себя вести будет. :)

shell-script ★★★★★ ()
Ответ на: комментарий от shell-script

Тогда нужно было на хабре писать! Хотя автору наверно за карму страшно!

Sky4eg ()
Ответ на: комментарий от KRoN73

Ну синтаксис на любителя. Мне к примеру очень удобно использовать namespace в своих проектах. Да и если уж на то пошло, то гиганты (Симфони, Зенд, Сайлекс) уже имеют в требованиях PHP не ниже 5.3. На мой взгляд это правильно. Массовость диктует моду =)

Sky4eg ()

видел внутренности магазина на webasyst - адская погибель, рекомендую как одно из приложений в php-ад.

hizel ★★★★★ ()
Ответ на: комментарий от KRoN73

так же, как и полно хостингов с 5.3, цена одинаковая, смысл держаться за

Дата выхода ПХП 5.2 - 2006-11-02

umren ★★★★★ ()
Ответ на: комментарий от Sky4eg

У меня там нет аккаунта. И нет желания туда попасть никакого. Хотя читаю хабр постоянно.

Хотя автору наверно за карму страшно!

Не тот возраст ;)

gray ★★★★★ ()
Ответ на: комментарий от KRoN73

Полно хостингов с 5.2 ещё.

Пример хостинга на SpaceWeb
OS: Linux 2.6
Apache: 1.3.37
Perl: 5.8.8
пояснение к версиям PHP PHP4: 4.4.4 ( mod )
пояснение к версиям PHP PHP5: 5.2.5 ( cgi )

northerner ★★★ ()
Ответ на: комментарий от umren

смысл держаться за

legacy. Поскольку в 5.3 нет ничего жизненно необходимого для меня, то нет смысла строить старых клиентов и говорить им: нафиг с пляжа, ищите другой хостинг :)

Я уже молчу про один сторонний проект, за переписывание которого только сейчас взялся. Там всё настолько прибито гвоздями, что до сих пор 2.6.15 ядро стоит, какой там PHP... :)

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

нет смысла строить старых клиентов и говорить им: нафиг с пляжа, ищите другой хостинг :)

Ну это Вы утрируете явно :) Адекватные хостеры просто предоставляют желающим использовать 5.3 отдельные серверы с 5.3.

Новые проекты разумно писать, используя новые инструменты. Старые проекты вряд ли есть смысл переписывать.

northerner ★★★ ()
Ответ на: комментарий от hizel

эм, а как-же security updates?

Ну, оно в качестве бэкенда к nginx на свежей машине стоит, в DMZ :) Но, вообще, вопросы не ко мне, я там не админю…

KRoN73 ★★★★★ ()
Ответ на: комментарий от northerner

Новые проекты разумно писать, используя новые инструменты

Это если проект пишется с нуля. А если используется единый на все проекты фреймворк, то совместимость нужно поддерживать до тех пор, пока она не станет вредить развитию. Как я уже говорил, на практике мне только get_called_class() не хватает. Но не настолько, чтобы пинать заказчиков. Только вопрос синтаксического сахара. Неймспейсы не актуальны, так как я реализовал вполне ещё удовлетворяющий workaround ещё во времена PHP4.

Вот с PHP4 на PHP5 — да, я категорично слинял почти сразу после набора популярности второго, там разница была, действительно, велика :)

KRoN73 ★★★★★ ()
Ответ на: комментарий от Sky4eg

гиганты (Симфони, Зенд, Сайлекс) уже имеют в требованиях PHP не ниже 5.3

Первому зенду достаточно и php 5.2.4 пруф, а второй еще не вышел (бета не в счет)

anthill ()
Ответ на: комментарий от anthill

Я про второй и говорю. Жду не дождусь его выхода! А про первый я знаю...

Sky4eg ()

Забавно !

Пэхэпэшники спорят о своем убогом языке, что им использовать 5.2 или 5.3 Кое кто утверждает, что «гиганты» уже перешли на 5.3 ))) Все посты читаются как сплошной анекдот. )))

yanka ★★ ()
Ответ на: Забавно ! от yanka

А ширше блеснуть мыслей? Какой язык не является убогим? С Вашей точки зрения. ;))

gray ★★★★★ ()
Ответ на: Забавно ! от yanka

Все посты читаются как сплошной анекдот. )))

Ну да, когда читаешь про войну версий Django с версиями Python или RoR с версиями Ruby — то это уже просто грустно :)

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

Полно хостингов с 5.2 ещё.

Какой смысл использовать шаред хостинги, если ВПСки сейчас по баксу за десяток?

KDE41user ()
Ответ на: комментарий от KDE41user

Вопрос не ко мне, я просто программист, а не админ/советник по IT :) Мне за советы денег не платят. А поддержка 5.2 мне ничего не стоит.

KRoN73 ★★★★★ ()
Ответ на: комментарий от KDE41user

Не каждый может настроить впс и в последствии содержать его в рабочем состоянии!

Sky4eg ()
Ответ на: Забавно ! от yanka

Сочуствую вашему развитию. Если вы фанатеете по какому-либо языку, то не стоит говорить, что все другое ужасно! PHP практически идеально справляется со своими задачами, он достаточно прост. Да не спорю среди нас уйма говнокодеров из-за мизерного порога вхождения в язык, но есть и те, кто пишет грамотно и очень серьезные проекты и относится к своему делу ответственно.

Sky4eg ()
Ответ на: комментарий от Sky4eg

Не каждый может настроить впс и в последствии содержать его в рабочем состоянии!

Провайдеры уже не предоставляют услуг по настройке впс?

KDE41user ()
Ответ на: комментарий от KDE41user

Это лишние деньги и порой весьма не малые. А настроенная впс по дефолту редко может соответствовать требованиям

Sky4eg ()
Ответ на: комментарий от Sky4eg

Это лишние деньги и порой весьма не малые.

Если мы говорим о сайтах «я и моя собака», тогда не вопрос. В других случаях стоимость настройки мизерная по сравнению с другими расходами.

KDE41user ()
Ответ на: комментарий от KDE41user

согласен, в данный момент беру дедик в hetzner и буду сам себе хостер =) проекты из вдс выросли.

Sky4eg ()
Ответ на: комментарий от shell-script

Ну а ты думаешь, зачем новость на лоре запостили? Чтобы под нагрузкой посмотреть, как себя вести будет. :)

Вы уверены, что сайт проекта написан с его использованием? ;)

northerner ★★★ ()
Ответ на: комментарий от hizel

видел внутренности магазина на webasyst - адская погибель, рекомендую как одно из приложений в php-ад.

Абсолютно согласен. Как-то, пару лет назад, мне попался в руки магазин на этом деле, владелец хотел много мелочей докрутить. А внутри дикий ад, много неиспользуемых файлов, несколько дублирующих способов работать с БД, смесь html с php прям в контроллерах (хотя рядом же были нормальные шаблоны). В общем, создавалось впечатление сильно перепиливаемой недоделки, которую выдали в процессе работы.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.