LINUX.ORG.RU

Apache Hive 0.7

 , ,


0

1

Разработчики Apache Hive объявили о выходе новой версии: 0.7. Hive — система для выполнения аналитических запросов над большими объемами данных, постронная на базе Apache Hadoop. Hive предоставляет SQL-подобный язык запросов и хорошо подходит для ad-hoc запросов к большим данным. Подробнее о системе можно узнать из вводного видео.

В этой версии:

  • Поддержка индексов, при помощи которых возможно ускорение группировки, сортировки и объединения таблиц
  • Поддержка авторизации и аутентификации
  • Опциональная модель конкурентного доступа с блокировками, построенная на базе Apache Zookeeper

>>> Подробности

★★★★★

>SQL-подобный язык запросов

Поддержка индексов, при помощи которых возможно ускорение группировки, сортировки и объединения таблиц

Поддержка авторизации и аутентификации


wooow!

к большим данным.

Это порадовало отдельно, 1 апреля, как никак :)

yaws ()

какая хорошая шутка.

зы : а что это за «карма» появилась????

Kompilainenn ★★★★★ ()

всё конечно хорошо, вот только на hive-0.7 в данный момент ещё имеются баги:

1. https://issues.apache.org/jira/browse/HIVE-2062 - в транк залили, в бранч нет, в итоге в релизе нету, вариант или патчить или использовать старый jdbc драйвер
2. https://issues.apache.org/jira/browse/HIVE-2075 - в старой версии хайва работало, в текущей облом, где баг ещё недокопал
3. https://issues.apache.org/jira/browse/HIVE-2063 - если хочешь обновлять хайв, то надо и хадуп обновлять, иначе придётся веселиться с патчами в том же jdbc ещё раз

в общем за релиз хотелось бы поставить большой минус

Humanoid ()
Ответ на: комментарий от maxcom

пока не тестили, поэтому утверждать не могу, после стабилизации текущей работы будем смотреть.

В продакшене гоняется hadoop + hive, в планах стоит внедрение hbase, но тут возникла проблемка, для hbase надо отдельная ветка hadoop или сборка от cloudera.

Запланировали обновление версии hadoop до сборки клоудеры, вылезли ошибки о том, что наш hive не может с этой версией работать (крутился 0.6, 0.7 ветка работает с обоими версиями).

Обновили хайв, посыпались баги, попатчили, обновили хадуп, хайв опять обвалился, что-то патчим, что-то откатываем (для примера п.3 выше).

Humanoid ()
Ответ на: комментарий от Humanoid

чую это хорошо что я к Hadoop только присматриваюсь и пока еще нигде не заюзал

maxcom ★★★★★ ()
Ответ на: комментарий от maxcom

ну клоудеровская сборка вроде достаточно стабильная...

ott ★★★★★ ()
Ответ на: комментарий от ott

у нас использовалась версия хайва 0.6, самосборная, уже пытались раньше интегрировать первые версии hbase + некоторые плюшки нужны были.

У клоудены в версии 2 хайв 0.5, хбэйс древнющий, интеграции между ними нету.

версия 3 бета 4 ---- хадуп с патчами из следующих версий, хайв сборка из транка 0.7 (мы сами собирали один в один), хбэйс тоже без каких либо патчей (точно такую же версию слить можно с сайта апача)

когда нужна стабильность - клоудера подходит идеально, когда нужны новая функциональность, то тут сложнее, релиз у них долго поддерживается, в итоге получаем как RHEL - вроде и есть новое, но местами такое старьё.

п.с. баги что перечислил выше в сборках hive от клоудеры так же присутсвуют, проверяли, на данный момент hive у них без единого патча.

Humanoid ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.