LINUX.ORG.RU

Вышел Gajim 0.14

 , , , ,


0

0

2 сентября, через полгода разработки, вышла новая версия популярного XMPP (Jabber) клиента, использующего Python и PyGtk.

В числе новшеств:

  • Поддержка jingle для голосового и видео-общения
  • Ускорен запуск клиента
  • Повторный автоматический вход (auto re-join) в конференции
  • Поддержка определения местоположения (через Geoclue)
  • Более строгое соответствие стандартам XDG
  • Поддержка CAPTCHA для конференций
  • Исправления многочисленных ошибок

>>> Cайт проекта

★★★★★

Проверено: JB ()

Хороший клиент, но я в последнее время предпочитаю Pidgin.

GotF ★★★★★ ()

отлично, ждем когда соберут в PPA :)

JB ★★★★★ ()

ох. а пакетов под ubutu пока что нет :(

aim1159 ★★★★★ ()

jingle кто-нибудь уже тестил? а с psi+? :)

anonymous ()

А ебилд есть в каком нибудь оверлее?

vertexua ★★★☆☆ ()

А иконку с нормальной прозрачностью в трей они сделали?

ostin ★★★★★ ()

Отличный клиент. Спасибо за новость. Ебилды уже в дереве. :}

Insomnium ★★★★ ()
Ответ на: комментарий от GotF

Еще бы pidgin умел список конференций с сервера ввиде закладок забирать...

ostin ★★★★★ ()

хех... а есть что-нибудь похожее, но без питона?

devl547 ★★★★★ ()

Не нужно. Есть же Tkabber.

anonymous ()

Хорошая штука, но тяжеловата. Empathy 2.30 уже заменил.

Valeg ★★★ ()

Глянуть что ли? Особенно интересно вот это

Поддержка jingle для голосового и видео-общения

Раньше пользовался, но оттолкнуло то, что он тормоз, написанный на пузоне.

Flaming ★★ ()
Ответ на: комментарий от GotF

P.S.: а до mcabber'а им всем далеко.

Шаблон затрещал, но выдержал.

urlin ()
Ответ на: комментарий от GotF

>до mcabber'а им всем далеко.

аудио/видео он может?

Хороший клиент, но я в последнее время предпочитаю Empathy.

bohm ★★★★★ ()
Ответ на: комментарий от Flaming

Раньше пользовался, но оттолкнуло то, что он тормоз, написанный на пузоне.

Хороший жабир клиент должен быть написан на эрланге и крутится в облаке? Я давно подозревал, что производительность там нужна ого-го. :)

urlin ()

Что из этого обязательно необходимо для видео общения?

1. Сервер jabber, который специально поддерживает jingle

2. Отдельная установка плагинов/библиотек jingle

3. Поддержка веб-камера и настройки софта и у собеседника тоже

Как настраивали и тестировали?

vertexua ★★★☆☆ ()
Ответ на: комментарий от anonimbus

Кто избавился?

 * dependency graph for net-im/gajim-0.14
 `--  net-im/gajim-0.14  ~amd64 
  `--  x11-libs/gtk+-2.20.1-r1  (x11-libs/gtk+) amd64 
  `--  dev-python/pygtk-2.17.0  (>=dev-python/pygtk-2.16.0) ~amd64 
  `--  sys-devel/gettext-0.18.1.1-r1  (>=sys-devel/gettext-0.17-r1) ~amd64 
  `--  dev-util/intltool-0.41.1  (>=dev-util/intltool-0.40.1) amd64 
  `--  dev-util/pkgconfig-0.25-r2  (dev-util/pkgconfig) amd64 
  `--  dev-lang/python-2.6.5-r3  (=dev-lang/python-2*) amd64 
  `--  dev-python/pyopenssl-0.10-r1  (dev-python/pyopenssl) amd64 
  `--  dev-python/sexy-python-0.1.9-r1  (dev-python/sexy-python) amd64 
  `--  app-crypt/gnupg-2.0.16-r1  (app-crypt/gnupg) amd64 
  `--  dev-python/pycrypto-2.1.0  (dev-python/pycrypto) amd64 
  `--  dev-python/dbus-python-0.83.1  (dev-python/dbus-python) ~amd64 
  `--  dev-libs/dbus-glib-0.86  (dev-libs/dbus-glib) amd64 
  `--  dev-python/notify-python-0.1.1-r1  (dev-python/notify-python) amd64 
  `--  net-dns/avahi-0.6.27-r1  (net-dns/avahi) ~amd64  [dbus gtk python]
  `--  dev-python/libgnome-python-2.28.1  (dev-python/libgnome-python) amd64 
  `--  dev-python/gnome-keyring-python-2.30.2  (dev-python/gnome-keyring-python) amd64 
  `--  dev-python/egg-python-2.25.3  (dev-python/egg-python) amd64 
  `--  x11-libs/libXScrnSaver-1.2.0  (x11-libs/libXScrnSaver) amd64 
  `--  dev-python/libasyncns-python-0.7.1  (dev-python/libasyncns-python) ~amd64 
  `--  net-dns/bind-tools-9.7.1  (net-dns/bind-tools) ~amd64 
  `--  app-text/gtkspell-2.0.16  (app-text/gtkspell) amd64

ostin ★★★★★ ()

поделки на бидоне не нужны

ArtemZ ()

хороший клиент, но в последнее время предпочитаю psi

thunar ★★★★★ ()

Замечательный IM-client. Предпочитаю его всем остальным.

Pronin ★★★★ ()

Предпочитаю mcabber, но gajim регулярно собирается из hg.
Хороший клиент.

dark_lord ()
Ответ на: комментарий от Lumi

>> Подправь ebuild от 0.13

Такой умный череп не жмет, явно ты ебилд новый собирал

anonymous ()

Отлично!

Долгожданная поддержка джингл для джабер-клиента на питоне!

Уже качаю. <негромко>Ура!</негромко>

k0valenk0_igor ★★★ ()
Ответ на: комментарий от vertexua

Что из этого обязательно необходимо для видео общения?

1. Сервер jabber, который специально поддерживает jingle

Это точно не нужно. Джингл поддерживается только клиентом

k0valenk0_igor ★★★ ()
Ответ на: комментарий от k0valenk0_igor

>Ну, сделай на перле!

Есть уже! Хотя когда я на него смотрел последний раз, оно было кривое до безобразия.

anonymous ()
Ответ на: комментарий от ostin

> А иконку с нормальной прозрачностью в трей они сделали?

да, починили

JB ★★★★★ ()

Славный клиент. Сам сижу на mcabber, но друзья и девушка пользуются gajim'ом.

daemonpnz ★★★★★ ()
Ответ на: комментарий от vertexua

1 - такого нет, это client-side-фича
2 - да, зависит от клиента (в gajim, например, надо доставлять нужное, см. окошко поддерживаемых фич в справке; в Psi+ нужна psimedia)
3 - да, твой клиент должен «увидеть», что чужой клиент поддерживает звонки.

YAR ★★★★★ ()
Ответ на: комментарий от anonymous

> Такой умный череп не жмет, явно ты ебилд новый собирал

eix gajim | grep Installed
Installed versions: 0.13.4-r1[1](20:15:28 16.04.2010)(X crypt dbus gnome idle libnotify nls spell srv trayicon xhtml -avahi)

Lumi ★★★★★ ()

Хорошая новость. А то огорчала скорость выхода версий гаджима.

buddhist ★★★★★ ()

Согласно коммитам этот джингл уже с client-side шифрованием XTLS. Кроме гаджима, XTLS draft кто-нибудь поддерживает?

shahid ★★★★★ ()
Ответ на: комментарий от JB

спасибо. но я бы хотел дождаться билда из офф. ppa

aim1159 ★★★★★ ()

Gajim заваливает Pidgin (разных версий) при попытке позвонить видео/голосом)

Для Google Talk Gajim говорит что у него нет поддержки видео.

Печаль...

aim1159 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.