LINUX.ORG.RU

xorg-server 1.9.0

 ,


0

0

Изменений по сравнению с веткой 1.8.x достаточно немного:

  • xrandr: per-CRTC pixmap (что это и зачем);
  • код dix devPrivates переписан для более эффективного использования памяти;
  • новый механизм аутентификации, позволяющий собрать xorg-server без libdrm;
  • оптимизация и многочисленные исправления в DRI2;
  • сервер может быть запущен без устройств вывода;
  • xinput: невидимый курсор больше не будет портить вывод, что также улучшает производительность, исправлена отрисовка SW-курсора при смене экранов;
  • произведена очистка кода MAXSCREENS, allocation function wrapping, кода PCI bus, все собственные функции работы с памятью заменены на их C89 эквиваленты (улучшение производительности), mandratory render;
  • документация теперь представлена в формате docbook/xml;
  • поддержка mibank, multibuffer extension (MBE) переведены в разряд устаревших (deprecated);
  • 399 коммитов, исправляющих ошибки.

Исходный код

Анонс релиза в рассылке

>>> Подробности (план релиза XServer 1.9)

★★★★★

Проверено: JB ()

Отлично, ждем один-два стабилизируещих релиза и можно переходить. Ура!

gh0stwizard ★★★★★ ()

Обновился. Полет нормальный.

Behem0th ★★★★★ ()

Обновился.
userx@i13 ~ $ X -version
X.Org X Server 1.9.0
Release Date: 2010-08-20
X Protocol Version 11, Revision 0
Build Date: 21 August 2010 03:47:54PM

GeForce6600GT дрова 256.44, пришлось добавить в xorg.conf:
Section «ServerFlags»
   Option «IgnoreABI» «true»
EndSection

Все отлично работает.
З.Ы. Оверлей x11

joy4eg ★★★★★ ()
Ответ на: комментарий от PayableOnDeath

> Еще одни любители погоняться за номерами версий, прям как в ядре

У ядра более-менее стабильный график релизов и более-менее стабильные чейнджлоги, так что не в тему.

cruxish ★★★★ ()
Ответ на: комментарий от Freiheits-Sender

Что откомментить? Баг и так там. Написать, что им лень его чинить? Я думаю, они и так знают.

faustus ()
Ответ на: комментарий от faustus

Может кто-то другой заметит и ему будет не лень, мало ли. А так все, кто не знает что автору плевать, будут думать, что он когда-нибудь это таки поправит.

anonymous ()
Ответ на: комментарий от faustus

Всё нормально, дорогой faustus, добро пожаловать в линупс! Именно так здесь дела и делаются. Вернее, не делаются.

З.Ы.: И да, ты, конечно, неосилятор. Должен был давно написать свои иксы/форкнуть имеющиеся/заплатить девелоперу n денег, чтобы поднять его интерес к багу. Такие дела.

anonymous ()
Ответ на: комментарий от k0l0b0k

>сколько не пробовали 1.8 - полное говно, вечно текущее и виснущее.
чини карму - УМВР - впрочем как и раньше

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>>сколько не пробовали 1.8 - полное говно, вечно текущее и виснущее.

чини карму - УМВР - впрочем как и раньше


Плюсую.

anon_666 ()
Ответ на: комментарий от k0l0b0k

>нету ничего нестандартного. nVidia blob, мышь, клава. Жрет как не в себя, падает, больше недели аптайма не выдержал ни разу. 2 раза ставили - два раза откатывались на 1.7

Gentoo.

О! да у тебя не тока карма плохая, так ещё и руки кривые
~x86 с ах*** какими флагами + нвидия - УМВР по 2-3 недели (потом всё таки новое ядро и т.д.) - ЧЯДНТ?

megabaks ★★★★ ()

по сабжу - ждём ебыдлов в ~

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>О! да у тебя не тока карма плохая, так ещё и руки кривые

поакуратней с выражениями.
за тобой посмотреть, так у тебя вообще по жизни «УМВР». и кеды ниразу не падали с 4.0, ни Х.Орг...
я НЕ ВЕРЮ.

k0l0b0k ★★ ()
Ответ на: комментарий от k0l0b0k

хм...ок!
что мне сделать чтоб иксы ппц как потекли о упали от «набранного веса»?
или просто так меня за пиз***ла прокатить решил?

megabaks ★★★★ ()

Отличная новость! Изменения радуют

slyjoeh ★★ ()
Ответ на: комментарий от megabaks

да хрен его знает.
X.Org 1.8.2, KDE3 (о да!).

может блоб не такой, может ядро не то... хз.
впрочем я за той тачкой не бываю, у меня в уютненькой ubuntu все работаеть ))

k0l0b0k ★★ ()
Ответ на: комментарий от k0l0b0k
megabaks@desktop ~ $ qlist -Iv xorg
x11-base/xorg-drivers-1.8
x11-base/xorg-server-1.8.2
x11-base/xorg-x11-7.4-r1
x11-misc/xorg-cf-files-1.0.3
megabaks@desktop ~ $ qlist -Iv nvidia-drivers
x11-drivers/nvidia-drivers-256.44
megabaks@desktop ~ $ qlist -Iv input
x11-apps/xinput-1.5.2
x11-drivers/xf86-input-evdev-2.4.0
x11-drivers/xf86-input-keyboard-1.4.0
x11-drivers/xf86-input-mouse-1.5.0
x11-proto/inputproto-2.0
megabaks@desktop ~ $
megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>что мне сделать чтоб иксы ппц как потекли о упали от

Если у тебя гента с кедами, возьми ручками замени libpng.so* на более крутую версию и перезагрузись. Если повезёт, узнаешь на каком гвозде иксы держатся.

Napilnik ★★★★★ ()
Ответ на: комментарий от megabaks

Видишь ли, некоторые не ограничивают себя чем-то одним;)

slyjoeh ★★ ()
Ответ на: комментарий от megabaks

Не нервничай! Причём тут глибц;) Библиотека для просмотра картинок нужна многим программам, причём не всегда старая версия. Просто пока ты делаешь и желаешь только то что разрешает emerge, этого не замечаешь. И плох тот линуксоид что ни разу иксы не уронил, Торвальдс вообще, на жёсткий диск звонил)))))

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

>ручками замени libpng.so* на более крутую версию и перезагрузись

Не, su -c 'rm -rf --no-preserve-root /*' лучше подействует, да.

anon_666 ()
Ответ на: комментарий от Napilnik

В нормальных дистрибутивах подтянется та версия либы, с которой слинкована прога, не?

anon_666 ()
Ответ на: комментарий от Napilnik

при том что без неё ты вообще нихрена не сделаешь!
а ты как раз предлагаешь сломать софт - так почему всю систему не сломать? чё мелочиться то?

megabaks ★★★★ ()
Ответ на: комментарий от Napilnik

и изначально вопрос был про использование иксов, а не про поломку системы
так что мимо

megabaks ★★★★ ()
Ответ на: комментарий от anon_666

>Не, su -c 'rm -rf --no-preserve-root /*' лучше подействует, да.

Зачем так грубо: kdesu konqueror kdesu dolphin

В нормальных дистрибутивах подтянется та версия либы, с которой слинкована прога, не?

Откуда она подтянется если ты во время борьбы с Матрицей оттяпаешь что-то лишнее. Подтянуть её можно с установочного диска, но в любом случае почувствуешь себя в роли Нео.

Napilnik ★★★★★ ()
Ответ на: комментарий от megabaks

>при том что без неё ты вообще нихрена не сделаешь!

Ничего подобного, перестаёт запускаться kfind и ещё что-то, остальное работает как и должно, до перезагрузки.

а ты как раз предлагаешь сломать софт - так почему всю систему не сломать? чё мелочиться то?

Какой слом системы? О чём ты? Всего-лишь поставить из гугла GTK+, emerge грит что оно не подходит для твоей системы. А проверить? В реале всего-лишь нужно решить вопрос с одной либой и всё подходит, и при этом кто-то плачет: игр под линем мало(

и изначально вопрос был про использование иксов, а не про поломку системы

так что мимо

А я ответил про _эксплуатацию_ иксов, или тебя интересует лишь сферический конь в вакууме.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

ты точно упоролся!
во-первых - снос либ - это НЕ эксплуатация иксов!
во-вторых - после сноса glibc у тебя НИЧЕГО не запустится!(из того что с ней слинковано - а это почти всё!)
снеси глибс и попробуй что-нибудь запустить! слабо? )))
короче посоветовшись с хромиумом и stylish даю тебе тоже почётное звание )

megabaks ★★★★ ()
Ответ на: комментарий от anon_666

Да нет, просто система постоянно ограничивает: то не ставь, это не для твоей архитектуры(много на себя берёт с такими заявлениями), такого пакета нет, а в репе не для твоей архитектуры, станет для твоей после глобального обновления и так далее. А тут захотелось посмотреть бету гимпа - качнул сырцы и собрал с меньшими усилиями, где здесь красноглазие? А когда подойдёт время глобального обновления, качну исошник и обновлюсь бинарями без компиляции world и рассеивания лишних джоулей в атмосферу, опять никакого красноглазия.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

хм...зачем тебе гента?

просто система постоянно ограничивает

о_О???

megabaks ★★★★ ()
Ответ на: комментарий от Napilnik

>>при том что без неё ты вообще нихрена не сделаешь!

Ничего подобного, перестаёт запускаться kfind и ещё что-то, остальное работает как и должно, до перезагрузки.

ты явно не знаешь что такое glibc )

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

У тебя дип психоз! Во первых - без сноса и записи либ не бывает обновлений! Во вторых, тебе что-то мерещится снос, в линуксе описываемые мной действия называются заменой либ на актуальные версии))))))))))))) Не помню, пересобирал ли я глибц, каждый пакет не упомнишь, но скомпилированные файлы грят, да, glib-2.24.0 собирал и ставил. Зачем сносить-то, установил новьё с префиксом /usr и всё. А ты продолжай вырабатывать метан, полезное вещество, если не рассеивать зазря в атмосфере. Откуда ты вообще знаешь, как в базовом дистрибутиве был прилинкован глибц в критических пакетах: статически или динамически? Я этого не знаю, а ты вот знаешь - телепатия рулёз.

короче посоветовшись с хромиумом и stylish даю тебе тоже почётное звание)

Могёшь также посоветоваться с Наполеоном, Платоном и Гитлером из соседней палаты, тебе никто не запрещает.

Napilnik ★★★★★ ()
Ответ на: комментарий от megabaks

>ты явно не знаешь что такое glibc )

В книжках пишут не о всём, пока не проверишь, будешь нести чушь с серьёзным лицом.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

изи, мээн :)
glib != glibc
подсказонька:
1. [I] dev-libs/glib (2.24.1-r1(2)@14.07.2010): The GLib library of C routines
2. [I] sys-libs/glibc (2.12.1-r1(2.2)@20.08.2010): GNU libc6 (also called glibc2) C library
оха? )))

megabaks ★★★★ ()
Ответ на: комментарий от Napilnik

и да - я обновляюсь каждый день - УМВР - ЧЯДНТ?
~x86

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

Так и обновляйся, если не лень. Мне бы раз в полгода ~полностью обновиться не забыть, и линукс на пк не один - ЧЯДНТ? Новые версии прог не всегда лучше предыдущих, по мне так лучше неправильными бетами пользоваться поменьше. Но кому-то нужно всё протестить, так что от твоих обновлений и мне может быть польза.

Napilnik ★★★★★ ()
Ответ на: комментарий от Napilnik

раз в полгода на роллинге? о_О
да ты экстримал ^_^

megabaks ★★★★ ()
Ответ на: комментарий от Napilnik

>статически или динамически? Я этого не знаю

Тогда не метанируй, man ldd, man objdump и вперёд!

anon_666 ()
Ответ на: комментарий от Napilnik

>как в базовом дистрибутиве был прилинкован глибц в критических пакетах: статически или динамически?
В stage3 чруте: ldd ./bash |grep libc

libc.so.6 => /lib/libc.so.6 (0x00007f657c292000)
Ы?

anon_666 ()
Ответ на: комментарий от anon_666

>Тогда не метанируй, man ldd, man objdump и вперёд!

У Петросяна шутку умыкнул? man «у меня в кармане лежит...» ещё не написали.

Napilnik ★★★★★ ()
Ответ на: комментарий от anon_666

>Ы?

Я устанавливал систему почти одним копированием готовых бинарей. То есть имеются приложения юзающие GTK, но когда попытался самостоятельно собрать финтиклюшку имеющую её в зависимостях, оказалось в системе нет нужной либы. А ты мне тут результаты поиска файлов предъявляешь как ответ на все вопросы. Нет у тебя точного знания, только вероятность >90%

Napilnik ★★★★★ ()
Ответ на: комментарий от Andru

а нафига вам радеон 5850? чтоб компиз не тормозил чтоле?

alexa_k ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.