LINUX.ORG.RU

Вышел Thunar 1.1.0

 , ,


0

0

Вышла новая версия графического файлового менеджера из состава Xfce.

Из изменений:

  • ThunarVFS заменён на GIO. Это даёт, в частности, возможность работать с файлами и папками по сети (FTP, SMB, etc.) так же, как и в Nautilus;
  • на боковой панели теперь отображается значок «Сеть». Значок «Корзина» оттуда теперь можно убрать;
  • прогресс всех операций с файлами отображается в одном диалоге (как в Nautilus);
  • минимальный размер боковой панели теперь считается из расчёта на символы UTF-8, а не байты. Таким образом, исправлен баг, при котором боковая панель не желала сжиматься меньше довольно большого размера, если на ней были закладки с русскими буквами.

>>> Архив

На FreeBSD пока что минорные обновления Xfce4:

> pkg_version -v | grep need
Terminal-0.2.12_4                   <   needs updating (port has 0.4.3)
Thunar-1.0.1_1                      <   needs updating (port has 1.0.1_2)
libchamplain-0.4.2                  <   needs updating (port has 0.4.3)
libexo-0.3.101_1                    <   needs updating (port has 0.3.106)
libxfce4gui-4.6.1_1                 <   needs updating (port has 4.6.2)
mousepad-0.2.16_2                   <   needs updating (port has 0.2.16_3)
orage-4.6.1_1                       <   needs updating (port has 4.6.1_2)
p5-Compress-Raw-Zlib-2.023          <   needs updating (port has 2.024)
thunar-archive-plugin-0.2.4_3       <   needs updating (port has 0.2.4_4)
xfburn-0.4.1_3                      <   needs updating (port has 0.4.1_4)
xfce4-appfinder-4.6.1_1             <   needs updating (port has 4.6.1_2)
xfce4-desktop-4.6.1_1               <   needs updating (port has 4.6.1_2)
xfce4-mixer-4.6.1_1                 <   needs updating (port has 4.6.1_2)
xfce4-notification-daemon-0.3.7_6   <   needs updating (port has 0.3.7_7)
xfce4-panel-4.6.1_1                 <   needs updating (port has 4.6.3)
xfce4-print-4.6.1_1                 <   needs updating (port has 4.6.1_2)
xfce4-screenshooter-plugin-1.6.0_1  <   needs updating (port has 1.6.0_2)
xfce4-session-4.6.1_1               <   needs updating (port has 4.6.1_2)
xfce4-settings-4.6.1_2              <   needs updating (port has 4.6.4)
xfce4-systemload-plugin-0.4.2_8     <   needs updating (port has 0.4.2_9)
xfce4-utils-4.6.1_1                 <   needs updating (port has 4.6.1_2)
xfce4-weather-plugin-0.7.3          <   needs updating (port has 0.7.3_1)
xfce4-wm-4.6.1_1                    <   needs updating (port has 4.6.1_2)
xfce4-xkb-plugin-0.4.3_7            <   needs updating (port has 0.4.3_8)

iZEN ★★★★★ ()
Ответ на: комментарий от los_nikos

Классно! Спасибо большое за старания!

Только вот я все-равно не знаю, ждать ли объявления на официальном сайте или нет.

hibou ★★★★★ ()
Ответ на: комментарий от hibou

Наверное лучше подождать, кто-то видимо апрувит, хотя может и бот собирает страницы.

los_nikos ★★★★★ ()
Ответ на: комментарий от LucidFox

Какая-то странная прозрачость и какой-то переизобретенный AVFS.

t184256 ★★★★★ ()

Ура! Ему не хватает только вкладок (добавили же в pcmanfm, значит это не утяжеляет прогу)

Divius ★★ ()

Вижу новость на главной.
Первая строка:
«Внимание модераторам. С этой новостью мы договорились подождать до освещения на оффициальном сайте.»

Думаю, какой придурок подтвердил, не убрав.
захожу - шаман.
Захожу на сайт:
http://thunar.xfce.org/index.html
«Thunar 1.0.0 was released on 2009/02/26»

Шаман, такой шаман.

Pavval ★★★★★ ()
Ответ на: комментарий от Pavval

Ох лол, «новость» годичной давности. И ведь никто не заметил даже. ЛОР такой ЛОР ;)

yet_another_anon ()

Thunar отличный ФМ... В принципе новшеств в этой версии с гулькин пенис...Лучше бы отделили его от XFCE, вот было бы лучшей новостью.

anonymous ()
Ответ на: комментарий от Pavval

В том и дело что нету.

Ну ладно, архив есть - может кому пригодится.

hibou ★★★★★ ()
Ответ на: комментарий от anonymous

>Лучше бы отделили его от XFCE, вот было бы лучшей новостью.

Так его и отделяют, и двигают в направлении гнома. Говнюки.

anonymous ()
Ответ на: комментарий от anonymous

Re: Вышел Thunar 1.1.0

Цитируем anonymous

Лучше бы отделили его от XFCE

В принципе, зависимости не особо страшные. Не то что Nautilus, например.

GotF ★★★★★ ()
Ответ на: комментарий от annulen

Ну так xfce - это вообще проект «маленького лёгкого и правильного гнома» :)

С уважением, ваш К.О. :)

matimatik ()

омг.. выкосил нах hal с dbus'oм. а автомаунт devd'ом.. прешел на тхунар а теперь и с него перейду. нах хал с дбасом его же и так пытаются выкосить везде и уйти с него?

belial_bsd ()
Ответ на: комментарий от belial_bsd

а что, сам тхунар юзает хал?.. ЕМНИП только thunar-volume-manager...

matimatik ()
Ответ на: комментарий от evrey

да, на лоре много вантузятнегофф :-( их везде много, всё ещё... но ничего, вендекапец не за горами :-)

matimatik ()
Ответ на: УРА!!! Дождались! от lig

Re: УРА!!! Дождались!

> Вот теперь можно снова закапывать GNOME.

Угу, тогда уж с тунаром вместе, потому что его тянет, сцуко.

anonymous ()
Ответ на: комментарий от anonymous

> Ага, щас, это gio в glib, а для работы ему gvfs нужна, которая как раз половину гнома и тянет.

Не нужна. Для «всяких сетевых папок» нужна, но половину Гнома это не тянет.

LucidFox ()
Ответ на: комментарий от Pavval

>>не все уверены, что вкладки нужны...

Но никто не заставляет их юзать, если они есть.

Не поспоришь :) просто те, кому они не нужны, ленятся реализовавывать... Вы можете помочь проекту :)

matimatik ()
Ответ на: комментарий от matimatik

Если честно, я до перехода на Thunar вкладками в Nautilus не пользовалась почти никогда. Всё равно у меня все окна прячутся за одной иконкой в Docky, а перетаскивать файлы удобнее в окно, чем прицеливаясь в ма-а-аленький корешок вкладки.

С точки зрения эргономики зачем телеге пятое колесо - непонятно. Наверное, «чтобы было». Или «чтобы отвязались».

LucidFox ()
Ответ на: комментарий от anonymous

Ага, щас, это gio в glib, а для работы ему gvfs нужна, которая как раз половину гнома и тянет.

> pkg_info -r gvfs-1.4.3
Information for gvfs-1.4.3:

Depends on:
Dependency: xineramaproto-1.1.2
Dependency: xf86vidmodeproto-2.2.2
Dependency: xextproto-7.0.5
Dependency: renderproto-0.9.3
Dependency: randrproto-1.3.0
Dependency: kbproto-1.0.3
Dependency: inputproto-1.5.0
Dependency: fixesproto-4.0
Dependency: dri2proto-2.0
Dependency: damageproto-1.1.0_2
Dependency: compositeproto-0.4
Dependency: font-util-1.0.1
Dependency: encodings-1.0.2,1
Dependency: xmlcatmgr-2.2
Dependency: xmlcharent-0.3_2
Dependency: iso8879-1986_2
Dependency: expat-2.0.1_1
Dependency: docbook-xml-4.5
Dependency: docbook-xml-4.4_1
Dependency: docbook-xml-4.3
Dependency: docbook-xml-4.2_1
Dependency: docbook-sk-4.1.2_4
Dependency: docbook-5.0_1
Dependency: docbook-4.5_2
Dependency: docbook-4.4_2
Dependency: docbook-4.3
Dependency: docbook-4.2
Dependency: docbook-4.1_3
Dependency: docbook-4.0_3
Dependency: docbook-3.1_4
Dependency: docbook-3.0_4
Dependency: docbook-2.4.1_1,1
Dependency: docbook-1.4
Dependency: docbook-xsl-1.75.2
Dependency: gnome_subr-1.0
Dependency: dmidecode-2.10
Dependency: cups-client-1.4.2_3
Dependency: pciids-20091229
Dependency: hicolor-icon-theme-0.11
Dependency: gnomehier-2.3_12
Dependency: python26-2.6.4
Dependency: libproxy-0.2.3
Dependency: perl-threaded-5.10.1
Dependency: png-1.2.41
Dependency: jpeg-7
Dependency: jbigkit-1.6
Dependency: tiff-3.9.2
Dependency: pkg-config-0.23_1
Dependency: xproto-7.0.15
Dependency: pixman-0.16.0
Dependency: libtasn1-2.3
Dependency: libfontenc-1.0.4
Dependency: libXdmcp-1.0.2_1
Dependency: libXau-1.0.4
Dependency: libICE-1.0.4_1,1
Dependency: libSM-1.1.0_1,1
Dependency: freetype2-2.3.11
Dependency: mkfontscale-1.0.6
Dependency: mkfontdir-1.0.4
Dependency: fontconfig-2.8.0,1
Dependency: font-misc-meltho-1.0.0_1
Dependency: font-misc-ethiopic-1.0.0
Dependency: font-bh-ttf-1.0.0
Dependency: bitstream-vera-1.10_4
Dependency: xorg-fonts-truetype-7.4
Dependency: pcre-8.00
Dependency: libvolume_id-0.81.1
Dependency: libsigsegv-2.5
Dependency: m4-1.4.13,1
Dependency: libpthread-stubs-0.3_3
Dependency: libxcb-1.5
Dependency: xcb-util-0.3.6_1
Dependency: libdrm-2.4.12
Dependency: libX11-1.2.1_1,1
Dependency: libXt-1.0.5_1
Dependency: libXrender-0.9.4_1
Dependency: libXft-2.1.14
Dependency: libXfixes-4.0.3_1
Dependency: libXext-1.0.5,1
Dependency: libXxf86vm-1.0.2
Dependency: libXrandr-1.3.0
Dependency: libXmu-1.0.4,1
Dependency: libXinerama-1.0.3,1
Dependency: libXi-1.2.1,1
Dependency: libXdamage-1.1.1
Dependency: libXcursor-1.1.9_1
Dependency: libXcomposite-0.4.0,1
Dependency: libGL-7.4.4
Dependency: libGLU-7.4.4
Dependency: libglut-7.4.4
Dependency: jasper-1.900.1_8
Dependency: glitz-0.5.6_2
Dependency: cairo-1.8.8,1
Dependency: libffi-3.0.9
Dependency: libdaemon-0.12
Dependency: icu-3.8.1_2
Dependency: sqlite3-3.6.19
Dependency: gdbm-1.8.3_3
Dependency: libiconv-1.13.1
Dependency: libxml2-2.7.6_1
Dependency: py26-libxml2-2.7.6
Dependency: gettext-0.17_1
Dependency: popt-1.14
Dependency: libgpg-error-1.7
Dependency: libgcrypt-1.4.4
Dependency: libxslt-1.1.26
Dependency: glib-2.22.4
Dependency: getopt-1.1.4_1
Dependency: gamin-0.1.10_3
Dependency: gio-fam-backend-2.22.4
Dependency: shared-mime-info-0.70
Dependency: pango-1.26.2
Dependency: libIDL-0.8.13
Dependency: dbus-1.2.16_1
Dependency: dbus-glib-0.82
Dependency: avahi-app-0.6.25_2
Dependency: policykit-0.9_5
Dependency: eggdbus-0.6
Dependency: bison-2.4.1,1
Dependency: gobject-introspection-0.6.7
Dependency: polkit-0.95_3
Dependency: consolekit-0.4.1_2
Dependency: hal-0.5.13_12
Dependency: bash-4.0.35
Dependency: rarian-0.8.1
Dependency: gnome-doc-utils-0.18.1
Dependency: ORBit2-2.14.17
Dependency: libcddb-1.3.1
Dependency: cdparanoia-3.9.8_8
Dependency: libcdio-0.82_1
Dependency: lzo2-2.03_2
Dependency: gnutls-2.8.3
Dependency: atk-1.28.0
Dependency: gtk-2.18.5
Dependency: libnotify-0.4.5_1
Dependency: gconf2-2.28.0
Dependency: policykit-gnome-0.9.2_2
Dependency: gnome-keyring-2.28.2
Dependency: gnome-mount-0.8_3
Dependency: libsoup-2.28.2

Где тут «половина гнома»?

iZEN ★★★★★ ()
Ответ на: комментарий от belial_bsd

> омг.. выкосил нах hal с dbus'oм. а автомаунт devd'ом.. прешел на тхунар а теперь и с него перейду. нах хал с дбасом его же и так пытаются выкосить везде и уйти с него?

А мне надоел devd. Он не может монтировать носители от «интерактивного» пользователя, а монтирует только от того, для которого вписано правило.
Да, к тому же, в devd приходится флэшку монтировать в sync-режиме, что отрицательно сказывается на скорости записи для неё.

Снова интегрировал Thunar и HAL, прописал правила для группы в PolicyKit.conf, и всё работает.

iZEN ★★★★★ ()
Ответ на: комментарий от LucidFox

Ну да, именно чтоб отвязались :)

Нравятся почему-то некоторым эти вкладки шопесец...

matimatik ()

Когда уже хоть в одном не KDE-шном файлом менеджере появится возможность разделения окна на две части? А то приходится вот mc пользоваться

prorok2k ()

Замечательная новость, мой любимый фм, сейчас попробую собрать из архива

Lennox ★★★★★ ()
Ответ на: комментарий от matimatik

>>>не все уверены, что вкладки нужны...

Но никто не заставляет их юзать, если они есть.


Не поспоришь :) просто те, кому они не нужны, ленятся реализовавывать... Вы можете помочь проекту :)


<нежно>Спасибо большое конечно, но у меня уже есть Dolphin</нежно>

Pavval ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.