LINUX.ORG.RU

GNU libC 2.4


0

0

Готовясь к выпуску Fedora Core 5 её разработчики форсировали выход новой стабильной версии самой главной библиотеки всех линукс дистрибутивов glibc. В этой версии добавлены новые полезные функции, появилась поддержка интерфейса inotify ядра Линукса, добавлены новые локальные страницы в iconv, LinuxThreads модель нитей теперь не поддерживается, а также произведено множество других изменений. Для использования этой версии библиотеки рекомендуются ядра версий 2.6.16 и выше.

Скачать: ftp://ftp.gnu.org/gnu/glibc/glibc-2.4... README: http://sources.redhat.com/cgi-bin/cvs...

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Re: GNU libC 2.4

FC5 будет 100% несовместима с ядрами до 2.6.0. Грустно. Или это прогресс?

birdie ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от birdie

Re: GNU libC 2.4

Из spec файла glibc в FC:

Conflicts: kernel < 2.6.9
Conflicts: gcc4 <= 4.0.0-0.6

%ifarch ppc s390 s390x
BuildRequires: gcc >= 4.1.0-0.17
%endif

Вот вам и совместимость.

birdie ★★★★★ ()

Re: GNU libC 2.4

смерть linuxthreads и ядрам 2.4.x

ananas ★★★★★ ()

Re: GNU libC 2.4

> рекомендуются ядра версий 2.6.16 и выше.

я что то пропустил ?

anonymous ()
Ответ на: Re: GNU libC 2.4 от birdie

Re: GNU libC 2.4

Да ладно, оно и сейчас достаточно условно совместимо:

---> Package udev.i386 0:071-0.FC4.3 set to be updated

---> Error: udev conflicts with kernel < 0:2.6

alt-x ★★★★★ ()

Re: GNU libC 2.4

Так а че вы хотели от дистра который используется для тестирования инноваций. А вобще правильно, рубить нужно такие вещи. Пичальная статистика, при разработке новых версий виндовса 90% процентов уходит на работу по потдержке старого софта, а отсюда и морально устаревший АПИ и все остальное...

Maclaud ()
Ответ на: Re: GNU libC 2.4 от Maclaud

Re: GNU libC 2.4

Да линукс вполне себе поддерживает старый софт. Давеча обнаружил у себя в /usr/local игрушку, квест Hopkins FBI, которую я устанавливал более 5 лет назад. Как ни странно, бинарник до сих пор запускается, хотя был установлен во времена rh7.0 или даже 6.2, уже не помню.

alt-x ★★★★★ ()

Re: GNU libC 2.4

Обратная овместимость - это, конечно, очень хорошо, но когда она начинает мешать шевелиться (как, например, в случае в уже упомянутой Windows или IA-32) - это уже не так приятно.

Если нужно, чтобы работал старый софт, то пусть стоят старые библиотеки. Если хочется новых библиотек, то придётся выбросить старый софт (который писался без взгляда в будущее, что само по себе жутко неправильно).

const86 ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от const86

Re: GNU libC 2.4

А чего-то вроде libmap.conf в линуксе нет? Тогда действительно грустно.

// pppp

anonymous ()
Ответ на: Re: GNU libC 2.4 от const86

Re: GNU libC 2.4

насколько я ничего не понимаю, совместимость поломана между либц и ядром а не между приложениями и либц

sergej ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

>А чего-то вроде libmap.conf в линуксе нет? Тогда действительно грустно.

А для чего он (в двух словах)?

blaster999 ★★ ()
Ответ на: Re: GNU libC 2.4 от const86

Re: GNU libC 2.4

>который писался без взгляда в будущее, что само по себе жутко неправильно

Да нет. Практика, как раз показывает, что человек не может предсказывать будущее. По статистике 47% фич которые были имплементированы из расчета на будущее, редко, либо никогда не используются. Как правило, имеет смысл писать софт, который решает сегоднящние задачи, потому что заврашние решатся завтра гораздо проще. Поэтому собственно, открытые исходники и рулят - они позволяют не засорять код фичами, которые могут никогда не потребоваться, но в то же время, всегда легко добавить новые фичи.

Впрочем, открытость исходников является только необходимым условием. Достаточным она не является - если проект написан через одно место и недокументирован, его как правило, легче выкинуть, чем привести в хорошее состояние.

А по поводу взгляда в будущее: ты уже знаешь, в каком универе будут учиться твои внуки? :) Что-нибудь предпринял, чтобы помочь им в этом? А уверен, что то что ты можешь сейчас предпринять, им в этом хоть как-то поможет? Вот и с поколениями софта та же самая история.

alt-x ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от blaster999

Re: GNU libC 2.4

>>А чего-то вроде libmap.conf в линуксе нет? Тогда действительно грустно.

>А для чего он (в двух словах)?

Чтобы разные приложения могли использовать разные версии одной и той же библиотеки. Можно и разные библиотеки, если они совместимы по API.

// pppp

anonymous ()
Ответ на: Re: GNU libC 2.4 от blaster999

Re: GNU libC 2.4

>>А чего-то вроде libmap.conf в линуксе нет? Тогда действительно грустно.
>А для чего он (в двух словах)?
Это хорошая штука:
http://www.freebsd.org/cgi/man.cgi?query=libmap.conf&apropos=0&sektio...
Только вот, libmap.conf, все-же, к разговору о совместимости ядра и glibc отношения не имеет. Поскольку, FreeBSD -- это не только ядро, а ядро+базовая система, и эти части в ней всегда отлично синхронизированы. Только лишь при построении новой системы (сперва собирается ядро, потом userspace) можно нарваться на подобное, но процесс обновления системы всегда очень хорошо документирован и, если следовать инструкциям, опасаться просто нечего.

letusarise ()
Ответ на: Re: GNU libC 2.4 от sergej

Re: GNU libC 2.4

> насколько я ничего не понимаю, совместимость поломана между либц и ядром а не между приложениями и либц

Хм, а linuxthreads - это про что? Хотя может я и прогнал слегка. Но всё равно общая мысль остаётся той же.

const86 ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от const86

Re: GNU libC 2.4

насколько я понял, изменили реализацию posix threads и она теперь заточена под 2.6. Но поскольку они posix на приложениях это не должно сказаться.

sergej ★★★★★ ()

Re: GNU libC 2.4

Ну все, вот и толстая полярная лисичка (песец) идет к ораклистам и жабистам - опять половина интернета будет ныть "как поставить оракел X.Y на Fedora Core 5 :-)

no-dashi ★★★★★ ()

Re: GNU libC 2.4

А кто в курсе когда выйдет linux-3.0?
На сколько я помню изменение major версии производится при несовместимом изменении интерфейсов. Так что на linux3 не будут работать старые проги :) Чувствую не скоро ждать нам такого чуда, ну разве что Линусу станет совсем скушно и решит встряхнуть общественность.

Toster ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

> А чего-то вроде libmap.conf в линуксе нет? Тогда действительно грустно.

А зачем, у меня некоторые приложения для libc5 замечательно до сих пор работают без пересборки (не знаю правда, как с приложениями для X-сервера). В одном из старых slackware был такой пакет совместимости, в 10.1 он нормально работал.

saper ★★★★ ()

Re: GNU libC 2.4

> ... самой главной библиотеки всех линукс дистрибутивов glibc

на счет _всех_, эт автор погорячился.

> ... ядра версий 2.6.16 и выше

с чем и имею честь всех поздравить. помниться, больная на голову часть GNU-сообщества сильно поддерживала идеи о том что интерфейсы ядра должны всё время меняться, и нечего их замораживать для коммерсантов. за что боролись, однако... все (почти ;)) рано или поздно вырастают из подгузников. даже если подгузники с открытой технологией изготовления и стирки :)

lb ()
Ответ на: Re: GNU libC 2.4 от Toster

Re: GNU libC 2.4

>>Так что на linux3 не будут работать старые проги :)

Что за бред? Интерфейс системных вызовов никто ломать не собирается.

mitix ()
Ответ на: Re: GNU libC 2.4 от lb

Re: GNU libC 2.4

2 lb (*) (07.03.2006 0:11:23)

> на счет _всех_, эт автор погорячился.

М-мм-ммм... Эт как? Уволили из разряда "главных" библиотек? :-)

> за что боролись, однако... все (почти ;)) рано или поздно вырастают из подгузников. даже если подгузники с открытой технологией изготовления и стирки :)

Дык ета... И каковы тады будут критерии роста и развития (в смысле роста и развития технологии) системы, как сущности? ;-)

P.S. Ради Бога, не поймите меня превратно. Для меня стандарт - "как бы" мнээ-э... почти святое. Кирпич - "почти" эталон "универсального" строительного модуля... И это - не есть плохо! Институт до сих пор, в основном, использует в работе SCO (не к ночи будет сказано)... Но! Linux тем и интересен, что его развитие динамично. Тут открываются новые возможности. Их надо изучать, а не страдать от того, что не можем своевременно применить (часто давно и хорошо известное)... ;-)

R_Valery ★★★ ()

Re: GNU libC 2.4

> Для использования этой версии библиотеки рекомендуются ядра версий 2.6.16 и выше

забавная интерпретация фразы "All Linux kernel versions prior to 2.6.16 are known to have some bugs that may cause some of the tests related to pthreads in "make check" to fail."

ananas ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от birdie

Re: GNU libC 2.4

Теперь придётся поставить пятую Федору. Разве могу я пройти мимо такого. Опять Красные Шапки всех обставили :)

Lumi ★★★★★ ()

Re: GNU libC 2.4

А ссылку можно было бы и на tar.bz2 дать, как никак на 5 метров меньше

ftp://ftp.gnu.org/gnu/glibc/glibc-2.4.tar.bz2

Да, и объясните мне как её (глибц) переставлять, если все приложения работают через неё? Я один раз сделал make install, так система просто зависла.

anonymous ()
Ответ на: Re: GNU libC 2.4 от birdie

Re: GNU libC 2.4

>Официальный ананс слегка запоздал

Зато ЛОР как всегда не дремлет! ;))))) Впереди анонсов всех! %))))))))))

vovans ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

> Я один раз сделал make install, так система просто зависла.

Гагага!!! :-))))) Ещё бы не зависла :-)

Dimez ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

только через систему управления пакетами, в любом дистрибутиве

Syncro ★★★★★ ()

Re: GNU libC 2.4

кстати, пожалейте ньюбов, не давайте ссылок скачать в подобных новостях(ядра, base system), все-равно тем немногим, кто будет сам выкачивать этот тарболл расположение известно

Syncro ★★★★★ ()

Re: GNU libC 2.4

...выход новой стабильной версии самой главной библиотеки всех линукс дистрибутивов glibc...

так уж и всех! никогда этим куском г не пользовался и в будущем не собираюсь

anonymous ()
Ответ на: Re: GNU libC 2.4 от Lumi

Re: GNU libC 2.4

гм, притягивание за уши версии теперь так называется ? тогда s/всех/пользователей

Syncro ★★★★★ ()

Re: GNU libC 2.4

Таки вы мне скажите, если я обновлюсь, у меня че софт работать не будет, который не обновился или был скомпилен на FC4?

Extremal ()
Ответ на: Re: GNU libC 2.4 от no-dashi

Re: GNU libC 2.4

>Ну все, вот и толстая полярная лисичка (песец) идет к ораклистам и жабистам - опять половина интернета будет ныть "как поставить оракел X.Y на Fedora Core 5 :-)

А что, 10g, всё еще на старых нитях? А то смысл, ставить старый Оракл на новую систему?

И при чём тут жаба? Жаба как раз одной из превых научилась использовать преимущества новых нитей.

alt-x ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от Extremal

Re: GNU libC 2.4

с FC4 - точно будет.

alt-x ★★★★★ ()

Re: GNU libC 2.4

несцо
будет шото типа compat-my_fucking_old-1.3.4.*

ttyS0 ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

А где тузеги со своим богом?

F00 ()
Ответ на: Re: GNU libC 2.4 от Toster

Re: GNU libC 2.4

>А кто в курсе когда выйдет linux-3.0? >На сколько я помню изменение major версии производится при несовместимом изменении интерфейсов. Так что на linux3 не будут работать старые проги :)

А знаете в связи с чем появилось вторая версия ядра? С поддержкой smp, и никаких несовместимостей не было, кстати 2.6 когда-то предполагали назвать 3.0

Dubrovsky ()
Ответ на: Re: GNU libC 2.4 от sarulezzz

Re: GNU libC 2.4

>>Да, и объясните мне как её (глибц) переставлять, если все приложения работают через неё? Я один раз сделал make install, так система просто зависла.

> Почитай здесь: http://www.tldp.org/HOWTO/Glibc-Install-HOWTO/the-install-of-glibc-itself.html

А как же в дистрибутивах обновление происходит? Тоже с перезагрузкой в сингле-моде?

anonymous ()
Ответ на: Re: GNU libC 2.4 от no-dashi

Re: GNU libC 2.4

Ты чо, прикалываешься?

Пока glibc-2.4 выйдет в продакшн, oracle9 уже все перестанут ставить(как oracle8)

Dimez ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

Вообще-то для этого есть ld.so и вся его машинерия ;-).

В том числе, и на FBSD.

AlexM ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от alt-x

Re: GNU libC 2.4

> Жаба как раз одной из превых научилась использовать преимущества новых нитей.

Расскажи это инсталлеру оракловскому из 8i :-)

no-dashi ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от Dimez

Re: GNU libC 2.4

> Пока glibc-2.4 выйдет в продакшн, oracle9 уже все перестанут ставить(как oracle8)

Сейчас glibc-2.3. И оаркел 8 во всю используется в работе.

no-dashi ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

> Чтобы разные приложения могли использовать разные версии одной и той же библиотеки. Можно и разные библиотеки, если они совместимы по API.

А так и происходит, для этого есть версии библиотек (major.minor.patchlevel) и дополнительные костели в виде libmap.conf не нужно, хотя, если очень припечет, всегда есть 'man ld.so' - как управлять загрузкой либ.

fi ★★★ ()
Ответ на: Re: GNU libC 2.4 от Dubrovsky

Re: GNU libC 2.4

> А знаете в связи с чем появилось вторая версия ядра? С поддержкой smp, и никаких несовместимостей не было

Весьма странно - я всю жизнь считал что перешли с COFF на ELF ;)), smp стало работать далеко не в 2.0.0, да и потом не в каждой версии - т.к. конфликтовало с dosemu :)

fi ★★★ ()
Ответ на: Re: GNU libC 2.4 от no-dashi

Re: GNU libC 2.4

Что значит "сейчас glibc-2.3"? Когда ты ставил оракел8, glibc-2.3 ещё не было.

Только не говори, что ты обновлял glibc, на котором оракл стоял, т.к. это плохо влияет на карму.

:-)

Dimez ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от Dimez

Re: GNU libC 2.4

> Когда ты ставил оракел8, glibc-2.3 ещё не было.

Это что, значит я в начале сентября ставил 8.1.6 не на 4-ю федору?! Ужас!!! А я-то и не знал! :-)

no-dashi ★★★★★ ()
Ответ на: Re: GNU libC 2.4 от anonymous

Re: GNU libC 2.4

>А как же в дистрибутивах обновление происходит? Тоже с перезагрузкой в сингле-моде?

В slackware просто upgradepkg и всё.

RatMann ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.