LINUX.ORG.RU

Firefox 69

 ,


3

2

Доступен выпуск Firefox 69.


Основные изменения:

  • Включена по умолчанию блокировка скриптов, осуществляющих майнинг криптовалют.
  • Настройка «Не разрешать сайтам воспроизводить звук» позволяет блокировать не только воспроизведение звука без явного взаимодействия со стороны пользователя, но и воспроизведение видео. Поведение можно задать глобально, либо конкретно для отдельного сайта.
  • Добавлена страница about:protections со статистикой работы защиты от отслеживания.
  • Менеджер паролей предлагает сохранённый пароль для всех субдоменов (т.е. пароль, сохранённый для login.example.com, будет предложен на странице example.com и всех субдоменах, а не только лишь на login.example.com).
  • WebRTC научился одновременно принимать потоки, закодированные разными видеокодеками, что полезно для многопользовательских конференций, где у участников могут быть разные клиенты.
  • На страницу about:support добавлен путь к исполняемому файлу Firefox.
  • Пользователи из США, а также пользователи локали en-US получат обновлённую страницу новой вкладки (иное число, размер и расположение блоков, более разнообразный контент из Pocket).
  • Плагин Flash лишился опции «Всегда включать». Запуск Flash-содержимого отныне требует нажатия со стороны пользователя. Поддержка Flash будет окончательно удалена в начале 2020 года (в ESR-выпусках она сохранится до конца того же года, после чего будет удалена, поскольку Adobe прекратит исправлять уязвимости во Flash).
  • Файлы userChrome.css и userContent.css отныне игнорируются по умолчанию. Их поддержку можно включить с помощью настройки toolkit.legacyUserProfileCustomizations.stylesheets (если у пользователя есть эти файлы и профиль хоть раз запускался в Firefox 68, настройка уже включена, таким образом, существующие пользователи не заметят неудобств). Этот способ кастомизации используется сравнительно небольшим числом пользователей, в том время как обращение к этим файлам (даже, если они не существуют) отнимает драгоценное время при каждом запуске. В будущих выпусках так же поступят с файлом user.js.
  • С целью уменьшения возможностей для фингерпринтинга из юзерагента убрана разрядность браузера (оставлена только разрядность ОС). Если раньше юзерагент 32-разрядного браузера, запущенного в 64-разрядной ОС, содержал «Linux i686 on x86_64», то теперь будет лишь «Linux x86_64». Указание разрядности браузера когда-то было необходимо для загрузки установщика Flash корректной разрядности. Сейчас, когда установщик Flash не зависит от разрядности браузера (да и поддержка Flash скоро канет в небытие), в этом уже нет нужды,
  • Включена поддержка API Resize Observer (механизм, с помощью которого сайт может отслеживать изменение размера того или иного элемента) и Microtask.
  • Объект navigator.mediaDevices object и метод navigator.mozGetUserMedia доступны только на сайтах, открытых по защищённому соединению.
  • Реализованы CSS-свойства overflow-block, overflow-inline, user-select, line-break, contain.
  • Включена поддержка публичных полей классов JavaScript.
  • Удалена поддержка устаревшего тега <keygen>, которая никогда не была реализована корректно.
  • Windows:
    • Добавлена поддержка приоритетов процессов. Процесс, обрабатывающий активную вкладку, получит больший приоритет, а фоновые вкладки - меньший (приоритет воспроизведения звука и видео уменьшаться не будет). Проведённые разработчиками тесты не показали негативного влияния на скорость загрузки вкладок или работы интерфейса, но не было отмечено и какого-то видимого ускорения работы, так что эффект, в основном, заключается в более рациональном распределении ресурсов CPU.
    • Добавлена поддержка WebAuthn HmacSecret через Windows Hello (начиная с Windows 10 1903).
  • macOS:
    • На компьютерах, оборудованных одновременно дискретной и встроенной графикой, Firefox по возможности более агрессивно переключается на экономичный GPU при воспроизведении содержимого WebGL. Кроме того, браузер будет избегать однократных и незначительных попыток задействовать высокопроизводительный графический процессор.
    • Finder отныне показывает прогресс загрузки файлов.
    • Установщик предлагается не только в формате dmg, но и pkg.
  • На устройствах с архитектурой ARM64 реализована поддержка JIT.
  • Инструменты разработчика:
    • Порядок вкладок изменён в соответствии с их популярностью.
    • Отладчик:
    • Консоль:
    • Сеть:
      • Ресурсы, заблокированные из-за смешанного содержимого или CSP, показываются на вкладке «Сеть» с указанием причины блокировки.
      • Вкладка «Сеть» получила опциональный столбец «URL», отображающий полный URL ресурса.

>>> Примечания к выпуску для разработчиков

>>> Подробности

Ответ на: комментарий от Aceler

Firefox 69

ЛОРовские тролли как обычно. Сначала ты написал, что файрфокс падает, а когда тебя начали прижимать, выяснилось, что падает только определённая версия

Хе-хе-хе. «Ты должен сделать добро из зла, потому что его больше не из чего сделать».(C)

Обсуждается конкретный релиз, направление развития и все такое. Черт подери, ты ведь даже не можешь утверждать, что в твоем дистрибутиве нет этой проблемы, однако бросаешься на защиту лисички как лев на свежее дерьмо!

anonymous ()
Ответ на: комментарий от anonymous

свежее дерьмо

А ты самокритичен.

anonymous ()
Ответ на: комментарий от anonymous

однако бросаешься на защиту лисички как лев на свежее дерьмо!

А ты самокритичен.

Не особенно самокритичен, но ты точно дислектик, или для тебя великий и могучий точно не родной.

anonymous ()
Ответ на: комментарий от anonymous

Причём тут это?

Ни на одной поддерживаемой Mozilla конфигурации данное падение не удасться повторить.

Что там наделали в FreeBSD — это проблемы чисто FreeBSD.

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Ни на одной поддерживаемой Mozilla конфигурации данное падение не удасться повторить.

Лично ты за базар отвечаешь? У тебя есть 69 лиса? Ты кто такой, родное сердце?

anonymous ()
Ответ на: комментарий от Aceler

только на экзотической платформе
FreeBSD

Aceler, да ты сам по части тролинга можешь уроки давать. :D

imul ★★★★★ ()
Ответ на: комментарий от anonymous

Ты сегодня расскажешь или нет, что надо сделать, чтоб лиса упала? 69 лиса у меня есть, ленсук версии 5.0 у меня есть, какие еще условия?

anonymous ()
Ответ на: комментарий от MozillaFirefox

д? на попеннете про этот релиз было упоминание, но если так - то ок

kott ★★★★★ ()
Ответ на: комментарий от imul

Я думал, FreeBSD используется либо фанатиками-антиГПЛьщиками, либо на legacy-серверах.

te111011010 ()
Ответ на: комментарий от te111011010

Я думал, FreeBSD используется либо фанатиками-антиГПЛьщиками, либо на legacy-серверах.

Да ты настоящий полодин! Истинную веру не поколеблет ничто, горе тем фактам.

anonymous ()
Ответ на: комментарий от te111011010

фанатиками-антиГПЛьщиками

И таких очень много. Раньше было ещё больше. И сейчас туда возможен наплыв из-за истерии по поттерингу. В любом случае это пока ещё не экзотика. Кстати, модератору наверное видно UA пишущих и он может на глаз оценить насколько та, или иная платформа экзотична.

imul ★★★★★ ()
Ответ на: комментарий от rebforce

Зачем её вообще изначально туда вносили?

В новости же написано: чтобы при скачивании того или иного плагина сайт вендора плагина мог предложить пользователю инсталлятор нужной разрядности, потому что разрядность плагина (не путать с дополнениями) завязана на разрядность браузера. Сейчас, во-первых, плагины (кроме Flash) уже не поддерживаются, а инсталлятор Flash уже давно содержит в себе оба плагина - 32- и 64-битные, поэтому никаким сайтам разрядность браузера уже не важна.

MozillaFirefox ★★★★★ ()
Последнее исправление: MozillaFirefox (всего исправлений: 1)
Ответ на: комментарий от MozillaFirefox

Благодарю за объяснение. Ох и жуть. То есть вывести сразу две княпочки - 32-bit и 64-bit — вендор плагина не в состоянии? А если я хочу с 64-битной системы скачать сразу два пакета, чтобы один из них впоследствии перенести на 32-битную?

В общем, правильно убрали.

rebforce ()
Ответ на: комментарий от DELIRIUM

Стараюсь избегать деловой переписки с россиянами.

Россиянам на это глубоко по х...

anonymous ()
Ответ на: комментарий от imul

Если даже пользователей десктопного линукса в народе считают экзотикой, то куда уж пользователям десктопной FreeBSD?

Кстати, модератору наверное видно UA пишущих и он может на глаз оценить насколько та, или иная платформа экзотична.

no-dashi в своё время делился наблюдениями.

te111011010 ()
Ответ на: комментарий от anonymous

А какой смысл пользоваться freebsd вместо linux? Прямо таки каждый bsd-шник только и хочет, что выпустить свою сборку ядра freebsd и не открывать исходники.

te111011010 ()
Ответ на: комментарий от anonymous

Ты сегодня расскажешь или нет, что надо сделать, чтоб лиса упала? 69 лиса у меня есть, ленсук версии 5.0 у меня есть, какие еще условия?

Ну он же сказал — нужно одно главное условие под названием FreeBSD 🙂

fornlr ★★★★★ ()

Поддержка Flash будет окончательно удалена в начале 2020 года

Ну вот я и дотянул с фиксом багов. Ещё полгода подождать, и можно со спокойной совестью все issue на github’е закрыть.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Ну вот я и дотянул с фиксом багов

Я примерно в 2011-2012 году создал багрепорт комбо. Про то что в Opera Presto+Flash не работает корректно VDPAU, а голубые рожи показывает, в отличии от других браузеров, под которые костыли подставили.

В итоге моментально всё это накрылось медным тазом. И Opera Presto, и Flash отправили в Legacy.

fornlr ★★★★★ ()

Замечательно. На винде уже обновился, под линукс специально обученные команды в данный момент собирают пакеты, долгий процесс, где-то сутки занимает.

anonymous ()
Ответ на: комментарий от anonymous

Subtitle Edit (кстати очень даже работает под вайном если есть моно) очень даже заменяет этот ваш SubRip который уже не обновлялся целую вечность и работает хуже на блюрей субтитрах. Ну а так вообще нет особо проблем в использовании VideoSubFinder (разве что без ABBYY он немножк неполезен поскольку тессеракт надо уметь готовить для этого дела)

anonymous ()
Ответ на: комментарий от fornlr

Ну этот-то баг починили, когда обновили версию с 11.2. Там просто не было VDPAU.

i-rinat ★★★★★ ()
Ответ на: комментарий от anonymous

долгий процесс

Можешь и на линуксе поставить бинарную сборку. Она обновляется несколькими кликами.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Ну да :) Я как раз об этом. Медный таз для починки багов хорошо работает.

fornlr ★★★★★ ()
Ответ на: комментарий от User_of_the_Kali

Соседа уже похакал, довольный ты наш?

anonymous ()

Много полезного. Спасибо за новость.

Satori ★★★★★ ()
Ответ на: комментарий от rebforce

То есть вывести сразу две княпочки - 32-bit и 64-bit — вендор плагина не в состоянии?

При скачивании многих виндопрограмм именно так и делается: при нажатии на «скачать» автоматически скачивается версия, исходя из разрядности и ОС, сообщённой в юзерагенте (потому что большинство пользователей пришли скачать для своей текущей ОС), а где-нибудь на странице уже есть ссылочка «а вон там вы можете скачать другие разрядности / под другие ОС».

MozillaFirefox ★★★★★ ()
Последнее исправление: MozillaFirefox (всего исправлений: 1)
Ответ на: комментарий от i-rinat

Ну вот я и дотянул с фиксом багов. Ещё полгода подождать, и можно со спокойной совестью все issue на github’е закрыть.

В ESR поддержка сохранится до конца 2020 (потому что он основан на выпуске, где она ещё была в полном объёме). Плюс кто-то может захотеть держать у себя старый билд браузера с флешем для какого-то специфичного сайта...

MozillaFirefox ★★★★★ ()
Ответ на: комментарий от i-rinat

Можешь и на линуксе поставить бинарную сборку.

Её еще не собрали, в процессе.

anonymous ()
Ответ на: комментарий от anonymous

Ну у меня есть 69 лиса и она не упала при переходе по твоей ссылке. Какие аргументы дальше будут?

kss ★★★★★ ()
Ответ на: комментарий от i-rinat

Нет уж, 'pkcon get-updates' говорит, что мейнтейнеры пока еще собирают. Завтра или послезавтра прилетит.

anonymous ()
Ответ на: комментарий от anonymous

На кой, если это безо всяких дополнений скрывается тремя кликами?

rebforce ()
Последнее исправление: rebforce (всего исправлений: 1)
Ответ на: комментарий от rebforce

А если куки почистишь или приватное окно откроешь? Ты любитель зондов?

anonymous ()
Ответ на: комментарий от imul

Я давно не модератор, если ты намекаешь на моё определение экзотичности.

Aceler ★★★★★ ()
Ответ на: комментарий от DELIRIUM

- Ну чо он хотел?

- *** его знает!

- Ну ты ему помог?

- Да!

- ***бись! Пошли накатим!


Навевает «Охота и рыбалка» :)

hbars ★★★★★ ()
Ответ на: комментарий от anonymous

Subtitle Edit использует кривой tesseract и не справляется даже с VobSUB, боже упаси им распознавать сабы. Был такой один адепт. И хоть SE и работает под Mono (сам использую для перевода), но глючит. Для BluRay есть SupRip.
SubRip обновлялся в ноябре 2018 https://www.videohelp.com/software/Subrip

anonymous ()
Ответ на: комментарий от anonymous

Если на то пошло, в Subtitle Edit нет нужды. Преобразовать DVD (VobSub) субтитры через tesseract довольно качественно можно одной командой https://github.com/ruediger/VobSub2SRT (А SUP>VobSub можно получить MakeMKV>mkvextract). Но у меня VobSub2SRT терял несколько строк. Да и не доверяю я автоматике. SubRip с небольшим ручным обучением надежнее и не занимается отсебятиной.

тессеракт надо уметь готовить для этого дела

VideoSubFinder сам подготавливает сабы, удаляет все лишнее, оставляя только черный фон. Но все равно tesseract справляется только с идеальным начертанием. А после VideoSubFinder остаются всякие разрывы. Так что лучше использовать FineReader под виндой. Ну и это только для хардсаба, иначе из пушки по воробьям.

anonymous ()
Ответ на: комментарий от kickass

Это общесистемные настройки. Плохо сочетается с несколькими профилями браузера (у одного пользователя или у разных).

Pravorskyi ★★ ()

хороший ,годный выпуск смотря во что гугл привратил хром остается только лиса

dodgers ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.