LINUX.ORG.RU

Mandriva 2010 Spring

 ,


0

0

Сегодня, 8-го июля 2010 года, выходит Mandriva 2010 Spring (он же Mandriva 2010.1) под кодовым названием Farman.

Релизу сопутствовали драматические события: ухудшение финансового положения компании, слухи о продаже Mandriva, опровержение слухов, наконец, сообщение о спасении Mandriva таинственными спонсорами. Все это способствовало более чем месячной задержке релиза, но, тем не менее, не помешало разработчикам проделать огромную работу. Результатами их восьмимесячных трудов явилось следующее:

  • Базовая система: ядро Linux 2.6.33; драйвер ntfs-3g 2010.03.06; Glibc 2.11.1; GDB 7.1; увеличение скорости запуска приложений за счет сборки дистрибутива с ключами «-Wl,-O1»; собственный инструмент Dracut в качестве замены mkinitrd; отказ от HAL в дисковой подсистеме и подсистеме печати; microcode_ctl с поддержкой процессоров AMD и с автоматической загрузкой обновлений микрокода CPU; маршрутизатор USB/IP; Ruby 1.9.1 (параллельно с 1.8); Python 2.6.2;
  • Инструменты Mandriva: улучшения в гостевой учетной записи; клонирование инсталляции по методу KA; улучшенная поддержка шифрованных файловых систем в инсталляторе и Diskdrake; более четкое разделение URPMI-источников «Free» и «Non-free»; переработанный msecgui (с поддержкой ACL); блокировщик приложений drakguard;
  • Mandriva Directory Server 2.4.0: новые модули для поддержки пользовательских квот, массового импорта, хранения публичных SSH-ключей в LDAP; обновленная локализация;
  • X Window System: X.org 7.5, xserver 1.7.7, Mesa 7.8; драйвер Nouveau (с поддержкой KMS, 2D-ускорения и RandR 1.2) по умолчанию вместо драйвера nv; драйвер ATI версии 6.13; драйвер Intel версии 2.11.0; imwheel исключен из поставки;
  • Desktop-приложения: Firefox 3.6.6, а также браузеры Chromium и Opera в официальных репозиториях; OpenOffice 3.2; проигрыватель Clementine, xine-lib 1.2 с поддержкой VDPAU, медиа-центр XBMC; BitTorrent-клиенты Deluge 1.2.3, Transmission 1.92, qBittorrent; персональные менеджеры финансов Skrooge 0.7.0 и HomeBank 4.2.1; док-панель Avant Window Navigator 4.0; видеоредакторы Lives 1.3.2, Kdenlive 0.7.7.1 и, впервые в Mandriva, OpenShot 1.1.3;
  • GNOME 2.30.1: обновленная «фирменная» GTK+-тема Ia-Ora; улучшения в Epiphany, Evolution, Vinagre; новые модули GNOME Activity Journal (журнал активности GNOME, использующий Zeitgeist), GNOME Color Manager (модуль управления цветовыми профилями); новая игра LightsOff; поисковая служба Tracker в качестве замены Beagle; обновленный GNOME Display Manager 2.30.2; предварительная версия GNOME Shell 2.29.1;
  • KDE 4.4.3: Qt 4.6.2; обновленная Qt-тема Ia-Ora; улучшения в KDM; Nepomuk, использующий БД Virtuoso; Amarok 2.3.1; KTorrent 4.0; DigiKam 1.3.0; клиент микроблог-сервисов Choqok; портированный на KDE 4 персональный менеджер финансов KMyMoney;
  • Системные службы: замена Sysklogd на более современный rsyslog; Munin 1.4.4, Zabbix 1.8.2, SpamAssassin 3.1.1, Postfix 2.7.0; впервые включена система групповой работы Zarafa.

Mandriva Linux с давних пор имеет прочные позиции в научной среде. Но отдельных слов заслуживает «новый курс партии» Mandriva, направленный на дальнейшее сближение с академической и образовательной аудиторией и упрочение имеющихся позиций. В пресс-релизе особенно отмечается богатый набор образовательного и научного ПО, включенного в состав Mandriva 2010 Spring:

  • Sagemath — свободный математический пакет, комбинирующий мощь множества существующих opensource-модулей и графический интерфейс на Python;
  • Salome — платформа для пре- и постпроцессинга данных численных симуляций;
  • InVesalius — генератор трехмерных анатомических моделей по двумерным DICOM-изображениям, полученным в результате компьютерной томографии или ЯМР-обследования;
  • ROOT — платформа для обработки и анализа данных, зародившаяся в CERN, «сердце» исследований высоких энергий;
  • Axiom — система компьютерной алгебры, включающая строготипизированную, математически корректную иерархию типов и компилятор встроенного языка;
  • Tachyon — параллельная библиотека трассировки лучей;
  • Jmol — написанный на Java трехмерный просмотрщик разнообразных химических структур, включая кристаллы и биомолекулы;
  • SINGULAR — алгебраическая система полиномиальных вычислений, созданная в первую очередь для нужд коммутативной алгебры, алгебраической геометрии, теории сингулярностей и решения полиномиальных систем;
  • GAP — система вычислительной дискретной алгебры, с упором на вычислительную теорию групп. GAP предоставляет собственный язык программирования, а также написанную на нем библиотеку из тысяч алгебраических функций и обширную коллекцию алгебраических объектов;
  • ECL (Embeddable Common Lisp) — встраиваемый интерпретатор Common Lisp с поддержкой CLOS (в соответствии со стандартом ANSI X3J13), а также транслятор в язык С (для получения самостоятельных исполнимых файлов);
  • PolyBoRi — C++-библиотека, реализующая многочлены над булевыми полями;
  • Macaulay 2 — спонсируемая National Science Foundation система для исследований в области алгебраической геометрии и коммутативной алгебры;
  • LinAlg/LinBox — библиотека шаблонов C++ для точных высокопроизводительных линейно-алгебраических вычислений со структурированными матрицами над конечными полями или целыми числами.

Mandriva — один из исторически первых дистрибутивов Linux, который празднует в этом году свое 12-летие. За плечами у Mandriva богатая история переименований, слияний и поглощений (Edge IT, Lycoris, Conectiva, Linbox), а также финансовых падений и взлетов. Mandriva всегда ориентировалась на конечного пользователя, что позволило снискать славу одного из самых дружественных к пользователю дистрибутивов, и релиз 2010 Spring не стал исключением. Поддерживаются платформы x86-32 и x86-64; традиционно доступны три варианта носителей:

  • One — бесплатный LiveCD с возможностью инсталляции. Влючены некоторые проприетарные драйверы;
  • PowerPack — коммерческий DVD, включающий проприетарные драйверы и приложения, а также кодеки и DVD-проигрыватель Fluendo. К Powerpack прилагается поддержка;
  • Free — полностью свободный DVD. Возможность установки проприетарных, несвободных или патентно-сомнительных приложений появляется при подключении после инсталляции репозиториев Non-free и PLF.

Для загрузки Mandriva рекомендует воспользоваться BitTorrent-трекером в целях разгрузки зеркал. Важная информация, касающаяся апгрейда существующей инсталляции Mandriva до 2010.1, приведена на странице замечаний к выпуску.

Замечания к выпуску.

>>> Сайт Mandriva

★★

Проверено: Shaman007 ()

Ответ на: комментарий от gutaper

Кроме ЛОРа оно еще нигде не зарелизилось, даже офф. репы пока еще не готовы.

anonymous ()
Ответ на: комментарий от Lordwind

Вообще то фонд международный, Россия там как одна из составляющих. Рейман вообще заявил, что впервые слышит о сделке из СМИ.

anonymous ()
Ответ на: комментарий от HighwayStar

а свежее ядро и иксы весьма желательны для нормальной работы radeon, так у меня на 2.6.34 с иксами 1.8 работает и KMS И 3д на hd4200, а как с этим в мандриве?

Нормально, KMS и 3D на Radeon HD 4350.

guitarist ★★ ()

А прокомментируйте сей феномен:

установка geany

Для удовлетворения зависимостей должны быть установлены следующие пакеты:

- binutils-2.20.51.0.7-3mnb2.i586
- gcc-4.4.3-2mnb2.i586
- glib-gettextize-2.24.1-1mdv2010.1.i586
- glibc-2.11.1-8mnb2.i586
- glibc-devel-2.11.1-8mnb2.i586
- libatk1.0-devel-1.30.0-1mdv2010.1.i586
- libcairo-devel-1.9.6-3mdv2010.1.i586
- libfontconfig-devel-2.8.0-2mdv2010.1.i586
- libfreetype6-devel-2.3.12-1mdv2010.1.i586
- libgdk_pixbuf2.0_0-devel-2.20.1-1mdv2010.1.i586
- libglib2.0-devel-2.24.1-1mdv2010.1.i586
- libgtk+2.0_0-devel-2.20.1-1mdv2010.1.i586
- libice6-devel-1.0.6-2mdv2010.1.i586
- libpango1.0-devel-1.28.0-1mdv2010.1.i586
- libpcre-devel-8.02-1mdv2010.1.i586
- libpixman-1-devel-0.18.2-1mdv2010.1.i586
- libpng-devel-1.2.43-1mdv2010.1.i586
- libpthread-stubs-0.3-1mdv2010.1.i586
- libsm6-devel-1.1.1-2mdv2010.1.i586
- libstdc++-devel-4.4.3-2mnb2.i586
- libx11_6-devel-1.3.3-1mdv2010.1.i586
- libxau6-devel-1.0.5-2mdv2010.1.i586
- libxcb-composite0-1.6-1mdv2010.1.i586
- libxcb-damage0-1.6-1mdv2010.1.i586
- libxcb-devel-1.6-1mdv2010.1.i586
- libxcb-dpms0-1.6-1mdv2010.1.i586
- libxcb-glx0-1.6-1mdv2010.1.i586
- libxcb-randr0-1.6-1mdv2010.1.i586
- libxcb-record0-1.6-1mdv2010.1.i586
- libxcb-render0-1.6-1mdv2010.1.i586
- libxcb-res0-1.6-1mdv2010.1.i586
- libxcb-screensaver0-1.6-1mdv2010.1.i586
- libxcb-shape0-1.6-1mdv2010.1.i586
- libxcb-shm0-1.6-1mdv2010.1.i586
- libxcb-sync0-1.6-1mdv2010.1.i586
- libxcb-xevie0-1.6-1mdv2010.1.i586
- libxcb-xf86dri0-1.6-1mdv2010.1.i586
- libxcb-xfixes0-1.6-1mdv2010.1.i586
- libxcb-xinerama0-1.6-1mdv2010.1.i586
- libxcb-xprint0-1.6-1mdv2010.1.i586
- libxcb-xtest0-1.6-1mdv2010.1.i586
- libxcb-xv0-1.6-1mdv2010.1.i586
- libxcb-xvmc0-1.6-1mdv2010.1.i586
- libxcomposite1-devel-0.4.1-1mdv2010.1.i586
- libxcursor-devel-1.1.10-2mdv2010.1.i586
- libxdamage-devel-1.1.2-1mdv2010.1.i586
- libxdmcp6-devel-1.0.3-2mdv2010.1.i586
- libxext6-devel-1.1.1-2mdv2010.1.i586
- libxfixes3-devel-4.0.4-1mdv2010.1.i586
- libxft-devel-2.1.14-1mdv2010.1.i586
- libxi-devel-1.3-1mdv2010.1.i586
- libxinerama1-devel-1.1-1mdv2010.1.i586
- libxml2-devel-2.7.7-1mdv2010.1.i586
- libxrandr2-devel-1.3.0-3mdv2010.1.i586
- libxrender1-devel-0.9.5-2mdv2010.1.i586
- libxt-devel-1.0.8-1mdv2010.1.i586
- linux-userspace-headers-2.6.33-1mnb2.i586
- manbo-mandriva-files-gcc-4.4.3-2mnb2.i586
- multiarch-utils-1.0.10-1mdv2010.1.noarch
- pango-doc-1.28.0-1mdv2010.1.i586
- x11-proto-devel-7.5-5mdv2010.1.i586
- zlib1-devel-1.2.3-15mdv2010.1.i586

Будет использовано 140МБ дискового пространства.

elipse ★★★ ()
Ответ на: комментарий от elipse

А прокомментируйте сей феномен

поиграйтесь с ключами urpmi, я когда ставил geany у меня не было таких зависимостей.(графическим интсалятором практически не пользуюсь)

sol13 ★★★★ ()
Ответ на: комментарий от anonymous

mandriva-linux-one-2010-spring-KDE4-europe2-cdrom-i586.iso

Получить можно, если слегка подумать головой.

gutaper ★★★ ()
Ответ на: комментарий от elipse

У вас таки и glibc-2.11.1-8mnb2 не установлен? Или это такой метод троллинга?

капча tricks continued как бы намекает

anonymous ()
Ответ на: комментарий от PayableOnDeath

суся всем хороша, если бы не зависимости. Беда прям какая-то. Прозапас что-ли они их суют? и --no-recommends помогает только частично. Зачем всюду пихают в зависимости gtk допустим? Завернули в пакет драйвер nvidia - всенепременно подавай и гтк, завернули vlc (морда вроде как на qt переписана) - тоже гтк хочет. Это конечно не основные репы суси, можно и возразить, но все же... Думаю и в основных репах найдутся примеры.

gutaper ★★★ ()
Ответ на: комментарий от anonymous

Я запустил LiveCD One Gnomе,
обновил источники реп и попробовал поставить geаny через графический интсаллятор.
Почему это уже проходит как троллинг в юзерфрендли дистре ?
Вы можете это легко воспроизвести сами и не задавать глупых вопросов.

elipse ★★★ ()
Ответ на: комментарий от gutaper

а если gtk хоть как-то можно притянуть за уши, то вот зачем для драйверов nvidia и, допустим, mpd - cups-libs?

gutaper ★★★ ()
Ответ на: комментарий от elipse

У меня репозитории еще пока вообще не обновились. Посмотрел на зеркале яндекса - там тоже самое, на других зеркалах не смотрел. Сейчас качну One, поглядим.

anonymous ()
Ответ на: комментарий от Kuka

>что-то слабо верится, что ATLAS опережает стандартный BLAS «примерно в три раза». У вас есть подтверждение этому?

ipython

from numpy.linalg import *

from numpy.random import *

m=randn(2000,2000)

%time U,s,V=svd(m)

и смотрим на время. На компе 2.5GHz, при поддержке atlas должно быть 16-20 s. На мандриве будет около минуты. Это был частный пример, еще один mayavi2, виджеты зависают после отрисовки. Возможно надо пересобирать для соответствующей версии vtk и т.д. и т.п. Вывод, пакеты собираются для галочки, чтоб легче собрать, если пользователю нужна нормальная функциональность пусть пересобирает если хочет

anonymous ()
Ответ на: комментарий от elipse

>- glibc-2.11.1-8mnb2.i586

rpm -q --changelog glibc | head
* Втр Июн 08 2010 Oden Eriksson <oeriksson@mandriva.com> 6:2.11.1-8mnb2
+ Revision: 547264
- P95: security fix for CVE-2010-0015
- P96: security fix for CVE-2010-0296

* Пнд Май 31 2010 Herton Ronaldo Krzesinski <herton@mandriva.com.br> 6:2.11.1-7mnb2
+ Revision: 546806
- Fix permission of /usr/share/doc/glibc-devel/crypt_blowfish-1.0.2/*
files (#59585).

Вы пошто rc1 поставили?

redgremlin ★★★★★ ()

Даже я такие простыни не стелил.

Quasar ★★★★★ ()
Ответ на: Mandriva 2010 Spring от anonymous

Re: Mandriva 2010 Spring

> Чем это лучше FreeBSD?

тем, что это GNU/Linux )

anonymous ()

Мандрива, Мандрива...

Mandrake вообще-то. Редхат с кедами. Который умер. А то что появилось лет 5 назад, ничего, кроме жалости не вызывает. Умерло бы поскорее.

anonymous ()
Ответ на: Мандрива, Мандрива... от anonymous

Re: Мандрива, Мандрива...

«ROOT — платформа для обработки и анализа данных»

хммм ... надо будет бурёнычу шлёпнуть на мыло. Вот порадуется старик :)

Valeriy_Onuchin ★★ ()
Ответ на: комментарий от Kuka

> Как в мандриве со шрифтами бороться? - Подключил ПЛФ, установил фритайп... ноль на массу

Сейчас вроде бы такие вещи делаются через /etc/fonts/local.conf. По крайней мере, если хочется выборочно отключить антиалиасинг для определенного шрифта определенного размера, дык это точно туда. Пошарьтесь там по содержимому /etc/fonts, может, как раз найдете нужные опции.

Нигде не копался, а просто включил сглаживание в настройках Рабочего стола КДЕ и всё тут, ну и шрифт поставил общий, какой мне понравился...

anonymous ()
Ответ на: комментарий от Kuka

Если мне память не изменяет, то в ~/.fonts.conf . Вообще такие вещи можно в настройках kde править. Мне кстати шрифты по-умолчанию нравятся. FT с BCI уже давно не использую.

Reset ★★★★★ ()

кто знает , когда настроят репозиторий? - Не могу ничего установить себе нужного + в PLF чего-то нету дров nvidia..а так то дистром доволен

zibert ★★★ ()
Ответ на: комментарий от zibert

+1 Думал не хочет добавлять, потому что только-только релизнулось. Но время-то уже прошло, а воз и ныне там.

Не удаётся добавить источник. Ошибки:

...извлечение не удалось: сбой aria2: завершён с 4
нет доступа к источнику с дистрибутивом (не найден файл media.cfg)

Источник:Official2010.1- ()
gutaper ★★★ ()

О. Наконец осилили сделать, чтобы если ставится i586, а памяти 4 ГБ, то ставилось с PAE ядро. В 2010 не было такого.

gutaper ★★★ ()

Лихо вычищаются «не нужные более пакеты». Решил удалить kontact:

urpme kontact

Трампарам. И мне торжественно сообщается, что [портянка уж очень здоровая, не стал стелить] можно смело удалять практически все kde, так как бедное кде осиротело без контакта.

gutaper ★★★ ()
Ответ на: комментарий от gutaper

Скорей всего заркало тормозит. Попробуй добавить источники через easy urpmi. Если не поможет, в настройках замени арию на вгет. Это традиционный баг мандрива.

ramon13666 ★★★ ()
Ответ на: комментарий от annulen

Да зависимости там звиздец. Хотел снести гнома, так он сносит пакет базовой системы. Хотя стоит еще куча окружений.

ramon13666 ★★★ ()
Ответ на: комментарий от ramon13666

Да зависимости там звиздец. Хотел снести гнома, так он сносит пакет базовой системы. Хотя стоит еще куча окружений.

Закопать такой линупс. И забыть.

Serge ()
Ответ на: комментарий от ramon13666

>Да зависимости там звиздец. Хотел снести гнома, так он сносит пакет базовой системы. Хотя стоит еще куча окружений.

Во многих случаях зависмости можно выбрать при установке. Например, для друпала можно выбрать нужную базу данных (а не качать mysql); для опенофиса можно выбрать любую тему значков (не обязательно, как в убунте, ставить ту, которую навязали); OpenJDK или Sun и т.п. В других дистрибутивах я такого не видел. Однако как поменять выбор потом, ничего не удаляя, я пока не разобрался.

Есть немного стремный обходной путь - удалить пакеты через rpm -e --nodeps, и поставить что надо. На нарушенные зависимости в глубине urpmi не жалуется. Думаю, можно даже попробовать удалить пакет базовой системы и переустановить его urpmi, сделав другой выбор

annulen ★★★★★ ()
Ответ на: комментарий от annulen

Насчет выбора пакетов при утсановке. Ставился с ДВД диска, не нужное мне убирал еще при установке. Но в итоге все равно поставилась куча барахла, типа KPPP Akregator'a и прочего. И много было не видно в списке, в котором предлагалось выбирать пакеты.

gutaper ★★★ ()
Ответ на: комментарий от redgremlin

Используешь 2010,1. У меня 2010. Gconf сносит все, включая gstreamer, plasma, vlc. Полный список приводить не буду, только если интересно. и это я замечаю не только в данном релизе и не только с данным пакетом.

ramon13666 ★★★ ()
Ответ на: комментарий от gutaper

task-kde был выбран? Если да, это ответ на твои негодования.

ramon13666 ★★★ ()
Ответ на: комментарий от ramon13666

Везде свои нюансы. Если ставить с диска dual arch, там много мути насует вдовесок? В этом плане у суси хорошо: ставишь базовую систему с базовой X window. А дальше как хочешь. Но там зависимости шизанутые. В итоге все равно полно лукошко гумна получается. Мандриву вот тыкаю, нравится. Отзывчивый интерфес, шрифты не убивают глаза, как в сусе. И еще в сусе не нравится отсебятина, напрмер вырезать dht из торрента по причине политики «партии». Втихую причем.

gutaper ★★★ ()
Ответ на: комментарий от gutaper

Не знаю. Если это лив-сд, то много чего наставит. А разгребать будешь как я. Если обычный установщик, во время выбора пакетов ставишь галку «я сам выберу необходимые пакеты», а затем выбираешь. Главное не наставить метапакетов (task-kde, task-gnome etc). Но GTK все равно нужно держать, так как Mandriva Control Center написан только ка нем. А вообще ментейнерам за такое надо по рукам надавать.

ramon13666 ★★★ ()
Ответ на: комментарий от gutaper

>И много было не видно в списке, в котором предлагалось выбирать пакеты.

надо было идти дальше, при установке с ДВД можно сконфигурировать с точностью до пакета

annulen ★★★★★ ()

Хотел поставить - а она не смогла инициализировать мою Nvidia Ge-Force 8400 Это сферический ппц в вакууме

skpy ()
Ответ на: комментарий от annulen

Можно поподробней куда идти дальше? Если в Ж, то подробней не надо :)

Вот выбрал я вручную указать. Там много групп, вида «офисная станция» и прочее. Поснимал все, что не нужно. Отметил отдельную выборку пакетов. Там тоже поубирал не нужное. В итоге имею кучу барахла, которую было просто не видно там. Вот человек говорит, что это из-за наличия task-* пакетов.

gutaper ★★★ ()
Ответ на: комментарий от skpy

Попробуй без ACPI. Или не смогла найти при настройке графической системы? И да, скорей всего это чудо под названием Nouveao.

ramon13666 ★★★ ()
Ответ на: комментарий от skpy

у меня 9600GT отлично работает, при установке завелась (2010.0 Free, сейчас несвободный драйвер использую)

annulen ★★★★★ ()
Ответ на: комментарий от ramon13666

>И да, скорей всего это чудо под названием Nouveao.

вполне вероятно

annulen ★★★★★ ()
Ответ на: комментарий от ramon13666

Ну расовой неприязни к gtk у меня нет. Не замечал, что зависимости напиханы «чтобы все было?»

У меня еще при каждом заходе в ЦУ лезет на экран «Журнал утилит Mandriva Linux» :)

gutaper ★★★ ()

сага о мандриве
не оставим в беде любимый дистрибутив

kto_tama ★★★★★ ()
Ответ на: комментарий от ramon13666

а вот и нет у меня task-kde. Сортировка в ЦУ по Метапакетам установленным показывает, что есть только task-pulseaudio, task-x11, basesystem, basesystem-minimal

gutaper ★★★ ()
Ответ на: комментарий от gutaper

>У меня еще при каждом заходе в ЦУ лезет на экран «Журнал утилит Mandriva Linux» :)

Какой феерический криворук!

anonymous ()
Ответ на: комментарий от anonymous

Ну, наверное, ты, когда что-то смотришь не ползьзовав раньше - сразу и безоговорочно знаешь что делать и почему все так, как есть. Какой банальный анонимус.

gutaper ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.