LINUX.ORG.RU

Все хотят независимости Java. Кроме Oracle

 , ,


0

2

Несколько дней назад JCP проголосовала ЗА и призвала Oracle к тому, чтобы выделить процесс разработки и сертификации Java в независимую организацию.

Так как эта организация имеет контроль над принятием нововведений в Java, то все планы Oracle по развитию этой технологии могут быть отвергнуты. Как минимум одна организация (ASF) пообещала устроить проблемы при принятии любых постановлений связанных с развитием Java. Так же могут поступить и другие члены организации, проголосовавшие за независимость технологии (Google, IBM, Red Hat, Intel, VMware, Nokia, AT&T, Research In Motion, Vodafone, Apache Software Foundation (ASF))

Борьба за независимость ведётся давно. Да и сама Oracle требовала от покойной Sun того же не далее чем в 2007 году. Sun отделывалась малозначительными отговорками. С приходом Oracle трения в организации нарастают быстрее. Oracle практически прекратила консультации с JCP и начала нагружать членов организации бессмысленными задачами. К примеру, от Oracle поступило предложение к членам организации предоставить список независимых организаций по разработке технологий и стандартизации, на примере которых можно было бы организовать независимость Java. После того, как в качестве примеров были представлены W3C, OASIS, OMG и соответствующие планы, Oracle ответила в стиле покойной Sun.

То есть Oracle делает всё, чтобы настроить JCP против себя и, похоже, движется к роспуску организации. Так, сотрудники Sun уже предлагали распустить JCP, когда было задержано принятие J2EE 6 из-за неразрешённых проблем с лицензированием TCK.

>>> Подробности

★★★☆

Проверено: JB ()

Ответ на: комментарий от r

>Чего в линуксе сейчас действительно нехватает так это стандартизированной веб-ориентированной платформы которая бы развертывалась в паору кликов включая всякие кластерные варианты.

А можно «например»? ЗЫЖ 1С 8.2?

ManiTux ()
Ответ на: комментарий от EvgGad_303

> где там написано про 32битную ос?

В документе с многообещающим названием Supported System Configurations: http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html

Три первых строчки таблицы говорят про Solaris Sparc 32 bit. И нигде не написано, что подразумевается, что эта 32х битная ОС должна быть установлена на 64х битный комп. Или это должно быть очевидно? :)))

там, кстати, сказано что если ты хочешь 64бит, то сначала ставишь 32бит, а потом 64 сверху.

Да, тоже ржал. Почему надо ставить 64 сверху, если в конце концов поддерживается только 64?

Но на самом деле, думаю, что злого умысла не было: сан просто не знал, что их 32х битная сборка дефектная. Но это и удивляет.

alt-x ★★★★★ ()
Ответ на: комментарий от ManiTux

>А можно «например»?

Пример того чего нет? В винде IIS. Апач - древнее поделие годное только для пыхаю Жабьи фигни a) нестандартизированы, b) требуют большого прикладывания рук.

r ★★★★★ ()
Ответ на: комментарий от EvgGad_303

>а так для сана/оракула это давно неподдерживаемая архитектура и не стоит особо надеяться увидеть поддержку в новых версиях продуктов ))))))

И, кстати, если она неподерживаемая, то сан мог бы об этом просто сказать, вместо того чтобы устравиать цирк в баге, который, в ссылке по сслыке. А то не все жабофилы нутром могут почувствовать, какие архитектуры неподдреживаемые.

Сану-то оно так удобнее. Покупайте T3 заместо ваших старых T2. Уж он-то - точно поддерживаемый! )

alt-x ★★★★★ ()
Ответ на: комментарий от alt-x

> Три первых строчки таблицы говорят про Solaris Sparc 32 bit. И нигде не написано, что подразумевается, что эта 32х битная ОС должна быть установлена на 64х битный комп.

Там нет ни слова про ОС. Заголовок первого столбца - «Hardware Platform». В других столбцах речь уже про JRE и JDK. Хотя, конечно, «Hardware Platform» - тоже нехорошо, лучше бы обозвали Instruction Set Architecture и написали что-нибудь типа v8plus (а не v8), а для 64-битных версий - v9.

Или это должно быть очевидно? :)))

Видимо да. Дело в том, что насколько я понимаю, на сегодня нет ни одной до сих пор поддерживаемой аппаратной SPARC системы от Sun Oracle, которая поддерживала бы загрузку 32-битного ядра.

Это, однако, никак не мешает запускать поверх 64-битного ядра 32-битные приложения.

Но на самом деле, думаю, что злого умысла не было: сан просто не знал, что их 32х битная сборка дефектная. Но это и удивляет.

Ничего удивительного - им нафиг не сдалось сертифицировать продукт на системах, которые не то что давно не продаются, а уже даже не обслуживаются.

Для v8 надо что-нибудь постарее брать - типа 1.4.сколько-нибудь, если не раньше.

mukoh ()

Кто отпустит курицу, несущую золотые

Deleted ()
Ответ на: комментарий от mukoh

>> Три первых строчки таблицы говорят про Solaris Sparc 32 bit.

Заголовок первого столбца - «Hardware Platform». В других столбцах речь уже про JRE и JDK. Хотя, конечно, «Hardware Platform» - тоже нехорошо, лучше бы обозвали Instruction Set Architecture и написали что-нибудь типа v8plus (а не v8), а для 64-битных версий - v9.

Или это должно быть очевидно? :)))

Видимо да. Дело в том, что насколько я понимаю, на сегодня нет ни одной до сих пор поддерживаемой аппаратной SPARC системы от Sun Oracle, которая поддерживала бы загрузку 32-битного ядра.

Тогда что вообще может означать их «Hardware Platform» - Solars SPARC 32 bit? 32х битные приложения - это не platform и уж совсем никак не hardware.

Но на самом деле, думаю, что злого умысла не было: сан просто не знал, что их 32х битная сборка дефектная. Но это и удивляет.

Ничего удивительного - им нафиг не сдалось сертифицировать продукт на системах, которые не то что давно не продаются, а уже даже не обслуживаются.

Если она не поддерживается - не надо пытаться её поддерживать под лозунгом «добавьте ключик, авось заработает». Просто убрать её поддержку - и всё.

alt-x ★★★★★ ()
Ответ на: комментарий от alt-x

> Тогда что вообще может означать их «Hardware Platform» - Solars SPARC 32 bit? 32х битные приложения - это не platform и уж совсем никак не hardware.

Ну я ж говорю - коряво написано. Надо было написать ISA, и для 32-битных JVM написать v8plus, а для 64-битных - v9. Правда, пришлось бы объяснять, что такое ISA.. Ну или Mode бы назвали.

Если она не поддерживается - не надо пытаться её поддерживать под лозунгом «добавьте ключик, авось заработает». Просто убрать её поддержку - и всё.

Ну когда-то поддерживалась, а потом перестала, а ключик убрать забыли. Думаю, не стоит из-за этого так переживать. Ну а если сильно надо жабу на эмуляторе v8 погонять - взять 1.4 или более раннюю.

mukoh ()
Ответ на: комментарий от mukoh

> Ну когда-то поддерживалась, а потом перестала, а ключик убрать забыли.

Ключик убрать как раз не забыли. Забыли убрать сообщение о том, что поддерживается, забыли перекомпилить, под v8plus всё кроме двух со-шек, и забыли убрать линк на то как устанавливать для 32х битных компов с «How do I download and install Java for my Solaris 32-bit computer?» http://www.java.com/en/download/help/5000010600.xml . Очень забывчивые люди.

Java 5, похоже, что работает в 99% случаев. Её роняет оракловский драйвер только и попытки установить безопасное соединение.

Думаю, не стоит из-за этого так переживать.

Так не переживайте. :)

если сильно надо жабу на эмуляторе v8 погонять - взять 1.4 или более раннюю.

Нафик-нафик. Непротестированные продукты в качестве test case не годятся.

alt-x ★★★★★ ()

Итак, IBM официально присоединилась к Oracle с целью участия в разработке OpenJDK. IBM хоронит свой JDK jRockit

Karapuz ★★★★★ ()
Ответ на: комментарий от Karapuz

> IBM официально присоединилась к Oracle с целью участия в разработке OpenJDK. IBM хоронит свой JDK jRockit

jRockit никогда не принадлежал IBM. :) А с 2008го он и вовсе в собственности Оракла. Причём они его развивали и, вероятно, будут развивать и дальше, как минимум для платформы ExaLogic.

alt-x ★★★★★ ()
Ответ на: комментарий от alt-x

>> Думаю, не стоит из-за этого так переживать.

Так не переживайте. :)

Так я и не переживаю.. А вот вы прям целое исследование провели, где чего и сколько забыли.

> если сильно надо жабу на эмуляторе v8 погонять - взять 1.4 или более раннюю.
Нафик-нафик. Непротестированные продукты в качестве test case не годятся.

C чего это они непротестированные? Вот они то как раз и есть шанс что протестированные, в отличие от последних.

mukoh ()
Ответ на: комментарий от mukoh

> Так я и не переживаю.. А вот вы прям целое исследование провели, где чего и сколько забыли.

Неа. Я спросил гугла что поставить, он вывел меня на сановскую страницу. Попробовал версии там указанные - и получил результаты.

если сильно надо жабу на эмуляторе v8 погонять - взять 1.4 или более раннюю.

Нафик-нафик. Непротестированные продукты в качестве test case не годятся.

C чего это они непротестированные? Вот они то как раз и есть шанс что протестированные, в отличие от последних.

Ну, шанс-то есть, конечно. Он был и для последних официально поддерживаемых. Но шанс не годится. Годятся факты.

alt-x ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.