LINUX.ORG.RU

jQuery 2.0

 ,


0

1

Вышла новая версия популярной JavaScript библиотеки jQuery — 2.0.

Основные изменения:

  • Удаление поддержки браузеров Internet Explorer 6-8, благодаря чему библиотека стала меньше и быстрее. По сообщениям авторов, наиболее проблемными из поддерживаемых браузеров являются старые версии WebKit, используемые в Android 2.x.
  • Возможность собрать собственную версию библиотеки, выбрав только часть из ее 12 модулей.
  • Совместимость API с jQuery 1.9.

Поддержка версии 1.x будет также продолжена, выпуск 1.10 с исправлениями ошибок состоится в течение двух ближайших месяцев.

>>> Подробности

★★★★★

замечательно. интересно, какой % совместимости плагинов?

dib2 ★★★★★ ()

We sadly had to back out some optimizations that aren’t supported by older versions of WebKit such as Android 2.3, but most of those didn’t have a significant size impact. Still, we plan to bring them back as soon as we can! To help us out, anytime you see an old Android phone you can “accidentally” whack it with a hammer.

anonymous ()
Ответ на: комментарий от anonymous

К сожалению, нам пришлось воздержаться от некоторых оптимизаций, которые не поддерживаются старыми версиями WebKit (таких как в Android 2.3), но большая часть из них не оказавала большого влияния на размер. Тем не менее, мы планируем их восстановить так скоро, как сможем! Чтобы помочь нам, всегда когда увидите старый Android-телефон, можете «нечаянно» херакнуть его молотком.

Это из объявления о второй бете: http://blog.jquery.com/2013/03/01/jquery-2-0-beta-2-released/

anonymous ()

ну наконец-то выпилили ослика.

dikiy ★★☆☆☆ ()

в течении двух ближайших месяцев

В течение же

anonymous ()

Ожидал во второй версии чуть больший ChangeLog

Kamikadze ()

shimon, еще «По сообщения авторов,»

aol ★★★★★ ()

Краткость - сестра таланта, блин. Скоро тут делать нечего будет. Следующим шагом будет лаконичное «сабж» в теле новости.

// Ушёл на опеннет за более подробной новостью.

anonymous ()

Удаление поддержки браузеров Internet Explorer 6-8

RIP. А жаль, хорошая библиотека была.

Legioner ★★★★★ ()
Ответ на: комментарий от Legioner

Она и есть. И первая ветка ещё будет обновляться. Емли так уж нужен этот осёл.

vovans ★★★★★ ()

Жаль, для махрового энтерпрайза jQuery 2.0 непригодна. Хотя ъ энтерпрайз ее не использует вовсе.

anonymous ()
Ответ на: комментарий от anonymous

Опеннетовская машина времени ничто, в сравнении с ЛОРовской.

dib2 ★★★★★ ()
Ответ на: комментарий от Legioner

> Удаление поддержки браузеров Internet Explorer 6-8

RIP. А жаль, хорошая библиотека была.

А еще я люблю обмазываться старыми негодными браузерами и ... Иду, бывало, на варезник с Quantum Fireball, и собираю в него все старые браузеры, которые найду. Потом открываю в них фейсбук , гуглоплюс и подолгу умиляюсь результату...

shimon ★★★★★ ()

Ну и кому оно без поддержки самого популярного корпоративного бровзера нужно? В интранетах этого jQuery 2 еще лет дцать не будет.

anonymous ()

Удаление поддержки браузеров Internet Explorer 6-8

Всё правильно сделали. Старички посидят на старых версиях, ничего страшного.

anonymous ()
Ответ на: комментарий от Legioner

Не нужны же. Даже вовсе без поддержки IE - библиотека будет жить.

anonymous ()
Ответ на: комментарий от anonymous

В интранетах этого jQuery 2 еще лет дцать не будет.

Видимо, разрабам jQuery пох на интранеты.

tailgunner ★★★★★ ()
Ответ на: комментарий от anonymous

корпоративного бровзера

Корпорации со своими продуктами под IE6 могут и не обновляться, а если обновляются, то пусть переписывают сразу с учётом современных реалий, делов то. Проблемы злобных буратин волнуют только их самих.

anonymous ()
Ответ на: комментарий от Legioner

А нафига их подддержка нужна? Во первых на дворе уже давно есть IE9, да и IE нафиг не нужен. Особенно когда есть Unix, для которого IE и отродясь не было.

Kamikadze ()
Ответ на: комментарий от anonymous

В интранетах этого jQuery 2 еще лет дцать не будет.

Ванга, залогинтесь!

metrokto ★★ ()
Ответ на: комментарий от Kamikadze

Во первых на дворе уже давно есть IE9,

Не совместимый с газиллионом приложений, написаных под IE6 only. Весь корпоративный мир живет на них и никуда оттуда двигаться в обозримом будущем не собирается.

да и IE нафиг не нужен.

Обожаю деревенских аналитегов. Лапти бы хоть снял, деревенщина, они воняют.

anonymous ()
Ответ на: комментарий от vovans

Она и есть.

Её основной смысл был в унифицированной работе с джаваскриптом на разных браузерах с разными API. Если не поддерживать старые браузеры, то можно использовать нормальное современное API, которое все современные браузеры и так поддерживают и смысла от jQuery уже нет.

И первая ветка ещё будет обновляться. Емли так уж нужен этот осёл.

Ну значит первая ветка не RIP.

Legioner ★★★★★ ()
Ответ на: комментарий от anonymous

Не так все будет. Старую ветку форкнут и продолжат развивать, а про jQuery 2 скоро все забудут.

anonymous ()
Ответ на: комментарий от anonymous

Не нужны же. Даже вовсе без поддержки IE - библиотека будет жить.

На вася.народ.ру может не нужны. А в серьёзных проектах доля IE6 может достигать 90%, я не говорю уже о том, что в диком интернете подавляющее большинство машин работают под XP, а это не выше IE8.

Legioner ★★★★★ ()
Ответ на: комментарий от anonymous

Не совместимый с газиллионом приложений, написаных под IE6 only

Новый жквери протиснется через астрал и встанет на некрофильские серверы поборников Майкрософта?

anonymous ()
Ответ на: комментарий от Kamikadze

А нафига их подддержка нужна?

Чтобы зарабатывать больше денег.

Во первых на дворе уже давно есть IE9

Для XP нет. Кроме того многим людям не нравится изменения в интерфейсе начиная с IE 7 и они предпочитают консервативный IE 6.

да и IE нафиг не нужен. Особенно когда есть Unix, для которого IE и отродясь не было.

Во-первых был, учи историю. Во-вторых Windows установлена на бОльшей части ПК и с этим придётся считаться, нравится тебе это или нет.

Legioner ★★★★★ ()
Ответ на: комментарий от Legioner

в серьёзных проектах
доля IE6 … 90%

Верни машину времени на место, хватит по прошлому кататься. XP на полных парах летит в Лету.

anonymous ()
Ответ на: комментарий от dib2

Совместимость API с jQuery 1.9.

какие на 1.9 - тот процент и совместим... ну тоесть маленький процент

q11q11 ★★★★★ ()
Ответ на: комментарий от Legioner

RIP. А жаль, хорошая библиотека была.

скажи ещё хорошие браузеры были

q11q11 ★★★★★ ()
Ответ на: комментарий от shimon

ааааааа, поднял настроение с утра, спасибо

q11q11 ★★★★★ ()
Ответ на: комментарий от Legioner

Во-первых был, учи историю.

БЫЛ, я и не говорил о том что его не было.. Но поскольку им пользуются в Unix до сей поры, в Unix его поддержка особо и не нужна.

Kamikadze ()
Ответ на: комментарий от anonymous

Лапоть деревенский, зайди в любую компанию из Fortune 100 и удивись количеству десктопов с XP/IE6 (а оно там близко к 100%).

anonymous ()
Ответ на: комментарий от Kamikadze

Особенно когда есть Unix, для которого IE и отродясь не было.

Вы много сидели под Unix'ом ? Под каким именно ?

WindowsXP ★★ ()
Ответ на: комментарий от anonymous

XP на полных парах летит в Лету.

Откуда на ЛОРе столько деревенщины? В селе Кукуево наконец-то появился доступный местным алканавтам интернет?!?

anonymous ()
Ответ на: комментарий от Kamikadze

RedHat 7.3, на данный момент на Арче.

Нет таких Unix. школота

WindowsXP ★★ ()
Ответ на: комментарий от anonymous

зайди в любую компанию из Fortune 100 и удивись количеству десктопов с XP/IE6

Значит скоро эта компашка будет сидеть на неподдерживаемом некрофильском говне или наконец апгрейдит свои виндусы. Всё нормально.

anonymous ()
Ответ на: комментарий от anonymous

Ну и кому оно без поддержки самого популярного корпоративного бровзера нужно? В интранетах этого jQuery 2 еще лет дцать не будет.

Корпоративный рынок мало кому нужен, калеки могут сколько угодно вариться в собственном соку.

maxcom ★★★★★ ()
Ответ на: комментарий от anonymous

О, покалеченый илитарий.

Support status

Mainstream support: Ended on April 14, 2009[2] Extended support: Extended Support until April 8, 2014 for Windows XP with Service Pack 3 and Windows XP x64 Edition with Service Pack 2

Дальше всё, ад и погибель.

anonymous ()
Ответ на: комментарий от q11q11

скажи ещё хорошие браузеры были

В своё время хорошие. По нынешним меркам отвратительные. Необходимости их подержки это не отменяет.

Legioner ★★★★★ ()
Ответ на: комментарий от WindowsXP

Нет таких Unix. школота

Для тех, кому нужны бумажки, вообще много чего нет.

tailgunner ★★★★★ ()
Ответ на: комментарий от anonymous

Значит скоро эта компашка будет сидеть на неподдерживаемом некрофильском говне или наконец апгрейдит свои виндусы. Всё нормально.

Деревенщина, не сняв лаптей, учит элиту мирового бизнеса, как им надо себя вести с IT. Шикарно!

На самом же деле будет так - Microsoft продлит поддержку в очередной раз, и все будут довольны. Если вдруг все бросятся легаси переписывать, то это будет стоить таких денег, что рядом с новым кризисом Великая Депрессия покажется раем.

anonymous ()
Ответ на: комментарий от maxcom

Корпоративный рынок мало кому нужен, калеки могут сколько угодно вариться в собственном соку.

Практика показывает, что именно эти ребята задают моду. Кто бабки платит, тот девушку и танцует, а бабки все, какие только есть - у них.

anonymous ()
Ответ на: комментарий от anonymous

Дальше продлят, никуда не денутся. Иначе их сожрут с говном. А то и вовсе обвинят в терроризме и подрыве устоев корпоративной Америки. И будет в Гуантанамо сидеть много-много индусов, и пара сотен белых манагеров с беджиками «Microsoft».

anonymous ()
Ответ на: комментарий от Legioner

Поставьте последний FireFox на Windows XP.
Правильно сделали, что удалили IE :)

Профессионалы-энтерпрайз-разработчики (Delphi, Java 6, IE 6.0, ...):
1) Никогда и ничего не обновляют бесплатно :)
2) Через какое-то время появляется новый суперпродукт от этих же разработчиков,
который уже не будет совместим с IE6.

WinLin2 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.