LINUX.ORG.RU

jQuery 2.0

 ,


0

1

Вышла новая версия популярной JavaScript библиотеки jQuery — 2.0.

Основные изменения:

  • Удаление поддержки браузеров Internet Explorer 6-8, благодаря чему библиотека стала меньше и быстрее. По сообщениям авторов, наиболее проблемными из поддерживаемых браузеров являются старые версии WebKit, используемые в Android 2.x.
  • Возможность собрать собственную версию библиотеки, выбрав только часть из ее 12 модулей.
  • Совместимость API с jQuery 1.9.

Поддержка версии 1.x будет также продолжена, выпуск 1.10 с исправлениями ошибок состоится в течение двух ближайших месяцев.

>>> Подробности

★★★★★

Ответ на: комментарий от anonymous

IE6 у рабов, у которых денег нет. У руководства с гаджетами полный порядок, им ie6 нафиг не уперся

maxcom ★★★★★ ()

Да когда уже кто-нибудь напишет интерпретатор какого-нибудь нормального языка на этом Г?

anonymous ()
Ответ на: комментарий от maxcom

IE6 - неизбежная часть инфраструктуры корпоративного интранета, в которую вложены (попипены) совершенно нереальные бабки. 3-4 миллиона за какую-либо тупенькую софтину для project management - это норма в корпоративной Америке. И вкладывать такие же деньги заново (по другом они не умеют) в переписывание всей этой инфраструктуры эти самые ребята с бабками не станут.

А те ребята, которым они заказывают за те самые миллионы новый софт будут и дальше вкладываться в развитие старой ветки jQuery.

anonymous ()
Ответ на: комментарий от anonymous

Анон, ты опять весь тред засрал. Ну хотят они неистово совокупляться с IE6 — да пожалуйста. Но без jquery2 — некрофилы должны страдать.

mix_mix ★★★★★ ()

Совместимость API с jQuery 1.9.

Годно.

iVS ★★★★★ ()

Удаление поддержки браузеров Internet Explorer 6-8, благодаря чему библиотека стала меньше и быстрее. По сообщениям авторов, наболее проблемными из поддерживаемых браузеров являются старые версии WebKit, используемые в Android 2.x.

Ничего не понял. Проблемным является webkit, а выкидывают почему-то IE. Где логика?

Reset ★★★★★ ()
Ответ на: комментарий от Reset

IE проблемным не является, потому что его выкинули, что тут понимать. Как только старый вебкит упадёт в процентах, его тут же и удалят.

anonymous ()
Ответ на: комментарий от anonymous

а кто её будет переписывать? зачем?

те, кто разворачивают новую инфраструктуру, будут её разворачивать на новых ОС. возможно даже на базе GNU/Linux.

Ford_Focus ★★★★★ ()
Ответ на: комментарий от anonymous

Думается мне, у IE 8 процентов раз в 20 больше, чем у андроида.

Просто несерьёзная библиотека с несерьёзным подходом к разработке. Стоит подумать об отказе от её использования в будущих проектах. Какие есть нормальные альтернативы?

Legioner ★★★★★ ()
Ответ на: комментарий от Legioner

Думается мне

А мне думается, что линуксы захватили десктопы.

Просто несерьёзная библиотека с несерьёзным подходом к разработке.

Да. Поддерживают старую версию библиотеки для старых браузеров, это несерьёзно! Или ты предлагаешь тащить ещё пару лет их наследие во время разработки, когда WinXP помирать собралась?

Стоит подумать об отказе от её использования в будущих проектах. Какие есть нормальные альтернативы?

Никаких и нет, товарищ. Да и это тоже не подарок, но лучше нет.

anonymous ()
Ответ на: комментарий от mix_mix

Ты тупой. Эти «некрофилы» девушку ужинают, они ее и танцевать будут. А jquery2 зачахнет.

anonymous ()
Ответ на: комментарий от Ford_Focus

а кто её будет переписывать? зачем?

Затем, глупый айтишнег, что мир не вокруг айти вертится. Эта инфраструктура критична для работы бизнеса, но сама по себе не цель.

те, кто разворачивают новую инфраструктуру, будут её разворачивать на новых ОС. возможно даже на базе GNU/Linux.

Старая инфраструктура работает. Новую с нуля никто делать не станет. Новые элементы инфраструктуры должны легко интегрироваться в существующую - а это значит, что все новые интранет проекты должны работать под IE6, поскольку он стоит у всех планктонин в конторе, и необходим для работы со старыми элементами инфраструктуры.

anonymous ()
Ответ на: комментарий от anonymous

У тебя, походу, спермотоксикоз, чувак.

anonymous ()
Ответ на: комментарий от anonymous

ты так и не ответил - _переписывать_ зачем?

если нет необходимости переписать всё с нуля, то какая вообще необходимость в новой версии библиотеки?

Ford_Focus ★★★★★ ()
Последнее исправление: Ford_Focus (всего исправлений: 1)
Ответ на: комментарий от Ford_Focus

ты так и не ответил - _переписывать_ зачем?

Я и говорю, что переписывать никто никогда это добро не станет.

если нет необходимости переписать всё с нуля, то какая вообще необходимость в новой версии библиотеки?

Повторяю для альтернативно одаренных: все новые проекты должны интегрироваться в существующую инфраструктуру. А это означает, что у клиентов на десктопах XP и IE6, даже если у тебя на сервере новомодное супе-пупер-хипстерское барахло вроде линухов и руби на рельсах. jQuery и была всегда особенно полезна для тех, кто вынужден разрабатывать что-то новое с такими условиями. Там, где все хорошо и легко, никакой jQuery и так не надо.

anonymous ()
Ответ на: комментарий от anonymous

все новые проекты должны интегрироваться в существующую инфраструктуру

1) почему проект обязательно должен использовать новую версию библиотеки?
2) почему клиент обязательно должен использовать устаревшую (оффициально не поддерживаемую и потенциально опасную) версию программы?

Ford_Focus ★★★★★ ()
Ответ на: комментарий от anonymous

Дополнительно к очень нужному IE6 поставить Opera/Firefox/Chrome?
В интернет через IE6 ходите?

WinLin2 ()
Ответ на: комментарий от WinLin2

В интернет в таких местах обычно не пускают вообще. Объяснять планктону, каким браузером по каким урлам интранета ходить никто не станет.

anonymous ()
Ответ на: комментарий от Ford_Focus

1) почему проект обязательно должен использовать новую версию библиотеки?

Потому, что разработчики хотят новые фичи. Они не по своей воле со старым говном возятся, а в силу непреодолимых обстоятельств. В остальном хочется нового и удобного.

2) почему клиент обязательно должен использовать устаревшую (оффициально не поддерживаемую и потенциально опасную) версию программы?

Ты таки альтернативно одаренный. Потому, что на IE6 завязана вся корпоративная инфраструктура, и заменить его на что-то более новое невозможно.

anonymous ()
Ответ на: комментарий от anonymous

в силу непреодолимых обстоятельств

они не могут воспользоваться новой библиотекой. также как и новой ос.

заменить

зачем?

Объяснять планктону, каким браузером по каким урлам интранета ходить никто не станет

сделать ярлыки, запускающий браузер с определенной страницей. у хрома под это дело целый application mode есть. собственно руками урлы никто и не забивает - все нужные ресурсы выведены ярлыками на рабочем столе.

Ford_Focus ★★★★★ ()
Последнее исправление: Ford_Focus (всего исправлений: 1)
Ответ на: комментарий от Binary

есть немного свободного времени на отдых, а играть на gma950 совсем не получается =(

Ford_Focus ★★★★★ ()

Я только одного не понял, зачем нужны разные версии, если разница между размерами файлов 10%. Вроде были разговоры об офигенной экономии и выпиливании тонн кода.

Vit ★★★★★ ()
Ответ на: комментарий от Vit

Экономия то бывает не только в размере, но и в сложности поддержки. Мне вообще не очень нравится, как написан jquery, но совместимость между браузерами она держит, действительно, неплохо, иногда задумываешься, какой ценой.

Binary ★★★★★ ()
Ответ на: комментарий от Binary

иногда задумываешься, какой ценой

Какой-какой. 100 кило жабаскрипта, которые браузер должен прожевать и выполнить. На страницу. А потом у них браузеры тормозят.

anonymous ()

Все, кто отписался про смерть сабжа в связи с отказом от поддержки говна мамонта, скажите, правда, что когда выходит новая версия, старую уже использовать никак не получится?

cdshines ★★★★ ()
Ответ на: комментарий от cdshines

А то! Видус вей — если не ставишь последнюю версию, то ты лох. Поддерживается старая версия и даже апдейты будут? Неважно!

anonymous ()

По сообщениям авторов, наболее проблемными из поддерживаемых браузеров являются старые версии WebKit, используемые в Android 2.x.

Блин, у меня как раз 2.3.4.

drull ★☆☆☆ ()
Ответ на: комментарий от anonymous

Потому, что разработчики хотят новые фичи. Они не по своей воле со старым говном возятся, а в силу непреодолимых обстоятельств. В остальном хочется нового и удобного.

Так новые фичи будут появляться параллельно в jQuery 1.x и 2.x. 2-я ветка это не более новая версия, а версия которая работает быстрее из-за того что нет поддержки старых браузеров. Для интернет-проектов нужно по прежнему пользоваться 1.x и про это говорят все, начиная с самих авторов jQuery.

jQuery 2 позиционируется как библиотека для приложений с заранее известной базой браузеров: Chrome/Firefox-расширения, сайты для смартфонов/планшетов, интернет-киоски и т.п.

anonymous ()

Всё правильно делают. ИЕ8 как раз к концу года закопают.

Tigger ★★★★★ ()
Ответ на: комментарий от anonymous

Вообще, я говорил про ресурсы на тестирование и поддержку этого всего, но и тут правильно подмечено, а что поделать то?

Binary ★★★★★ ()

Ослика выпилили, что положительно скажется на процессе отказа от старых версий IE. Теперь многие сайты на jQuery 2.0 будут просить пользователя обновить браузер. Прям праздник какой-то...

lucentcode ★★★★★ ()
Ответ на: комментарий от lucentcode

Прям праздник какой-то...

тебе-то что за дело до этого, объясни? как твоя жизнь к лучшему изменится?

anonymous ()
Ответ на: комментарий от Legioner

Необходимости их подержки это не отменяет.

тоесть нужно продолжать кушать кактус и не двигаться вперёд

q11q11 ★★★★★ ()

У меня возникла ошибка в jquery 2.0, в 1.9.1 не было проблем.
Сижу разбираюсь.

WinLin2 ()
Ответ на: комментарий от anonymous

Ну и кому оно без поддержки самого популярного корпоративного бровзера нужно?

но ведь Хром поддерживается!

user_id_68054 ★★★★★ ()
Ответ на: комментарий от q11q11

Движение вперед - это поддержка стандартов всеми браузерами. А jQuery по определению - для нейтрализации проблем работы с зоопарком и со старым барахлом, не умеющим из коробки модные фичи. Там, в будущем, места для jQuery нет. И они сами себя убивают, отказываясь от своей главной фичи, от поддержки старого барахла.

anonymous ()
Ответ на: комментарий от anonymous

написаных под IE6 only

Мы всё ещё говорим про Jquery?

Xellos ★★★★★ ()
Ответ на: комментарий от Xellos

Еще один альтернативно одаренный?

Читай медленно, много раз, пока не дойдет:

Современная корпоративная инфраструктура строится на XP + IE6, и при таком количестве неподъемного легаси, в ближайшие годы такой она и останется. Любые новые разработки должны в эту инфраструктуру вписываться. И именно здесь и рулит jQuery - позволяет на этом говне хоть как-то пользоваться современными подходами.

anonymous ()
Ответ на: комментарий от anonymous

Чем вас не устраивает jquery без слоёв совместимости? Выборки то и анимации им делать очень даже. А ещё деферреды там всякие и аяксы..

Binary ★★★★★ ()
Ответ на: комментарий от Binary

Смотришь на это всё и кажется, что частые релизы браузеров это не так уж и плохо…

anonymous ()
Ответ на: комментарий от tailgunner

Видимо, разрабам jQuery пох на интранеты.

В интранетах принято пользоваться велосипедами.

shimon ★★★★★ ()
Ответ на: комментарий от anonymous

Современная корпоративная инфраструктура строится на XP + IE6, и при таком количестве неподъемного легаси, в ближайшие годы такой она и останется.

По-моему, первое слово лишнее у тебя.

«Тащим говно, за которое по молодости-глупости заплатили втридорога» !== «современная инфраструктура».

shimon ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.