LINUX.ORG.RU

В ядро 2.6.36 будет добавлена поддержка KMS для видеочипов NVidia Fermi

 ,


0

0

В ядро Linux версии 2.6.36 войдёт код отвечающий за KMS для видеокарт GeForce GTX 470/480. К сожалению, ни 2D EXA, ни 3D с использованием Gallium3D пока поддерживаться не будут.

Также стоит обратить внимание на данную таблицу. Из таблицы можно сделать следующие выводы о состоянии FOSS драйверов для видеочипов NVidia:

  • В текущий момент нет полнофункционального драйвера ни для одного видеочипа
  • Наиболее функциональны драйверы у чипов NV30/40/50
  • Для чипов NV30/40/50 реализована поддержка OpenGL 2.1 через Gallium3D (OpenGL 2.1 — максимальная версия OpenGL которую поддерживает Mesa/Gallium3D)
  • Реализация поддержки TV выхода есть только для чипа NV30
  • Технологию Multicard, в текущий момент, поддерживается только для NV40/50
  • Suspend поддерживается всеми чипами, за исключением Fermi
  • Технология энергосбережения не поддерживается ни одним чипом на данный момент
  • Поддержка OpenCL, HDMI audio, SLI тоже пока не реализована
  • Для чипов NV04/05/10/20 в текущий момент идёт разработка поддержки 3D (через классическую Mesa)
  • Для чипов Fermi реализована поддержка только KMS

>>> Подробности

★★★★★

Проверено: svu ()

Ответ на: комментарий от Evtomax

Для чипов NV30/40/50 реализована поддержка OpenGL 2.1 через Gallium3D (OpenGL 2.1 — максимальная версия OpenGL которую поддерживает Mesa/Gallium3D)

Для чипов NV04/05/10/20 в текущий момент идёт разработка поддержки 3D (через классическую Mesa)

Поддержка OpenCL, HDMI audio, SLI тоже пока не реализована

И никакой cuda или vdpau.

Dudraug ★★★★★ ()
Ответ на: комментарий от Dudraug

> И никакой cuda или vdpau.

Я не занимаюсь числодроблением, и мой процессор нормально тянет 720p.

Evtomax ()
Ответ на: комментарий от Evtomax

То есть фейлы авторов свободной альтернативы, ты оправдываешь.

Dudraug ★★★★★ ()
Ответ на: комментарий от Dudraug

> То есть фейлы авторов свободной альтернативы, ты оправдываешь.

Ты можешь без помощи техники поднять 200 килограмм? Нет? Фейл! И никаких тебе оправданий нет! :)

Evtomax ()
Ответ на: комментарий от Evtomax

Ты можешь без помощи техники поднять 200 килограмм? Нет? Фейл! И никаких тебе оправданий нет! :)

Хреновая анлогия, я хочу чтобы то что я купил работало, так как должно. На проприетарном блобе я это получаю, а опен сурсники не осилили. Не понятно зачем вообще этот велосипед нужен, когда есть работающий блоб.

Dudraug ★★★★★ ()
Ответ на: комментарий от Dudraug

блоб не умеет KMS (дада, мне важна скорость старта иксов и переключения видеорежимов). с блобом текут памятью иксы. блоб закрыт в конце концов.

madgnu ★★★★★ ()
Ответ на: комментарий от Dudraug

> Хреновая анлогия, я хочу чтобы то что я купил работало, так как должно.

Меня не беспокоит функционал, который мне не нужен, ибо мне от его работоспособности не горячо и не холодно.

Не понятно зачем вообще этот велосипед нужен, когда есть работающий блоб.


Зачем мне блоб, если меня устраивает свободный драйвер?

А если учесть, что драйвер пишется без документации, то это офигенный вин.

Evtomax ()
Ответ на: комментарий от madgnu

блоб не умеет KMS (дада, мне важна скорость старта иксов и переключения видеорежимов)

Мне нужен нормальный opengl, vdpau, нормальное 3д и стабильность.

Dudraug ★★★★★ ()
Ответ на: комментарий от Dudraug

> Мне нужен нормальный opengl, vdpau, нормальное 3д и стабильность.

Свободный драйвер не подходит для решения твоих задач. А для моих подходит. Поэтому свободный драйвер нужен, а разработчики - молодцы :)

Evtomax ()
Ответ на: комментарий от Evtomax

Они костыль делают. В первую очередь функционал, только потом свободность.

Dudraug ★★★★★ ()
Ответ на: комментарий от Evtomax

Если так называемый «свободный» драйвер ограничивает мои возможности, то он не может называться действительно свободным.

Reset ★★★★★ ()
Ответ на: комментарий от Reset

>Если так называемый «свободный» драйвер ограничивает мои возможности, то он не может называться действительно свободным.

Глупее ничего не слышал. Свободный драйвер должен не ограничвать прав пользователя, блджад, что нуво и делает.

anonymous ()
Ответ на: комментарий от Reset

> Если так называемый «свободный» драйвер ограничивает мои возможности, то он не может называться действительно свободным.

Каким образом я страдаю от того, что не реализованы не нужные мне возможности? :)

Evtomax ()
Ответ на: комментарий от Dudraug

> Они костыль делают. В первую очередь функционал, только потом свободность.

Блоб - это костыль. Свободный драйвер многим людям позволяет не юзать костыль. Если тебе не позволяет, это не значит, что другим не позволяет.

Evtomax ()
Ответ на: комментарий от Evtomax

Тогда у тебя с головой что-то не то, зачем тогда нвидию покупал? Если это все не нужно?

Dudraug ★★★★★ ()

Вот если я начну на компе что-то большое просчитывать и одновременно смотреть видео, то я подумаю о необходимости для меня аппаратного декодирования видео. Если я внезапно увлекусь 3D играми, то подумаю о необходимости эффективного 3D ускорения. Если куплю себе зомбоящик, то подумаю о необходимости TV выхода. Если куплю себе ноут, то подумаю о необходимости поддержки энергосбережения.

Но на данный момент я не вижу для себя причин обо всём этом беспокоиться :)

Evtomax ()
Ответ на: комментарий от Dudraug

> зачем тогда нвидию покупал? Если это все не нужно?

Ибо знал, что есть рабочий полнофункциональный проприетарный драйвер. А из-за того, что я жутко ленивый, не хотелось гуглить по поводу других карточек :)

Evtomax ()
Ответ на: комментарий от Dudraug

И было это 2 года назад, когда я увлекался творчеством в Blender :)

Evtomax ()
Ответ на: комментарий от anon_666

>>nouveau ... производительность в 2D у этого драйвера никакая

4.2

Да ну? Может со включеным компизом это и не заметно(где и так все сверкает-мелькает) а вот без него все становится очевидно. Причем даже сами разработчики драйвера признавали это что EXA реализовано не лучшим образов. Более менее что-то можно выжать из noveau это только drm-git-libdrm-git(либо .21)/xf86-video-noveua-git, релизные версии оооочень сильно отстают от общего прогресса драйвера.

TheMixa ★★★ ()
Ответ на: комментарий от linuxfan

linuxfan> Есть, называется nvidia-glx.

4.2

Он не полнофункциональный.

Quasar ★★★★★ ()
Ответ на: комментарий от Quasar

>Он не полнофункциональный.

Тем, что не поддерживает никому не нужный KMS?

linuxfan ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.