LINUX.ORG.RU

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

 , , ,


0

0

На сайте разработчиков, в вики, появились два столбца «Evergreen» и «Evergreen (RHD)». Evergreen - это кодовое название видеокарт с чипом R800 ( Radeon HD 5xxx ). Стоит отметить, что драйвер будет полнофункциональный. Вот некоторые фичи:

  • Поддержка OpenGL 3.2
  • Поддержка OpenCL, OpenVG (через Gallium3D)
  • Поддержка KMS, DDX, EXA, XvMC, DRI2
  • Поддержка HDMI-audio, DisplayPort, TV Out
  • Поддержка энергосбережения

Скорее всего, опять будут три ветки драйверов: Catalyst, radeon и radeonhd.

>>> Подробности

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

А когда допилят чтобы на старых картах (R300) хотя бы сраненькое 3D работало

Уже полгода как не тормозит на свободных

xorik ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

ага-ага
> direct rendering: Yes


производительность этого 3D, да, низка, но, если я был бы геймером, вероятно я сидел бы на топ-карте и на венде, не правда ли? мне свистелки не нужны, мне работать надо, быстрый 2D мне в этом только помогает, а вот Xv помогает расслабиться после тяжёлого дня, посмотрев фильм какой-нибудь.

PayableOnDeath ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

кстати почему у R500 тоже vendor string R300?
ладно хоть в dmesg пишет что loading R500 microcode =) а то совсем было бы подозрительно

v0rbis ★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

> кстати почему у R500 тоже vendor string R300?

Это название проекта. Всего три проекта. R200 — для чипов R200, R300 — для чипов R300/400/500 и R600 — для чипов R600/700/800

Root-msk ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>>ati-drivers-9999
>наверное xf86-video-ati-9999?! не?!

да-да, так точно. зашёл специально, чтоб поправить.
ато ведь взаимоисключающие параграфы... такие параграфы!

mcdebugger ★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

А я уж было испугался, думал ати открыло свои дрова. :)

daemonpnz ★★★★★ ()

Re: OpenSource драйвера для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>это на какой? такой ати, у меня 3д есть и на r300 и на r600

У меня на RV630 от 3D - одно название и шестерёнки. В ГуглеЭрсе проблемы с текстурами и тормоза, в компизе - тормоза, часть игр вообще не идёт...

KRoN73 ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

> У меня на RV630 от 3D - одно название и шестерёнки. В ГуглеЭрсе проблемы с текстурами и тормоза, в компизе - тормоза, часть игр вообще не идёт...

В федоре 12 вроде как намечаются заметные улучшения в этом вопросе.

Deleted ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>вроде как намечаются

Вот когда это будет устоявшийся факт, тогда и будет другой разговор :)

KRoN73 ★★★★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

федора 12 как бэ пока что бета и RV630 её не переваривает вместе с KMS

ky0j1n ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>У меня на древней как говно мамонта GeForce 7950 GT тыщу лет уже GL_VERSION = 2.1.2 Я вами восхищаюсь, правда. Столько мужества !

А мне по барабану по большей части: я в игры не играю ;)

GladAlex ★★★★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>А ведь для включения полноценного 3д достаточно ввести команду (в генту) "emerge ati-drivers && set opengl ati" и счастье у вас в доме :) Еще в помощь "aticonfig --initial --input=/etc/X11/xorg.conf" и "Xorg -configure".

А что нужно сделать в openSUSE?

GladAlex ★★★★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>я ушел с fglrx сразу как последний из их релизов перестал поддерживать новый ксорг, да-да, не сразу как они дропнули у себя, а именно когда уже последний рабочий драйвер перестал работать в новом окружении.

Точно! fglrx давно уже не работает с новыми иксами.

GladAlex ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

В чём баг то? Шестерёнки на окошко налезают?

Ага, вроде фигня, а неприятно.

e000xf000h ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Так судя по всему больше ни у кого, кроме тебя не воспроизводится. Посему ошибка в ДНК скорее всего ;)

GladAlex ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Но прошло время и ситуация с открытыми драйверами ATI на сегодня такова, что следующая видеокарта будет однозначно этой фирмы...

Наивный + ССЗБ

Ишь ты, как задергался, толстячок, когда в лужу посадили.

Буратино-триумфатор?

просто не надо было вякать про то, в чем нихрена не разбираешься... ^_^

Точно-точно, помолчал бы уже чем газифицировать.

видеокарта Radeon X1250 (RS400)

И как это сопоставимо с Radeon x200M, скажи мне толстячок, и если быть точнее в

в Dell Inspirion 1501 установлен Radeon m1150X а не 1250 как ты напеЙсал.

Во первых северный мост и южный мост в Dell Inspiron 1501 от AMD/ATI , в ноуте с которого я скриншот приевел северный мост Intel южный ATI, что само по себе уже не тривиальная задача.

Теперь в лужу сел ты, спецЫалист-газификатор

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Так судя по всему больше ни у кого, кроме тебя не воспроизводится. Посему ошибка в ДНК скорее всего ;)

Ошибка в ДНК как раз у тебя, остряк, ибо Здесь пример на другом ноуте с другой картой, это эпический баг, вендотролли о нем просто не знают.

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

> федора 12 как бэ пока что бета и RV630 её не переваривает вместе с KMS

У меня на Live CD KMS запустился. HD2600XT (RV630)

Deleted ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

> Так судя по всему больше ни у кого, кроме тебя не воспроизводится. Посему ошибка в ДНК скорее всего ;)

Что, неужели больше ни у кого шестерёнки на окошко не налезают? =)

Deleted ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

> ...пример на другом ноуте с другой картой, ...

Все ваши примеры на KDE, что наводит на мысль, которую я озвучил в посте выше: http://www.linux.org.ru/jump-message.jsp?msgid=4161856&cid=4163181

TOHbl4 ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Сдаётся мне, что это глюк KDE/Qt, а не драйверов... потому как у меня, например не воспроизводится

Врядли, скорее всего это косяк kwin'a, если отключить эфекты то нормально отрисовывает.

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Что и требовалось доказать, а ты обижался ;)

GladAlex ★★★★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

У меня такая же проблема на 3650 и тоже под KDE 4 но у меня меса дрм и драйвер из гида, думал что проблема в последних версиях гида.

anonymous ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Что и требовалось доказать, а ты обижался ;)

А я и не обижался, просто единственный аргумент который приводят фанбои АТИ, это то что у них все работает, а все остальные дураки.

Так сложилось что одновременно являюсь владельцем карт от ATI/AMD, nVidia и Intel, так что какие бывают с ними проблемы я отлично знаю.

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>Так сложилось что одновременно являюсь владельцем карт от ATI/AMD, nVidia и Intel, так что какие бывают с ними проблемы я отлично знаю.

Часто проблема решается сменой дистрибутива ;)У меня под федоркой кде постоянно вешалось при запуске/выходе скринсейвера или при переключении Х-вых консолей по Ctrl-Alt-F7/F8, вешая при этом весь компьютер, про 3д можно было и не мечтать. Плюс к тому были страшные артефакты во весь экран. В openSUSE всё завелось и не доставляло никогда проблем, всё работает стабильно.

GladAlex ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Часто проблема решается сменой дистрибутива ;)

Дистрибутив который использую всем устраивает, локальные баги исправляются, баги дистрибутива то же, пускай не сразу, но все же исправляют. По этому смысла менять дистрибутив не вижу. :)

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Месье вообще знакомо понятие DRI1 и DRI2, и чем они отличаются... Это не баг, так должно быть... Нвидиа просто взяла, и переписала половину иксов, поэтому у них там нормально выводится, если же играть по правилам, то так и должно быть. Не нравится - собираем-компиляем ФОСС-драйвер, и наслаждаемся нормальными "шестеренками" под компизом/квином и значительным падением производительности. Естественно, нужно подходящее ведро .31+ или что-то там надо для r600+? Без KMS DRI2 не будет работать...

Можете продолжать дальше, глядишь и к диетологу ходить не надо будет, просто будет имплозия)

Fat_Green_Liar ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>По этому смысла менять дистрибутив не вижу. :)

тогда сделай вдоль. от этого все выиграют

registrant ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

У него все проблемы от отсуствия DRI2, сейчас сделаю скрин с DRI2 на rv770 и без перекрытия шестеренок

B084 ★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>А что разве не работает?

Уже работает, только что заметил, что в арче ядро пропатчили.

duott ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Кушай, троллюшка:
[url=http://rghost.net/550315] DRI2 в действии[/url]

Fat_Green_Liar ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Вот http://img43.imageshack.us/i/kmsdri2glxgears.png/

никаких неправельных перекрытий окон.

обратите внимание на renderer string

а вот она, но без DRI2

OpenGL renderer string: Mesa DRI R600 (RV770 9442) 20090101 TCL

B084 ★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Месье вообще знакомо понятие DRI1 и DRI2, и чем они отличаются...

Мосье-то в курсе, и о понятии DRI и DRI2, и чем они отличаются,

xorg.log с DRI:

RADEON(0): [dri] Visual configs initialized

RADEON(0): [dri] Found DRI library version 1.3.0 and kernel module version 1.31.0

RADEON(0): Direct rendering experimental on RS400/Xpress 200 enabled

AIGLX: Screen 0 is not DRI2 capable

AIGLX: enabled GLX_MESA_copy_sub_buffer

AIGLX: enabled GLX_SGI_make_current_read

AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control

AIGLX: enabled GLX_texture_from_pixmap with driver support

AIGLX: Loaded and initialized /usr/lib/dri/r300_dri.so

GLX: Initialized DRI GL provider for screen 0

C DRI2 логи нужны?

e000xf000h ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Кушай, троллюшка: DRI2 в действии

Жердяй, где на скрине видно что это запущено на ATI?

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

При работе в ДРИ1 может быть только ОДИН гл-клиент... поэтому такие веселые штуки получаются при появлении второго... Для этого придумали [s]Windows 7[/s] DRI2. Каталист-фглрх (если про него говорить) не поддерживает второй режим. О чем идет речь? Логи вообще можно на пастебин засовывать...

Fat_Green_Liar ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

http://imagebin.ca/view/nIpMrUac.html

Так ясно? На кадры можно не смотреть, в фоне компиляется 2.6.32-rc5

Fat_Green_Liar ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

тогда сделай вдоль. от этого все выиграют

Покажи на личном примере, слабо или не Ъ?

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Так ясно? На кадры можно не смотреть, в фоне компиляется 2.6.32-rc5

Ясно видно одно, то что:

1. Это x1600 XT или x1600 PRO, на «onboard» не тянет.

2. То, что mesa 7.7-devel, когда будет в стабильных тогда и поговорим, а пока ATI facepalm.png

e000xf000h ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Кстате, а в атишных этих хренях есть такая штука как digital vibrance?

Нищеброд со сраным монитором детектед.

Монитор что надо. Т.е. вибранса в ати нету? Для меня это киллер-фича

slyjoe ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Почему-то уверен, что и в 7.6, и даже в 7.5.1 это есть... При наличии ядра с поддержкой KMS на радеоне.

Fat_Green_Liar ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

Очередной видеосрач, в котором нотариально заверенными скриншотами подтверждается почти полная импотенция "комьюнити" по части вопросов создания работающего 3D.

Идак, в линуксе никогда не будет нормального 3D с открытыми драйверами, потому что:

1. Писать драйвера гораздо сложнее чем падучий, глючный и тормозной открытый софт, а писать драйвера 3D, работающие максимально эффективно еще сложней.

2. DRI давно устарел, DRI2 мертв изначально, ибо это высер комьюнити. Напоминаю, что такие вещи как Direct3D и OpenGL являлись результатом работы компетентных групп людей, именно поэтому эти два стандарта успешны. Также хочется напомнить, что поверх этих бредовых DRI и DRI2 нет ни одного вменяемого работающего драйвера, в то время как Nvidia, переписав кучу всего в своих бинарных блобах, смогла достигнуть высокой производительности 3D даже на Linux.

linuxfan ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>Очередной видеосрач, в котором нотариально заверенными скриншотами подтверждается почти полная импотенция "комьюнити" по части вопросов создания работающего 3D. Бгг. Дурик. Это КДЕшные глюки. Почитай тему. RadeonHD пишется программистами Novell. Их работу оплачивает АМД, так как изза патентных проблем они не могут.

Убогие ведузятнеги пошли какие-то.

>Идак, в линуксе никогда не будет нормального 3D с открытыми драйверами, потому что: У меня открытые прекрасно работают. И Да, на компьютере работаю. В игры дети на консоли играют.

>1. Писать драйвера гораздо сложнее чем падучий, глючный и тормозной открытый софт, а писать драйвера 3D, работающие максимально эффективно еще сложней. Ох, не заплачь бедолага. Как мне тебя жаль. Всё то тебе сложно, глючно и тормознуто. Может к доктору сходишь? Запишись на курс лечения под названием эвтанзия. Должно помочь.

anonymous ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>Очередной видеосрач, в котором нотариально заверенными скриншотами подтверждается почти полная импотенция "комьюнити" по части вопросов создания работающего 3D.
Бгг.
Дурик.
Это КДЕшные глюки. Почитай тему.
RadeonHD пишется программистами Novell. Их работу оплачивает АМД, так как изза патентных проблем они не могут.

Убогие ведузятнеги пошли какие-то.

>Идак, в линуксе никогда не будет нормального 3D с открытыми драйверами, потому что:

У меня открытые прекрасно работают. И Да, на компьютере работаю. В игры дети на консоли играют.


>1. Писать драйвера гораздо сложнее чем падучий, глючный и тормозной открытый софт, а писать драйвера 3D, работающие максимально эффективно еще сложней.

Ох, не заплачь бедолага. Как мне тебя жаль. Всё то тебе сложно, глючно и тормознуто. Может к доктору сходишь? Запишись на курс лечения под названием эвтанзия. Должно помочь.

anonymous ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>И Да, на компьютере работаю.

Секретарша тоже на компьютере работает.

>В игры дети на консоли играют.

На консольных играх вырастают разве что дебилы. Замечательные вещи вроде пошаговых стратегий (привет, HoMM!) или других вещей, которые не сильно затормаживают уственное развитие, как шутерный шлак, на консолях не приживаются в силу высокой степени тупизны консольщиков в среднем. Я уже не говорю о том, что графика на CPU практически всегда будет лучше, чем на убогих консолях.

linuxfan ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>Покажи на личном примере, слабо или не Ъ?

сделать тебе вдоль? ЕМНИП, это уголовно накзуемо. все-таки есть в мире высшая справедливость - у таких как ты ни хрена не работает.

registrant ★★★★★ ()

OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>На консольных играх вырастают разве что дебилы

зря ты столько в консольки играл

registrant ★★★★★ ()

Re: OpenSource драйверы для ATI видеокарт будут поддерживать самые старшие модели — Radeon HD 5xxx

>На консольных играх вырастают разве что дебилы. Замечательные вещи вроде пошаговых стратегий (привет, HoMM!) или других вещей, которые не сильно затормаживают уственное развитие, как шутерный шлак, на консолях не приживаются в силу высокой степени тупизны консольщиков в среднем.

Ой, затормаживает развитие не "тупые" шутеры, а тупые геймеры, курглосуточно играющие ничего другого не умеющие и не знающие. А также интеллектуальные "вещи вроде пошаговых стратегий" не особо то развивают, а создают впечатления развития:) и убивающие кучу времени.

Вот потом с пеной у рта и доказывают какое плохое 3D на ATI (и не надо про проф работу, вы много знаете дизайнером или моделистов на линукс работающих?), уже давно пора забыть про 3D-игры как класс а они все ищут идолов и ждут когда им кто-то напишет дрова. А если так хочется играть то зачем себя мучать wine'ом и девелоперов своими воплями - go to windows.

Вот скажите чем по большому не устраивают для повседневной работы xf86-video-ati catalyst-driver nvidia-driver?

TheMixa ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.