LINUX.ORG.RU

Драйвер Nouveau NVK теперь поддерживает спецификацию Vulkan 1.3

 , ,

Драйвер Nouveau NVK теперь поддерживает спецификацию Vulkan 1.3

0

1

На GitLab’е одного из разработчика (Faith Ekstrand) появилась информация, что NVK теперь поддерживает спецификацию Vulkan 1.3. Столь продолжительное время велась разработка поддержки расширений VK_KHR_shader_float16_int8 (vk 1.2) и VK_EXT_texture_compression_astc_hdr (vk 1.3).

Теперь поддержка Vulkan 1.3 есть, но предстоит реализовать ещё много расширений (nvk Extensions:126(56.0%), Version 1.3).

>>> Подробности

В столь продолжительного времени велась разработка

->

Cтоль продолжительное время велась разработка

dataman ★★★★
()

То есть если у вас видеокарта RTX, то драйвер Nouveau достиг уровня проприетарного драйвера Nvidia?

ConLenov ★★★
()
Ответ на: комментарий от ConLenov

достиг уровня

Нет.

Когда достигнет хотя бы turnip/anv по уровню поддерживаемых расширений - тогда можно будет говорить об этом.. но не факт.

whbex
()

Прирост по сравнению с проприетарным драйвером есть у 1,5 игр. При этом пока что работает только на картах начиная с RTX 2060. В чем смысл, если это было бы нужнее более старым картам, которые уже официально или в скором времени deprecated, хотя бы начиная с Pascal.

xDShot ★★★★★
()
Ответ на: комментарий от xDShot

У меня на gtx 1050 вулкан вполне работает (даже zink). А вот из-за отсутствия реклокинга (спасибо нвидиа за то, что не дает прошивок) она с nouveau полностью мусор. А вот насчет kepler’а в дс пишут что - Kepler does work if you set NVK_I_WANT_A_BROKEN_VULKAN_DRIVER=1 but it’s a bit sketchy. It’s only partially implemented

linuxuser112
() автор топика
Последнее исправление: linuxuser112 (всего исправлений: 4)
Ответ на: комментарий от ConLenov

Не совсем. Вот когда рейтресинг в вулкане запилят и в блендере поддержат - то будет совсем :-)

vitalif ★★★★★
()
Ответ на: комментарий от xDShot

Ну, рано или поздно и 2xxx серия станет deprecated, а у них хотя бы будет открытый драйвер. :)

Скорее всего тут нацеливаются на 2xxx и выше из-за GSP, для которого и прошивки есть, и открытая ядрёная часть. Которую всё равно переписывают в ядрёный драйвер nouveau, что странное решение, но ладно, он хотя бы в upstream.

a1ba
()
Ответ на: комментарий от a1ba

Почему странно ? Нормальные дистры не держут в своих репах пропер дрова. А так будет все из коробки, да всякие фичи для вайланда будут сразу пихать, аля амд.

mx__ ★★★★★
()

Ну вот, теперь ещё в версиях вулкана разбираться...

kirill_rrr ★★★★★
()

Nouveau - это все еще древнее заклинание, переводящееся на современный язык как: «Я не смог установить нормальный драйвер Nvidia!»?

Was2023
()
Ответ на: комментарий от IIIypuk

Ещё бы GitLab написать правильно

насколько я помню правильное написание после известных событий стало такое: Hitlab.

borisych ★★★★★
()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.