LINUX.ORG.RU

Ответ на: Re: GNOME 2.8 в SARGE от macavity

Re: Re: GNOME 2.8 в SARGE

да нет. всё в порядке.

btw, firefox 1.0 тоже уже в "sarge"

aim1159 ★★★★★ ()
Ответ на: Re: GNOME 2.8 в SARGE от macavity

Re: Re: GNOME 2.8 в SARGE

> Все, кирдык, релиз отъезжает минимум на год. :)

Мало, мало... думаю на два, а куда торопится? Вся жизнь впереди :) Можно еще KDE засунуть последнюю :)

anonymous ()

Re: GNOME 2.8 в SARGE

урааа =]

JB ★★★★★ ()
Ответ на: Re: Re: GNOME 2.8 в SARGE от anonymous

Re: Re: Re: GNOME 2.8 в SARGE

ИМХО: Вот, как раз таки KDE 3.3 и надо было включать в sarge, а не это глюкалово.

Объясните откуда столько неприязни к KDE? Почему GNOME войдет, а KDE нет?

olegk ★★ ()

Re: GNOME 2.8 в SARGE

never ending story?

Пока будут ипаться с 2.8, выйдет 3.0. И т.д., и т.п. Не будет вам никакого сержанта!

anonymous ()
Ответ на: Re: GNOME 2.8 в SARGE от anonymous

Re: Re: GNOME 2.8 в SARGE

>Не будет вам никакого сержанта!

А как же сержант Пеппер? Он уж давно вышел!

Avarielf ()
Ответ на: Re: Re: Re: GNOME 2.8 в SARGE от olegk

Re: Re: Re: Re: GNOME 2.8 в SARGE

> Объясните откуда столько неприязни к KDE?

Объясните а почему все должны любить это угребище?

> Почему GNOME войдет, а KDE нет?

Наверное потому, что KDE team дебиана не может привести эту KDE к пригодному для использования виду. Присоединяйся, помогай.

anonymous ()

Re: GNOME 2.8 в SARGE

Господа!

А такой вопрос. Когда я переползал с RH9 на Slack9.1, то явственно заметил, что в последнем как гном, так и kde ну прямо-таки летают в сравнении с первым. Никак не ожидал от них такой прыти, ежели честно. А теперь вопрос - дебиан по этому показателю ближе к Slack или таки к RH?

Только прошу не бить ногами за невольную провокацию возможных Heilige Kriege :)

yozhhh ★★★ ()
Ответ на: Re: GNOME 2.8 в SARGE от yozhhh

Re: Re: GNOME 2.8 в SARGE

Может это у тебя машинка помощней стала? ;) Я как раз отметил обратное, правда дистрибута не менял...

annoynimous ★★★★★ ()
Ответ на: Re: Re: GNOME 2.8 в SARGE от annoynimous

Re: Re: Re: GNOME 2.8 в SARGE

> Может это у тебя машинка помощней стала? ;) Я как раз отметил обратное, правда дистрибута не менял...

Не, тот же самый ноутбук. Мозилла как тормозила, так и тормозит с той же скоростью, а вот KDE вроде шустрей стала. Потом на ещё одном компьютере попробовал - результат тот же.

yozhhh ★★★ ()
Ответ на: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: GNOME 2.8 в SARGE

>> Объясните откуда столько неприязни к KDE? Почему GNOME войдет, а KDE нет?

>ИМХО: потому что ты идиот

Хорошая аргументация. Да, много чего приятного на LOR услышать можно. В споры я вступать не хочу, так что считай, как хочешь - твое право.

olegk ★★ ()
Ответ на: Re: Re: Re: GNOME 2.8 в SARGE от olegk

Re: Re: Re: Re: GNOME 2.8 в SARGE

Что ты хочешь услышать от человека, который не приходит на мероприятия, которые сам организовывает? А KDE конечно же рулит. ИМХО.

mikhail ()
Ответ на: Re: Re: Re: GNOME 2.8 в SARGE от olegk

Re: Re: Re: Re: GNOME 2.8 в SARGE

> ИМХО: Вот, как раз таки KDE 3.3 и надо было включать в sarge, а не это глюкалово.

ты забыл процитировать эту свою мега-аргументированную фразу. сходи в аптеку капли для глаз купи.

кде постороен на библиотеке ку-те, которая не гпл, что мешает политики лицензий дебиана включать её "официально". теперь понятно?

o1o ()
Ответ на: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

вообще то я был в Питере в это время. командировка...

o1o ()
Ответ на: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

$ apt-cache search --names-only libqt3
libqt3-compat-headers - Qt 1.x and 2.x compatibility includes
libqt3-dev - Qt development files
libqt3-headers - Qt3 header files
libqt3-i18n - i18n files for Qt3 library
libqt3-java - Java bindings for Qt
libqt3-jni - Java bindings for Qt ( Native libraries )
libqt3-mt-dev - Qt development files (Threaded)
libqt3c102 - Qt GUI Library, Version 3
libqt3c102-ibase - InterBase/FireBird database driver for Qt3
libqt3c102-mt - Qt GUI Library (Threaded runtime version), Version 3
libqt3c102-mt-ibase - InterBase/FireBird database driver for Qt3 (Threaded)
libqt3c102-mt-mysql - MySQL database driver for Qt3 (Threaded)
libqt3c102-mt-odbc - ODBC database driver for Qt3 (Threaded)
libqt3c102-mt-psql - PostgreSQL database driver for Qt3 (Threaded)
libqt3c102-mt-sqlite - SQLite database driver for Qt3 (Threaded)
libqt3c102-mysql - MySQL database driver for Qt3
libqt3c102-odbc - ODBC database driver for Qt3
libqt3c102-psql - PostgreSQL database driver for Qt3
libqt3c102-sqlite - SQLite database driver for Qt3


$ apt-cache show kdebase
Package: kdebase
Priority: optional
Section: kde
Installed-Size: 20
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: all
Version: 4:3.2.2-1
Depends: kappfinder (>= 4:3.2.2-1), kate (>= 4:3.2.2-1), kcontrol (>= 4:3.2.2-1), kdebase-bin (>= 4:3.2.2-1), kdebase-data (>= 4:3.2.2-1), kdebase-kio-plugins (>= 4:3.2.2-1), kdeprint (>= 4:3.2.2-1), kdesktop (>= 4:3.2.2-1), kfind (>= 4:3.2.2-1), khelpcenter (>= 4:3.2.2-1), kicker (>= 4:3.2.2-1), klipper (>= 4:3.2.2-1), kmenuedit (>= 4:3.2.2-1), konqueror-nsplugins (>= 4:3.2.2-1), konqueror (>= 4:3.2.2-1), konsole (>= 4:3.2.2-1), kpager (>= 4:3.2.2-1), kpersonalizer (>= 4:3.2.2-1), ksmserver (>= 4:3.2.2-1), ksplash (>= 4:3.2.2-1), ksysguard (>= 4:3.2.2-1), ktip (>= 4:3.2.2-1), kwin (>= 4:3.2.2-1), libkonq4 (>= 4:3.2.2-1)
Recommends: kdm (>= 4:3.2.2-1), xfonts-konsole (>= 4:3.2.2-1)
Filename: pool/main/k/kdebase/kdebase_3.2.2-1_all.deb
Size: 18372
MD5sum: 419fd790f4e9cf3a341b71575b8337e8
Description: KDE Base metapackage
 KDE is a powerful Open Source graphical desktop environment
 for Unix workstations. It combines ease of use, contemporary
 functionality, and outstanding graphical design with the
 technological superiority of the Unix operating system.
 .
 This package depends on the minimum number of packages to provide a
 simple yet fully functional KDE desktop.


anonymous ()
Ответ на: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от anonymous

Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>>ИМХО: Вот, как раз таки KDE 3.3 и надо было включать в sarge, а не это глюкалово.

>ты забыл процитировать эту свою мега-аргументированную фразу. сходи в аптеку капли для глаз купи.

Забыл. Прошу прощения. Но это не только мое мнение(не мне об этом судить по крайней мере). Если мне не изменяет память, то сами разработчики GNOME так считают, и не скрывают. Вспомните обращение за помощью. Сейчас вы скажите, что это нормально для Open Source проекта, может быть... Страно только, что они об этом вынуждены просить. А чехарда с библиотеками? Какой смысл такой нестабильный проект включать в Sarge. Хотя не знаю, может быть 2.6 был совсем никакой для Debian? Только такое объяснение можно найти.

olegk ★★ ()
Ответ на: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>кде постороен на библиотеке ку-те, которая не гпл, что мешает политики лицензий дебиана включать её "официально". теперь понятно?

http://www.trolltech.com/download/qt/x11.html

Неплохо бы перед тем как говорить что-либо проверять это.

mikhail ()
Ответ на: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>кде постороен на библиотеке ку-те, которая не гпл

Не совсем, Linux/X11 версия под двойной лицензией (GPL для некоммерч. пользования).

>что мешает политики лицензий дебиана включать её "официально".

См. выше, конфликта с DCC нет.

Зато есть:

->исторические причины (Qt БЫЛА не-GPL, поэтому в ее (и KDE) сторону в Debian изначально не смотрели (этак во времена Potato).

->недостаток человеко-временных ресурсов в Debian KDE Team, (волонтеры, вперред, шагом марш!)

Avarielf ()
Ответ на: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от Avarielf

Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

> ->исторические причины (Qt БЫЛА не-GPL, поэтому в ее (и KDE) сторону в Debian изначально не смотрели (этак во времена Potato).

пф... поддерживать КДЕ, как мне кажется, всё таки проще, чем ГНОМ. а причины то неисторические: *потенциально* пользователь дебиана не может продавать свой дистрибутив.

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>мальчик, ты английский знаешь? там ниже тебя попроавили уже

Это ко мне? Если что, то инфа, приведенная выше, цитирована по памяти.

>Что ты имеешь ввиду под "для коммерческого пользования"?

В твоем/вашем-же линке все описано, некоммерческое, те:

Running software developed by others (e.g. KDE)

-> Использование программ написанных другими

Development of open source/non-proprietary software

-> Разработка открытого п.о.

Avarielf ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от Avarielf

Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

про английский я сказал, но не вам. вы всё правильно помните насчёт их лицензии. я насчёт исторических причин и проблем двойной лицензии

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>Ты только что орал, что Qt не под GPL.

Произшло непонимание. Я так-сказать наоборот орал что оно GPL, но с иключениями.

Qt (ДАВНО, когда на земле ссали живые динозавры, а большинство было в стадии Госплана) БЫЛ (прошедшее время, 3ее лицо) неGPL.

Доказательства - см. историю происхождения Mandrake

Avarielf ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от Avarielf

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>Произшло непонимание. Я так-сказать наоборот орал что оно GPL

Я не тебе.

>оно GPL, но с иключениями.

FSF запрещает при использовании их лицензии накладывать дополнительные ограничения. Они тебе предлагают дополнительные возможности, а не ограничения. По ссылке написаны два наиболее частых применения. К программе прилагается лицензии GPL и QPL. Ты можешь использовать ту из них, которую хочешь.

>Qt (ДАВНО, когда на земле ссали живые динозавры, а большинство было в стадии Госплана) БЫЛ (прошедшее время, 3ее лицо) неGPL.

Знаю, ну и что? Речь о настоящем.

>я насчёт исторических причин и проблем двойной лицензии

Причём исторические причины, когда речь о включении KDE _3.3_ в _Sarge_? Двойная лицензия никаких проблем не несёт. Любой автор любой известной проги под GPL может продать своему соседу Васе Пупкину прогу под BSDL, и при этом ты не узнаешь об этом никогда. Тем не менее твои _права_ как пользователя GPL софта никто не может отнять, даже автор.

mikhail ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от Avarielf

Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

смотрите, тут сверху (где большим написано RE: и прочее) пишется кто, на что отвечает:

Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE ***от mikhail*** 02.12.2004 1:40:51

я тоже долго этого не видел :)

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

> Любой автор любой известной проги под GPL может продать своему соседу Васе Пупкину прогу под BSDL, и при этом ты не узнаешь об этом никогда.

ты новый клоун? или почему ты объяснишь своё непонимание отличий гпл от бсд. в бсд ты можешь всё, что угодно делать при сохранении заметок о копирайте. гпл такого не позволяет. я могу взять код постгрес, изменить ридми, "закрыть" своей коммерческой лицензией и продавать как свой продукт.

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

> Тем не менее твои _права_ как пользователя GPL

пользователь лицензии :))))) вьюноша купи капли для глаз, а то страшно становится.. http://www.multik.ru/other/redeye/ - на почитай.

ты путаешь лицензию (право на обладание) с копирайтом (авторским владением)

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

>*потенциально* пользователь дебиана не может продавать свой дистрибутив.

И как это понимать? Те части, которые нельзя продавать или которые без исходников, или для использования частных лиц, или т. д., у Debian включены в non-free. Они лежат себе спокойно на FTP и их качают, но на дисках и их образах их нет. Диски можно продавать, дарить, вешать в кабине троллейбуса и т. д. Смотреть FAQ'и на сайте дебиана.

Ты пьяный или под дурака косишь?

mikhail ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

за базаром следи, а то ведь найду, положу в багажник чорного бумера и увезу в лес

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

Я ничего не путаю. Лицензия предоставляет пользователю определённые в ней права. Но пользователь должен соблюдать обязанности. Тебе же говорят, что любой автор проги под GPL или любой другой лицензией (если авторские права принадлежат только ему или все остальные авторы согласны) может в любой момент продать/отдать кому-либо данную прогу под любой другой лицензией. Получается своего рода двойная лицензия. Домашнее задание: доказать что !@#$ и %^&*, которые входят в состав Debian под GPL, не имеют двойной лицензии.

mikhail ()
Ответ на: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от olegk

Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

я вам грубо ответил только для того, чтобы показать вам ваш же пост - про кривость и прочее. взяли и обосрали работу разработчиков просто так :) ничего против вас лично не имею и иметь не могу.

к примеру, у меня постоянно development ветка gnome - глюки есть, но насчёт чехарды с библиотеками... такого не бывает - лишь однажды - когда компилил древнюю прогу ей нужна была древняя libxml определённой версии.

про просьбы - ну всякое бывает. в этом, как мне кажется, ничего зазорного, особенно для open source. сравнивать кде с гномом не могу, потому что первым не пользуюсь. а вот вторым во всём доволен.

o1o ()

Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

Ты мне скажи, что я неправильно сказал в этом треде? Пожалуйста список. Вот ты несколько перлов допустил, типа Qt не под GPL, пользователи Debian не должны продавать Debian и прочее.

mikhail ()
Ответ на: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

http://www.debian.org/social_contract#guidelines

Свободное распространение

Лицензия никакой части Debian не может запрещать никакой группе людей продавать или раздавать ПО как компонент собранного дистрибутива ПО, содержащего программы из нескольких различных источников. Лицензия не может требовать авторского гонорара или иного вознаграждения за такую продажу.

mikhail ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от mikhail

Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

а лицензия троллтеха может. в этом и дело, у дебиана нет авторских/исключительных прав на кюте. пострадают пользователи дебиана.

да знаю я когда и где у тебя занятия. не переживай.

o1o ()
Ответ на: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE от o1o

Re: Re: Re: Re: Re: Re: Re: Re: Re: GNOME 2.8 в SARGE

Конечно, http://progmeistars.lv/index.php?lang=ru&act=scheduleseniors . Trolltech не могут отменить GPL на Qt на те версии, которые они уже отпустили под GPL. Двойная лицензия значит, что ты берёшь любую их них и используешь по своему усмотрению. Если тебе не нравится QPL, используй под GPL. К твоему сведению, в Debian'е Qt и KDE на первом диске уже давно. И эти диски продаются: http://www.debian.org/CD/vendors/ .

mikhail ()

Re: GNOME 2.8 в SARGE

Решили двух зайцев убить: и чтоб стабильный был для сервака и чтоб не выглядел как раритет для десктопа НИЗЯ!!!

Dubrovsky ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.