LINUX.ORG.RU

GNOME 3.12

 ,


1

2

Сегодня GNOME Project выпустил GNOME 3.12. Новый релиз GNOME 3 включает в себя множество новых функций, усовершенствований и обновлений, а также новых возможностей и API для разработчиков приложений. В новой версии продолжилось улучшение удобства использования GNOME 3, также она включает в себя огромное количество мелких исправлений и улучшений.

Маттиас Clasen от имени GNOME Release Team сказал: «Это потрясающий релиз GNOME, он приносит много новых функций и усовершенствований, в том числе папки приложений, расширенный статус системы и поддержку дисплеев с высоким разрешением». Он также поблагодарил сообщество GNOME за их работу над релизом, говоря: «Эти шесть месяцев усилия были бы невозможны без всего сообщества GNOME, состоящего из разработчиков и друзей по всему миру».

Основные изменения этого релиза включают:

  • Значительные обновления интерфейса для поиска и установки приложений
  • Видоизменение внешнего вида приложений Video и gedit.
  • Поддержка дисплеев высокого разрешения.
  • Значительные обновления программного обеспечения и веб-приложений.
  • Ускорение запуска, а также более эффективное использование ресурсов.
  • Новые папки приложений, которые позволяют организовывать уже установленные приложения.
  • Серьёзные обновления веб-браузера GNOME, с улучшением производительности и интерфейса.
  • Три новых приложения – Logs, Sound Recorder, и Polari – новый IRC-клиент для GNOME.
  • В Photos обновлена интеграция с Facebook
  • Новые возможности поиска по Terminal.
  • Интегрирована поддержка Google Cloud Print.
  • Обновлённый Initial Setup Assistant.
  • Использование нового виджета «popoverts» в числе основных приложений.

3.12 также является крупным релизом для разработчиков, он поставляется с новыми виджетами интерфейса и API, а также с улучшенной документацией.

Релиз содержит множество других улучшений, которые вы можете прочитать в release notes.

Свежий релиз GNOME был встречен с нетерпением партнерами проекта. Кристиан Шаллер, менеджер Red Hat Desktop Team, сказал: «Red Hat очень рад видеть сообщество GNOME продолжающим продвигать рабочий стол GNU/Linux вперед. Мы с нетерпением ждем нововведений в GNOME 3.12, прибывающих в будущих версиях Fedora и Red Hat Enterprise Linux». GNOME 3 уже используется многими компаниями, которым пришлись по душе улучшения в новой версии.

Арун SAG, инженер-разработчик программного обеспечения в Yahoo Inc сказал: «GNOME является основным окружением рабочего стола для многих разработчиков Yahoo. Он обеспечивает прочную основу для опытных пользователей GNU/Linux, позволяя добиться цели, от чтения письма до написания кода.»

>>> Подробности

★★

Проверено: mono ()

Ответ на: комментарий от DonkeyHot

Т.ч. такую реакцию народа на изменения следует считать признаком *необходимости* большого количества перемен.

Да-да, если тебе на пузо положить включенный утюг, а ты начнёшь орать, то эту реакцию следует считать признаком необходимости большого количества перемен

anonymous ()
Ответ на: комментарий от AP

Некоторым людям достаточно посмотреть в глаза на полсекунды дольше, чем надо, чтобы они озверели.

Это твой личный опыт? Учитывая, какой ты неадекват, оно и неудивительно. Так что ищи проблему в себе.

anonymous ()
Ответ на: комментарий от Polugnom

Нет, его сделали еще более элегантным и красивым.

Красивое отсутствие интерфейса? Пустое окно? Бинарник нулевого размера. Теряюсь в догадках.

anonymous ()
Ответ на: комментарий от unanimous

totem практически идеален в своей предупредительной ненужности

fixed.

petrosha ★★★★★ ()
Ответ на: комментарий от rictb

1) в ошыбке ясно написано что нужно поставить gst-plugins-ugly 2) у тебя скорее всего не подключены репозитории 3) у тебя Ubuntu

да, нет, да. Нафига это нужно устанавливать в процессе? Место экономим? Почему нельзя как с мплэйер или влц, когда все сразу?

Нет, это не магазин для одной Ubuntu, а каталог приложений в репозиториях для различных пакетных систем дистрибутивов, написанный с нуля и хорошо интегрированный в GNOME. Скорость работы и отзывчивость замечательная.

То-есть все отличие в том, что выпилен магазин? И за коммерческими приложениями - велком куда-то еще?

Сложность настраиваемая.

Ну было бы странно, если бы они еще и гнучесс переписали, но по дефолту-то зачем?

petrosha ★★★★★ ()
Ответ на: комментарий от petrosha

Интересно, каков процент возможностей встроенного клиента Видео по сравнению с VLC или mplayer?

А много ли надо? Я вот так подумал, из возможностей мне надо лишь нормальные сабы, отдельная дорога и удобные хоткеи.

Deleted ()
Ответ на: комментарий от vitalikp

юнити это конечно классно, но! Меня сильно беспокоит что он сильно подвязан к убунте. Если это другой дистр придется тащить много левых пакетов.

Зачем тебе другой дистр?

Deleted ()
Ответ на: комментарий от Deleted

Я например пользуюсь федорой. Мне что бы юнити поставить надо на убунту перейти? А если нет какова цена юнити на той же федоре будет?

vitalikp ()

GNOME является основным окружением рабочего стола для многих разработчиков Yahoo

Бедняжки((

ritsufag ★★★★★ ()
Ответ на: комментарий от petrosha

То-есть все отличие в том, что выпилен магазин?

Нет, магазин не выпиливали, потому что код совершенно другой. Основная разница в том, что GNOME Software выглядит целосно с тем же GNOME и делает самое простое, что требуется от пакетного менеджера, при этом не зависая на полминуты как это часто делает USC.

И за коммерческими приложениями - велком куда-то еще?

Пока что да. Но я игры все-равно бы покупал на gog.com или оффсайтах - все остальное бы пиратил.

Ну было бы странно, если бы они еще и гнучесс переписали, но по дефолту-то зачем?

GNU Chess к GNOME никаким боком. Какой дефолт и где? Дефолтные игры GNOME должны виглядеть как весь GNOME. По поводу сложности - в Iagno 3.10 лично для меня сложность адская.

rictb ()
Ответ на: комментарий от BeerSeller

Пытаюсь обновиться на федоре 20. Выдает такую ошибку: Защищенные версии multilib: gsettings-desktop-schemas-3.11.91-1.fc20.x86_64 != gsettings-desktop-schemas-3.10.1-1.fc20.x86_64 Ошибка: Защищенные версии multilib: libsoup-2.45.92-1.fc20.x86_64 != libsoup-2.44.2-1.fc20.x86_64 Ошибка: Защищенные версии multilib: 1:NetworkManager-glib-0.9.9.1-3.git20140317.fc20.x86_64 != 1:NetworkManager-glib-0.9.9.0-33.git20131003.fc20.x86_64 Ошибка: Защищенные версии multilib: at-spi2-core-2.11.91-1.fc20.x86_64 != at-spi2-core-2.10.2-1.fc20.x86_64 Ошибка: Защищенные версии multilib: at-spi2-atk-2.11.5-1.fc20.x86_64 != at-spi2-atk-2.10.2-1.fc20.x86_64

Как обойти это без последствий?

anonymous ()
Ответ на: комментарий от BeerSeller

Вот так:

[rhughes-f20-gnome-3-12-i386]
name=Copr repo for f20-gnome-3-12 owned by rhughes (i386)
baseurl=http://copr-be.cloud.fedoraproject.org/results/rhughes/f20-gnome-3-12/fedora-$releasever-i386/
skip_if_unavailable=True
gpgcheck=0
cost=900
enabled=1

[rhughes-f20-gnome-3-12-x86_64]
name=Copr repo for f20-gnome-3-12 owned by rhughes (x86_64)
baseurl=http://copr-be.cloud.fedoraproject.org/results/rhughes/f20-gnome-3-12/fedora-$releasever-x86_64/
skip_if_unavailable=True
gpgcheck=0
cost=800
enabled=1

BeerSeller ★★★★ ()
Ответ на: комментарий от BeerSeller

да, две подключил. Сначала подключил только х64, список защищенных либ был в несколько раз больше, потом обе подключил, но этих 5 пакетов осталось.

anonymous ()
Ответ на: комментарий от anonymous

это уже yum update с --skip-broken

без параметра:

Помилка: Пакунок: nm-connection-editor-0.9.9.0-9.git20140123.fc20.x86_64 (@updates)
             Потребує: libgnome-bluetooth.so.12()(64bit)
             Вилучення: 1:gnome-bluetooth-libs-3.10.0-1.fc20.x86_64 (@koji-override-0/$releasever)
                 libgnome-bluetooth.so.12()(64bit)
             Оновлено: 1:gnome-bluetooth-libs-3.12.0-1.fc20.x86_64 (rhughes-f20-gnome-3-12-x86_64)
                ~libgnome-bluetooth.so.13()(64bit)
Помилка: Пакунок: rhythmbox-3.0.2-1.fc20.x86_64 (@updates)
             Потребує: libcogl-pango.so.15()(64bit)
             Вилучення: cogl-1.16.0-2.fc20.x86_64 (@koji-override-0/$releasever)
                 libcogl-pango.so.15()(64bit)
             Оновлено: cogl-1.18.0-1.fc20.x86_64 (rhughes-f20-gnome-3-12-x86_64)
                ~libcogl-pango.so.20()(64bit)
Помилка: Пакунок: rhythmbox-3.0.2-1.fc20.x86_64 (@updates)
             Потребує: libcogl.so.15()(64bit)
             Вилучення: cogl-1.16.0-2.fc20.x86_64 (@koji-override-0/$releasever)
                 libcogl.so.15()(64bit)
             Оновлено: cogl-1.18.0-1.fc20.x86_64 (rhughes-f20-gnome-3-12-x86_64)
                ~libcogl.so.20()(64bit)
 Щоб обійти проблему, спробуйте скористатися параметром --skip-broken
 Спробуйте віддати команду: rpm -Va --nofiles --nodigest

Из доп.репозиториев в общем только rpm-fusion:

dropbox.repo
fedora-updates-testing.repo
rhughes-f20-gnome-3-12.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-updates-testing.repo
fedora.repo
google-chrome.repo
rpmfusion-free.repo
rpmfusion-nonfree.repo
fedora-updates.repo
google-talkplugin.repo
rpmfusion-free-updates.repo
rpmfusion-nonfree-updates.repo

anonymous ()

gnome-shell по прежнему жрёт всю память что находит?

Lokidrow ()
Ответ на: комментарий от anonymous

конфликты версий библиотек. я бы не ставил их из двух разных реп.

внимательнее посмотри зависимости пакетов которые обновляешь.

vitalikp ()

больше всего в гноме 3 нравиться вот это:

2014-02-21-portage-import
  Title                     MATE being added to Portage
  Author                    Sander Sweers <infirit@gmail.com>
  Posted                    2014-02-21
  Revision                  1

After a long period of living in the mate-overlay, MATE 1.6 is
in the process of being added to Portage. 

...
anonymous ()
Ответ на: комментарий от anonymous

Странно. По идее ритмкоробка должна быть в той репе.

BeerSeller ★★★★ ()
Ответ на: комментарий от BeerSeller

Так и есть.

Название: rhythmbox Архитектура: x86_64 Версия: 3.0.2 Выпуск: 1.fc20 Объем: 14 M Источник: installed Из источника: rhughes-f20-gnome-3-12-x86_64

Попробуй yum clean all сначала. Или просто удалить временно эти пакеты. (т.е. rhythmbox и nm-connection-editor). Потом просто заново поставить.

BeerSeller ★★★★ ()
Ответ на: комментарий от BeerSeller

Удалил пакеты и все нормально обновилось. Спасибо.

anonymous ()
Ответ на: комментарий от vitalikp

категории слетели:( все значки программ скопом отображаются.

ключ категорий org.gnome.shell.app-folder-categories переселился в org.gnome.desktop.app-folders.

мне пока не удалось настроить, то ли гномовцы сломали, то ли не хватает чего.

vitalikp ()
Ответ на: комментарий от rictb

Основная разница в том, что GNOME Software выглядит целосно с тем же GNOME и делает самое простое, что требуется от пакетного менеджера, при этом не зависая на полминуты как это часто делает USC

И тем не менее это опять не очень нужное повторение. В том же минте под циннамоном работает USC совершенно безразрывно.

petrosha ★★★★★ ()
Ответ на: комментарий от vitalikp

Я знал, что гномовцы садисты. В этом релизе тоже отличились. Категории старым способом нельзя вернуть. Самый простой способ поставить пакет gnome-software и там есть гуи настраивать папки с меню. У кого же его нет делаем так.

Первое, что делаем это переносим настройки стандартных категорий из старого ключа.

# старые значения ключа
dconf read /org/gnome/shell/app-folder-categories
# новое расположение
dconf write /org/gnome/desktop/app-folders/folder-children "..."

# у меня получилось так
dconf write /org/gnome/desktop/app-folders/folder-children "['System', 'Accessories', 'Utilities', 'Sundry', 'Internet', 'Development', 'Office', 'Graphics', 'Multimedia', 'Games']"

После этих изменение станет видно пустые квадратики категорий.

Далее есть два варианта. В ручную прописать каждый desktop файл или привязать к папкам стандартные категории.

Делается это так. Возьмем для примера две категории Office и Game.

# добавить категорию офисные програмы
dconf write /org/gnome/desktop/app-folders/folders/Office/categories "['Office']"
# добавить категорию игры
dconf write /org/gnome/desktop/app-folders/folders/Games/categories "['Game']"

ну далее по аналогии. В результате все новые значки будут появляться в стандартных категориях, если это в них указано.

что бы добавить desktop файл в определенную категорию нужно сделать следующее.

#  Добавить значек игры mygame1 в категорю Games
dconf write /org/gnome/desktop/app-folders/folders/Games/apps "['mygame1.desktop']"

Думаю можно еще создавать свои категории. Пока не экспериментировал, но не думаю что что-то сложное. Единственное категории не отображаются подписи:(

На это натолкнула статья тут https://blogs.gnome.org/mclasen/2014/03/17/app-folder-configuration/.

vitalikp ()

Потыкал предложенный Live CD.

Выглядит, конечно, весьма симпатично: минималистично и современно. Совмещённые заголовки забавны, пока не запустишь программу, которая их не поддерживает (а такие вне GNOME почти все).

Но вот всё это без толку, если оно падает каждые несколько минут. Заходишь в Activities, запускаешь Web, появляется его окно и через две секунды пропадает. Запускаешь ещё раз - то же самое. Через несколько итераций падает вся оболочка, причём насовсем. Приходится перезагружать. Видеокарта Intel, так что всё должно работать нормально, а вот хрен.

Меню статусов вымораживает: зачем отображать пункт Battery при отсутствующей батарее, на стационарной системе?

В общем, попробовав большинство приложений, сделал вывод, что GNOME красиво выглядит на снимках экрана, но работать в нём всё ещё невозможно, по крайней мере мне.

Вообще, довольно странное ощущение: вроде всегда было, что в GNOME ощутимо меньше возможностей и настроек, чем в KDE, но реализованы они были более качественно что ли, более вылизаны были. Сейчас же KDE 4.11, которым пользуюсь постоянно, производит впечатление более продуманной в мелочах среды, чем GNOME, при этом явно выигрывая в гибкости. Похоже, GNOME начинает (продолжает?) терять свои былые сильные стороны, не приобретая новые. А жаль: конкуренция ещё никому не вредила.

anonymous ()
Ответ на: комментарий от petrosha

У Минта менеджер вообще другой(и да, он довольно быстр). Сравни хотя бы скриншоты, дизайн у них совершенно разный: Ubuntu Software Center, Mint Software Manager и GNOME Software.

Очень нужное повторение, поскольку новые приложения GNOME отличаются дизайном от «просто GTK+ приложений».

rictb ()
Ответ на: комментарий от eugeno

в jessie не войдет любой Gnome выше 3.10, потому что Jessie уже Frozen. А также потому что разработчики debian копипастят LTS-релиз Ubuntu, в данном случае 14.04, в который не попадет Gnome выше 3.10

anonymous ()

Почему никто не написал о том, что терминал теперь умеет в рефлоу текста?

NeXTSTEP ★★ ()
Ответ на: комментарий от anonymous

потому что Jessie уже Frozen

Ты упоролся. Ну или пишешь нам из будущего.

А также потому что разработчики debian копипастят LTS-релиз Ubuntu, в данном случае 14.04, в который не попадет Gnome выше 3.10

В LTS GNOME вообще не попадёт, ибо находится в universe, который Canonical не то что Long Term, а вообще не Support.

В следующий раз старайся лучше, а то вместо нормального троллинга лишь выглядишь дебилом.

anonymous ()
Ответ на: комментарий от anonymous

Jessie уже Frozen

У тебя уже 5 ноября на дворе?

разработчики debian копипастят LTS-релиз Ubuntu

О, да я гляжу, ты вообще из параллельной вселенной.

eugeno ★★★★★ ()
Ответ на: комментарий от anonymous

Все, что ты назвал - проблемы LiveCD. В нормальных дистрибутивах гном работает стабильно.

equeim ★★ ()
Ответ на: комментарий от anonymous

Идиот. LTS-релиз - основа для debian.

anonymous ()
Ответ на: комментарий от eugeno

Ubuntu 8.04= Debian 5 (Lenny) (Gnome 2.22) Ubuntu 10.04 = Debian 6 (sqeeze) (Gnome 2.30) Ubuntu 12.04 = Debian 7 (Wheezy) (Gnome 3.4) Ubuntu 14.04 = Debian 8 (Jessie) (Gnome - ?) теперь вопрос на засыпку: Какой будет Gnome? Открываем beta 2 ubuntu 14.04 а там... 3.10. Вывод: В jessie Gnome > 3.10 не будет.

anonymous ()
Ответ на: комментарий от anonymous

Равенство версий ничего не говорит о направлении движения пакетов, которое в реальности противоположное заявленному тобой. Вот, читай, просвещайся: http://www.ubuntu.com/about/about-ubuntu/ubuntu-and-debian.

Более того, зайдём на страницу пакета, например, gnome-shell: http://packages.ubuntu.com/trusty/gnome-shell. Справа красуется примечательная категория «Original Maintainers (usually from Debian)». Nuff said.

Ну и напоследок цитата из ChangeLog:

gnome-shell (3.10.3-0ubuntu1) trusty; urgency=medium

* New upstream release (LP: #1269916)

* Merge from Debian

Нельзя троллить на темы, которые так элементарно проверяются, иначе рискуешь быть публично ткнутым носом в собственное враньё. Ну ничего, не расстраивайся: негативный опыт - тоже опыт.

anonymous ()
Ответ на: комментарий от anonymous

Ubuntu 8.04= Debian 5 (Lenny) (Gnome 2.22) Ubuntu 10.04 = Debian 6 (sqeeze) (Gnome 2.30) Ubuntu 12.04 = Debian 7 (Wheezy) (Gnome 3.4) Ubuntu 14.04 = Debian 8 (Jessie) (Gnome - ?) теперь вопрос на засыпку: Какой будет Gnome? Открываем beta 2 ubuntu 14.04 а там... 3.10. Вывод: В jessie Gnome > 3.10 не будет.

Учи матчасть, неуч. Это убунта основана на дебиане, а не наоборот. Пакеты для LTS-выпусков убунта берет из тестинга. Так как Wheezy была заморожена 30 июня 2012 года, то в нее вошел последний на тот момент, мартовский выпуск GNOME 3.4, который попал и в убунту 12.04. А Jessie будет заморожен только 5 ноября, и туда успеет перекочевать сентябрьский GNOME 3.14. Как уже бесят эти школьники, которые думают, что весь мир вертится вокруг бубунты.

eugeno ★★★★★ ()
Последнее исправление: eugeno (всего исправлений: 1)

Все нравится в gnome 3. Только dash панель (именно панель, которая раскрывается на весь экран, а не док) не нравится. Заместо нее использую cairo dock. Как ее отключить или хотя бы чтобы при наведении мышкой в верхний левый угол не открывалась автоматически? Google по этому поводу молчит, облазил практически все. Но может плохо искал?!

И еще если возможно, то при наведении мышкой в нижний край - отключить выпячивающуюся панель (название не знаю), там еще значек шестеренки (насткройка уведомлений). При использовании cairo dock очень сильно мешает. Как отключить?

anonymous ()
Ответ на: комментарий от vitalikp

обновлю гном гляну что там не так с gedit, самому стало интересно.

дошли руки до gedit. посмотрел, закрыл, вернул обратно старую версию.

могу описать только двумя словами — «планшетный маразм».

классический стиль можно было бы и оставить. буду к gvim привыкать наверно, он ближе к телу. но мне зачастую надо открыть текстовый файл только для того что бы скопировать часть текста. поэтому даже не знаю.

vitalikp ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.