LINUX.ORG.RU

Определена дата заморозки Debian Jessie

 , ,


0

2

Команда разработчиков с радостью сообщает, что ветка Jessie дистрибутива Debian GNU/Linux будет заморожена 5 ноября 2014 года.

Следующая заморозка будет немного отличаться от предыдущих:

  • в первый месяц заморозки будут приниматься только важные исправления;
  • после 3 месяца заморозки удаленные пакеты не смогут вернуться в testing-ветку;
  • пакеты с серьезными проблемами и пакеты, от таких пакетов зависящие будут автоматически удаляться после 3 месяца заморозки.

Поступившие предложения о целях следующего релиза:

  • поддержка systemd в каждом пакете с init-сценариями;
  • усиление безопасности исполняемых файлов ELF;
  • поддержка переменных CFLAGS и CXXFLAGS в debian/rules;
  • clang как дополнительный компилятор;
  • набор утилит для кросс-разработки, возможность кросс-сборки системы;
  • SELinux;
  • UTF-8.

Список принятых целей будет опубликован позже, после обсуждений и консультаций с отстаивающими эти цели.

Политика заморозки

>>> Анонс

★★★★★

Проверено: Shaman007 ()

Debian = Debora + Ian. -> Debora Ian Jessie. Хо-хо-хо...

Evolve32 ()
Ответ на: комментарий от NaN

Pulseaudio и D-Bus в Debian Wheezy уже зависят от systemd.

Это заявление - случай так называемого вранья или некомпетенции.

tailgunner ★★★★★ ()
Ответ на: комментарий от aim1159

Перешли из-за инит системы?! Ну и правильно, что перешли, за чем в дебиан сообществе полудурки.

anonymous ()
Ответ на: комментарий от Reset

Ёпта, ещё одно чмо на з.п. у мелкомягких.

anonymous ()

поддержка systemd

И чего все так пугаются? Оно и сейчас там есть, хочешь - ставь. Полная совместимость с systemd не означает перехода на него или впихивания по дефолту.

Knigochey ()

clang

Давно пора.

anonymous ()
Ответ на: комментарий от tailgunner

Это заявление - случай так называемого вранья или некомпетенции.

apt-cache depends pulseaudio
pulseaudio
  Зависит: libasound2
  Зависит: libc6
  Зависит: libcap2
  Зависит: libdbus-1-3
  Зависит: libfftw3-3
  Зависит: libgcc1
  Зависит: libice6
  Зависит: libltdl7
  Зависит: liborc-0.4-0
  Зависит: libpulse0
  Зависит: libsamplerate0
  Зависит: libsm6
  Зависит: libsndfile1
  Зависит: libspeexdsp1
  Зависит: libstdc++6
  Зависит: libsystemd-daemon0
  Зависит: libsystemd-login0
  Зависит: libtdb1
  Зависит: libudev0
  Зависит: libwebrtc-audio-processing-0
  Зависит: libx11-6
  Зависит: libx11-xcb1
  Зависит: libxcb1
  Зависит: libxtst6
  Зависит: adduser
  Зависит: lsb-base
  Зависит: consolekit
  Зависит: udev
  Зависит: libasound2-plugins
  Предлагает: pulseaudio-utils
  Предлагает: pavumeter
  Предлагает: pavucontrol
  Предлагает: paman
  Предлагает: paprefs
  Рекомендует: pulseaudio-module-x11
  Рекомендует: gstreamer0.10-pulseaudio
  Рекомендует: rtkit
  Ломает: <libltdl3>
apt-cache depends dbus
dbus
  Зависит: libc6
  Зависит: libdbus-1-3
  Зависит: libexpat1
  Зависит: libselinux1
  Зависит: libsystemd-login0
  Зависит: adduser
  Зависит: lsb-base
  Предлагает: dbus-x11
NaN ()

UTF-8.

А что сейчас не так с UTF-8 в Debian?

rtvd ★★★★★ ()
Ответ на: комментарий от Reset

поэтому selinux в 99.99% случаев просто вырубают

Его надобно просто настроить. Потом всё будет работать.

Mandatory Integrity Control

Эта та хрень, которая по дефолту не даёт директории шарить ?

dada ★★★★★ ()
Ответ на: комментарий от NaN

libsystemd-login0

Это всего лишь либа, она ничего не делает. Если она так напрягает, можешь попробовать пересобрать без поддержки, вроде можно.

Knigochey ()
Ответ на: комментарий от NaN

Как вполне очевидно, systemd в зависимостях нет. Правда, некомпетентые люди часто путают libsystemd-login0 с самим systemd.

tailgunner ★★★★★ ()
Ответ на: комментарий от Extraterrestrial

Рано радуешься. Или уже 2015 наступил? :D

ArtKun ★★★★★ ()

Нормально. Марка держится.

dark77 ()
Ответ на: комментарий от Reset

Интересно, это они специально пошли против Космонавта не стали внедрять upstart и apparmor ?

В wheezy apparmor есть.

anonymous ()
Ответ на: комментарий от tailgunner

То есть, libsystemd-login0 никакого отношения к systemd не имеет?

NaN ()
Ответ на: комментарий от dada

Его надобно просто настроить. Потом всё будет работать.

Почему это не могут сделать разработчики дистрибутива?

Эта та хрень, которая по дефолту не даёт директории шарить ?

Нет, это дополнительные метки безопасности на объектах (так называемый integrity level), в частности, UAC их использует.

Reset ★★★★★ ()

А нужен ли SELinux на десктопе?

NaN ()
Ответ на: комментарий от NaN

То есть, libsystemd-login0 никакого отношения к systemd не имеет?

То есть это не systemd // К.О.

tailgunner ★★★★★ ()
Ответ на: комментарий от Reset

Почему это не могут сделать разработчики дистрибутива?

Они же по дефолту предоставляют несколько конфигов.
хочешь их вруби, не хочешь - настраивай.

dada ★★★★★ ()

очередная плановая замена хладагента.
В следующий раз вкорячат системд.

Bad_ptr ★★★★ ()
Ответ на: комментарий от NaN

Нужен, например, для ограничения прав браузеров.

Reset ★★★★★ ()

UTF-8.

да вы подождите, пусть стабилизируют сначала

unt1tled ★★★★ ()

ветка Jessie будет заморожена 5 ноября 2014

уже и дмьяныч гонит версии... не к добру это

q11q11 ★★★★★ ()
Ответ на: комментарий от Darth_Revan

А ещё PulseAudio зависит от systemd-udev, вот ужас!

Нет такого пакета.

NaN ()
Ответ на: комментарий от Darth_Revan

Это в Sid, родной. В Sid пусть хоть от HURD зависит, мне всё равно.

NaN ()

/поддержка systemd в каждом пакете с init-сценариями;

Созрели, наконец

Lennox ★★★★★ ()
Ответ на: комментарий от BMX

Если выпустят ALT Linux 8.0 «Люся», ты не будешь пользоваться ним не из-за названия.

«Смешарики» - ассиметричный ответ ALT Linux! ALT Linux 8.0 «Нюша», ALT Linux 9.0 «Копатыч» (ЛОР-версия - «Закопатыч»).

Запас есть! http://ru.wikipedia.org/wiki/Смешарики

Zubok ★★★★★ ()

поддержка systemd в каждом пакете с init-сценариями;

Спорно. Правда у них хватит пороху разбить его попакетно.

усиление безопасности исполняемых файлов ELF;

За счёт чего? Некоторые опции из hardened уже сейчас при сборке используются.

поддержка переменных CFLAGS и CXXFLAGS в debian/rules;

В сочетании с предыдущим пунктом - много пакетов патчилось в части системы сборки, чтобы упомянутые флаги подхватывались.

clang как дополнительный компилятор;

Как дополнительный тестер, разве что. Изя, цып-цып-цып, кто там кудахтал про уникальные передовые нанотехнологии во фре?

набор утилит для кросс-разработки, возможность кросс-сборки системы;
UTF-8.

Непонятно, что имеется в виду.

SELinux;

Однозначно нет. Эта штука работает только в малоизменяемой среде. Роутер, телефон без рута, нас. Для десктопе - будет снесена при первых же проблемах из-за высокого порога вхождения. На серверах она тоже бесполезна из-за перманентного траха в настройке при установке конфигурации, отличной от дефолтной. Кэш сквида вынес на отдельный раздел - уже караул. кастомный php собрал в /opt - тушите свет. Лучше apparmor + часть патчей из pax'а.

anonymous ()
Ответ на: комментарий от derlafff

я так понимаю, что они ужесточили сам период заморозки. хотя я сам не знаю, что у них до этого было

До этого просто не было чётких планов. Точную дату заморозки объявляли за неделю до оной, релиза — за две недели.

eugeno ★★★★★ ()
Ответ на: комментарий от i_gnatenko_brain

Жизнь вообще несправедливая штука, и иногда это таки приходится делать.

leave ★★★★★ ()
Ответ на: комментарий от Reset

Интересно, это они специально пошли против Космонавта не стали внедрять upstart и apparmor ?

А ты только сейчас заметил, что поделки космонавта нужны только ему самому и его последователям?

eugeno ★★★★★ ()
Ответ на: комментарий от lucky_guy

Поддержка utf-8 появилась в RH8.0 аж в 2002 году. Теперь мы знаем на сколько лет (11) отстает дебиан от красношапки.

Reset ★★★★★ ()
Последнее исправление: Reset (всего исправлений: 1)
Ответ на: комментарий от anonymous

rc-buggy

Я вдруг понял, что это значит. Спасибо.

Gotf ★★★ ()

поддержка systemd в каждом пакете с init-сценариями;

Неет. только не эта похабщина. всё же хочется верить, что мейнстримом останется init. несмотря на все заезды товарищей, которым нужен быстрогрузящийся веб-сервер с чумовыми логами для загрузки сервера

hawai ()

Лучше бы этот ненужный дистрибутив заморозили навсегда!

anonymous ()
Ответ на: комментарий от Valkeru

Да не, упоролись авторы программ, которые в 21 веке заставляют при их использовании совершать манипуляции, чтобы текст в UTF-8 не сломать. Тот же mysql в примерах :}

Deleted ()
Ответ на: комментарий от AX

В чем соболезнования то? Наоборот мы улыбаемся над вами всеми в уголку)

v9lij ★★★★★ ()
Ответ на: комментарий от Reset

Поддержка utf-8 появилась в RH8.0 аж в 2002 году.

И что, в 2002 году (да и сейчас) в RH нет тех проблем, о которых говорится здесь? Кто-то здесь врёт.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.