LINUX.ORG.RU

Вышел Calculate Linux 18.12

 , , ,


0

1

Мы рады представить вашему вниманию релиз Calculate Linux 18.12!

В новой версии добавлена поддержка установки системы на Btrfs с поддержкой сжатия в формате zstd, в релиз вошла новая редакция дистрибутива для образовательных учреждений (CLDXE), оптимизирован размер серверных редакций дистрибутива, добавлена поддержка переноса программ при переустановке системы. ISO-образы запакованы в формат zstd, что ускорило время загрузки LiveCD, запуска программ и установки системы.

Для загрузки доступны следующие редакции дистрибутива: Calculate Linux Desktop с рабочим столом KDE (CLD), Cinnamon (CLDC), Cinnamon (CLDL), Mate (CLDM) и Xfce (CLDX и CLDXE), Calculate Directory Server (CDS), Calculate Linux Scratch (CLS) и Calculate Scratch Server (CSS).

Программное обеспечение

  • 32-х и 64-х битные сборки переведены на ядро 4.19.9.
  • KDE Applications обновлен до версии 18.08.3.
  • KDE Plasma до версии 5.14.3.
  • Cinnamon обновлён до версии 4.0.3.

Установка системы

  • Формат сжатия LiveCD переведён на zstd, за счёт чего сократилось время на загрузку Live образа, установку системы, запуск приложений, подготовку модифицированного образа системы.
  • Добавлена поддержка установки системы на Btrfs с использованием сжатия zstd.
  • Добавлена миграция установленных программ во время переустановки системы.
  • Добавлена поддержка обновления пакетов во время первой загрузки системы.
  • Добавлен выбор файловой системы при авторазметке.
  • Исправлено вычисление необходимого места при авторазметке.

Calculate Linux Desktop LXQt

  • Исправлена работа с ресурсами SMB.
  • Исправлено перетаскивание иконок на рабочий стол.
  • Исправлен вызов свёрнутого приложения из другого рабочего стола.
  • Добавлена графическая утилита настройки принтера.

Calculate Directory Server

  • Исправлена генерация сертификата для Postfix.

Прочее

  • В релиз вошла новая редакция дистрибутива Calculate Linux Desktop Xfce Education для образовательных учреждений.
  • В утилитах Calculate добавлена поддержка мониторов с высоким разрешением DPI.
  • Добавлена поддержка используемого в VirtualBox по умолчанию для Unix-систем времени.
  • Добавлена поддержка настройки формата времени утилитой cl-setup-boot-live.
  • Добавлена поддержка форматов сжатия образа системы zstd и lz4.
  • Сокращён размер серверных версий дистрибутива за счёт исключения из сборки неиспользуемых Firmware.
  • Исправлено подключение доменных ресурсов при использовании Samba 4.8 и выше.
  • В Gajim отключены сообщения об изменении статуса собеседника в окне чата.
  • Обновлён перевод утилит на французский язык.
  • Отключено удаление пакетов, используемых для сборки при выполнении обновления.
  • Количество бинарных пакетов репозитория составляет 13 058 шт.

Обновление

Для обновления выполните cl-update, либо загрузите новый образ в директорию /var/calculate/linux и выполните cl-install.

>>> Анонс

★★★★★

Проверено: maxcom ()

Ответ на: комментарий от iluha16

Я живу за мкадом. Ну, это если пару часов ехать в одну сторону от красной площади.

Если тебе что-то не нужно, рад за тебя. А то что я выше описал, нужно почти каждому, кто пользуется дистрибутивом на постоянной основе.

Печально быть чсвшным «не нужно» в 2019 году.

LightDiver ★★★★★ ()
Последнее исправление: LightDiver (всего исправлений: 1)
Ответ на: комментарий от balsoft

ну я рад что тебе весело. пользуюсь gentoo и это никак не мешает работе. привык и как следствие от других дистрибутивов тошнит, нигде не чуствую себя как дома в отличии от gentoo.

iluha16 ()
Ответ на: комментарий от alexferman

Просто там некоторые вещи, как я понимаю, решают голосованием, а комьюнити в последние годы познало свое величие от того, что они уже все изучили и понимают, а следовательно новички, как бы, и не люди, и продвигает немного неадекватное для массового пользователя.

LightDiver ★★★★★ ()

Ультиматум(дополнение)

Верните стабильный софт. Впихнутый фф найтли косячит жутко, а переустановка на нормальный - опять же трафик, да еще и понять нужно, что это именно косяк нового софта.

LightDiver ★★★★★ ()
Ответ на: Ультиматум от LightDiver

Верните нано.

Лорчую, плюсую и категорически «ЗА».

Тем кому нужен vim, чтобы программировать его и так поставят, им всё равно его потом настраивать и дополнять.

Nano хотя бы сходу можно пользоваться для правки конфигов и комиттов, не вспоминая «что это».

MC то хотя бы в базовой поставке есть? Если и его при этом нет, то тогда... у меня нет слов, чтобы выразить разочарование. Если всё-таки есть, то это хоть как-то их оправдывает.

grem ★★★★★ ()
Ответ на: комментарий от Partisan

Учиться лучше на том, что потом можно будет использовать для работы

Вы методичку перепутали, гражданин. После этого обычно говорят «поэтому в школах должен быть только Windows». Но вы, кажется, собирались сказать что-то другое?

бесалатных

Те, которые без салата, что ли?

точно так же не нужен

убогий дистрибутив

И в чём же убогость Альта, интересно?

hobbit ★★★★★ ()
Ответ на: комментарий от alexferman

Мне надо чтобы я установил ось и дальше вообще забыл, что она существует. Потому что я работаю с софтом, а не осью. Этот дистрибутив вполне это позволяет.

LightDiver ★★★★★ ()
Ответ на: комментарий от balsoft

Вообще-то любой дистр следует обновлять хотя быв раз в месяц. Это так трудно, там ведь буквально минут 10 на

apt update && apt upgrade -y
или
yum update -y
? Но удобнее LTS дистры, к которым Fedora не относится. Лучше Debian stable, Ubuntu LTS или CentOS.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Я про обновление мажорной версии. Дело в том, что у rolling-дистров каждое обновление по опасности поломки всего сравнимо с dist-upgrade в release-дистрах. Это нормально для локалхоста, но очень плохо для компьютерного класа.

balsoft ()
Ответ на: комментарий от balsoft

Нет, не сравнимо. Основные проблемы с обновлениями возникают именно после длительного перерыва между релизами. Используй стабилный софт и гента будет работать годами без проблем.

LightDiver ★★★★★ ()
Ответ на: комментарий от balsoft

Дело в том, что у rolling-дистров каждое обновление по опасности поломки всего сравнимо с dist-upgrade в release-дистрах

Дело в том, что ты бредишь - аппдейт роллинг-системы как раз намного менее рискованный, чем дист-апгрейд релизного шлака, догадайся почему.

alexferman ()
Ответ на: комментарий от iluha16

Илюша, 16 — это твой возраст? Максимализм и самовлюбленность прямо из ушей прет.

Wine бывает нужен. Есть ПО, которое не так просто заменить, а покупать лицуху винды — зачастую жирно.

nano уступает vim во многом — но намного интуитивней управляется — и это хорошо, зачем мучить пользователей при простой правке текста?

IRС — Internet Relay Chat, жаргонное название «ирка».

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от alexferman

Тогда бы он даже писать не смог сюда, для такого нужен минимум в 70-80, иначе и алфавит не выучить. Собственно, при IQ 16 даже передвигаться человек сам не способен.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от balsoft

Ну так вот, ставился альт 1 раз из 4.

Давай ссылку на твой тикет в багтрекере альта, даже интересно, что ты там натворил.

Хотя там была история, когда диски с альтлинуксом рассылала сторонняя фирма, при этом умудрилась эти диски портить. Но если бы у тебя был диск из этой партии, он бы, наверное, ни на один комп не поставился.

Альт - просто поделие очередных распильщиков бабла

Мальчик, Альт выходит ещё с тех времён, когда никакого бабла в России на линуксе ещё не пилили (его и сейчас с как минимум не меньшим успехом можно пилить на продукции MS или Adobe).

этот кал ещё и за деньги продают.

А, понятно, эксперт по калу детектед.

hobbit ★★★★★ ()
Ответ на: комментарий от poedyatel

Просто этот дистрибутив не требует переустановок и новых скачиваний каждые полгода. У кого он уже установлен редко качают новые «релизы». Возможно, проще сразу скачать ежендельный срез. Он не через торрент.

LightDiver ★★★★★ ()
Ответ на: комментарий от hobbit

Давай ссылку на твой тикет в багтрекере альта, даже интересно, что ты там натворил.

Зачем багтрекер, вай? Энто же лицензионное ПО, я звонил в поддержку. Мне сказали «у вас проблемы с железом» и на этом разговор закончился. Что я делал? Вставлял диск, загружал альт, пытался поставить, установщик просто повисал посреди установки, перезагрузка, следующая попытка. Сейчас я понимаю, что это были проблемы с драйверами с некоторой вероятностью, но Ubuntu древняя на то же железо вставала спокойно.

Мальчик, Альт выходит ещё с тех времён, когда никакого бабла в России на линуксе ещё не пилили (его и сейчас с как минимум не меньшим успехом можно пилить на продукции MS или Adobe).

Ах да, я же совсем забыл. «Не пытайся объяснить злым умыслом то, что можно объяснить человеческой глупостью». Такой вариант я тоже не исключаю.

balsoft ()
Ответ на: комментарий от balsoft

Нет, не могут со стабильным софтом. Это уже конкретный косяк должен быть.

Проблемы возникают обычно в двух случаях:

1) Если система управления пакетами не может разобраться чего там наустанавливал юзер. Обычная проблема релизных дистрибутивов. Почти отсутствует в РР, если разработчики дистрибутива думают о юзерах.

2) При косяках с обновленным софтом. Такие чаще всего в тестовом и нестабильном. Пользуй стабильное и будет тебе счастье.

LightDiver ★★★★★ ()
Ответ на: комментарий от LightDiver

Я про случай, когда стоит куча софта из нестабильных коммьюнити реп (например, AUR) и при этом ты регулярно обновляешь систему. С релизом в таком случае проблем меньше, чем с роллингом (за исключением переходов на следующий релиз). Я сам сижу на условно-роллинг дистре и знаю, о чём говорю.

balsoft ()
Ответ на: комментарий от balsoft

Это вообще не проблема. Как я писал выше, такая проблема отсутствует, если разработчики думают от юзерах. Автоматом можно обновлять только официальное и не трогать сторонние оверлеи.

В крайнем случае калька имеет вариант обновления релизным методом. В тексте новости он описан, кстати.

LightDiver ★★★★★ ()
Последнее исправление: LightDiver (всего исправлений: 1)
Ответ на: комментарий от alexferman

Дистрибутив-победитель в спецолимпиаде обновления по крону.

Ты так и не ответил на вопрос.

Покажи мне дистрибутив, способный шесть лет подряд обновляться по крону.

Odalist ★★★★★ ()