LINUX.ORG.RU

Словарь для консоли

 ,


1

5

Написал для своих нужд, но может кому пригодится)
Словарь носит чудное название maggot-dict (не спрашивайте почему)
Умеет:

  • Bash completion
  • Цветастый вывод
  • Написан на питоне без каких либо зависимостей (совместим с python 3)
  • Поддерживает словари в формате Dict (.dict|.idx) Lingvo (.dsl)

Для счастливых обладателй арчлинукс ставится также просто как

yaourt maggot-dict-git
Живет Здесь!

>>> Просмотр (1600x1200, 334 Kb)



Проверено: JB ()

Ответ на: комментарий от cheerfulboy

Про pep8 ничего не слышал, да?

дрочка на левые стандарты не нужна
главное - результат

pacify ★★★★★ ()
Ответ на: комментарий от pacify

Это скажешь тОМу _кто Будет чИТАТЬ __твой__ код.

urxvt ★★★★★ ()
Ответ на: комментарий от urxvt

Это скажешь тОМу _кто Будет чИТАТЬ __твой__ код.

Обычно вопросов не возникает. Люди либо читают, либо - проходят мимо.
Причем, читают не так и мало - регулярно мне пишут письма с вопросами по моим небольшим программкам.

pacify ★★★★★ ()

Круто!

А есть у него конкурент - консольный клиент, читающий словари лингво? Хочу из репозитория ставить...

zzo ()

Ошибка при установке:

[01:05:06] root@voyager:[/home/bohdan/sources/maggot-dict]: python setup.py install
running install
running build
running build_py
running install_lib
creating /usr/local/lib/python2.6/dist-packages/MaggotDict
copying build/lib.linux-x86_64-2.6/MaggotDict/xdg.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict
copying build/lib.linux-x86_64-2.6/MaggotDict/dictionary.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict
copying build/lib.linux-x86_64-2.6/MaggotDict/console.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict
creating /usr/local/lib/python2.6/dist-packages/MaggotDict/providers
copying build/lib.linux-x86_64-2.6/MaggotDict/providers/dictionary.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict/providers
copying build/lib.linux-x86_64-2.6/MaggotDict/providers/dsl.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict/providers
copying build/lib.linux-x86_64-2.6/MaggotDict/providers/__init__.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict/providers
copying build/lib.linux-x86_64-2.6/MaggotDict/__init__.py -> /usr/local/lib/python2.6/dist-packages/MaggotDict
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/xdg.py to xdg.pyc
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/dictionary.py to dictionary.pyc
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/console.py to console.pyc
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/providers/dictionary.py to dictionary.pyc
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/providers/dsl.py to dsl.pyc
SyntaxError: ('invalid syntax', ('/usr/local/lib/python2.6/dist-packages/MaggotDict/providers/dsl.py', 287, 57, 'transcription_map = {code: transcription_conv (value) for code, value in {\n'))

byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/providers/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.6/dist-packages/MaggotDict/__init__.py to __init__.pyc
running install_data
copying maggot-dict-cli -> /usr/local/bin
copying scripts/maggot-dict-cli -> /etc/bash_completion.d
running install_egg_info
Writing /usr/local/lib/python2.6/dist-packages/maggot_dict-1.0.egg-info

Пробую запуститить после этого:

[01:07:45] bohdan@voyager:[~/sources/maggot-dict]: maggot-dict-cli more
Traceback (most recent call last):
  File "/usr/local/bin/maggot-dict-cli", line 8, in <module>
    from MaggotDict import *
  File "/usr/local/lib/python2.6/dist-packages/MaggotDict/__init__.py", line 2, in <module>
    from .dictionary import *
  File "/usr/local/lib/python2.6/dist-packages/MaggotDict/dictionary.py", line 9, in <module>
    from . import providers
  File "/usr/local/lib/python2.6/dist-packages/MaggotDict/providers/__init__.py", line 2, in <module>
    from .dsl import *
  File "/usr/local/lib/python2.6/dist-packages/MaggotDict/providers/dsl.py", line 287
    transcription_map = {code: transcription_conv (value) for code, value in {
                                                            ^
SyntaxError: invalid syntax

Debian Stable

observer ★★★ ()

Алсо, скриншот понравился. Хороший вкус.

observer ★★★ ()
Ответ на: комментарий от pacify

дрочка на левые стандарты не нужна

Не забывай сказать это своему работодателю, когда пойдешь быдлокодить в офис

cheerfulboy ()
Ответ на: комментарий от cheerfulboy

Не забывай сказать это своему работодателю, когда пойдешь быдлокодить в офис

Это вряд ли. Работал по офисам 10 лет, перешел на фриланс - заработываю в несколько раз больше.

pacify ★★★★★ ()
Ответ на: комментарий от pacify

Это вряд ли. Работал по офисам 10 лет, перешел на фриланс - заработываю в несколько раз больше.

Конечно, рядовой заказчик не очень разбирается в твоем быдлокоде, вот и платит. А в офисе обычно не совсем идиоты сидят. Так что все понятно.

cheerfulboy ()
Ответ на: комментарий от observer

Ошибка при установке

python 2.6
а нужно >= 2.7 (он вышел уже года 3 назад и сейчас именно он стейбл)
обновитесь!

А есть у него конкурент - консольный клиент, читающий словари лингво? Хочу из репозитория ставить...

если бы я про такой знал то возможно бы не писал свой.

pasl ()
Ответ на: комментарий от cheerfulboy

Конечно, рядовой заказчик не очень разбирается в твоем быдлокоде, вот и платит.

Им пофигу. Им нужен результат, а не динамично развивающийся коллектив. ;)

pacify ★★★★★ ()

Для счастливых обладателй арчлинукс

Тонко!

garrys_game ()

Цветовая схема захардкодена?

spyro ()

У меня на слаквари отказывается работать, бида-пичаль. Хотел его на слабую машинку поставить.

Hoodoo ★★★★★ ()

Я, конечно, извиняюсь, но если я вдруг захочу посмотреть значение слова maggot в этом словаре, то как я должен поступить? Как я понял, по «d maggot» оно выводит список слов, начинающихся на maggot, а не его значение.

damnemall ()

Решил попробовать. Вердикт: говно.

1) В зависимостях гордо значится только питон, а миллион необходимых модулей не перечислен. Предлагается пользователю самому догадаться по исключениям. 2) Не работает. 3) Не говорит, почему. Не найдено слово, и все. Хотя словарей я ему подпихнул миллион, и в разных форматах. 4) Установить можно, а удалить - нет. Прощальный поцелуй что надо!

zzo ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.