LINUX.ORG.RU

OpenRA (20110906)

Я пытался когда-то запустить, а мне моно выругалось и отказалось.

vurdalak ★★★★★ ()

А как вы делали скриншоты? Ну и к слову, какой у вас дистрибутив?

Spoofing ★★★★★ ()
Ответ на: комментарий от Spoofing

Дистриб - Gentoo Linux. Скрины делал старым дедовским способом: в консоли import shot001.png и тыкнуть на окно с игрой. )

l ()
Ответ на: комментарий от vurdalak

Надо было поглядеть в логи в ~/.openra/Logs/ и выяснить причину, почему не запускается. Одна из самых вероятных причин - слишком древняя видеокарта (OpenGL < 1.4) Попробуйте новый релиз, он больше поддерживает.

l ()
Ответ на: комментарий от l

OpenGL 3.2, так что должно было работать. Но могу и новый релиз попробовать на всякий случай.

vurdalak ★★★★★ ()
Ответ на: комментарий от l

> Одна из самых вероятных причин - слишком древняя видеокарта (OpenGL < 1.4)

OpenGL версии выше 1.4 для цыц-клоуна… Современные технологии современные.

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

В винде на древней GeForce 7300 GT на разрешении 1024x768 выдает 50 FPS. Вы сами вспомните, что за разрешения были в C&C и под какими ОС это все работало. ) А так, для эстетов, есть режим удвоенной пикселизации, можете вспомнить старые добрые времена 640x480. ) Плюс, OpenRA юзает всякие эффекты.

l ()
Ответ на: комментарий от l

> В винде на древней GeForce 7300 GT

Как бе у меня сейчас 6600 :) OpenArena выдает где-то под 80 FPS на 1280x1024. Но я вообще о другом — можно вообще не требовать видеоакселератора же, но современные технологии не могут. Подозреваю там какие-то сторонние библиотеки типа SDL?

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

6600 GT и 7300 GT где-то одинаковы по производительности, но OpenArena, ага, написана на ANSI C, да еще и небось со всякими оптимизациями. Юзается в основном OpenGL (альтернативно для более старых видюх Nvidia Cg) + OpenAL. SDL чуть юзается, вроде, для ввода и интерфейса пользователя, но оно там на производительность не влияет. )

l ()
Ответ на: комментарий от OldWiseCat

dune2k лежит пока недоделанный. Нужно переконвертить там ресы из него.

l ()
Ответ на: Кейн с нами? от fhh

Да, можно и по локальной сети, если нет инета.

l ()

А кампанию оно не поддерживает, только сетевую игру?

Psych218 ★★★★★ ()

Последний раз когда пробовал, регулярно крашилось во время игры.

Nxx ★★★★★ ()
Ответ на: комментарий от tensai_cirno

по мне, mono в линуксе не нужен. пускай свой Tomboy и F-Spot в винде юзают.

// не понимаю я этих дотнетчиков, что они в линуксе то забыли...

qbbr ★★★★ ()
Ответ на: комментарий от Nxx

> Последний раз когда пробовал, регулярно крашилось во время игры.

Сыграл 4 партии с ботами. Ни разу не крашилось, вообще никаких глюков, всё качественно и аккуратно. Правда моно пришлось тащить в систему… И плохо, что кампании нет.

Psych218 ★★★★★ ()

По скриншотам сразу видно что игра ужасна(и это не из-за графики).

Norgat ★★★★★ ()
Ответ на: комментарий от Aceler

>OpenGL версии выше 1.4 для цыц-клоуна… Современные технологии современные.

Да уж. Оригиналу вроде надо было 486 c 8 мб рам и любая vlb/pci видео карта (или типа того).

Лучше бы они попросили открыть исходники оригинального RA...

Rost ★★★★ ()
Ответ на: комментарий от Rost

> Да уж. Оригиналу вроде надо было 486 c 8 мб рам и любая vlb/pci видео карта (или типа того).

Оригинал не умеет идти в разрешении 1680x1050 например.

По скриншотам сразу видно что игра ужасна(и это не из-за графики).

Не играли в оригинальный RA и судите по скриншотам???

Psych218 ★★★★★ ()

Не вызывает желания поиграть, но одобряю. Графическая составляющая больше напоминает KKND, нежели CnC

l0stparadise ★★★★★ ()

>OpenGl

mono

Судя по всему в авторах у этой поделки жуткие быдлокодеры… Жалобы на вылеты в данном обсуждении подтверждают этот факт.

fat_angel ★★★★★ ()
Ответ на: комментарий от Psych218

>> Да уж. Оригиналу вроде надо было 486 c 8 мб рам и любая vlb/pci видео карта (или типа того).

Оригинал не умеет идти в разрешении 1680x1050 например.

Программная отрисовка нынче, судя по всему, не в моде…

fat_angel ★★★★★ ()
Ответ на: комментарий от tensai_cirno

CLR для .NET == JRE для JAVA ?

если CLR, это интерпретация bytecode->nativecode, то dotnet всеволеж использует это технологию.

qbbr ★★★★ ()
Ответ на: комментарий от Nxx

Крэши были вызваны, в основном, рассинхронизацией в результате наличия бага в моно. Сейчас эта проблема решена в новых версиях моно.

l ()
Ответ на: комментарий от devnullopers

Есть режим двойной пикселизации, наподобие как в оригинальном RA 1. )

l ()
Ответ на: комментарий от Kompilainenn

Да, кстати, скрины RA - это из реплэя. А скрины C&C - из реальной игры с ботами. )

l ()
Ответ на: комментарий от l

Для текущей версии OpenRA не хватает зависимостей на Сусе. Раньше было нормально.

Nxx ★★★★★ ()
Ответ на: комментарий от l

И в меню попадает в раздел «Игры/Другие» вместо «Игры/Тактика и стратегия»

Nxx ★★★★★ ()
Ответ на: комментарий от l

В общем, если вы разработчик, сделайте зависимость от mesa-dri-drivers-experimental мягкой, так как нормально запускается и без этого. И вообще, возможно, эта зависимость по имени пакета не нужна, так как rpm автоматом проставляет зависимости по именам слинкованных библиотек, а название пактов может отличаться между дистрами.

Nxx ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.