LINUX.ORG.RU

Wordpress - картинки по https

 


0

1

Здравствуйте.

Некоторое время назад сталкивался с такой проблемой и нашёл тогда её решение. Но сейчас забыл и найти информацию не могу.

Проблема заключается в следующем:
Если посадить весь сайт (WP) на https , то загруженные пользователями картинки выгружаются на страницы по http и браузеры пользователей говорят им, что на страницах есть небезопасное содержимое и т.д.

Кроме того, переведя весь сайт на https я столкнулся с проблемой загрузки изображений на сайт: WP сообщает, что произошла ошибка, попробуйте позже :)

Способ решения заключался в том, чтобы в разделе Настройки>Медиафайлы указать путь к директории, в которой хранятся изображения, начиная с https:// , и тогда всё начинало работать нормально: картинки выгружались на страницы по https , браузеры показывали, что соединение безопасно и с загрузкой картинок тоже проблем небыло.

Для этого необходимо было добавить какой-то код в один из php-файлов (возможно functions.php). И тогда в разделе Настройки>Медиафайлы появлялись ещё две строки в которых можно было задавать путь к картинкам. В предыдущих версиях эти строки были, а потом их убрали.

Может ещё есть какой-то способ решения.

Помогите решить проблему описанным способом (нужен php-код) или каким-то другим.

Заранее благодарю за ответы!

Нашел у себя на диске файлик с описанием решения проблемы, а по описанию нашёл и обсуждение на сайте Wordpress.

В файл ./wp-content/themes/ваша-тема/functions.php добавляем следующий код:

if(get_option('upload_path')=='wp-content/uploads' || get_option('upload_path')==null) {
update_option('upload_path',WP_CONTENT_DIR.'/uploads');
}
Тогда у вас в меню Настройки>Медиафайлы появляются две строки: путь к файлам картинок и URL-путь к файлам картинок.
В строке URL вводите https://ваш-домен/wp-content/uploads/

Теперь на страницы вашего сайта картинки будут выгружаться по https и соответственно браузеры будут показывать красивый зелёный замочек в строке адреса.

Если этого не происходит, то нужно посмотреть исходный код страниц. У меня, например, по http грузился логотип темы с сайта разработчика. Заменил на свой. Теперь всё в порядке.

Здесь обсуждение этой темы: https://wordpress.org/support/topic/wordpress-35-where-the-option-settings-me...

Всем успехов!

san-sanych ()
Ответ на: комментарий от san-sanych

По идее должно быть достаточно изменить адрес «адрес сайта» и «адрес wordpress» в разделе настроек «общее».

Ну и заменить старые захардкоженые urlы в постах

MrClon ★★★★★ ()
Последнее исправление: MrClon (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.