LINUX.ORG.RU

Нет, он ещё не готов. Пока можно поставить из других веток.

GotF ★★★★★ ()

[17:45:44][aitap@Tarkus ~]> aptitude --disable-columns versions wine
p 1.0.1-3.4 unstable 450
i 1.3.32-1 100
[17:45:54][aitap@Tarkus ~]>

Ой, и действительно. Но он же там был старьё страшное, так что это не так уж и плохо? Поставьте из репозитория frickelplatz.de, или руками из http://dev.carbon-project.org/debian/wine-unstable/.

AITap ★★★★★ ()

frickelplatz.de

Все равно в официальной дебрепе мейнтейнер на него, видимо, забил (1.1.42 было, когда я последний раз смотрел).

Deleted ()
Ответ на: комментарий от coldy

Скайрим уж точно не нужен. В сравнении с старыми готиками кажется недоделанным, кривоватым и слишком скучным.

Deleted ()
Ответ на: комментарий от AITap

На ppa есть. Прекрасно ставится на testing и прекрасно на нём работает.

Xellos ★★★★★ ()
Ответ на: комментарий от coldy

А как тогда в «Вельмака», «Скайрим» под линуксом?

Кто все эти люди?

r_asian ★☆☆ ()
Ответ на: комментарий от Deleted

Быть не может. Там же полный реалтайм.

GotF ★★★★★ ()

так нечего неэмулировать же

registrant ★★★★★ ()
Ответ на: комментарий от buddhist

А вот в старых готиках адский баланс.

А я-то думал, мне это только кажется %)

GotF ★★★★★ ()
Ответ на: комментарий от buddhist
Release date(s) 	
PlayStation 2, Xbox
 * NA 2004-10-26
 * PAL 2005-03-24
Windows
 * PAL 2005-06-17
 * NA 2005-06-27
Steam
 * NA 2009-12-12
Apple iOS
 * NA 2011-12-1

Скрины ужасны, и опять только под вайн, зачем?

coldy ★★ ()
Ответ на: комментарий от GotF

Так сложилось, что в первую готику я поиграл только в 2011 году и аж офигел от того, что любой враг мог меня убить с 1-2 ударов.

buddhist ★★★★★ ()
Ответ на: комментарий от buddhist

Готика 1 сильно бажная и падучая, да еще и с балансом не очень (но все равно она меня настолько притянула, что даже это не помешало ее пройти). А у второй вроде все нормально.

Deleted ()

wine не нужен, а если нужен, есть исходники на winehq.org и playonlinux.

curufinwe ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Третью, если честно, играл всего несколько минут. Первое впечатление - «уже не тот», но практически не играл, поэтому объективную оценку дать не могу.

Deleted ()

Потому что 1.3.36 есть в community и multilib

Или ты хочешь в тестинг какую-нибудь кривую промежуточную бету, чтобы добровольно слать багрепорты? :))

stevejobs ★★★★☆ ()

Даже если и были, смысла мало, так как версия была бы где-то полгодичной давности. А за полгода там много чего сделают. ИМХО, но лучше поставить с дебок (ссылка с офсайта), но там разгребать, что каким ставить.

ymuv ★★★★ ()

Провославный testing

Это мы сейчас про дебиан?

ymuv ★★★★ ()

Его выпилил из расовых соображений?

Нет, из лицензионных. Wine при первом запуске приложения, пытающегося отобразить HTML, устанавливает Gecko, пользуясь готовой бинарной сборкой Gecko под win32 (http://downloads.sourceforge.net/project/wine/Wine Gecko/1.4/wine_gecko-1.4-x...). Debian же требует, чтобы бинарники, от которых есть исходники, были скомпилированы из этих самых исходников на машине под управлением Debian. До недавних пор этого Debian'овцы не умели, поэтому и была старая версия, которая не поддерживала Gecko.

AEP ★★★★★ ()
Ответ на: комментарий от AEP

поэтому и была старая версия, которая не поддерживала Gecko

Неправда. В Lenny и Squeeze wine поддерживает Gecko, и предлагает его скачать при первом требовании от приложения.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

OK. В любом случае, такое скачивание противоречит политике Debian, и я вообще удивлен, что wine оттуда за это не выбросили вместо заморозки версии.

AEP ★★★★★ ()
Ответ на: комментарий от stevejobs

Или ты хочешь в тестинг какую-нибудь кривую промежуточную бету, чтобы добровольно слать багрепорты? :))

Мы про провославный разговариваем, а не про прыщавый!

alpha2 ()

Поставил последнюю бету Wine в Debian old-stable (Lenny). Просто перешёл по ссылке Download в http://winehq.org/ и скачал deb-src. Собралось после одной правки: там компилятор задали как gcc-4.5, так как с 4.6 не собирается. Автор spec-файла не ожидал наверное, что кто-то будет компилировать с gcc-4.3. Поправил на просто gcc - и скомпилировалось с первой попытки.

Вот список команд, если кому-нибудь интересно:

# apt-get build-dep wine // установка зависимостей
$ mkdir build-wine && cd build-wine // создание каталога build-wine и заход в него
$ wget http://dev.carbon-project.org/debian/wine-unstable/wine-unstable_1.4~rc3.orig.tar.bz2 && wget http://dev.carbon-project.org/debian/wine-unstable/wine-unstable_1.4~rc3-0.1.dsc && wget http://dev.carbon-project.org/debian/wine-unstable/wine-unstable_1.4~rc3-0.1.debian.tar.bz2 // загрузка DEB-SRC с помощью консольной утилиты
$ dpkg-source -x wi[tab] // распаковка архива
$ cd wine[tab] // заход в распаковавшийся каталог
$ kwrite debian/rules // исправление указанной выше ошибки
$ fakeroot ./debian/rules binary // компиляция wine
$ cd .. // переход в каталог выше
$ rm -rf wine-unstable_1.4~rc3-0.1 // удаление отработанного исходного кода
# dpkg -i *.deb // установка

Последнее действие лучше делать не со всеми deb-пакетами, а со всеми, у которых нет -dev и -dbg. Создать новый каталог, перейти в него, скопировать/сделать ссылки файлы/файлов туда, и выполнить последнюю команду. Если кому-нибудь нужно, выложу бинарники для Debian Lenny x86.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

kwrite debian/rules // исправление указанной выше ошибки

А что за ошибка-то, и как исправить? У меня писал про сертификат вроде.

g8 ()
Ответ на: комментарий от ZenitharChampion

Короче, повторяю процедуру Вашу. Дошел до распаковки архива.

root@g8:/home/g8/build-wine/build-wine# ls
wine-unstable_1.4~rc3-0.1.debian.tar.bz2  wine-unstable_1.4~rc3.orig.tar.bz2
wine-unstable_1.4~rc3-0.1.dsc
root@g8:/home/g8/build-wine/build-wine# dpkg-source -x wine-unstable_1.4~rc3-0.1.debian.tar.bz2 
dpkg-source: ошибка: синтаксическая ошибка в wine-unstable_1.4~rc3-0.1.debian.tar.bz2 в строке 1: строка неизвестного формата (не поле-двоеточие-значение)
root@g8:/home/g8/build-wine/build-wine# dpkg-source -x wine-unstable_1.4~rc3.orig.tar.bz2 
dpkg-source: ошибка: синтаксическая ошибка в wine-unstable_1.4~rc3.orig.tar.bz2 в строке 1: строка неизвестного формата (не поле-двоеточие-значение)
root@g8:/home/g8/build-wine/build-wine# dpkg-source -x wine-unstable_1.4~rc3-0.1.dsc 
gpgv: keyblock resource `/root/.gnupg/trustedkeys.gpg': ошибка открытия файла
gpgv: Подпись создана Вск 12 Фев 2012 16:08:54 GMT+5 ключом RSA с ID E1DE59D2
gpgv: Не могу проверить подпись: открытый ключ не найден
dpkg-source: предупреждение: проверка подписи для ./wine-unstable_1.4~rc3-0.1.dsc завершилась неудачно
dpkg-source: инфо: извлечение wine-unstable в wine-unstable-1.4~rc3
dpkg-source: инфо: распаковывается wine-unstable_1.4~rc3.orig.tar.bz2
dpkg-source: инфо: распаковывается wine-unstable_1.4~rc3-0.1.debian.tar.bz2
dpkg-source: инфо: накладывается debian-changes-from-1.1.32-1.patch
dpkg-source: инфо: накладывается readd_xpm.patch
dpkg-source: инфо: накладывается function_grep.patch
dpkg-source: инфо: накладывается Bug#29667_proposed-fix.patch
dpkg-source: инфо: накладывается Bug#29669_proposed-fix.patch
root@g8:/home/g8/build-wine/build-wine# 

Где я не прав? И вообще, какой архив из этих 3-ех нужно было распаковывать?

g8 ()
Ответ на: комментарий от g8

Немного не так, нужно делать dpkg-source -x и файл с расширением dsc. А вторая команда прошла успешно, всё распаковалось! Ругается только на то что неизвестный источник.

Теперь удали в том, что распаковалось, всё, кроме каталога debian, и распакуй в это место релиз 1.4. Так как у тебя всё от root, то для этого подойдёт команда gksu nautilus. если нет gksu, то gksudo.

Просто всё, кроме установки зависимостей, можно делать от пользователя.

А потом fakeroot ./bedian/rules binary и начнётся компиляция. Если от root, то «fakeroot» не нужен. Всё снова будет медленно. Затем создадутся DEB-пакеты.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion
/home/g8/build-wine# ls
build-wine
wine-unstable-1.4~rc3
wine-unstable_1.4~rc3-0.1.debian.tar.bz2
wine-unstable_1.4~rc3-0.1.debian.tar.bz2.1
wine-unstable_1.4~rc3-0.1.dsc
wine-unstable_1.4~rc3-0.1.dsc.1
wine-unstable_1.4~rc3.orig.tar.bz2
wine-unstable_1.4~rc3.orig.tar.bz2.1
wine-unstable_1.4~rc3.orig.tar.bz2.2

Пойду пока себе i386 лучше поставлю( И заново буду пытаться.

g8 ()
Ответ на: комментарий от ZenitharChampion

Да там нету папки debian. И я уже с i386 сижу, ибо комп не настолько мощный для amd 64. Вот, ставлю wine из центра приложений.

Вы умный, не подскажете, gt 2900 radeon нормально поддерживается дефолтными дровами в дебиане? У меня когда запускалась контра, подтормаживала, а потом и в винде стало тупить - цвет ставился либо на 16, либо на 32 бит. У меня всегда было на 32, а тут стало на 16 автоматом. И при смене значения менялось все равно на 16.

Думал что питания не хватает, нет 8-pin засунут в карту, а не 6.

g8 ()
Ответ на: комментарий от g8

Мой самый первый компьютер с поддержкой AMD64 был AMD Athlon 64 3000+, то есть один из первых AMD64-процессоров вообще. Памяти было 512 Мб, увеличил до 1024 потом. На нём стоял 64-битный дистрибутив Linux, и никакой разницы с 32-битным! Замедлений и излишней ресурсоёскости я не видел. Ну и провёл тесты архиватора и аудиокодеков lame и oggenc в одинаковых 32- и 64-битных дистрибутивах - было на несколько секунд быстрее.

Видеокарта мощная, и тебе повезло: серию X1xxx прекратили поддерживать в AMD, и последний драйвер для него - 9.3, который вышел 3 года назад. Он не работает на ядрах Linux старше 2.6.28 и X-сервере старше версии 1.5. У тебя X2900GT, и он отлично поддерживается новейшим драйвером версии 12.2! А в Debian по-умолчанию, скорее всего, идёт открытый драйвер, который уступает в скорости 3D-ускорения, но гораздо стабильнее в повседневной работе. Рекомендую попробовать оба драйвера. Затем загрузить с сайта компании AMD последнюю версию официального закрытого драйвера, и из консоли трансформировать его в пакет для своего дистрибутива. Кажется, это команды «sh ati-driv[tab] --list-pkgs», а затем "--build-pkg debian/stable". например. Но я не уверен точно в том, что написал все буквы команд правильно. Вообще этот драйвер может устанавливаться с графическим установщиком и оттуда же предложить сделать пакет, но он предлагает его только для Red Hat, Fedora и SuSE, остальные варианты доступны только из консоли.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Еще раз спасибо, я проприетарный где-то нашел и поставил. Вроде бы всё отличненько!)

g8 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.