LINUX.ORG.RU
ФорумTalks

openSuSE 11.4


0

2

Скоро будет новый релиз, пока готов релиз-кандидат. Решил я потестить 11.4. Моя домашняя установка получена путём многократных обновлений старых версий и всё работает хорошо. Поэтому смысл тестировать есть только свежую установку. Записав диск, я пошёл на работу.

До начала работы оставалось полчаса, установка завершилась в 10:02. Копирование файлов занимало 20 минут, 10 минут я занимался настройкой до и после него. До - разметка дисков, экран выбора DE, набор программ (набирал по-максимуму, везде галочки поставил), часовые пояса и всё такое. Умилила галочка «Автоматическая установка». Я не понял что это и нажал на Справка. Там среди прочих пунктов, доступных на этом экране, объяснили, что эта галочка включает/выключает дополнительные вопросы, и новичкам лучше эту галочку поставить. Ставлю/убираю - количество шагов установки слева растёт/уменьшается, вот это и умилило. После - пароли пользователя, вариант того, чтобы пользователь был ещё и рутом я убрал, затем попросили пароль root. Настройка оборудования, сети, обновление. Умилило то, что в «Подробнее» при копировании файлов один из последних устанавливался PulseAudio, а в настройке оборудование в «Звук» была строчка: PulseAudio: включен (отключить). Такие гиперссылки доступны для разных параметров, чтобы менять их, например, «Брандмауэр: включен (отключить), или SSH: Служба SSH будет отключена, порт SSH будет закрыт.

Короче говоря - установка, как всегда, высший класс. Я получил установленную систему, которую не надо настраивать: в ней уже установлены именно те программы, которыми я всегда пользуюсь, а те, которыми не пользуюсь, не установлены. Исключением являются проприетарные программы: драйвер nVidia (для openSuSE существует официальный репозитарйи на сайте nvidia.com) и видеокодеки (репозитарий сообщества их добавляет).

Далее, система загрузилась, и мне было приятно осознавать, что глюки со звуком я сразу отсёк, одним кликом мыши отключив PulseAudio. Но возникли проблемы с графикой: второй этап установки, который сразу после перезагрузки, выглядел мусором на экране и совершенно не пострадавшим курсором мыши поверх него. Это оставило негативное впечатление, но в Интернет лезть не пришлось: недавно эта проблема обсуждалась на ЛОРе и решается параметром nomodeset при загрузке: глючный nouveau. Я в той теме кстати сглупил, посоветовав отредактировать xorg.conf, которого больше нет, и запустить конфигуратор видео, sax2, которого больше нет начиная с openSuSE 11.3, но в стороннем репозитарии он есть.

Что делать дальше - разумеется ставить драйвер. И вот возникло две крупные проблемы: я настроил Интернет с USB-3G-модема, всё определилось и готово к запуску, жму „Готово“ - и всё. А что нажимать-то? Можно установить KPPP (тоже требует донастройки - SUID-бит, и добавление пользователя в группу dialout), в чем проблем нет, потому что всё лежит на установочном диске. А можно установить QInternet, и в системном трее на основе только что настроенного Интернета появится значок „Соединиться!“. Только почему он сам не появляется, а когда Интернет по модему настроен, YaST просит доустановить с DVD пакет smpppd, а qinternet не просит? Чтобы узнать про Qinternet пришлось устанавливать соединение из консольного wvdial, править /etc/resolv.conf (wvdial заявил, что проприсать туда DNS самостоятельно не смог), потом с Qinternet разумеется всё заработало как надо.

Вторая проблема с разделом NTFS с Windows. Размечая диск, я не задал ему точку монтирования, и при нажатии по его значку в „Мой компьютер“ я увидел ошибку. Ошибка заключалась в том, что „Нет программы для монтирования дисков, запустить менеджер пакетов?“, Жму „Да“ и получаю менеджер пакетов. Закрываю, снова вижу ту ошибку. Жму „Нет“ и вижу „Открыть с помощью...“, файл file:///dev/sda1. Точку монтирования можно задать из YaST, можно и из консоли подключить диск. Но в чём проблема-то? Причину подсказал KDE 3, который я установил позднее: пользователь не имеет прав подключать диски через HAL. Настраиваем HAL - и всё работает!

Кстати, о KDE 3. На странице Wiki о нём сказано, что если вы хотите сменить экран загрузки системы на KDM 3, отредактируйте файл такой-то, заменив переменную такую-то на kdm3. И в скобочках - это можно сделать из YaST в „Отредактировать /etc/sysconfig“. Захожу в это GUI - кайф! Много нужных системных файлов на выбор, и ничего руками писать не надо - выпадающие списочки, в котором я выбрал kdm3! В итоге за исключением соединения с Интернетом по wvdial, я ни разу не воспользовался консолью в этом дистрибутиве! Вот такие впечатления от openSuSE 11.4. Если бы не пришлось допиливать эти баги, всё было бы хорошо. Надеюсь, релиз 12.1 будет готовым полностью!

И ещё одна проблема. Запустил менеджер пакетов сразу после подключения репозитария nvidia, а также libdvdcss и packman для видеокодеков. Он долго загружал новые списки пакетов, выдавая ошибку. Вот раз за разом выдавая одну и ту же ошибку с ожиданием по 5 минут между ними. «Пропустить обновление» выдавало мне список того, что автоматически решило установиться (кодеки и видеодрайвер) и ошибку после нажатия на «Установить». «Есть зависимость от libvdpau-devel, а самого пакета нет ни в одном репозитарии! Можно и игнорировать конечно, но решайте сами». Просто загрузились все репозитарии, кроме OSS (открытое ПО). Лезу в консоль, zypper update, наконец, прояснил ситуацию. Мой тормозной Интернет всё никак не может догрузить большой файл со списком пакетов OSS, выдавая то «Обрыв связи при 30 оставшихся килобайтах», то при 500 килобайтах. С третьей попытки всё скачалось, но неужели нельзя было сделать доскачивание с места обрыва?

ZenitharChampion ★★★★★ ()

>YaST просит доустановить с DVD пакет smpppd

да, за это стоило бы пристрелить разрабов. даже на dvd его не кладут

С третьей попытки всё скачалось, но неужели нельзя было сделать доскачивание с места обрыва?

докачка точно есть для пакетов (там через aria2c качается). думал, что и насчет остального так же

registrant ★★★★★ ()
Ответ на: комментарий от registrant

> да, за это стоило бы пристрелить разрабов. даже на dvd его не кладут

Кладут - а иначе как бы я соединился с Интернетом, если бы этого пакета не было на DVD?

докачка точно есть для пакетов (там через aria2c качается). думал, что и насчет остального так же

А для архива со списком пакетов не работала, просто эти MTS - козлы. Мало того что стали бороться со скайпом - они ещё и с торрентами борятся. Один файл скачивать можно, грузить второй одновременно - нельзя, превышение времени ожидания. Или просто страничку в Интернете открыть вторую, пока загружается первая. А эти списки, наверное, и пытались загрузиться в многопоточном режиме. С МегаФоном такого не было у меня - возможно, потому что на МегаФоне безлимитка быстрая, а на MTS - медленная.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

>Кладут

значит исправились. раньше такая плюха точно была

пытались загрузиться в многопоточном режиме

кстати, да. у арии кажись эта опция по умолчанию стоит

registrant ★★★★★ ()

Дома поставил 12.1 RC2 с LXDE, полет нормальный. Единственное нарекание - yast почему-то стал очень тормозным.

Manhunt ★★★★★ ()

Такое ощущение, что читаешь ман по установке 95 венды на новое серверное железо.

Igron ★★★★★ ()
Ответ на: комментарий от Igron

Ссылку в студию, чтобы присутствующие смогли оценить схожесть по десятибалльной шкале. А так нет, нету такого ощущения.

oguretz ()

На какие только люди извращения идут, нет чтоб сразу Дебиан поставить и не мучаться

coldy ★★ ()
Ответ на: комментарий от pyometra

Тем, что не страдает траблами описанными в шапке треда. Хотя КДЕ3 только в олдстэйбл

coldy ★★ ()
Ответ на: комментарий от ZenitharChampion

Идеала не существует, но ntfs разделы монтируется без проблем, нуво рабочий, пульса по дефолту не ставится(кто вообще мог придумать Пульсу ставить по дефолту???), а чем wvdial не устроил тебя я вообще не понял

coldy ★★ ()
Ответ на: комментарий от pyometra

Stable - понятно где и понятно почему. Testing и остальные - просто удобны, а «лучше»/«хуже» не тот критерий в таком случае.

Solace ★★ ()

11.4 уже 8 месяцев как бы. Пост не читал.

Yareg ★★★ ()

Ставил я ту Зюзю 12.1.

ШГ так и не исправили, на экране мазня сранью, а не шрявты.

Да, монтирование нтфс разделов просто феерическое.
ТВтюнер Авер 509 так никто и не удосужился впилить, хотя по интернетам бегаю простыни воплей голосящих. А тюнеру то уже лет 6.

И вот так под конец 2011 года на моем винте остались только НТФС разделы, такой Линукс не нужен.

Буду ждать когда андроед без бубна будет запускаться в Коробке или ВМвари.

Deleted ()
Ответ на: комментарий от Deleted

Самым лучшим Линуксом как-то претендуют стать дистрибутивы от hazar leopard, tonymacx86, iAtkos/

Линукс самоподелился на 0

Deleted ()
Ответ на: комментарий от Deleted

>Самым лучшим Линуксом как-то претендуют стать дистрибутивы от hazar leopard, tonymacx86, iAtkos/

Не осиливший поставить оригинальный мак на PC детекдед!

USSR ()

Kubuntu 11.10

Далее, система загрузилась, и мне было приятно осознавать, что глюки со звуком я сразу отсёк, одним кликом мыши отключив PulseAudio.
Приятно осознавать, что проблемы со звуком отсечены, благодаря тому, что установлен свежий PulseAudio, а не версия двухлетней давности.
> И вот возникло две крупные проблемы: я настроил Интернет с USB-3G-модема, всё определилось и готово к запуску, жму «Готово» - и всё. А что нажимать-то? Можно установить KPPP
KPPP устанавливается по-умолчанию.
> Вторая проблема с разделом NTFS с Windows.
Нет такой проблемы. То есть вообще. hal, кстати, тоже нет.
> глючный nouveau
nouveau в последней стабильной Kubuntu чуть ли не на год свежее, чем в последней стабильной openSUSE. Результат немного предсказуем.

Итого: трёх перечисленных проблем в Kubuntu нет, а посыл о заведомой глючности актуальной версии PulseAudio имеет столько же оснований, сколько посыл о заведомой глючности ALSA. Бесплатный бонус: в репах лежит OpenGL ES-версия KWin, которая работает гораздо шустрее OpenGL-версиии.

RussianNeuroMancer ★★★★★ ()
Ответ на: Kubuntu 11.10 от RussianNeuroMancer

Есть одно НО: если ТС сказать, что какая-то *buntu будет работать лучше, чем «любой rpm-based дистрибутив» (с), у него может случиться разрыв шаблона ) Я и предлагать не стал

coldy ★★ ()
Ответ на: комментарий от coldy

Я знаю. Но ведь надо же это было когда-нибудь сделать. Вот и случай удачный представился.

RussianNeuroMancer ★★★★★ ()
Ответ на: Kubuntu 11.10 от RussianNeuroMancer

Не знаю как насчёт Kubuntu,а Ubuntu глючна сама по себе. В той теме, где у пользователя глючил nouveau без nomodeset, это кстати было везде: и в Ubuntu, и в openSuSE, и в Fedora.

nouveau глючит только в определённых конфигурациях. Например на 1680x1050 всё заработало. Но у меня было 1024x768 максимум, вот там и заглючило.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Не знаю как насчёт Kubuntu,а Ubuntu глючна сама по себе.
PulseAudio в Kubuntu добавили на два, или даже три года позже, чем он появился в Ubuntu. Просто пример.

> nouveau глючит только в определённых конфигурациях.
И только на определённых картах. Например полгода назад проблемы с VGA-выходом были как на GeForce 7300 Go, так и на GeForce 7400 Go. Как минимум в nouveau от августа работу VGA-выхода на 7300 Go поправили. И я даже не стану в очередной раз напоминать, что поддержка этих двух видеокарт в блобе сломана напрочь, начиная с 270 версии. Таким образом и блоб nVidia тоже глючит только в определённых конфигурациях, и только на определённых картах. (Причём, как мы видим на данном примере, некоторые карты nouveau поддерживает лучше блоба.) Нужно проверять в актуальных версиях и репортить баги, потому что если в столкнётесь с тем же, с чем столкнулся я в случае с 7300 Go, 7400 Go, 8600M GT, то будете вынуждены использовать nouveau - не будет других вариантов просто. Поэтому важно заранее подготовиться к худшему сценарию развития событий, и репортить баги в nouveau.

В общем, вы бы попробовали. Не стоит чесать все Ubuntu-based под одну гребёнку. И, нет, KDE3 в Kubuntu вы не найдёте, но уже пора бы и в KDE4 осмотреться - 4.7.2 в основных репах, а 4.7.3 в Kubuntu Updates PPA.

RussianNeuroMancer ★★★★★ ()

openSuSE 11.4 (Gnome) чудесна, в этом нет сомнений =]

neocrust ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Не стоит чесать все Ubuntu-based под одну гребёнку

А ещё не стоит сравнивать дистрибутив 8-месячной давности и дистрибутив, которому сейчас дней 10. Сравнивать нужно с RC2, где тоже новый nouveau.

И, нет, KDE3 в Kubuntu вы не найдёте

Найду: эксклюзивно для Ubuntu создаётся TDE. В версии 3.5.12 список поддерживаемых дистрибутивов расширился Slackware, а в 3.5.13 - RHEL. Насчёт PPA - разумеется nouveau из updates глючить не будет, но я не пустил дистрибутив обновляться в процессе установки, в которой всё работело. Просто потому что у меня USB-модем.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

А ещё не стоит сравнивать дистрибутив 8-месячной давности и дистрибутив, которому сейчас дней 10. Сравнивать нужно с RC2, где тоже новый nouveau.
Верно, но ведь речь шла не только о nouveau. Например вы указали на то, что ни KPPP, ни QInternet без допиливания не работают. Причём допиливание требует таких манипуляций, которые вы никогда не простили бы Ubuntu-based дистрибутивам, ведь так?

> Найду: эксклюзивно для Ubuntu создаётся TDE.
Наверное. Но зачем? KDE4 уже давно не 4.0, и даже не 4.3.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Причём допиливание требует таких манипуляций, которые вы никогда не простили бы Ubuntu-based дистрибутивам, ведь так?

Да. Надеюсь, в следующем релизе исправят.

ZenitharChampion ★★★★★ ()

> править /etc/resolv.conf

Это ты зря. Теперь не сможешь менять настройки DNS из Яста. А чего стоило прописать DNS в свойствах сети.

Nxx ★★★★★ ()
Ответ на: комментарий от registrant

> да, за это стоило бы пристрелить разрабов. даже на dvd его не кладут

Почему-то в 11.2 у меня ничего не просило.

Nxx ★★★★★ ()
Ответ на: комментарий от Manhunt

> Единственное нарекание - yast почему-то стал очень тормозным.

У меня стоит самый последний яст из репозитория Yast:Head, тормозов никаких не видно.

Nxx ★★★★★ ()

> что глюки со звуком я сразу отсёк, одним кликом мыши отключив PulseAudio.

А какие у тебя глюки со звуком?

Nxx ★★★★★ ()
Ответ на: Kubuntu 11.10 от RussianNeuroMancer

> Нет такой проблемы. То есть вообще. hal, кстати, тоже нет.

Ога, в openSUSE 12.1 тоже хала нет. Что за сравнение старого релиза с новым?

Nxx ★★★★★ ()
Ответ на: комментарий от registrant

Может, потому что я ставил с LiveCD, а не с DVD. Во всяком случае, к интернетку по pptp подключилось сразу.

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

> У меня стоит самый последний яст из репозитория Yast:Head, тормозов никаких не видно.

Как воспроизвести:
* загружаешь образ CD для сетевой инсталляции (12.1 RC2, 64-bit)
* грузишься с болванки
* доходишь до разметки диска
* начинаешь бродить по диалогам разметки диска

Время отклика на добрую половину кнопок составляет 1 секунду и больше.

Однако тупит не только диалог разметки, просто именно в нем мне тормоза впервые бросились в глаза.

Manhunt ★★★★★ ()
Ответ на: комментарий от Manhunt

Может, оно в сеть лезет при сетевой инсталляции?

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

Ога, в openSUSE 12.1 тоже хала нет. Что за сравнение старого релиза с новым?
Окей, давайте сравним по этому критерию openSUSE 11.4 и Kubuntu 11.04. Догадываетесь, какой будет результат сравнения, или подсказать?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Окей, давайте сравним по этому критерию openSUSE 11.4 и Kubuntu 11.04.

В Убунте/кубунте 11.04 hal был. Кстати, ты тоже, как и все убунтоиды считаешь кубунту и убунту разными дистрибутивами?

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

В кубунте 11.04 hal был.
Ой ли?
> Кстати, ты тоже, как и все убунтоиды считаешь кубунту и убунту разными дистрибутивами?
Я считаю что пакеты ubuntu-desktop, ubuntu-default-settings и kubuntu-desktop, kubuntu-default-settings мейнтят люди с различным подходом - cм. выше пример про Pulse Audio.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от Manhunt

>Однако тупит не только диалог разметки, просто именно в нем мне тормоза впервые бросились в глаза.

раньше был косяк, что яст при малейших телодвижениях в процессе установки перепроверял все зависимости в пакетах. м.б. решили вернуть?

registrant ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> С чего вы взяли, что он должен быть установлен?

Ты утверждал, что в убунте его нет. А он есть. А в openSUSE 12.1 hal'а нет. А в openSUSE 11.4 было также, как в убунте 11.10.

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

Ты утверждал, что в убунте его нет. А он есть.
Следуя вашей логике - в Убунте есть Плазма и КВин!
> А в openSUSE 11.4 было также, как в убунте 11.10.
А почему монтирование NTFS-разделов у ТС тогда не работало?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Следуя вашей логике - в Убунте есть Плазма и КВин!

Конечно. Или что у тебя на компе не установлено - того и в дистрибутиве как-бы нету? Не вижу - значит, нету, да?

А почему монтирование NTFS-разделов у ТС тогда не работало?

Не работало, наверно, потому что прав не было.

А на hal он ссылается наверно, потому что использовал KDE3.

Nxx ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

KDE4 в 11.4 использует udisks, вот список зависимостей kdelibs:

/bin/sh
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
/usr/bin/perl
libX11.so.6()(64bit)
libQtCore.so.4()(64bit)
libQtGui.so.4()(64bit)
libkdecore.so.5()(64bit)
libkdeui.so.5()(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libxml2.so.2()(64bit)
libkio.so.5()(64bit)
libQtDBus.so.4()(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
udisks
libQtXml.so.4()(64bit)
libkparts.so.4()(64bit)
libgssapi_krb5.so.2()(64bit)
libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit)
libresolv.so.2()(64bit)
libresolv.so.2(GLIBC_2.2.5)(64bit)
shared-mime-info
libQtNetwork.so.4()(64bit)
libkfile.so.4()(64bit)
libphonon.so.4()(64bit)
libkhtml.so.5()(64bit)
libQt3Support.so.4()(64bit)
libktexteditor.so.4()(64bit)
libQtScript.so.4()(64bit)
libacl.so.1()(64bit)
libacl.so.1(ACL_1.0)(64bit)
libkrosscore.so.4()(64bit)
libxslt.so.1()(64bit)
libxslt.so.1(LIBXML2_1.0.11)(64bit)
libkjs.so.4()(64bit)
libenchant.so.1()(64bit)
libkdewebkit.so.5()(64bit)
libexslt.so.0()(64bit)
libkde3support.so.4()(64bit)
libkemoticons.so.4()(64bit)
libsoprano.so.4()(64bit)
libaspell.so.15()(64bit)
libkatepartinterfaces.so.4()(64bit)
libkdeinit4_kbuildsycoca4.so()(64bit)
libkdeinit4_kconf_update.so()(64bit)
libkdeinit4_kded4.so()(64bit)
libkdeinit4_kio_http_cache_cleaner.so()(64bit)
libkdeinit4_klauncher.so()(64bit)
libkjsembed.so.4()(64bit)
libkntlm.so.4()(64bit)
libkunittest.so.4()(64bit)
upower
libjasper.so.1()(64bit)
libHalf.so.6()(64bit)
libIex.so.6()(64bit)
libIlmImf.so.6()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
libqt4-x11 >= 4.7.1
kdelibs4-branding = 11.4
kdelibs4-core = 4.6.0
libkde4 = 4.6.0
soprano >= 2.5.63
libstrigi0 >= 0.7.3.99
shared-mime-info >= 0.90
shared-desktop-ontologies >= 0.5
Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

Конечно. Или что у тебя на компе не установлено - того и в дистрибутиве как-бы нету? Не вижу - значит, нету, да?
Вы так и не поняли, что речь шла про дефолтную установку?
> А на hal он ссылается наверно, потому что использовал KDE3.
Иначе говоря - в зависимостях пакетов KDE3 забыли указать hal, так?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Иначе говоря - в зависимостях пакетов KDE3 забыли указать hal, так?

Это у вас в дебах можно что-то забыть указать в зависимостях :-) Если оно собрано с hal, то слинкованная библиотека попадет в зависимости автоматом. Но да, просто установить пакет hal не достаточно, в 11.4 эта служба выключена по-умолчанию, ее надо в Ясте включить, в модуле системных служб.

Но я не уверен, что у топикстартера была эта проблема, похоже, у него проблема, связанная с отсутствием разрешения монитировать NTFS от юзера по-умолчанию.

Nxx ★★★★★ ()

хрень твоя 11.4. установка граба отрапортовала об успехе установки на GPT(1stage на 0LBA 1.5stage на специальном разделе) и инсталлер радостно полез в ребут при помощи kexeca. загрузилось все летает. при перезагрузке(я уже даже предвидел это) граб не взлетел. нахрен так жить посаны? жду 12.1

parrot ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.