LINUX.ORG.RU
ФорумTalks

Обзор графических просмотрщиков


0

3

По мотивам вот этого треда.

Сделал обзор графических просмотрщиков для GNU/Linux. Может быть, будет полезен кому-нибудь. ;)

Рассмотрены следующие программы: viewnior, eog, gpicview, ristretto, mirage, comix, feh, gqview, geeqie. Конечно, есть и другой софт для просмотра, модификации и каталогизации изображений, но невозможно объять необъятное.

gqview помер уже давно. вместо него есть другой проект на его кодовой базе, вот только название у него плохо запоминающееся

ZaeLam3l ()

> viewnior, eog, gpicview, ristretto, mirage, comix, feh, gqview, geeqie.

По ссылке не ходил, gwenview с писке нету, обзор неполный => не нужно.

name_no ★★ ()
Ответ на: комментарий от name_no

Если будет не лень, напишу вторую часть, т.к. не всё, что планировалось обозреть, было описано. А то просмотрев 9 программ, я слегка задолбался и решил, что для первой части этого хватит.

geekless ★★ ()

ну как же ж без Gvenview то ??? Рекомендую дополнить! :)

Jetty ★★★★★ ()

Жаль, не находил на Линуксе ничего Асидиси подобного, типа FastStone Image Viewer под виндами. Весьма удобная концепция.

Valeg ★★★ ()
Ответ на: комментарий от geekless

>А чем geeqie не Асидиси-подобен?

Вот он довольно близок. Если бы ещё умел удобный фуллскрин режим, и когда смотрел, несколько фич не хватало.

Valeg ★★★ ()
Ответ на: комментарий от duott

>gwenview идеален

aptitude install gwenview
Следующие НОВЫЕ пакеты будут установлены:
gwenview kdebase-runtime{a} kdebase-runtime-data{a}
kdegraphics-libs-data{a} kdelibs-bin{a} kdelibs5-data{a}
kdelibs5-plugins{a} kdoctools{a} libattica0{a} libclucene0ldbl{a}
libiodbc2{a} libkde3support4{a} libkdecore5{a} libkdesu5{a} libkdeui5{a}
libkdnssd4{a} libkfile4{a} libkhtml5{a} libkio5{a} libkipi7{a}
libkjsapi4{a} libkjsembed4{a} libkmediaplayer4{a} libknewstuff2-4{a}
libknewstuff3-4{a} libknotifyconfig4{a} libkntlm4{a} libkparts4{a}
libkpty4{a} libkrosscore4{a} libktexteditor4{a} libkutils4{a}
libnepomuk4{a} libnepomukquery4a{a} libplasma3{a} libpolkit-qt-1-0{a}
libqca2{a} libqt4-opengl{a} libsolid4{a} libsoprano4{a} libssh-4{a}
libstreamanalyzer0{a} libstreams0{a} libthreadweaver4{a} libutempter0{a}
oxygen-icon-theme{a} phonon{a} phonon-backend-xine{a}
plasma-scriptengine-javascript{a} shared-desktop-ontologies{a}
soprano-daemon{a}
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
kaboom virtuoso-minimal
0 пакетов обновлено, 51 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 53,4 MB архивов. После распаковки 134 MB будет занято.

Это точно просмотрщик картинок, а не 3d-шутер или IDE?

Polugnom ★★★★★ ()
Ответ на: комментарий от geekless

>geeqie

geeqie - мой дефолтный просмотровщик, удобные хоткеи, много настроек
gwenview мне неудобен, мало настроек, прокрутка при просмотре колесом мыши не работает, хоткеи на zoom дикие

x905 ★★★★★ ()
Ответ на: комментарий от Polugnom

> Это точно просмотрщик картинок, а не 3d-шутер или IDE?

В точку! :D

geekless ★★ ()

скриншотов не хватает

aho ()
Ответ на: комментарий от Pavval

> Это точно 2011 год с терабайтными винтами?

Это точно планета человеков разумных? С каких-то пор размер программы должен зависить от размера винта, а не от функций программы?

geekless ★★ ()
Ответ на: комментарий от Pavval

134 Мб. для простого просмотра картинок? Нет, спасибо, хотя на дворе и 2011 год, но в такой идиотизм я пока ещё не ударился.

Polugnom ★★★★★ ()
Ответ на: комментарий от geekless

С каких-то пор размер программы должен зависить от размера винта, а не от функций программы?

Для тех, кто не в теме: KDE - довольно тесно интегрированая DE с большим числом зависимостей между компонентами. Ну и не забываем передать привет тем, кто это пакетировал (сам в Дебиане не в восторге).

А из размеров современных винтов следует только то, что или 1. у кого-то допотопный комп, или 2. просто хочется потроллить на ЛОРе и надо придумать повод.

Pavval ★★★★★ ()

Там даже gwenview нету, УГ.

erfea ★★★★★ ()
Ответ на: комментарий от Pavval

> KDE - довольно тесно интегрированая DE с большим числом зависимостей между компонентами.

Ну как обычно. Опять пошел бред про тесную интеграцию и зависимости. Для полноты клинической картины еще осталось приплести, что КДЕ — отдельная ОС поверх линукса.

Перевожу с кедофанбойского на русский: разработчики кед не осилили нормально разбить систему на компоненты с четко определенными интерфейсами и функциями. Тем временем неспешно шел 2011-й год...

А из размеров современных винтов следует только то, что или 1. у кого-то допотопный комп, или 2. просто хочется потроллить на ЛОРе и надо придумать повод.

У меня около полутора терабайт общая емкость данных с винтов. Но это не значит, что я буду благосклонно смотреть, как криворукие программисты хотят засрать мою систему ненужным говном.

geekless ★★ ()

Мне кажется, или среди рассмотренных просмотровщиков нет ни одного на QT? =]

neocrust ★★★★★ ()
Ответ на: комментарий от geekless

Перевожу с кедофанбойского на русский: разработчики кед не осилили нормально разбить систему на компоненты с четко определенными интерфейсами и функциями.

О да, уверенным тоном спорол полную ахинею. Поздравляю. Пруфы, привязывающие твой бред к приведенным зависимостям gvenview будут?

Pavval ★★★★★ ()

Такое без скринов публиковать нельзя.

Deleted ()

xnview идеален для обычного просмотра. geeqie более тяжеловесный. ristretto легкий, но подглючивает.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Pavval

> 1. у кого-то допотопный комп, или 2. просто хочется потроллить на ЛОРе и надо придумать повод.

3. bloatware ненужно

cvs-255 ★★★★★ ()
Ответ на: комментарий от cvs-255

1. у кого-то допотопный комп, или 2. просто хочется потроллить на ЛОРе и надо придумать повод.

3. bloatware ненужно

А почему bloatware не нужно? Потому что или 1. у кого-то допотопный комп, или 2. просто хочется потроллить на ЛОРе и надо придумать повод.

Pavval ★★★★★ ()

Тема просмотра RAWок не раскрыта. Обзор говно.

daemonpnz ★★★★★ ()

Скриншотов нет, выводов нет. Обзор неполный.

athost ★★★★★ ()
Ответ на: комментарий от Polugnom

ещё один, который пытается ставить kde-шные проги и удивляется, что они зависят от kde

duott ★★★★★ ()

>Сделал обзор графических просмотрщиков для GNU/Linux.

Название не соответствует теме обзора, рассмотривается какой-то говнософт и ни упомянуто ниодного «графического просмотрщика», gwenview, например.

madcore ★★★★★ ()
Ответ на: комментарий от Pavval

> fixed

Уж если взялся фиксить, фикси как следует:

«Отстутсвует в репах Федоры и тянет за собой KDE, не нужна»

dexpl ★★★★★ ()

Почему нет самого адекватного просмотрщика GwenView?

pevzi ★★★★★ ()

> GPicView

low memory usage


Поржал. Это единственная гляделка, которая умудрялась у меня уходить в своп при просмотре гифок (:

pevzi ★★★★★ ()
Ответ на: комментарий от pevzi

Поржал. Это единственная гляделка, которая умудрялась у меня уходить в своп при просмотре гифок (:

Она кешировала все кадры, не замечая того, что они зациклены?:)

Pavval ★★★★★ ()
Ответ на: комментарий от Pavval

Не знаю уж, в чем там загвоздка, но после последовательного просмотра 10-15 гифок она сжирала примерно с гигабайт памяти.

pevzi ★★★★★ ()
Ответ на: комментарий от Polugnom

Неужели?

Судя по ебилду, в генте оно зависит от KDE-софта только от kdelibs.

К тому же, gwenview - часть _DE_ KDE. Для интеграции с DE зависимости вполне себе обоснованные.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

Ну aptitude show тоже показывает в зависимостях только kdebase-runtime, libc6 (>= 2.2), libexiv2-9, libgcc1 (>= 1:4.1.1), libjpeg62 (>= 6b1), libkdecore5 (>= 4:4.4.0), libkdeui5 (>= 4:4.4.0), libkfile4 (>= 4:4.4.0), libkio5 (>=4:4.4), libkipi7 (>= 4:4.4.1), libkparts4 (>= 4:4.4),libnepomuk4 (>= 4:4.4), libphonon4 (>=4:4.6.0really4.3.80), libqt4-svg (>= 4:4.5.3), libqtcore4 (>= 4:4.6.1), libqtgui4 (>= 4:4.6.1),libstdc++6 (>= 4.1.1), phonon.
То есть, на первый взгляд ничего страшного. Однако при установке возникает совсем другая картина.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

То есть, на первый взгляд ничего страшного. Однако при установке возникает совсем другая картина.

Ты часом не пытаешься ставить еще и _рекомендуемые_ пакеты, помимо зависимостей? А вообще приведеный изначально список зависимостей довольно обоснован.

Pavval ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.