LINUX.ORG.RU

> Ещё интересно, почему Гугл не планирует портировать Google Earth?

о_О Куда портировать? Под linux есть давно.

Cancellor ★★★★☆ ()

Earth и так нативный, ибо на qt, winelibs-ами там не пахнет.
А к maps-ам вам какой клиент, кроме браузера нужен?

CyberTribe ★★ ()
Ответ на: комментарий от antony986

ВНЕЗАПНО оно стало нативным? Во всяком случае до этого там был вендовый Google Earth, приклеенный к Wine'у.

Lighting ★★★★★ ()
Ответ на: комментарий от Cancellor

Похоже уже пофиксили и сам клиент.

Информация не 100%, но после очередного обновления оно загрузилось безо всяких манипуляций с удалением libQt* из директории приложения.

edigaryev ★★★★★ ()
Ответ на: комментарий от edigaryev

Неужто гугловцы наконец-то осилили собрать Qt? Надо бы глянуть...

Cancellor ★★★★☆ ()
Ответ на: комментарий от Lighting

> Во всяком случае до этого там был вендовый Google Earth, приклеенный к Wine'у.

Здесь точно никто не путает гуглеёрз и пикасу?

sin_a ★★★★★ ()
Ответ на: комментарий от Cancellor

Хотя...

fox@darkstar:~/Install$ aria2c http://dl.google.com/earth/client/current/GoogleEarthLinux.bin
fox@darkstar:~/Install$ ls -l Google*
-r-xr-xr-x 1 fox fox 25989559 2010-01-05 23:56 GoogleEarth-5.1.3533.1731.bin
-rw-r--r-- 1 fox fox 25989559 2010-02-05 20:15 GoogleEarthLinux.bin
fox@darkstar:~/Install$ cmp -b GoogleEarth{Linux,-5.1.3533.1731}.bin 
fox@darkstar:~/Install$
В версии 5.1.3533.1731 таки приходилось подменять либы, а по вышеуказанной ссылке отдают именно её.

Cancellor ★★★★☆ ()
Ответ на: комментарий от Cancellor

Старые файлы как лежали, так и сейчас лежат. Новые почему-то не добавились.

edigaryev@brick /opt/googleearth $ ls | grep libQt
libQtCore.so.4.dist
libQtGui.so.4.dist
libQtNetwork.so.4.dist
libQtWebKit.so.4.dist
portage говорит что помимо 5.1.3533.1731 есть еще 5.1.3533.1731-r1.
edigaryev@brick ~ $ eix googleearth
[I] x11-misc/googleearth
     Available versions:  4.2.205.5730!m!s (~)4.3.7284.3916!m!s (~)5.0.11733.9347!m!s (~)5.1.3509.4636_beta!m!s (~)5.1.3533.1731!m!s (~)5.1.3533.1731-r1!m!s {qt-bundled}
     Installed versions:  5.1.3533.1731-r1!m!s(20:05:26 01.02.2010)(-qt-bundled)
     Homepage:            http://earth.google.com/
     Description:         A 3D interface to the planet

edigaryev ★★★★★ ()
Ответ на: комментарий от Cancellor

Кстати, есть более простой способ, о котором почему-то часто забывают:

LANG=ru_RU.CP1251 googleearth
LORanymous ()
Ответ на: комментарий от LORanymous

CP1251

быстро и решительно ушел с богомерзким чайлд порном 1251 с моих лоров!

NuclearPhoenix ()

О боже! Кажется в моих отстойниках утечки!!!

bioreactor ★★★★★ ()

В генту недавно появидась версия с флагом qt-bundled, без которого всё нормально работает.

У меня есть вопрос, кстати. Допустим, с помощью карт google я сделал карту какой-нибудь деревни или посёлка. Законно ли это, могу я иметь авторские права на этот «план» опубликовать его под лицензией типа CC-SA, или нет?

Явояется ли обводка изображений в векторном редакторе «derivative work»?

Google Maps/Earth Terms of Service

(b) copy, translate, modify, or make derivative works of the Content or any part thereof;

octy ★★ ()
Ответ на: комментарий от octy

> Законно ли это

без разрешения правообладателя на карты - нет

Явояется ли обводка изображений в векторном редакторе «derivative work»?

да

unC0Rr ★★★★★ ()
Ответ на: комментарий от Cancellor

Cancellor

Это лечится подменой libQt*


Не всегда, к сожалению.
С большой вероятностью, и без подмены .so-шек лечится добавлением папок со шрифтами в секцию «Files» xorg.conf (если его нет, ничего не мешает его создать, или подправить соответствующую xml-ку для hal)

Ну, например:

Section "Files"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/75dpi/"
    ..... 
    FontPath        "/usr/share/fonts/intlfonts/"
EndSection

Myp3ik ★★ ()
Ответ на: комментарий от Lighting

>Во всяком случае до этого там был вендовый Google Earth, приклеенный к Wine'у.

Хм. И Qt - вайновый? ;)

KRoN73 ★★★★★ ()
Ответ на: комментарий от Cancellor

Пробовал разные варианты, помогла замена libQt*

Вылечил так:

find /usr/lib -iname «libqt*» (пригляделся)

и потом:

cp /usr/lib/libQtWebKit.so.4.5.3 /home/leonder/.local/google-earth/libQtWebKit.so.4

Аналогично для libQtNetwork.so.4.5.3, libQtGui.so.4.5.3 и libQtCore.so.4.5.3

leonder ()
Ответ на: комментарий от NuclearPhoenix

>>>LANG=ru_RU.CP1251 googleearth

CP1251

быстро и решительно ушел с богомерзким чайлд порном 1251 с моих лоров!

Да уж проще подставить эти несколько символов (пусть и богомерзких) перед командой запуска googleearth, чем шаманить с подменой либ.

LORanymous ()
Ответ на: комментарий от Myp3ik

Всё открывается нормально работает быстро и не падает.

Есть небольшая проблема с панорамио - оно работает не всегда. Непонятно почему. Окошко открывается, а фотка не загружается, но не всегда.

leonder ()
Ответ на: комментарий от Myp3ik

Слои Panoramino и Wikipedia нормально открываются ?

Проверил на ноутбуке, там такой же дистрибутив, как у меня на дестопе (debian squeeze), но не i386, а amd64, и видеокарта ati mob. radeon x1150 с открытым драйвером (против встроенного на десктопе intel, работающего на ура).

Так вот. Запустил установочный бинарник, установил в ~/.local, запустил программу - то же самое - вместо русских букв что-то невнятное из кашицы точек, интерфейс убогий, аж глаза режет, аки голимое оффтоп95.

В общем, сохранил libQt* в отдельный каталог и сделал подмену из /usr/lib. Запускаться не захотело, ругнувшись на webkit и какую-то в нем ошибку. Вернул оригинальный webkit - запустилось и работает. Но не грузятся картинки ни в panoramio, ни в страничках с Wiki.

Какую lib надо еще подменить, как считаете? Или еще методы лечения? И да, на дестопе тоже перестало панорамио работать, странно.

leonder ()

РЕШЕНО (Panoramio в google earth)

http://www.opennet.ru/tips/info/2177.shtml

в моем случае получилось так:

ln -fs /usr/lib/qt4/plugins/imageformats/libqjpeg.so /home/leonder/.local/google-earth/plugins/imageformats/libqjpeg.so

ln -fs /usr/lib/qt4/plugins/imageformats/libqgif.so /home/leonder/.local/google-earth/plugins/imageformats/libqgif.so

leonder ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.