LINUX.ORG.RU
ФорумTalks

Хилый закос под Gentoo^_^


0

0

В очередной раз не успел поставить, но на выходных обязательно. А пока извращаюсь над убунтой:

:~$ cat /usr/bin/emerge
#!/bin/bash
if [[ $1 = "--sync" ]]
then
        sudo apt-get update
        exit 0
elif [[ $1 = "world" ]]
then
        sudo apt-get upgrade
        exit 0
elif [[ $1 = "--search" ]]
then
        if [[ $2 ]]
        then
                apt-cache search "$2"
                exit 0
        else
                echo "no arguments passed"
                exit 65
        fi
elif [[ $1 = "--unmerge" ]]
then
        if [[ $2 ]]
        then
                sudo apt-get remove "$2"
                exit 0
        else
                echo "no arguments passed"
                exit 65
        fi
 elif [[ $1 ]]
        then
                sudo apt-get install "$1"
                exit 0
        else
                echo "no arguments passed"
                exit 65
fi

★★★★

Re: Хилый закос под Gentoo^_^

#0000FF

jcd ★★★★★ ()

Re: Хилый закос под Gentoo^_^

Если закос под gentoo, то использовать нужно apt-build

Cancellor ★★★★☆ ()

Re: Хилый закос под Gentoo^_^

Чем бы дитя не тешилось...

GotF ★★★★★ ()

Re: Хилый закос под Gentoo^_^

Стереотипы такие стереотипы

name_no ★★ ()

Re: Хилый закос под Gentoo^_^

с тем же успехом можно положить на рабочий стол венды ярлык "/bin/bash"->cmd.exe и утверждать, что это линукс.

nu11 ★★★★★ ()

Re: Хилый закос под Gentoo^_^

>не успел поставить

как это хорошо характеризует генту (;

hired777 ()

Re: Хилый закос под Gentoo^_^

sudo apt-get install «$1»

А вот здесь, товарищ, мы вас и поправим...

sudo apt-build install "$i"
shimon ★★★★★ ()
Ответ на: Re: Хилый закос под Gentoo^_^ от nu11

Re: Хилый закос под Gentoo^_^

Когда стояла винда, так и было, только на cygwin.exe Да, не линукс, а GNU/Windows

wingear ★★★★ ()
Ответ на: Re: Хилый закос под Gentoo^_^ от shimon

Re: Хилый закос под Gentoo^_^

Да, и впрямь. Тогда так, а то в убунте его нет по умолчанию:

sudo apt-build install "$1"
        if [[ !$? ]]
        then
                echo "you need to install apt-build first. Would you like to get it now?(y/n)"
                read cond
                if [[ $cond = "y" ]]
                        then
                                sudo apt-get install apt-build
                                sudo apt-build install "$1"
                        else
                                exit
                fi
        fi

wingear ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.