LINUX.ORG.RU
ФорумTalks

Flightgear 1.9.1


0

0

Вышел. На Генту собрался. Ебилды нужны?

Как обычно, без каких-либо гарантий и уверенности, что заработает. Но у меня работает нормально.

★★★★★

Re: Flightgear 1.9.1

еще добавь ЧЯДНТ

sansei ()

games-simulation/flightgear/flightgear-1.9.1.ebuild

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.0.0.ebuild,v 1.4 2008/09/20 12:44:47 gentoofan23 Exp $

inherit autotools eutils games

MY_PN=FlightGear
MY_P=${MY_PN}-${PV}
DESCRIPTION="Open Source Flight Simulator"
HOMEPAGE="http://www.flightgear.org/";
SRC_URI="mirror://flightgear/Source/${MY_P}.tar.gz
mirror://flightgear/Shared/FlightGear-data-${PV}.tar.bz2"
# Скачать вручную с сайта FlightGear-1.9.1.tar.gz
# и FlightGear-data-1.9.0.tar.bz2,
# переименовать второй в FlightGear-data-1.9.1.tar.bz2


LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="sdl"

DEPEND="virtual/glut
~dev-games/simgear-1.9.1
>=media-libs/plib-1.8.5
media-libs/freealut
=media-libs/openal-9999
>=media-gfx/openscenegraph-2.7.5
sdl? ( media-libs/libsdl )"
# С последним стабильным openal при столкновении с землёй ругается на NaN
# Не уверен насчёт минимальной версии media-gfx/openscenegraph, с 2.7.5 работает

S=${WORKDIR}/${MY_P}

src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/flightgear-1.0.0-sdl.patch"
eautoreconf
}

src_compile() {
egamesconf \
--disable-dependency-tracking \
$(use_enable sdl) \
|| die
emake -j1 || die "emake failed"
}

src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
insinto "${GAMES_DATADIR}"/${MY_PN}
doins -r ../data/* || die "doins failed"
newicon ../data/Aircraft/T38/thumbnail.jpg ${PN}.jpg
make_desktop_entry fgfs FlightGear /usr/share/pixmaps/${PN}.jpg
dodoc AUTHORS ChangeLog NEWS README Thanks
prepgamesdirs
}

question4 ★★★★★ ()

media-libs/openal-9999.ebuild

# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.6.372.ebuild,v 1.8 2009/01/26 04:37:26 jer Exp $

inherit eutils cmake-utils git

MY_P=${PN}-soft-${PV}

DESCRIPTION="A software implementation of the OpenAL 3D audio API"
HOMEPAGE="http://kcat.strangesoft.net/openal.html";
# SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
EGIT_REPO_URI="git://repo.or.cz/openal-soft.git"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="alsa oss debug"

DEPEND="alsa? ( media-libs/alsa-lib )"

S=${WORKDIR}/${MY_P}

DOCS="alsoftrc.sample"

src_compile() {
local mycmakeargs=""

use alsa || mycmakeargs="${mycmakeargs} -DALSA=OFF"
use oss || mycmakeargs="${mycmakeargs} -DOSS=OFF"
use debug && mycmakeargs="${mycmakeargs} -DCMAKE_BUILD_TYPE=Debug"

cmake-utils_src_compile
}

pkg_postinst() {
einfo "If you have performance problems using this library, then"
einfo "try add these lines to your ~/.alsoftrc config file:"
einfo "[alsa]"
einfo "mmap = off"
}

question4 ★★★★★ ()

dev-games/simgear-1.9.1.ebuild

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-1.0.0.ebuild,v 1.5 2008/11/18 15:47:39 loki_val Exp $

inherit eutils

MY_P="SimGear-${PV/_/-}"
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/";
SRC_URI="mirror://simgear/Source/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""

DEPEND=">=media-libs/plib-1.8.4
media-gfx/openscenegraph
media-libs/openal
media-libs/freealut"
# Версии не ставил. ИМХО, те же, что и для FlightGear.

S=${WORKDIR}/${MY_P}

src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/simgear-1.0.0-test.patch
# epatch "${FILESDIR}"/simgear-1.0.0-gcc44.patch
# старый патч для GCC не подходит, на 4.1.2 собралось и без него
}

src_compile() {
econf || die
emake -j1 || die "emake failed"
}

src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc NEWS AUTHORS
}

question4 ★★★★★ ()

Модераторам

Если считаете, что этому не место в Talks — переносите в General, Development или Games.

question4 ★★★★★ ()

Re: Flightgear 1.9.1

а когда он заработает?
в google-earth уже есть симулятор крутой

anonymous ()
Ответ на: Re: Flightgear 1.9.1 от anonymous

Re: Flightgear 1.9.1

> а когда он заработает?

У меня работает.

Только Сессна всё время на месте крутится :(

question4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.