LINUX.ORG.RU

Написать ебилд для catfish

 ,


0

1

На ЛОРе пару дней назад была новость, что вышел новый Catfish 1.4.6. В дереве портажа до сих пор 1.2.2. Вот ссылка на открытый баг: https://bugs.gentoo.org/570568 Хочется написать-таки ебилд для новой версии, но я в этом полный профан. Мои знания ограничиваются обычной установкой и настройкой генты, я не знаю ни одного языка программирования и не могу написать ничего сложнее сортировки пузырьком на паскале. Поэтому я ищу кого-нибудь, кому было бы не жалко потратить немного времени и вместе написать новый ебилд.

Ответ на: комментарий от anonymous

Я сделал все, что написано в https://wiki.gentoo.org/wiki/Handbook:AMD64/Portage/CustomTree#Defining_a_cus... глава Defining a custom repository. Дальше нужно следовать этой статье, а я не пойму, что делает эта куча команд в начале: https://wiki.gentoo.org/wiki/Custom_repository

sgasgar23 ()

я в этом полный профан

Отличная возможность это поменять
https://wiki.gentoo.org/wiki/Basic_guide_to_write_Gentoo_Ebuilds

не знаю ни одного языка программирования

ebuild - это bash-скрипт. bash-то ты знаешь, коль установил Генту?
Если есть сомнения, то вот: https://www.opennet.ru/docs/RUS/bash_scripting_guide/abs-guide-flat.tar.gz

И товарищ Harald в первом посте дело говорит.

Kroz ★★★★★ ()
Ответ на: комментарий от Bruce_Lee

Спасибо! Надо же, сегодня добавили. А почему он у меня не отображается? eix-sync я сделал

# eix catfish
[I] dev-util/catfish
     Available versions:  1.2.2 {PYTHON_SINGLE_TARGET="python2_7 python3_4 python3_5 python3_6" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"}
sgasgar23 ()