LINUX.ORG.RU
ФорумTalks

Documentation/Changes в kernel

 , ,


0

1

гм, а его вообще меняют ?

Во всех ветках меньше 4.19

Current Minimal Requirements
****************************
====================== ===============  ========================================
        Program        Minimal version       Command to check the version
====================== ===============  ========================================
GNU C                  3.2              gcc --version

Это наглая ложь!

gcc-4.3.3 падает при попытке скомпилировать какой-то файл в ядре > 4.14.52 (давненько не видел такого)

если верить git log, то требования к gcc последний раз меняли в 2006 г.

Вот в 4.19 все честно - минимальные требования 4.6

PS забавно, но gcc-4.3.3 не может собрать > gcc-5.x :)

★★★★★

gcc-4.3.3 падает

А как падает то?

Deleted ()
Ответ на: комментарий от Deleted

Под «падает» обычно другое понимают. А по ссылке - нормальное сообщение об ошибке.

Deleted ()
Ответ на: комментарий от Deleted

Как бы то ни было, ядро не собирается с gcc < 4.6, поэтому их поддержку убрали вместе с сопутствующим легаси.

Deleted ()
Ответ на: комментарий от Deleted

что-то типа

i686-pc-linux-gnu-gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.

За 20 лет я такое видел всего пару раз, чтоб gcc падал не по причине кривого железа.

Гугление показало, что я не одинок в этой проблеме.

vel ★★★★★ ()
Ответ на: комментарий от vel

Ммм... Ну это скорее в самом gcc баг какой-то.

Может таки обновить его? =)

Кстати, 4.3.3 - не самая последняя версия в ветке 4.3.*.

Deleted ()
Ответ на: комментарий от Deleted

Да я уже обновил до 7.2.0 и binutils до 2.26

gcc-8 пока выбешивает своей дотошной тупизной :)

vel ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)