LINUX.ORG.RU

Установка драйвера тюнера GOTVIEW USB Master. Проблема.

 , gotview, , ,


0

1

Добрый день. Не могу скомпилировать драйвер, вылетает ошибка после «make»: In file included from <command-line>:0: /home/comp/Documents/AZLinux704D1_v1.0.0.4/linuxdriver/v4l/config-compat.h:4: fatal error: linux/autoconf.h: No such file or directory compilation terminated.

Залез в этот хедер, а тот хочет: #include <linux/autoconf.h> #include <linux/mmdebug.h> Очевидно обоих в /usr/include/linux их нет, хотя можно встретить в разных папках «/usr/src/linux-headers-2.6.35-32-generic/include».

Требования драйвера: System require: linux kernel up to 2.6.29, kernel devel package [я так понимаю имеются в виду исходники linux-headers-2.6.35-32-generic], binutils - suggested version is 2.11.x., gcc - suggested versions are: 2.95.3 (maybe 2.95.4) and 3.2+., XFree86 - suggested version is always the newest (4.3). [Вроде нет в Ubuntu], make - suggested version is always the newest (at least 3.79.x).

Доп. инф: Система: Ubuntu 10.10 maverick, 2.6.35-32-generic.

Установлены пакеты: linux-headers-2.6.35-32-generic, build-essential, autoconf, libncurses5-dev,

Брал драйвер для linux здесь: http://www.gotview.ru/olimp/viewtopic.php?f=27&t=9573

PS Сама процедура установки выглядит так: 2) Install Azurewave card driver $ cd linuxdriver

$ rm v4l/.version

$ make menuconfig(use default)

$ make clean

$ make //Здесь вылетает ошибка

$ make install

$ make rmmod

$ make insmod

$ rmmod tm6010.ko

$ insmod v4l/tm6010.ko atv_std=0 ir_decode=0

or you can run install.sh. //А такого файла нет


Не нашел, как удалить тему. Но проблема была в допустимой версии ядра. По идее она должна быть до 2.6.29. Тюнер вернул в магаз, купил AverTV Volar Go.

nwbie
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.