LINUX.ORG.RU
ФорумTalks

Готовится к выпуску Wine 4.0. Время искать баги!

 , ,


0

1

Каждые 2 недели выпускается Release Candidate (rc) Wine 4.0. Сейчас их уже 4, всего будет 5.

Я призываю всех, кто пользуется Wine, запустить всё используемое вами программное обеспечение и потестить. Если есть регрессии - зарепортить баг здесь: https://bugs.winehq.org/

>>> Debian repo

>>> Ubuntu repo

>>> Fedora repo

>>> openSUSE OBS

Slackware packages

Перемещено jollheef из opensource

31 декабря

testday

Зенитар, ты упорот

anonymous ()
Ответ на: комментарий от anonymous

В смысле? Я же не говорю, что это надо делать сегодня?

А, ты про тег... Для тестовых недель Fedora был введён этот тег, и я не вижу смысла плодить новые

ZenitharChampion ★★★★★ ()

В Новом Году хочу пожелать всем линуксоидам побольше прослоек и трансляторов. Чтобы лились они рекой и заворачивались в друг-друга.

С новым вином 🍷!

fornlr ★★★★★ ()

Всех с НГ!!! Анона в толксы!!!

anonymous ()

кто пользуется Wine

Эти ваши прослойки и трансляторы никому ненужны.

Odalist ★★★★★ ()

А кто помнит страницу в Wine где была таблица какой API вызов реализован, а какой пока нет?

Там ещё было что-то типа :«реализовано 127 000(76%.)

И показаны какие stubs.

А то давно не следил за проектом, а сейчас найти ту страницу не могу...

fsb4000 ★★★ ()
Ответ на: комментарий от fsb4000

Это будет кукурузный бестолковый показометр, тк одну программу чинят, а другая ломается из-за этой починки, потому что программы опираются на баги и нестандартное поведение венды.

nvidia ()

Я купил и установил дисяточку. А Сколько стОит ваше время, тестировщики ?

lenin386 ★★★ ()

В смысле 4.0? Недавно же было 0.9.

Nervous ★★★★ ()

в сиде и арче уже давно завезли

amd_amd ★★ ()

Ubuntu PPA

!!! PLEASE NOTE THAT THIS REPOSITORY IS DEPRECATED !!!
«Шарик, ты балбес»
Твоя хроническая ненависть к Бубунте уже перешла все границы.

athost ★★★★★ ()
Последнее исправление: athost (всего исправлений: 1)

Я призываю всех, кто пользуется Wine, запустить всё используемое вами программное обеспечение и потестить. Если есть регрессии - зарепортить баг здесь:

Все важные для меня баги, что были годы назад, все есть. Регрессия, что появилась - давно зарепортил. На месте.

gag ★★★★★ ()

Как перекатиться на это со стейджинга?

Moondancer ()

Готовится к выпуску Wine 4.0. Время искать баги!

Они бы вначале закрыли баги в 3.x.

У меня в >=3.10 половина софта не работает.

mord0d ★★★ ()

как проект, вайн вызывает восхищение. Но так и не придумал, для чего бы мне его заюзать. А еще раздражают появляющиеся вордпады и блокноты после установки сабжа, предлагающие открыть в себе всё подряд, смысл сей фичи ускользает от меня.

Deleted ()
Ответ на: комментарий от mord0d

Про то и тема. Надо оставить баг-репорты, а то разработчики не знают

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Они не знают, как зайти на собственный багтрекер? Сам-то на нём был хоть раз? Там столько багов, что не 4.0, а 0.0.4 выпускать.

mord0d ★★★ ()
Ответ на: комментарий от ZenitharChampion

Я про конкретно твои баги.

Мне и старых (чужих) хватает, чтобы ничего не работало.

Баги сами себя не зарепортят.

Не забудь сказать разработчикам, что они (баги) ещё и сами себя не пофиксят.

mord0d ★★★ ()
Ответ на: комментарий от Deleted

так и не придумал, для чего бы мне его заюзать.

В игры играть, естественно.

tailgunner ★★★★★ ()
Ответ на: комментарий от mord0d

Лично я зарепортил два бага в период тестирования 3.0, и один в 4.0. Все пофикшены. Так не всегда - бывает что баг не исправляют долго. Но тема не об этом. Тема о поиске регрессий. Когда в 3.0 работало, а в 4.0 работать перестало. Вот об этом тема. Разрабы не могут протестировать весь софт, поэтому нужна помощь сообщества. На то и нужны альфы, беты и релиз-кандидаты...

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Когда в 3.0 работало, а в 4.0 работать перестало.

Так и я о том. Когда в 3.0 работало, а в 3.10 перестало.

mord0d ★★★ ()
Ответ на: комментарий от mord0d

Я тоже с таким сталкивался )) Например в 2008 установил Photoshop CS2 в Wine 1.1.16, а там инструмент Кисть рисует в сантиметре от курсора мыши. А на 1.0 всё норм было

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Moondancer

> Как перекатиться на это со стейджинга?

Так Staging же тоже обновляется до 4.0-rcn

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Чот пока не. Зато в репах бастера уже 4-й. Они совсем упоролись обновлять перед самой заморозкой? Ещё выкинут, чего доброго. Лучше б GTK+3 выкинули, всё равно он устарел уже.

Moondancer ()
Ответ на: комментарий от Moondancer

Лучше б GTK+3 выкинули

Подожди, еще крысу не до конца туда портировали. Закопать все эти DE в одной могилке вместе со вторым питоном ящетаю.

bread ()
Ответ на: комментарий от bread

еще крысу не до конца туда портировали

И не нужно.

со вторым питоном

Но ведь третий питон тоже не нужен. Он даже нестабилен до сих пор.

Moondancer ()
Ответ на: комментарий от Moondancer

Да, надо бы портировать взад на православный гтк2 пока не поздно. АТО придется скоро три версии гытыки тащить, что совсем уже ахтунг.

bread ()
Ответ на: комментарий от bread

Чо там Audacious, кстати, всё сидят на GTK+2 или переметнулись в стан культевиндузятников, в котором уже есть QMMP и Audacious не нужен?

Moondancer ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)