LINUX.ORG.RU

Альтернативные браузеры

 ,


1

4

В связи с тем, что лисичка стремительно скурвивается, надо искать замену.
Из движков альтернативы по сути нет, только хромогий webkit/blink.
Но оригинальный хромог - зонд от гугла, и гтк3 (тащит даже с "-gtk3"). Поэтому ищу, так сказать, зборочку, желательно на qt.

Пока смотрю на qupzilla и otter browser, и как-то всё печально.
Otter Browser (косплеит оперу-престо) ещё ничего, хотя пока бета, но сборка на qtwebengine какая-то слишком урезанная, даже нельзя посмотреть SSL-сертификат (!), не работает «инспектор», может, ещё какие проблемы.
А qtwebkit протух, deprecated, например, не все галочки в html5 на ютубе (или ему нужен гстрёмер), короче, не дело.
ЧСХ, в Qupzilla 2.1 то же самое, видимо, это принципиальные проблемы qtwebengine. Хотя какие-то функции вернули (в 2.0 было ещё хуже).

Время пока есть, Firefox ESR будет поддерживаться еще долго, но как говорится, готовь сани летом, вылетит - не поймаешь. Какие есть браузеры, которые не зависят от gtk?
Я правильно понимаю, что на qt всё, что есть, работает поверх qtwebengine/qtwebkit?

Но оригинальный хромог - зонд от гугла

Ты занимаешься экономией на спичках

Deleted ()
Ответ на: комментарий от TheAnonymous

Ну т.е. отказываешься от стабильного, надежного, удобного (хотя тут кому как) браузера из-за мелочей. Да, де-факто слегка зонд. Но в интернете есть куда больше других угроз для privacy, гораздо более существенных.

Deleted ()

оригинальный хромог - зонд от гугла, и гтк3

gtk он для отрисовки вроде же не использует, диалоги дергает KDEшные, в чем проблема? А сервисами гугла никто тебя пользоваться не заставляет, гуглозонд можно себе вставить и в FF с точно таким же успехом.

mbivanyuk ★★★★★ ()

Чем тебе не нравится palemoon?

XShell ()
Ответ на: комментарий от XShell

Как вариант. Но у неё тоже gtk3, пока опционально. Но судя по тому, что поддержку шиндошс хр они выпилили ещё раньше, чем сам firefox, насчёт gtk2 те же опасения

И как там с поддержкой веб2.0 стандартов?

TheAnonymous ★★★★★ ()

MS Edge же, идеален во всём, uBlock есть, под тач самое то если вдруг.

eR ★★★★★ ()

зонд от гугла, и гтк3 (тащит даже с "-gtk3")

Да, тяжела и невесела жизнь тулкитофоба-параноика.

Polugnom ★★★★★ ()

Что не так с фаирфоксом? Работает вроде так же как всегда.

theurs ()

и гтк3 (тащит даже с "-gtk3")

Новый chromium перешёл на GTK+ 3, чтобы иметь улучшенную поддержку тем в дистрибутивах GNU/Linux:

http://www.omgubuntu.co.uk/wp-content/uploads/2017/03/before.jpg
http://www.omgubuntu.co.uk/wp-content/uploads/2017/03/after.jpg

Соответственно, жёсткая зависимость от GTK+ 3 — правильный подход. Ибо через несколько месяцев весь GTK+ 2 код будет удалён.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)

Я правильно понимаю, что на qt всё, что есть, работает поверх qtwebengine/qtwebkit?

Да. Из Firefox прошлым летом была полностью удалена поддержка Qt 5:

https://bugzilla.mozilla.org/show_bug.cgi?id=1282866

И скоро видимо будет удалена поддержка GTK+ 2

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)

Инспектор кода в Qupzilla работает.
А вот инфу о сертификате пока что никак не посмотреть...

Sorcus ()
Ответ на: комментарий от EXL

И скоро видимо будет удалена поддержка GTK+ 2

Да уже вроде.

sudopacman ★★★★★ ()
Ответ на: комментарий от theurs

да, ESR еще где-то год будет работать, но в текущих релизах уже гтк3 и приближающийся xul-капец

TheAnonymous ★★★★★ ()
Ответ на: комментарий от Sorcus

В 1.х работал, я про 2.х на qtwebengine. Там тоже можно включить, но только если открыть удалённый доступ к этому отладчику, что открывает какую-то хитрую дырень

TheAnonymous ★★★★★ ()

Какая разница, какую версию GTK тащить? А альтернативных лисе браузеров нет. Пора свой писать.

sudopacman ★★★★★ ()

А qtwebkit протух, deprecated, например, не все галочки в html5 на ютубе (или ему нужен гстрёмер), короче, не дело.

Поставь Otter из AppImage, или qt5-webkit-ng, если ты на раче

annulen ★★★★★ ()

Тот случай, когда шашечки важнее.

dk- ()
Ответ на: комментарий от dk-

Разумеется важнее, ехать то уже давно не получается.

StReLoK ☆☆ ()

Seamonkey. Но сейчас я пользую lynx, т.к. у SeaMonkey на фряхе почему-то отвалился сетевой стек. С диска страницы кажет, а с сети нет.

watashinoshi ()

плохо это или хорошо, но гтк2 — мёртв, поэтому, рано или поздно все перейдут на гтк3.

пример — МАТЕ — который клон второгнома, но всё равно умеет гтк3, а это о многом говорит

next_time ★★★★ ()
Ответ на: комментарий от next_time

гтк2 — мёртв

Да это уже понятно, и после перехода на wayland будет работать только с костылями.

поэтому, рано или поздно все перейдут на qt

фикс
Поэтому и ищу уже сразу не на gtk2, а на qt5

TheAnonymous ★★★★★ ()
Ответ на: комментарий от dk-

Без шашечек ездят на шиндошс, надо сказать, вполне неплохо.
Это тоже вариант, десяточка корпоративная ltsb - всё лучше, чем гтк3

TheAnonymous ★★★★★ ()

Я правильно понимаю, что на qt всё, что есть, работает поверх qtwebengine/qtwebkit?

Да. qutebrowser уже советовали? Туда интересные фичи завезут, пока автор будет на каникулах.

commagray ★★★★★ ()
Ответ на: комментарий от TheAnonymous

Это вот этот вебкит?

Дв

Напрягает, что пилят 1.5 анона

Я не аноним, а апрувер Qt Project :)

в qt на него забили.

Интеграция в CI-систему Qt уже есть, все бинарники собираются на тех же машинах, что и официальные. Осталось только смержить ветку wip/next в dev в http://code.qt.io/cgit/qt/qtwebkit.git/, и будет полноценная часть Qt

И да, ждём ебилдов

Их есть у меня: https://gist.github.com/annulen/309569fb61e5d64a703c055c1e726f71

annulen ★★★★★ ()
Ответ на: комментарий от eR

Под линукс запили сперва! Wine не в счёт, так как в нём многое тормозит.

VladKN ()
Ответ на: комментарий от VladKN

пусть тормозит. я подругу вчера трахал на сухую, писька болит пипец щас,но трахал же, тут так же.

eR ★★★★★ ()
Ответ на: комментарий от annulen

Ой, точно, на никнейм же надо смотреть :)

Осталось только смержить ветку wip/next в dev в http://code.qt.io/cgit/qt/qtwebkit.git/, и будет полноценная часть Qt

А это планируется? К какой версии примерно?
Я так понимаю, пока официальная политика Qt - мигрируйте на WebEngine

Их есть у меня

6.0? или это просто чтобы из оверлея было удобнее ставить?


Вообще, очень хорошо, так Otter Browser станет практически идеальным браузером. Спасибо за такую важную работу!

TheAnonymous ★★★★★ ()
Ответ на: комментарий от Deleted

О вы из тех кто в очередь на насилование шваброй заранее занимает?

slovazap ★★★★★ ()

Ещё один голос за seamonkey, у них хороший баланс между совместимостью с современным вебдванольным интернетом и прожорливостью к ресурсам. Дизайн конечно не ахти, но мы же смотрим в интернет, а не на рамочки вокруг него, правда? А ещё шикарный почтовый клиент, который я давно искал. Но я обычно не выхожу в инет без золотой тройки аддонов: noscript, httpsEverywhere, ublock. Palemoon например не все из них поддерживает.

Pyzia ★★★★ ()

А я вот подсел на umatrix, теперь не думаю, что перейду на бразуер, в котором нет похожего функционала.

Vigi ()
Ответ на: комментарий от TheAnonymous

xul-капец

и каким образом другой браузер тебя от этого спасет?

duraki ★★☆ ()
Ответ на: комментарий от TheAnonymous

А это планируется? К какой версии примерно?

В 5.10 точно будет, в 5.9 попробую толкнуть на правах превью, но не факт что пройдет

Я так понимаю, пока официальная политика Qt - мигрируйте на WebEngine

Не парься, все согласовано уже давно, проблема только в feature parity со старой версией

6.0? или это просто чтобы из оверлея было удобнее ставить?

Пока еще не определились как новую версию называть, привязка к версии Qt не устраивает

annulen ★★★★★ ()
Ответ на: комментарий от TheAnonymous

Под GTK+3 нет нормальных тем и не может быть в принципе
Почему GTK+3 — зло

Для тебя нормальная тема — это с оленем, которого прессует прогрессбар?

и ещё они ломают API в минорных версиях

Можно просто не обновлять GTK, пока под новую версию не запилят твою тему. (Хотя если у тебя собственная тема, то уже не прокатит, да.)

sudopacman ★★★★★ ()
Ответ на: комментарий от duraki

Никаким, но раз всё равно xul-капец, лучше уже перелезть на qt-шного хромога, нет смысла завязываться на gtk

TheAnonymous ★★★★★ ()
Ответ на: комментарий от sudopacman

это с оленем, которого прессует прогрессбар

В том числе.
И например, что-то похожее на курву, не запилить в принципе

Можно просто не обновлять GTK, пока под новую версию не запилят твою тему

Предлагаешь сидеть на gtk+3.14, которой уже сейчас почти 3 года?
Потому что тему oxygen переделывать не будут. Мне бы тоже не понравился такой бдсм, делаешь свою тему, тут минорное обновление - мы всё сломали, давай переделывай.

TheAnonymous ★★★★★ ()
Ответ на: комментарий от annulen

Не парься, все согласовано уже давно, проблема только в feature parity со старой версией

а что согласовано?

по сабжу - я купзиллу юзаю, оттер как-то кривоват

kott ★★★★★ ()
Ответ на: комментарий от sudopacman

оленем, которого прессует прогрессбар

Ха, рад, что кто-то помнит. Надо таки запилить.

bodqhrohro_promo ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.